The current theme cannot be loaded after update + Unable to access TTY

I’ve installed updates and this happened:

I’ve tried to follow the steps mentioned on GRUB but it’s not working, as every time I enter a command it says Unknown command ‘sudo’. My drive is encrypted and it didn’t decrypt when I entered GRUB, could this be the issue? I’d appreciate if anyone could help on what steps to follow. Thanks!

can you rerun update again?

Hi Brahma. It doesn’t let me go past the user selection screen like in the thread I attached. How can I update? Thanks!

edited, didnt noticed you cant access tty… do this:

1 Like

Or boot with the Manjaro USb stick, chroot into the system and run pacman -Syyu.

1 Like

Hi everyone,

I’m having the same issue.

Message Error

The current theme cannot be loaded due to the roors below, please selectanother theme.

file:///usr/share/sddm/themes/breath/Main.qml:26:1: plugin cannot be loadedfor module "org.kde.plasma.core" : Cannot load library /usr/lib/qt/qml/org/kde/plasma/core/ ( cannot open shared object file: no such file or directory)

Using chroot I ran the command

Pacman -Syyu

but still the same issue.

I also tried the solution from the other topic

pacman -S kcoreaddons kdbusaddons kwindowsystem kcodecs kconfig kirigami2 kquickimageeditor knotifications ki18n

it did not solved my issue.

Can anyone help me?

I solved the problem by reinstalling libunistring package!

pacman -S --overwrite \* libunistring

If this can help someone.

1 Like

I’ll try that too. Was your HD encrypted? Did you lose any data?

Thank you! I’m trying to self serve as much as possible but I’ve hit a wall. I booted from a Manjaro USB stick. Ran lsblk -f to identify the partition to mount. Ran sudo cryptsetup open /dev/sda2 backup to decrypt the partition.

Then tried to mount it doing sudo mount /dev/sda2 /mnt and got this:
mount: /mnt: unknown filesystem type ‘crypto_LUKS’.

I’ve tried to follow the steps here with no luck -

This is what lsblk gives back:

loop0 7:0 0 21.2M 1 loop /run/miso/sfs/livefs
loop1 7:1 0 717.4M 1 loop /run/miso/sfs/mhwdfs
loop2 7:2 0 1.9G 1 loop /run/miso/sfs/desktopfs
loop3 7:3 0 645.3M 1 loop /run/miso/sfs/rootfs
sda 8:0 0 238.5G 0 disk
├─sda1 8:1 0 300M 0 part
└─sda2 8:2 0 238.2G 0 part
└─backup 254:0 0 238.2G 0 crypt /mnt
sdb 8:16 1 3.6G 0 disk
├─sdb1 8:17 1 3.3G 0 part /run/miso/bootmnt
└─sdb2 8:18 1 4M 0 part

My understanding is that once I mount the partition, do chroot, and then run pacman -Ssyu it’ll be sorted. But I can’t mount the partition. All help is appreciated! :slight_smile:

Apologies for the formatting

you should be able to chroot:

sudo cryptsetup -v luksOpen /dev/sda2 cryptDrive
sudo mount /dev/mapper/cryptDrive /mnt
sudo manjaro-chroot /mnt

and rerun update:
pacman-mirrors --fasttrack 5 && pacman -Syyu
any errors post here

1 Like

Chroot worked this time. Thank you so much!

I reran the update but still was getting the theme error after a reboot. :confused:

The device is a Surface Pro 3 if that matters.

did you have any errors when running the update?
post the exact error message you get, take a picture of it…
and can you now boot normally, or you still stuck?

I ran the following:

  1. pacman-mirrors --fasttrack 5 && pacman -Syyu and after the checks it said ‘there is nothing to do’

  2. pacman -S --overwrite \* libunistring it said ‘warning: libunistring-1.1-2 is up to date – reinstalling’ and ran the update.

  3. pacman -S kcoreaddons kdbusaddons kwindowsystem kcodecs kconfig kirigami2 kquickimageeditor knotifications ki18n Same as point 2.

  4. sudo pacman -S --overwrite "*" plasma-desktop kpmcore Same as above.

  5. I also ran sudo pacman-mirrors -f5 && pamac upgrade --force-refresh && pamac install kservice which I saw on another thread and it gave this back:

sh-5.1# sudo pacman-mirrors -f5 && pamac upgrade --force-refresh && pamac install kservice
::INFO Downloading mirrors from Manjaro
::INFO => Mirror pool:
::INFO => Mirror status:
::INFO Using custom mirror file
::INFO Querying mirrors - This may take some time
  0.115 United_Kingdom :
::INFO Writing mirror list
::United_Kingdom  :$repo/$arch
::INFO Mirror list generated and saved to: /etc/pacman.d/mirrorlist
Warning: Building packages as dynamic user
Warning: Setting build directory to /var/cache/pamac
Synchronizing package databases...
Refreshing core.db...                                                                                         
Refreshing extra.db...                                                                                        
Refreshing community.db...                                                                                    
Refreshing multilib.db...                                                                                     
Refreshing linux-surface.db...                                                                                
Refreshing core.files...                                                                                      
Refreshing extra.files...                                                                                     
Refreshing community.files...                                                                                 
Refreshing multilib.files...                                                                                  
Refreshing linux-surface.files...                                                                             
Refreshing AUR...                                                                                             
Checking python2-six dependencies...                                                                          
Checking electron9 dependencies...
Checking python2 dependencies...
Checking libkipi dependencies...
Checking gnome-icon-theme dependencies...
Checking surface-dtx-daemon dependencies...
Checking ceph-libs dependencies...
Checking moneymanagerex dependencies...
Checking lib32-polkit dependencies...
Checking surface-control dependencies...
Resolving dependencies...
Checking inter-conflicts...

To build (10):
  ceph-libs           17.2.5-4   (15.2.17-1)  AUR
  python2             2.7.18-8   (2.7.18-5)   AUR
  electron9           9.4.4-6    (9.4.4-5)    AUR
  gnome-icon-theme    3.12.0-7   (3.12.0-6)   AUR
  lib32-polkit        122-1      (121-1)      AUR
  libkipi             22.04.0-1  (21.12.3-1)  AUR
  moneymanagerex      1.6.1-1    (1.5.5-1)    AUR
  python2-six         1.16.0-6   (1.16.0-5)   AUR
  surface-control     0.4.3-1    (0.4.1-2)    AUR
  surface-dtx-daemon  0.3.3-1    (0.3.1-1)    AUR

Edit build files : [e] 
Apply transaction ? [e/y/N] y

Cloning ceph build files...
System has not been booted with systemd as init system (PID 1). Can't operate.
Failed to connect to bus: Host is down
Error: Failed to build ceph

There were some of those AUR packages which I’ve not been able to update for months, like Electron - I’m not sure why, it just fails. Could it be related?

remove the packages - ceph, electron, python2, they were dropped, and cause issues:

sudo pacman -Rs ceph-libs electron9 python2 python2-six

and with error i meant the exact error that is shown regarding the ‘current theme’

That makes sense, thank you. I’ve ran the command and this happens. what can I do?

sh-5.1# sudo pacman -Rs ceph-libs electron9 python2 python2-six
checking dependencies…
error: failed to prepare transaction (could not satisfy dependencies)
:: removing python2 breaks dependency ‘python2’ required by python2-appdirs
:: removing python2 breaks dependency ‘python2’ required by python2-ordered-set
:: removing python2-six breaks dependency ‘python2-six’ required by python2-packaging
:: removing python2 breaks dependency ‘python2’ required by python2-pyparsing
:: removing python2 breaks dependency ‘python2’ required by python2-setuptools

Can you run pamac update ?

remove all python2 packages… python2 is no longer supported, and if you using anything that depends on it, replace it, or blacklist it from updating…

How can I replace it or remove it?

Sorted! I ran pacman -Rcns python2 and that removed the conflicting packages. :slight_smile:
Thank you

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.