[Testing Update x32] 2018-05-01 to 09 - Kernels, Keyring, Samba, Plasma

update
testing
manjaro32

#10
:: Different overlay package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                      manjaro-system           20180505-2           20180506-1


:: Different sync package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
      archlinux32-keyring-transition           20170628-1           20180411-1


:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                            composer            1.6.4-1.0            1.6.5-1.0
                            gnumeric          1.12.39-1.0          1.12.40-1.0
                             goffice          0.10.39-1.0          0.10.40-1.0
                                 mpc             0.29-2.0             0.30-1.0
                             python2           2.7.14-3.0           2.7.15-1.0


:: Different sync package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                        deepin-movie          1:3.2.4-1.0          1:3.2.5-1.0
                             dtkcore        1:2.0.7.1-1.0          1:2.0.8-1.0
                           dtkwidget            2.0.8-1.0            2.0.8-2.0
                               dtkwm            2.0.7-1.0            2.0.8-1.0
  firefox-developer-edition-i18n-ach           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-af           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-an           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-ar           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-as           61.0b1-1.0           61.0b2-1.0
  firefox-developer-edition-i18n-ast           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-az           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-be           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-bg           61.0b1-1.0           61.0b2-1.0
firefox-developer-edition-i18n-bn-bd           61.0b1-1.0           61.0b2-1.0
firefox-developer-edition-i18n-bn-in           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-br           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-bs           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-ca           61.0b1-1.0           61.0b2-1.0
  firefox-developer-edition-i18n-cak           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-cs           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-cy           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-da           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-de           61.0b1-1.0           61.0b2-1.0
  firefox-developer-edition-i18n-dsb           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-el           61.0b1-1.0           61.0b2-1.0
firefox-developer-edition-i18n-en-gb           61.0b1-1.0           61.0b2-1.0
firefox-developer-edition-i18n-en-us           61.0b1-1.0           61.0b2-1.0
firefox-developer-edition-i18n-en-za           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-eo           61.0b1-1.0           61.0b2-1.0
firefox-developer-edition-i18n-es-ar           61.0b1-1.0           61.0b2-1.0
firefox-developer-edition-i18n-es-cl           61.0b1-1.0           61.0b2-1.0
firefox-developer-edition-i18n-es-es           61.0b1-1.0           61.0b2-1.0
firefox-developer-edition-i18n-es-mx           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-et           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-eu           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-fa           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-ff           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-fi           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-fr           61.0b1-1.0           61.0b2-1.0
firefox-developer-edition-i18n-fy-nl           61.0b1-1.0           61.0b2-1.0
firefox-developer-edition-i18n-ga-ie           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-gd           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-gl           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-gn           61.0b1-1.0           61.0b2-1.0
firefox-developer-edition-i18n-gu-in           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-he           61.0b1-1.0           61.0b2-1.0
firefox-developer-edition-i18n-hi-in           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-hr           61.0b1-1.0           61.0b2-1.0
  firefox-developer-edition-i18n-hsb           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-hu           61.0b1-1.0           61.0b2-1.0
firefox-developer-edition-i18n-hy-am           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-ia           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-id           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-is           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-it           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-ja           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-ka           61.0b1-1.0           61.0b2-1.0
  firefox-developer-edition-i18n-kab           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-kk           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-km           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-kn           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-ko           61.0b1-1.0           61.0b2-1.0
  firefox-developer-edition-i18n-lij           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-lt           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-lv           61.0b1-1.0           61.0b2-1.0
  firefox-developer-edition-i18n-mai           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-mk           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-ml           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-mr           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-ms           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-my           61.0b1-1.0           61.0b2-1.0
firefox-developer-edition-i18n-nb-no           61.0b1-1.0           61.0b2-1.0
firefox-developer-edition-i18n-ne-np           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-nl           61.0b1-1.0           61.0b2-1.0
firefox-developer-edition-i18n-nn-no           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-or           61.0b1-1.0           61.0b2-1.0
firefox-developer-edition-i18n-pa-in           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-pl           61.0b1-1.0           61.0b2-1.0
firefox-developer-edition-i18n-pt-br           61.0b1-1.0           61.0b2-1.0
firefox-developer-edition-i18n-pt-pt           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-rm           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-ro           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-ru           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-si           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-sk           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-sl           61.0b1-1.0           61.0b2-1.0
  firefox-developer-edition-i18n-son           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-sq           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-sr           61.0b1-1.0           61.0b2-1.0
firefox-developer-edition-i18n-sv-se           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-ta           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-te           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-th           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-tr           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-uk           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-ur           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-uz           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-vi           61.0b1-1.0           61.0b2-1.0
   firefox-developer-edition-i18n-xh           61.0b1-1.0           61.0b2-1.0
firefox-developer-edition-i18n-zh-cn           61.0b1-1.0           61.0b2-1.0
firefox-developer-edition-i18n-zh-tw           61.0b1-1.0           61.0b2-1.0
                             kbibtex   0.8git20180405-1.0         1:0.7.90-1.0
              libperconaserverclient        5.7.21_20-1.0        5.7.21_21-2.0
                                ogre          1.10.11-4.0           1.11.0-1.0
                           ogre-docs          1.10.11-4.0           1.11.0-1.0
                      percona-server        5.7.21_20-1.0        5.7.21_21-2.0
              percona-server-clients        5.7.21_20-1.0        5.7.21_21-2.0
                            pgadmin4              3.0-1.0              3.0-2.0
              python-ndg-httpsclient            0.4.4-1.0            0.5.0-1.0
                       python-peewee            3.3.2-1.0            3.3.4-1.0
             python2-ndg-httpsclient            0.4.4-1.0            0.5.0-1.0
                      python2-peewee            3.3.2-1.0            3.3.4-1.0

#11

arch32 keyring update:

:: Different sync package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                 archlinux32-keyring         20180411-1.0         20180411-1.1
                                dbus           1.12.6-1.0           1.12.8-1.0
                           dbus-docs           1.12.6-1.0           1.12.8-1.0


:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                                 gjs         1:1.52.1-1.0         1:1.52.3-1.0
                      graphicsmagick           1.3.29-1.1           1.3.29-2.0
                                js52           52.7.3-1.0           52.7.3-2.0
                         kwallet-pam           5.12.5-2.1           5.12.5-3.0
                              polkit0.113+34+g29ba7af-1.0            0.114-1.0
                                vino  3.22.0+7+g74dd40f-13.22.0+11+g3977943-1.0


:: Different sync package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                                 cjs              3.6.1-1            3.8.0-1.0
                             corrade          2018.02-1.0          2018.04-1.0
                         dns-lexicon            2.2.2-1.0            2.2.3-1.0
                                 fzf           0.17.3-1.0           0.17.3-2.0
                                 iwd              0.1-3.0              0.2-1.0
                             jenkins            2.119-1.0            2.120-1.0
                             keepass             2.38-1.0             2.39-1.0
                              linbox            1.5.2-4.0            1.5.2-5.0
                             liteide             33.2-1.0             33.3-1.0
                              magnum          2018.02-2.0          2018.04-1.0
                      magnum-plugins          2018.02-1.0          2018.04-1.0
                           nltk-data            3.2.5-1.0              3.3-1.0
                    otf-font-awesome           5.0.11-1.0           5.0.12-1.0
                          perl-mouse            2.5.2-1.0            2.5.4-1.0
                         python-nltk              3.2.5-1              3.3-1.0
                 python-phonenumbers            8.9.4-1.0            8.9.5-1.0
                        python2-nltk              3.2.5-1              3.3-1.0
                python2-phonenumbers            8.9.4-1.0            8.9.5-1.0
                         qbittorrent            4.0.4-2.0            4.1.0-1.0
                     qbittorrent-nox            4.0.4-2.0            4.1.0-1.0
                               tint2             16.2-1.0             16.4-1.0
                    ttf-font-awesome           5.0.11-1.0           5.0.12-1.0

manjaro-system update which should automatically correct the js52 file conflict:

:: Different overlay package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                            dbus-x11             1.12.6-1             1.12.8-1
                      manjaro-system           20180506-1           20180507-1


:: Different overlay package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                    lightdm-settings              1.1.4-4              1.1.4-5
               lightdm-slick-greeter              1.1.4-6              1.1.4-7
         manjaro-webdad-settings-git        r17.6c9e694-1        r18.8c425dc-1
                openbox-themes-extra                1.0-3                1.0-4

#12

I found a conflicting file problem. js52 package conflicts with his own file. Deleting libmozjs-52.so.0 is a classical workaround.

:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Package (2)  Old Version  New Version  Net Change  Download Size

core/dbus    1.12.6-1.0   1.12.8-1.0     0,00 MiB       0,30 MiB
extra/js52   52.7.3-1.0   52.7.3-2.0     0,00 MiB      10,98 MiB

Total Download Size:   11,28 MiB
Total Installed Size:  46,32 MiB
Net Upgrade Size:       0,00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 dbus-1.12.8-1.0-i686                                                                                             308,9 KiB   555K/s 00:01 [####################################################################################] 100%
 js52-52.7.3-2.0-i686                                                                                              11,0 MiB   774K/s 00:15 [####################################################################################] 100%
(2/2) checking keys in keyring                                                                                                             [####################################################################################] 100%
(2/2) checking package integrity                                                                                                           [####################################################################################] 100%
(2/2) loading package files                                                                                                                [####################################################################################] 100%
(2/2) checking for file conflicts                                                                                                          [####################################################################################] 100%
error: failed to commit transaction (conflicting files)
js52: /usr/lib/libmozjs-52.so.0 exists in filesystem
Errors occurred, no packages were upgraded.

#13

I managed to move my arch32 and manjaro32 installs on the same btrfs partition with my main install. I boot the subvolumes with custom Grub entries, only getting the boot error couldn't mount /sys/firmware/efi/efivars [edited error message]. Even though I moved vmlinuz and initramfs to the same /boot parttition with x86_64 versions of the files. Otherwise no problems so far.
Edit: Only this error comes severla times when running update-grub from manjaro32

Incompatible libdevmapper 1.02.146 (2017-12-18) and kernel driver (unknown version).
Command failed
/dev/mapper/control: open failed: No such device
Failure to communicate with kernel device-mapper driver.
Check that device-mapper is available in the kernel.

I will probably uninstall os-prober or grub alltogether on manjaro32.


#14

I seem to think this is something to do with the dm-mod module…

Could you try a sudo modprobe dm-mod; sudo update-grub ?


#15

The background is that I have a test install of a LUKS encrypted system which is 64bit.
├─sdc4 crypto_LUKS 7b749090-f58c-484e-ae9f-e7415f72da2e
And it might be that 32bit Grub cannot handle it correctly.

However I can remember that LUKS encrypted installs worked just fine on my now broken netbook.

I will give you the output of modinfo dm-mod from i686 in several minutes.


#16

I updated archlinux32, all is fine. Right after the update modinfo dm-mod gave no such module, after reboot:

[eugen:~]->>> modinfo dm-mod
filename:       /lib/modules/4.16.6-1.0-ARCH/kernel/drivers/md/dm-mod.ko.xz
license:        GPL
author:         Joe Thornber <dm-devel@redhat.com>
description:    device-mapper driver
alias:          devname:mapper/control
alias:          char-major-10-236
srcversion:     8D59C922964C53858EB3CC7
depends:        
retpoline:      Y
intree:         Y
name:           dm_mod
vermagic:       4.16.6-1.0-ARCH SMP preempt mod_unload modversions 686 
parm:           reserved_rq_based_ios:Reserved IOs in request-based mempools (uint)
parm:           use_blk_mq:Use block multiqueue for request-based DM devices (bool)
parm:           dm_mq_nr_hw_queues:Number of hardware queues for request-based dm-mq devices (uint)
parm:           dm_mq_queue_depth:Queue depth for request-based dm-mq devices (uint)
parm:           stats_current_allocated_bytes:Memory currently used by statistics (ulong)
parm:           major:The major number of the device mapper (uint)
parm:           reserved_bio_based_ios:Reserved IOs in bio-based mempools (uint)
parm:           dm_numa_node:NUMA node for DM device memory allocations (int)
[eugen:~]->>> inxi -Fxxxz   
System:    Host: arch32 Kernel: 4.16.6-1.0-ARCH i686 bits: 32 compiler: gcc v: 7.3.1 Desktop: MATE 1.20.0 
           info: mate-panel wm: Metacity dm: lightdm 1.26.0 Distro: Arch Linux 
Machine:   Type: Desktop System: ASUS product: All Series v: N/A serial: N/A 
           Mobo: ASUSTeK model: AM1I-A v: Rev X.0x serial: N/A UEFI: American Megatrends v: 0801 
           date: 03/10/2016 
CPU:       Topology: Quad Core model: AMD Athlon 5370 APU with Radeon R3 bits: 64 type: MCP arch: Jaguar rev: 1 
           L2 cache: 2048 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 17606 
           Speed: 800 MHz min/max: 800/2200 MHz Core speeds (MHz): 1: 1389 2: 1476 3: 1131 4: 1140 
Graphics:  Card-1: Advanced Micro Devices [AMD/ATI] Kabini [Radeon HD 8400 / R3 Series] driver: radeon 
           v: kernel bus ID: 00:01.0 chip ID: 1002:9830 
           Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: ati,fbdev,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: AMD KABINI (DRM 2.50.0 / 4.16.6-1.0-ARCH LLVM 6.0.0) v: 4.5 Mesa 18.0.2 
           compat-v: 3.0 direct render: Yes 
Audio:     Card-1: Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio driver: snd_hda_intel v: kernel 
           bus ID: 00:01.1 chip ID: 1002:9840 
           Card-2: Advanced Micro Devices [AMD] FCH Azalia driver: snd_hda_intel v: kernel bus ID: 00:14.2 
           chip ID: 1022:780d 
           Sound Server: ALSA v: k4.16.6-1.0-ARCH 
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 v: 2.3LK-NAPI 
           port: e000 bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    HDD Total Size: 704.25 GiB used: 25.86 GiB (3.7%) 
           ID-1: /dev/sda model: KINGSTON_RBU-SNS size: 119.24 GiB serial: <filter> rev: 06.9 scheme: GPT 
           ID-2: /dev/sdb model: ST500LM012_HN-M5 size: 465.76 GiB serial: <filter> rev: 0002 scheme: GPT 
           ID-3: /dev/sdc model: SAMSUNG_MZHPU128 size: 119.24 GiB serial: <filter> rev: 501Q scheme: GPT 
Partition: ID-1: / size: 237.48 GiB used: 25.74 GiB (10.8%) fs: btrfs dev: /dev/sda3 
           ID-2: /boot size: 387.4 MiB used: 120.8 MiB (31.2%) fs: ext2 dev: /dev/sda2 
           ID-3: /home size: 237.48 GiB used: 25.74 GiB (10.8%) fs: btrfs dev: /dev/sda3 
           ID-4: /var size: 237.48 GiB used: 25.74 GiB (10.8%) fs: btrfs dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 22.5 C mobo: N/A gpu: radeon temp: 24 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 162 Uptime: N/A Memory: 2.21 GiB used: 219.1 MiB (9.7%) Init: systemd v: 238 Compilers: 
           gcc: 7.3.1 Shell: zsh v: 5.5.1 running in: mate-terminal inxi: 3.0.07 

Will check it on manjaro32 now.

Update: After reboot update-grub on manjaro32 went fine:

~ >>> modinfo dm-mod                                                                                                                                                                                                                        
filename:       /lib/modules/4.14.39-1-MANJARO/kernel/drivers/md/dm-mod.ko.gz
license:        GPL
author:         Joe Thornber <dm-devel@redhat.com>
description:    device-mapper driver
alias:          devname:mapper/control
alias:          char-major-10-236
depends:        dax
retpoline:      Y
intree:         Y
name:           dm_mod
vermagic:       4.14.39-1-MANJARO SMP preempt mod_unload modversions 686 
parm:           reserved_rq_based_ios:Reserved IOs in request-based mempools (uint)
parm:           use_blk_mq:Use block multiqueue for request-based DM devices (bool)
parm:           dm_mq_nr_hw_queues:Number of hardware queues for request-based dm-mq devices (uint)
parm:           dm_mq_queue_depth:Queue depth for request-based dm-mq devices (uint)
parm:           stats_current_allocated_bytes:Memory currently used by statistics (ulong)
parm:           major:The major number of the device mapper (uint)
parm:           reserved_bio_based_ios:Reserved IOs in bio-based mempools (uint)
parm:           dm_numa_node:NUMA node for DM device memory allocations (int)
~ >>> sudo update-grub                                                                                                                                                                                                                      
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-linux-ck
Found initrd image: /boot/initramfs-linux-ck.img
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/initramfs-linux.img
Found linux image: /boot/vmlinuz-4.17-x86_64
Found initrd image: /boot/initramfs-4.17-x86_64.img
Found linux image: /boot/vmlinuz-4.14-i686
Found initrd image: /boot/initramfs-4.14-i686.img
Found Manjaro Linux on /dev/sda3
Found Manjaro Linux on /dev/sdb1
Found Manjaro Linux on /dev/sdb1
Found Manjaro Linux on /dev/sdb1
Found Manjaro Linux on /dev/sdb1
Found memtest86+ image: /boot/memtest86+/memtest.bin
done

I wonder if that might cause an issue on an encrypted system. You get a kernel update, the module dm-mod gets unloaded - will you be able to boot the encrypted system? I hope it affects only the ability to boot other encrypted system, not the one where you did the kernel update.


#17

I got this same error a few weeks ago with x86_64; not sure why dm-mod wasn’t loaded or why all-of-a-sudden it was needed on one system but not another… Since then, no problems.

It only appeared to affect update-grub on the systems that were affected.


#18

Thanks for the tip :+1: . I also encountered the same issue while updating.


#19

There were two issues while updating.

resolving dependencies...
warning: cannot resolve "vibrancy-icons-teal", a dependency of "manjaro-lxde-settings"
:: The following package cannot be upgraded due to unresolvable dependencies:
      manjaro-lxde-settings

and another which seem to be resolved by deleting libmozjs-52.so.0 as suggested by the member @mocambo

error: failed to commit transaction (conflicting files)
js52: /usr/lib/libmozjs-52.so.0 exists in filesystem
Errors occurred, no packages were upgraded.

#20

I was running cinnamon until this update. I apparently have the same issue as


but needless to say, that fix is for 64 bit! I tried changing -x86_64 to -i686 in the package name, but that just gave me error 404.

Downgrading the kernel (4.14) did not help, so I’d say this is a cinnamon specific glitch. Xfce still works, so I’m able to run.

FWIW, I also had/fixed the libmozjs-52.so.0 issue, but it seems completely unrelated.


#21

Hopefully this lot will also fix Cinnamon:

:: Different overlay package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
            artwork-cinnamon-minimal           20180205-1           20180508-1
                 cinnamon-wallpapers           20180205-1           20180508-1
                            conky-i3           20180426-1           20180508-1
                          i3-scripts           20180118-1           20180508-1
                            kickshaw             0.5.26-1              0.6.4-1
                    lightdm-settings              1.1.4-5  1.1.4.r4.gf25d985-1
                 manjaro-i3-settings           20180423-1           20180508-1
             manjaro-i3-settings-dev           20180430-1           20180508-1
               manjaro-openbox-extra              1.2.2-1            1.3.0.6-2
          manjaro-openbox-grub-theme                1.0-3                1.3-1
                    sublime-text-dev             3.3143-1             3.3170-1
                manjaro-openbox-core                    -            1.3.0.6-2
          manjaro-openbox-extra-skel                    -            1.3.0.6-4
             manjaro-openbox-minimal                    -            1.3.0.6-2
        manjaro-openbox-minimal-skel                    -            1.3.0.6-4
                        wicd-patched                    -              1.7.4-1
:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                               ktnef            18.04.0-0                    -


:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                                gitg               3.26-1         1:3.26.0-1.0
                               ktnef                    -          18.04.0-1.0


:: Different overlay package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                            cinnamon              3.6.7-5                    -
                  libpackagekit-glib            1.1.9-1.1                    -
                        nemo-preview            3.6.2-0.1                    -
                          packagekit            1.1.9-1.1                    -
                 zsh-autosuggestions              0.4.2-1                    -
        zsh-history-substring-search              1.0.1-1                    -


:: Different sync package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                                 dcd              0.9.1-2            0.9.4-1.0
                    nginx-mod-brotli             1.12.2-3          1:0.1.1-1.0
                         bluegriffon                    -              3.1-1.0
                 bluegriffon-i18n-cs                    -              3.1-1.0
                 bluegriffon-i18n-de                    -              3.1-1.0
              bluegriffon-i18n-es-es                    -              3.1-1.0
                 bluegriffon-i18n-fi                    -              3.1-1.0
                 bluegriffon-i18n-fr                    -              3.1-1.0
                 bluegriffon-i18n-gl                    -              3.1-1.0
                 bluegriffon-i18n-he                    -              3.1-1.0
                 bluegriffon-i18n-hu                    -              3.1-1.0
                 bluegriffon-i18n-it                    -              3.1-1.0
                 bluegriffon-i18n-ja                    -              3.1-1.0
                 bluegriffon-i18n-ko                    -              3.1-1.0
                 bluegriffon-i18n-nl                    -              3.1-1.0
                 bluegriffon-i18n-pl                    -              3.1-1.0
                 bluegriffon-i18n-ru                    -              3.1-1.0
                 bluegriffon-i18n-sl                    -              3.1-1.0
                 bluegriffon-i18n-sr                    -              3.1-1.0
              bluegriffon-i18n-sv-se                    -              3.1-1.0
              bluegriffon-i18n-zh-cn                    -              3.1-1.0
              bluegriffon-i18n-zh-tw                    -              3.1-1.0
                            corebird                    -            1.7.4-2.0
                          cozy-stack                    -         2018M2S1-1.0
                     deepin-anything                    -            0.0.1-1.0
                                 din                    -               33-2.0
                            dscanner                    -            0.5.2-1.0
                          feedreader                    -2.0.2+559+g78d7ced8-1.0
                                gcc5                    -            5.5.0-1.0
                             gnucash                    -              3.1-1.0
                        gnucash-docs                    -              3.1-1.0
                         haskell-rio                    -          0.1.2.0-1.0
                               kitty                    -            0.9.1-1.0
               kvantum-theme-materia                    -         20180424-1.0
                                llpp                    -               27-1.0
                   materia-gtk-theme                    -         20180321-1.0
                         materia-kde                    -         20180424-1.0
                                mypy                    -            0.600-2.0
                        ocaml-lablgl                    -             1.05-6.0
    perl-file-copy-recursive-reduced                    -            0.006-1.0
                  perl-test-mocktime                    -             0.17-1.0
                             psensor                    -            1.2.0-4.0
                     psi-nowebengine                    -              1.3-5.0
                        python-fido2                    -            0.3.0-7.0
                          python-lz4                    -            1.1.0-2.0
                  python-mygpoclient                    -              1.8-1.0
                          python-pam                    -            1.8.3-1.0
                     python-pyblake2                    -            1.1.2-1.0
              python-pybtex-docutils                    -            0.2.1-1.0
         python-sphinxcontrib-bibtex                    -            0.4.0-1.0
                       python-tailer                    -            0.4.1-1.0
                    python-typed-ast                    -            1.1.0-2.0
                    python2-gtkglext                    -            1.1.0-8.0
                         python2-lz4                    -            1.1.0-2.0
                 python2-mygpoclient                    -              1.8-1.0
                    python2-pyblake2                    -            1.1.2-1.0
             python2-pybtex-docutils                    -            0.2.1-1.0
                 python2-qpid-proton                    -           0.22.0-1.0
        python2-sphinxcontrib-bibtex                    -            0.4.0-1.0
                            qrupdate                    -            1.1.2-2.0
                            quiterss                    -          0.18.10-2.0
                            rssguard                    -            3.5.6-2.0
                rssguard-nowebengine                    -            3.5.6-2.0
                           snap-sync                    -            0.4.2-3.0
                           verilator                    -            3.922-1.0
                               vocal                    -            2.2.0-1.0
                 zsh-autosuggestions                    -            0.4.2-2.0
        zsh-history-substring-search                    -            1.0.1-2.0

#22

WHAIT WHAT’S THIS???

:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                             firefox                    -               60.0-0
                    firefox-i18n-ach                    -               60.0-0
                     firefox-i18n-af                    -               60.0-0
                     firefox-i18n-an                    -               60.0-0
                     firefox-i18n-ar                    -               60.0-0
                     firefox-i18n-as                    -               60.0-0
                    firefox-i18n-ast                    -               60.0-0
                     firefox-i18n-az                    -               60.0-0
                     firefox-i18n-be                    -               60.0-0
                     firefox-i18n-bg                    -               60.0-0
                  firefox-i18n-bn-bd                    -               60.0-0
                  firefox-i18n-bn-in                    -               60.0-0
                     firefox-i18n-br                    -               60.0-0
                     firefox-i18n-bs                    -               60.0-0
                     firefox-i18n-ca                    -               60.0-0
                    firefox-i18n-cak                    -               60.0-0
                     firefox-i18n-cs                    -               60.0-0
                     firefox-i18n-cy                    -               60.0-0
                     firefox-i18n-da                    -               60.0-0
                     firefox-i18n-de                    -               60.0-0
                    firefox-i18n-dsb                    -               60.0-0
                     firefox-i18n-el                    -               60.0-0
                  firefox-i18n-en-gb                    -               60.0-0
                  firefox-i18n-en-us                    -               60.0-0
                  firefox-i18n-en-za                    -               60.0-0
                     firefox-i18n-eo                    -               60.0-0
                  firefox-i18n-es-ar                    -               60.0-0
                  firefox-i18n-es-cl                    -               60.0-0
                  firefox-i18n-es-es                    -               60.0-0
                  firefox-i18n-es-mx                    -               60.0-0
                     firefox-i18n-et                    -               60.0-0
                     firefox-i18n-eu                    -               60.0-0
                     firefox-i18n-fa                    -               60.0-0
                     firefox-i18n-ff                    -               60.0-0
                     firefox-i18n-fi                    -               60.0-0
                     firefox-i18n-fr                    -               60.0-0
                  firefox-i18n-fy-nl                    -               60.0-0
                  firefox-i18n-ga-ie                    -               60.0-0
                     firefox-i18n-gd                    -               60.0-0
                     firefox-i18n-gl                    -               60.0-0
                     firefox-i18n-gn                    -               60.0-0
                  firefox-i18n-gu-in                    -               60.0-0
                     firefox-i18n-he                    -               60.0-0
                  firefox-i18n-hi-in                    -               60.0-0
                     firefox-i18n-hr                    -               60.0-0
                    firefox-i18n-hsb                    -               60.0-0
                     firefox-i18n-hu                    -               60.0-0
                  firefox-i18n-hy-am                    -               60.0-0
                     firefox-i18n-id                    -               60.0-0
                     firefox-i18n-is                    -               60.0-0
                     firefox-i18n-it                    -               60.0-0
                     firefox-i18n-ja                    -               60.0-0
                     firefox-i18n-ka                    -               60.0-0
                    firefox-i18n-kab                    -               60.0-0
                     firefox-i18n-kk                    -               60.0-0
                     firefox-i18n-km                    -               60.0-0
                     firefox-i18n-kn                    -               60.0-0
                     firefox-i18n-ko                    -               60.0-0
                    firefox-i18n-lij                    -               60.0-0
                     firefox-i18n-lt                    -               60.0-0
                     firefox-i18n-lv                    -               60.0-0
                    firefox-i18n-mai                    -               60.0-0
                     firefox-i18n-mk                    -               60.0-0
                     firefox-i18n-ml                    -               60.0-0
                     firefox-i18n-mr                    -               60.0-0
                     firefox-i18n-ms                    -               60.0-0
                     firefox-i18n-my                    -               60.0-0
                  firefox-i18n-nb-no                    -               60.0-0
                     firefox-i18n-nl                    -               60.0-0
                  firefox-i18n-nn-no                    -               60.0-0
                     firefox-i18n-or                    -               60.0-0
                  firefox-i18n-pa-in                    -               60.0-0
                     firefox-i18n-pl                    -               60.0-0
                  firefox-i18n-pt-br                    -               60.0-0
                  firefox-i18n-pt-pt                    -               60.0-0
                     firefox-i18n-rm                    -               60.0-0
                     firefox-i18n-ro                    -               60.0-0
                     firefox-i18n-ru                    -               60.0-0
                     firefox-i18n-si                    -               60.0-0
                     firefox-i18n-sk                    -               60.0-0
                     firefox-i18n-sl                    -               60.0-0
                    firefox-i18n-son                    -               60.0-0
                     firefox-i18n-sq                    -               60.0-0
                     firefox-i18n-sr                    -               60.0-0
                  firefox-i18n-sv-se                    -               60.0-0
                     firefox-i18n-ta                    -               60.0-0
                     firefox-i18n-te                    -               60.0-0
                     firefox-i18n-th                    -               60.0-0
                     firefox-i18n-tr                    -               60.0-0
                     firefox-i18n-uk                    -               60.0-0
                     firefox-i18n-ur                    -               60.0-0
                     firefox-i18n-uz                    -               60.0-0
                     firefox-i18n-vi                    -               60.0-0
                     firefox-i18n-xh                    -               60.0-0
                  firefox-i18n-zh-cn                    -               60.0-0
                  firefox-i18n-zh-tw                    -               60.0-0
:: Different overlay package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                        palemoon-bin             27.9.0-1             27.9.1-1
                    palemoon-i18n-ar             27.9.0-1             27.9.1-1
                    palemoon-i18n-bg             27.9.0-1             27.9.1-1
                    palemoon-i18n-cs             27.9.0-1             27.9.1-1
                    palemoon-i18n-da             27.9.0-1             27.9.1-1
                    palemoon-i18n-de             27.9.0-1             27.9.1-1
                    palemoon-i18n-el             27.9.0-1             27.9.1-1
                 palemoon-i18n-en-gb             27.9.0-1             27.9.1-1
                 palemoon-i18n-es-ar             27.9.0-1             27.9.1-1
                 palemoon-i18n-es-es             27.9.0-1             27.9.1-1
                 palemoon-i18n-es-mx             27.9.0-1             27.9.1-1
                    palemoon-i18n-fi             27.9.0-1             27.9.1-1
                    palemoon-i18n-fr             27.9.0-1             27.9.1-1
                    palemoon-i18n-gl             27.9.0-1             27.9.1-1
                    palemoon-i18n-hr             27.9.0-1             27.9.1-1
                    palemoon-i18n-hu             27.9.0-1             27.9.1-1
                    palemoon-i18n-id             27.9.0-1             27.9.1-1
                    palemoon-i18n-is             27.9.0-1             27.9.1-1
                    palemoon-i18n-it             27.9.0-1             27.9.1-1
                    palemoon-i18n-ja             27.9.0-1             27.9.1-1
                    palemoon-i18n-kn             27.9.0-1             27.9.1-1
                    palemoon-i18n-ko             27.9.0-1             27.9.1-1
                    palemoon-i18n-nl             27.9.0-1             27.9.1-1
                    palemoon-i18n-pl             27.9.0-1             27.9.1-1
                 palemoon-i18n-pt-br             27.9.0-1             27.9.1-1
                 palemoon-i18n-pt-pt             27.9.0-1             27.9.1-1
                    palemoon-i18n-ro             27.9.0-1             27.9.1-1
                    palemoon-i18n-ru             27.9.0-1             27.9.1-1
                    palemoon-i18n-sk             27.9.0-1             27.9.1-1
                    palemoon-i18n-sl             27.9.0-1             27.9.1-1
                    palemoon-i18n-sr             27.9.0-1             27.9.1-1
                 palemoon-i18n-sv-se             27.9.0-1             27.9.1-1
                    palemoon-i18n-tl             27.9.0-1             27.9.1-1
                    palemoon-i18n-tr             27.9.0-1             27.9.1-1
                    palemoon-i18n-uk             27.9.0-1             27.9.1-1
                    palemoon-i18n-vi             27.9.0-1             27.9.1-1
                 palemoon-i18n-zh-cn             27.9.0-1             27.9.1-1
                 palemoon-i18n-zh-tw             27.9.0-1             27.9.1-1

#23

Same issue, same solution, deleting the libmozjs-52.so.0 link file (not the actual libmozjs-52.so file) fixed it.


#24

Or you could just manually force install js52 package … then continue with update.

sudo pacman -S js52 --force

#25

The latest update did fix my Cinnamon x32. Thanks :grin:


#26

The question is why didn’t the manjaro-system package take care of this in the same way as for x86_64? As far as I know it should work in exactly the same way… :thinking:


#27

https://forum.manjaro.org/uploads/default/original/3X/a/3/a3a09a38f753f96bc5169c5821691c4e9e5e49c1.png
Eben update gedrückt 1,1 gb an updates durchlaufen lassen wunderbar geklappt danke .


#28

#29

This topic was automatically closed after 2 days. New replies are no longer allowed.