[Testing Update i686] 2019-08-07 - iptables, systemd

The beginnings of another set.


Available kernels

Series Version PAE
linux316 3.16.71 No
linux44 4.4.188 No
linux49 4.9.188 No
linux414 4.14.138 No
linux419 4.19.66 Yes

Current difference to x32-stable

This thread will track updates to x32-testing as they are snapped over from x32-unstable
This post has a full difference to x32-stable, updates will be posted below as they occur.

Full list is available soon.


Any problems?

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Is x32-testing ready to be moved to x32-stable?

This will inform the snap process; there is no set threshold.

Please vote on the "is it ready yet?" poll but only when you feel this set is tested enough, and has a sufficient number of changes compared to x32-stable.

  • No or Not yet
  • Yes, x32-testing should be snapped to x32-stable at this point
  • Other (post)

0 voters

Known issues


iptables 1.8.3 is broken, downgrade to 1.8.2 for now.

systemd 242.85-1 breaks against iptables 1.8.3. Make sure you have 242.85-2 before rebooting.


unable to satisfy dependency 'libx265.so=169-32' required by ffmpeg

Skip x265 for the moment Check for updates.


Known to-do

@jonathon There is currently no testing announcement thread so I have raised a new thread for this.

This update to iptables fails:

Summary

[keith@Laptop1 ~]$ sudo pacman -Syu
[sudo] password for keith:
:: Synchronising package databases...
core is up to date
extra is up to date
community is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (1) iptables-1:1.8.3-1.2

Total Installed Size: 2.45 MiB
Net Upgrade Size: -0.03 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring [###########################################] 100%
(1/1) checking package integrity [###########################################] 100%
(1/1) loading package files [###########################################] 100%
(1/1) checking for file conflicts [###########################################] 100%
(1/1) checking available disk space [###########################################] 100%
:: Processing package changes...
(1/1) upgrading iptables [###########################################] 100%
:: Running post-transaction hooks...
(1/2) Reloading system manager configuration...
/usr/bin/systemctl: error while loading shared libraries: libip4tc.so.0: cannot open shared object file: No such file or directory
error: command failed to execute correctly
(2/2) Arming ConditionNeedsUpdate...
[keith@Laptop1 ~]$

NO NOT try to reboot your system as the kernel will dump and you will be unable to start your system.

Temporary fix: downgrade iptables:

If you have already tried to reboot your system you will need to chroot into it to do the downgrade.

Summary

[keith@Laptop1 ~]$ sudo downgrade iptables
Available packages:

    1. iptables 1 1.8.2 1.2 i686 (local)
    1. iptables 1 1.8.3 1.2 i686 (local)

select a package by number: 1
loading packages...
warning: downgrading package iptables (1:1.8.3-1.2 => 1:1.8.2-1.2)
resolving dependencies...
looking for conflicting packages...

Packages (1) iptables-1:1.8.2-1.2

Total Installed Size: 2.48 MiB
Net Upgrade Size: 0.03 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring [###########################################] 100%
(1/1) checking package integrity [###########################################] 100%
(1/1) loading package files [###########################################] 100%
(1/1) checking for file conflicts [###########################################] 100%
(1/1) checking available disk space [###########################################] 100%
:: Processing package changes...
(1/1) downgrading iptables [###########################################] 100%
:: Running post-transaction hooks...
(1/2) Reloading system manager configuration...
(2/2) Arming ConditionNeedsUpdate...
add iptables to IgnorePkg? [y/n] y
[keith@Laptop1 ~]$

2 Likes

I've pushed the old version of iptables to x32-testing, I'll check what has changed and if 1.8.3 needs to be rebuilt.

1 Like

Ah! This is caused by systemd needing to be rebuilt against the new iptables version!

Rebuilds incoming!

Rebuilt systemd:

:: Different overlay package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                            iptables          1:1.8.2-1.2                    -
                             systemd             242.85-1             242.85-2
                        systemd-libs             242.85-1             242.85-2
                  systemd-resolvconf             242.85-1             242.85-2
                  systemd-sysvcompat             242.85-1             242.85-2

Kernels are incoming uploaded:

:: Different overlay package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                            linux414           4.14.136-1           4.14.137-1
                    linux414-headers           4.14.136-1           4.14.137-1
                            linux419            4.19.64-1            4.19.65-1
                    linux419-headers            4.19.64-1            4.19.65-1
                             linux44            4.4.187-1            4.4.188-1
                     linux44-headers            4.4.187-1            4.4.188-1
                             linux49            4.9.187-1            4.9.188-1
                     linux49-headers            4.9.187-1            4.9.188-1


:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                  linux414-acpi_call            1.1.0-136            1.1.0-137
                   linux414-bbswitch              0.8-136              0.8-137
                linux414-broadcom-wl     6.30.223.271-136     6.30.223.271-137
                linux414-ndiswrapper             1.62-136             1.62-137
               linux414-nvidia-340xx          340.107-136          340.107-137
                      linux414-r8168         8.047.02-136         8.047.02-137
                  linux414-rt3562sta       2.4.1.1_r4-136       2.4.1.1_r4-137
                linux414-vhba-module         20190410-136         20190410-137
   linux414-virtualbox-guest-modules            6.0.8-136            6.0.8-137
    linux414-virtualbox-host-modules            6.0.8-136            6.0.8-137
                        linux414-zfs            0.8.1-136            0.8.1-137
                  linux419-acpi_call             1.1.0-64             1.1.0-65
                   linux419-bbswitch               0.8-64               0.8-65
                linux419-broadcom-wl      6.30.223.271-64      6.30.223.271-65
                linux419-ndiswrapper              1.62-64              1.62-65
               linux419-nvidia-340xx           340.107-64           340.107-65
                   linux419-nvidiabl              0.88-64              0.88-65
                      linux419-r8168          8.047.02-64          8.047.02-65
                linux419-vhba-module          20190410-64          20190410-65
   linux419-virtualbox-guest-modules             6.0.8-64             6.0.8-65
    linux419-virtualbox-host-modules             6.0.8-64             6.0.8-65
                        linux419-zfs             0.8.1-64             0.8.1-65
                   linux44-acpi_call            1.1.0-187            1.1.0-188
                 linux44-broadcom-wl     6.30.223.271-187     6.30.223.271-188
                    linux44-catalyst    1:15.201.1151-187    1:15.201.1151-188
                 linux44-ndiswrapper             1.62-187             1.62-188
                       linux44-r8168         8.047.02-187         8.047.02-188
                   linux44-rt3562sta       2.4.1.1_r4-187       2.4.1.1_r4-188
    linux44-virtualbox-guest-modules            6.0.8-187            6.0.8-188
     linux44-virtualbox-host-modules            6.0.8-187            6.0.8-188
                         linux44-zfs            0.8.1-187            0.8.1-188
                   linux49-acpi_call            1.1.0-187            1.1.0-188
                    linux49-bbswitch              0.8-187              0.8-188
                 linux49-broadcom-wl     6.30.223.271-187     6.30.223.271-188
                    linux49-catalyst    1:15.201.1151-187    1:15.201.1151-188
                 linux49-ndiswrapper             1.62-187             1.62-188
                linux49-nvidia-340xx          340.107-187          340.107-188
                       linux49-r8168         8.047.02-187         8.047.02-188
                   linux49-rt3562sta       2.4.1.1_r4-186       2.4.1.1_r4-188
                 linux49-vhba-module         20190410-186         20190410-188
    linux49-virtualbox-guest-modules            6.0.8-187            6.0.8-188
     linux49-virtualbox-host-modules            6.0.8-187            6.0.8-188
                         linux49-zfs            0.8.1-187            0.8.1-188
                   manjaro-architect             0.9.28-1             0.9.29-1
          manjaro-architect-launcher             0.9.28-1             0.9.29-1


:: Different overlay package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
      deepin-desktop-schemas-manjaro             3.13.7-1             3.13.9-1
              manjaro-openbox-config             1.19.0-9            1.19.0-15
    manjaro-openbox-desktop-settings             1.19.0-9            1.19.0-15
                           menulibre              2.2.0-4              2.2.1-1
1 Like

All updated and rebooted.

Thank you.

1 Like

Little sync:

:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                              ffmpeg          1:4.1.3-1.0          1:4.1.4-1.0
                                mdds            1.4.3-1.0            1.4.3-1.2
              postgresql-old-upgrade             10.9-1.0            10.10-1.0
                                x265              3.0-1.4            3.1.2-1.1


:: Different sync package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                         agda-stdlib             0.17-1.0              1.1-1.0
              ibus-table-extraphrase   1.3.9.20110826-3.2   1.3.9.20110826-3.3
                         libkkc-data            0.2.7-2.2            0.2.7-2.3
                            phonegap            8.2.2-2.0            8.2.2-2.1
                            pppusage           0.2.5-10.1           0.2.5-10.2
                         python-xapp            1.4.0-1.0            1.6.0-1.2
                        python2-xapp            1.4.0-1.0            1.6.0-1.2
                          wine_gecko             2.47-2.0             2.47-2.1

Unfortunately this update is failing.

Summary

[keith@Laptop1 ~]$ sudo pacman -Syu
[sudo] password for keith:
:: Synchronising package databases...
core is up to date
extra is up to date
community is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libx265.so=169-32' required by ffmpeg
[keith@Laptop1 ~]$

1 Like

Kernels:

:: Different overlay package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                            linux414           4.14.137-1           4.14.138-1
                    linux414-headers           4.14.137-1           4.14.138-1
                            linux419            4.19.65-1            4.19.66-1
                    linux419-headers            4.19.65-1            4.19.66-1


:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                  linux414-acpi_call            1.1.0-137            1.1.0-138
                   linux414-bbswitch              0.8-137              0.8-138
                linux414-broadcom-wl     6.30.223.271-137     6.30.223.271-138
                linux414-ndiswrapper             1.62-137             1.62-138
               linux414-nvidia-340xx          340.107-137          340.107-138
                      linux414-r8168         8.047.02-137         8.047.02-138
                  linux414-rt3562sta       2.4.1.1_r4-137       2.4.1.1_r4-138
                linux414-vhba-module         20190410-137         20190410-138
   linux414-virtualbox-guest-modules            6.0.8-137            6.0.8-138
    linux414-virtualbox-host-modules            6.0.8-137            6.0.8-138
                        linux414-zfs            0.8.1-137            0.8.1-138
                  linux419-acpi_call             1.1.0-65             1.1.0-66
                   linux419-bbswitch               0.8-65               0.8-66
                linux419-broadcom-wl      6.30.223.271-65      6.30.223.271-66
                linux419-ndiswrapper              1.62-65              1.62-66
               linux419-nvidia-340xx           340.107-65           340.107-66
                   linux419-nvidiabl              0.88-65              0.88-66
                      linux419-r8168          8.047.02-65          8.047.02-66
                linux419-vhba-module          20190410-65          20190410-66
   linux419-virtualbox-guest-modules             6.0.8-65             6.0.8-66
    linux419-virtualbox-host-modules             6.0.8-65             6.0.8-66
                        linux419-zfs             0.8.1-65             0.8.1-66
1 Like
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libx265.so=169-32' required by ffmpeg
Error installing repo packages

Still failing for me too.

Summary

keith@Laptop1 ~]$ sudo pacman-mirrors -f 5 && sudo pacman -Syu
[sudo] password for keith:
::INFO Downloading mirrors from repo.manjaro.org
::INFO Using custom mirror file
::INFO Querying mirrors - This may take some time
0.222 United_Kingdom : http://manjaro.mirrors.uk2.net/
0.257 United_Kingdom : http://mirror.catn.com/pub/manjaro/
..... United_Kingdom : http://repo.manjaro.org.uk/
0.315 United_Kingdom : https://www.mirrorservice.org/sites/repo.manjaro.org/re
::INFO Writing mirror list
::United_Kingdom : http://manjaro.mirrors.uk2.net/x32-testing/$repo/$arch
::United_Kingdom : http://mirror.catn.com/pub/manjaro/x32-testing/$repo/$arch
::United_Kingdom : https://www.mirrorservice.org/sites/repo.manjaro.org/repos/x32
::United_Kingdom : http://repo.manjaro.org.uk/x32-testing/$repo/$arch
::INFO Mirror list generated and saved to: /etc/pacman.d/mirrorlist
:: Synchronising package databases...
core is up to date
extra is up to date
community is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libx265.so=169-32' required by ffmpeg
[keith@Laptop1 ~]$

Edit: Tried changing to unstable branch but same error exists there too.

Summary

[keith@Laptop1 ~]$ sudo pacman-mirrors -m rank -c United_Kingdom -a -B unstable
[sudo] password for keith:
::INFO Branch in config is changed
::INFO Downloading mirrors from repo.manjaro.org
::INFO User generated mirror list
::------------------------------------------------------------
::INFO Custom mirror file saved: /var/lib/pacman-mirrors/custom-mirrors.json
::INFO Using custom mirror file
::INFO Querying mirrors - This may take some time
0.208 United_Kingdom : http://mirror.catn.com/pub/manjaro/
1.088 United_Kingdom : http://repo.manjaro.org.uk/
0.307 United_Kingdom : https://www.mirrorservice.org/sites/repo.manjaro.org/repos/
0.250 United_Kingdom : http://manjaro.mirrors.uk2.net/
::INFO Writing mirror list
::United_Kingdom : http://mirror.catn.com/pub/manjaro/x32-unstable/$repo/$arch
::United_Kingdom : http://manjaro.mirrors.uk2.net/x32-unstable/$repo/$arch
::United_Kingdom : https://www.mirrorservice.org/sites/repo.manjaro.org/repos/x32-unstable/$repo/$arch
::United_Kingdom : http://repo.manjaro.org.uk/x32-unstable/$repo/$arch
::INFO Mirror list generated and saved to: /etc/pacman.d/mirrorlist
::INFO To reset custom mirrorlist 'sudo pacman-mirrors -id'
::INFO To remove custom config run 'sudo pacman-mirrors -c all'
[keith@Laptop1 ~]$ sudo pacman -Syu
:: Synchronising package databases...
core is up to date
extra is up to date
community is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libx265.so=169-32' required by ffmpeg
[keith@Laptop1 ~]$

Edit 2: Further investigation shows that x265 3.1.2-1.1 provides libx265.so=176-32

Edit 3: Have updated using sudo pacman -Syu --ignore x265 and all appears to be OK so far.

Update from arch32. I'm happy about that because rebuilding ffmpeg is a faff and I was trying to avoid it. :grin:

:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                              ffmpeg          1:4.1.4-1.0            1:4.2-2.2
                     libuninameslist                    -         20190701-1.0
2 Likes

Successfully updated:
dav1d-0.2.1-1.0 ffmpeg-1:4.2-2.2 x265-3.1.2-1.1

Thank you.

Chromium:

:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                            chromium       76.0.3809.87-0      76.0.3809.100-0