[Testing Update i686] 2019-05-26 - Firefox, Thunderbird, Kernels

"Currently" it's Firefox, Thunderbird, and kernel updates.


Available kernels

Series Version PAE
linux316 3.16.68 No
linux318 3.18.140 EOL No
linux44 4.4.180 No
linux49 4.9.179 No
linux414 4.14.122 No
linux419 4.19.46 Yes

Current difference to x32-stable

This thread will track updates to x32-testing as they are snapped over from x32-unstable
This post has a full difference to x32-stable, updates will be posted below as they occur.

Full list is available here.


Any problems?

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Is x32-testing ready to be moved to x32-stable?

This will inform the snap process; there is no set threshold.

Please vote on the "is it ready yet?" poll but only when you feel this set is tested enough, and has a sufficient number of changes compared to x32-stable.

  • No or Not yet
  • Yes, x32-testing should be snapped to x32-stable at this point
  • Other (post)

0 voters

1 Like

Known issues

Known to-do

First update batch

:: Different overlay package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                            linux414           4.14.120-1           4.14.121-1
                    linux414-headers           4.14.120-1           4.14.121-1
                            linux419            4.19.44-1            4.19.45-1
                    linux419-headers            4.19.44-1            4.19.45-1
                             linux49            4.9.177-1            4.9.178-1
                     linux49-headers            4.9.177-1            4.9.178-1


:: Different sync package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                                file             5.36-1.0             5.37-1.0


:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                             firefox           66.0.5-0.1               67.0-0
                  linux414-acpi_call            1.1.0-120            1.1.0-121
                   linux414-bbswitch              0.8-120              0.8-121
                linux414-broadcom-wl     6.30.223.271-120     6.30.223.271-121
                linux414-ndiswrapper             1.61-120             1.61-121
               linux414-nvidia-340xx          340.107-120          340.107-121
               linux414-nvidia-390xx          390.116-120          390.116-121
                      linux414-r8168         8.047.01-120         8.047.01-121
                  linux414-rt3562sta       2.4.1.1_r4-120       2.4.1.1_r4-121
                        linux414-spl           0.7.13-120           0.7.13-121
                   linux414-tp_smapi             0.41-120             0.41-121
                linux414-vhba-module         20190410-120         20190410-121
   linux414-virtualbox-guest-modules            6.0.8-120            6.0.8-121
    linux414-virtualbox-host-modules            6.0.8-120            6.0.8-121
                        linux414-zfs           0.7.13-120           0.7.13-121
                  linux419-acpi_call             1.1.0-44             1.1.0-45
                   linux419-bbswitch               0.8-44               0.8-45
                linux419-broadcom-wl      6.30.223.271-44      6.30.223.271-45
                linux419-ndiswrapper              1.61-44              1.61-45
               linux419-nvidia-340xx           340.107-44           340.107-45
               linux419-nvidia-390xx           390.116-44           390.116-45
                   linux419-nvidiabl              0.88-44              0.88-45
                      linux419-r8168          8.047.01-44          8.047.01-45
                        linux419-spl            0.7.13-44            0.7.13-45
                   linux419-tp_smapi              0.41-44              0.41-45
                linux419-vhba-module          20190410-44          20190410-45
   linux419-virtualbox-guest-modules             6.0.8-44             6.0.8-45
    linux419-virtualbox-host-modules             6.0.8-44             6.0.8-45
                        linux419-zfs            0.7.13-44            0.7.13-45
                   linux49-acpi_call            1.1.0-177            1.1.0-178
                    linux49-bbswitch              0.8-177              0.8-178
                 linux49-broadcom-wl     6.30.223.271-177     6.30.223.271-178
                    linux49-catalyst    1:15.201.1151-177    1:15.201.1151-178
                 linux49-ndiswrapper             1.61-177             1.61-178
                linux49-nvidia-340xx          340.107-177          340.107-178
                linux49-nvidia-390xx          390.116-177          390.116-178
                       linux49-r8168         8.047.01-177         8.047.01-178
                   linux49-rt3562sta       2.4.1.1_r4-177       2.4.1.1_r4-178
                         linux49-spl           0.7.13-177           0.7.13-178
                    linux49-tp_smapi             0.41-177             0.41-178
                 linux49-vhba-module         20161009-177         20161009-178
    linux49-virtualbox-guest-modules            6.0.8-177            6.0.8-178
     linux49-virtualbox-host-modules            6.0.8-177            6.0.8-178
                         linux49-zfs           0.7.13-177           0.7.13-178
                         thunderbird           60.6.1-0.1             60.7.0-0
                 thunderbird-i18n-ar             60.6.1-0             60.7.0-0
                thunderbird-i18n-ast             60.6.1-0             60.7.0-0
                 thunderbird-i18n-be             60.6.1-0             60.7.0-0
                 thunderbird-i18n-bg             60.6.1-0             60.7.0-0
                 thunderbird-i18n-br             60.6.1-0             60.7.0-0
                 thunderbird-i18n-ca             60.6.1-0             60.7.0-0
                 thunderbird-i18n-cs             60.6.1-0             60.7.0-0
                 thunderbird-i18n-cy             60.6.1-0             60.7.0-0
                 thunderbird-i18n-da             60.6.1-0             60.7.0-0
                 thunderbird-i18n-de             60.6.1-0             60.7.0-0
                thunderbird-i18n-dsb             60.6.1-0             60.7.0-0
                 thunderbird-i18n-el             60.6.1-0             60.7.0-0
              thunderbird-i18n-en-gb             60.6.1-0             60.7.0-0
              thunderbird-i18n-en-us             60.6.1-0             60.7.0-0
              thunderbird-i18n-es-ar             60.6.1-0             60.7.0-0
              thunderbird-i18n-es-es             60.6.1-0             60.7.0-0
                 thunderbird-i18n-et             60.6.1-0             60.7.0-0
                 thunderbird-i18n-eu             60.6.1-0             60.7.0-0
                 thunderbird-i18n-fi             60.6.1-0             60.7.0-0
                 thunderbird-i18n-fr             60.6.1-0             60.7.0-0
              thunderbird-i18n-fy-nl             60.6.1-0             60.7.0-0
              thunderbird-i18n-ga-ie             60.6.1-0             60.7.0-0
                 thunderbird-i18n-gd             60.6.1-0             60.7.0-0
                 thunderbird-i18n-gl             60.6.1-0             60.7.0-0
                 thunderbird-i18n-he             60.6.1-0             60.7.0-0
                 thunderbird-i18n-hr             60.6.1-0             60.7.0-0
                thunderbird-i18n-hsb             60.6.1-0             60.7.0-0
                 thunderbird-i18n-hu             60.6.1-0             60.7.0-0
              thunderbird-i18n-hy-am             60.6.1-0             60.7.0-0
                 thunderbird-i18n-id             60.6.1-0             60.7.0-0
                 thunderbird-i18n-is             60.6.1-0             60.7.0-0
                 thunderbird-i18n-it             60.6.1-0             60.7.0-0
                 thunderbird-i18n-ja             60.6.1-0             60.7.0-0
                 thunderbird-i18n-ko             60.6.1-0             60.7.0-0
                 thunderbird-i18n-lt             60.6.1-0             60.7.0-0
              thunderbird-i18n-nb-no             60.6.1-0             60.7.0-0
                 thunderbird-i18n-nl             60.6.1-0             60.7.0-0
              thunderbird-i18n-nn-no             60.6.1-0             60.7.0-0
                 thunderbird-i18n-pl             60.6.1-0             60.7.0-0
              thunderbird-i18n-pt-br             60.6.1-0             60.7.0-0
              thunderbird-i18n-pt-pt             60.6.1-0             60.7.0-0
                 thunderbird-i18n-rm             60.6.1-0             60.7.0-0
                 thunderbird-i18n-ro             60.6.1-0             60.7.0-0
                 thunderbird-i18n-ru             60.6.1-0             60.7.0-0
                 thunderbird-i18n-si             60.6.1-0             60.7.0-0
                 thunderbird-i18n-sk             60.6.1-0             60.7.0-0
                 thunderbird-i18n-sl             60.6.1-0             60.7.0-0
                 thunderbird-i18n-sq             60.6.1-0             60.7.0-0
                 thunderbird-i18n-sr             60.6.1-0             60.7.0-0
              thunderbird-i18n-sv-se             60.6.1-0             60.7.0-0
                 thunderbird-i18n-tr             60.6.1-0             60.7.0-0
                 thunderbird-i18n-uk             60.6.1-0             60.7.0-0
                 thunderbird-i18n-vi             60.6.1-0             60.7.0-0
              thunderbird-i18n-zh-cn             60.6.1-0             60.7.0-0
              thunderbird-i18n-zh-tw             60.6.1-0             60.7.0-0
                    firefox-i18n-ach                    -               67.0-0
                     firefox-i18n-af                    -               67.0-0
                     firefox-i18n-an                    -               67.0-0
                     firefox-i18n-ar                    -               67.0-0
                     firefox-i18n-as                    -               67.0-0
                    firefox-i18n-ast                    -               67.0-0
                     firefox-i18n-az                    -               67.0-0
                     firefox-i18n-be                    -               67.0-0
                     firefox-i18n-bg                    -               67.0-0
                  firefox-i18n-bn-bd                    -               67.0-0
                  firefox-i18n-bn-in                    -               67.0-0
                     firefox-i18n-br                    -               67.0-0
                     firefox-i18n-bs                    -               67.0-0
                     firefox-i18n-ca                    -               67.0-0
                    firefox-i18n-cak                    -               67.0-0
                     firefox-i18n-cs                    -               67.0-0
                     firefox-i18n-cy                    -               67.0-0
                     firefox-i18n-da                    -               67.0-0
                     firefox-i18n-de                    -               67.0-0
                    firefox-i18n-dsb                    -               67.0-0
                     firefox-i18n-el                    -               67.0-0
                  firefox-i18n-en-ca                    -               67.0-0
                  firefox-i18n-en-gb                    -               67.0-0
                  firefox-i18n-en-us                    -               67.0-0
                  firefox-i18n-en-za                    -               67.0-0
                     firefox-i18n-eo                    -               67.0-0
                  firefox-i18n-es-ar                    -               67.0-0
                  firefox-i18n-es-cl                    -               67.0-0
                  firefox-i18n-es-es                    -               67.0-0
                  firefox-i18n-es-mx                    -               67.0-0
                     firefox-i18n-et                    -               67.0-0
                     firefox-i18n-eu                    -               67.0-0
                     firefox-i18n-fa                    -               67.0-0
                     firefox-i18n-ff                    -               67.0-0
                     firefox-i18n-fi                    -               67.0-0
                     firefox-i18n-fr                    -               67.0-0
                  firefox-i18n-fy-nl                    -               67.0-0
                  firefox-i18n-ga-ie                    -               67.0-0
                     firefox-i18n-gd                    -               67.0-0
                     firefox-i18n-gl                    -               67.0-0
                     firefox-i18n-gn                    -               67.0-0
                  firefox-i18n-gu-in                    -               67.0-0
                     firefox-i18n-he                    -               67.0-0
                  firefox-i18n-hi-in                    -               67.0-0
                     firefox-i18n-hr                    -               67.0-0
                    firefox-i18n-hsb                    -               67.0-0
                     firefox-i18n-hu                    -               67.0-0
                  firefox-i18n-hy-am                    -               67.0-0
                     firefox-i18n-ia                    -               67.0-0
                     firefox-i18n-id                    -               67.0-0
                     firefox-i18n-is                    -               67.0-0
                     firefox-i18n-it                    -               67.0-0
                     firefox-i18n-ja                    -               67.0-0
                     firefox-i18n-ka                    -               67.0-0
                    firefox-i18n-kab                    -               67.0-0
                     firefox-i18n-kk                    -               67.0-0
                     firefox-i18n-km                    -               67.0-0
                     firefox-i18n-kn                    -               67.0-0
                     firefox-i18n-ko                    -               67.0-0
                    firefox-i18n-lij                    -               67.0-0
                     firefox-i18n-lt                    -               67.0-0
                     firefox-i18n-lv                    -               67.0-0
                    firefox-i18n-mai                    -               67.0-0
                     firefox-i18n-mk                    -               67.0-0
                     firefox-i18n-ml                    -               67.0-0
                     firefox-i18n-mr                    -               67.0-0
                     firefox-i18n-ms                    -               67.0-0
                     firefox-i18n-my                    -               67.0-0
                  firefox-i18n-nb-no                    -               67.0-0
                  firefox-i18n-ne-np                    -               67.0-0
                     firefox-i18n-nl                    -               67.0-0
                  firefox-i18n-nn-no                    -               67.0-0
                     firefox-i18n-oc                    -               67.0-0
                     firefox-i18n-or                    -               67.0-0
                  firefox-i18n-pa-in                    -               67.0-0
                     firefox-i18n-pl                    -               67.0-0
                  firefox-i18n-pt-br                    -               67.0-0
                  firefox-i18n-pt-pt                    -               67.0-0
                     firefox-i18n-rm                    -               67.0-0
                     firefox-i18n-ro                    -               67.0-0
                     firefox-i18n-ru                    -               67.0-0
                     firefox-i18n-si                    -               67.0-0
                     firefox-i18n-sk                    -               67.0-0
                     firefox-i18n-sl                    -               67.0-0
                    firefox-i18n-son                    -               67.0-0
                     firefox-i18n-sq                    -               67.0-0
                     firefox-i18n-sr                    -               67.0-0
                  firefox-i18n-sv-se                    -               67.0-0
                     firefox-i18n-ta                    -               67.0-0
                     firefox-i18n-te                    -               67.0-0
                     firefox-i18n-th                    -               67.0-0
                     firefox-i18n-tr                    -               67.0-0
                     firefox-i18n-uk                    -               67.0-0
                     firefox-i18n-ur                    -               67.0-0
                     firefox-i18n-uz                    -               67.0-0
                     firefox-i18n-vi                    -               67.0-0
                     firefox-i18n-xh                    -               67.0-0
                  firefox-i18n-zh-cn                    -               67.0-0
                  firefox-i18n-zh-tw                    -               67.0-0
                         jdk-openjdk                    -          11.0.3.u7-0
                        jdk8-openjdk                    -         8.u212+b03-0
                         jre-openjdk                    -          11.0.3.u7-0
                jre-openjdk-headless                    -          11.0.3.u7-0
                        jre8-openjdk                    -         8.u212+b03-0
               jre8-openjdk-headless                    -         8.u212+b03-0
                         openjdk-doc                    -          11.0.3.u7-0
                         openjdk-src                    -          11.0.3.u7-0
                        openjdk8-doc                    -         8.u212+b03-0
                        openjdk8-src                    -         8.u212+b03-0


:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                         imagemagick         7.0.8.45-1.0         7.0.8.46-1.0
                     imagemagick-doc         7.0.8.45-1.0         7.0.8.46-1.0
             libqaccessibilityclient            0.4.0-2.1            0.4.1-1.0
                          live-media       2018.10.17-1.0       2019.05.12-1.0
                      mkvtoolnix-cli           33.1.0-2.0           34.0.0-1.0
                      mkvtoolnix-gui           33.1.0-2.0           34.0.0-1.0
                                qpdf            8.4.1-1.1            8.4.2-1.0
                              thunar            1.8.5-1.0            1.8.6-1.0


:: Different sync package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                      doublecmd-gtk2            0.9.2-2.0            0.9.3-1.0
                       doublecmd-qt5            0.9.2-2.0            0.9.3-1.0
                               hugin         2018.0.0-7.0         2019.0.0-1.0
                   python-matplotlib            3.0.3-1.0            3.1.0-1.0
                                qcad        3.22.0.11-1.0         3.22.1.0-1.0
                              racket              7.0-1.1              7.3-1.0
                      racket-minimal              7.0-1.1              7.3-1.0
                            sdrangel            4.8.0-1.0            4.8.0-2.0
                                 snd             19.3-1.0             19.4-1.0
                           terraform          0.11.13-1.0          0.11.14-1.0
                              waybar            0.6.4-1.0            0.6.5-1.0
                                cage                    -              0.1-3.1
                         deepin-kwin                    -            0.0.6-1.0
deepin-polkit-agent-ext-gnomekeyring                    -            0.1.0-1.0
                           fatresize                    -            1.0.4-3.0
                             fluajho                    -              1.2-1.0
                         jami-daemon                    -         20190503-1.0
                    java-sqlite-jdbc                    -         3.27.2.1-1.0
                            patroneo                    -              1.2-1.0
             switchboard-plug-locale                    -            2.4.1-1.0

and some Manjaro package updates:

:: Different overlay package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                               i-nex              7.6.0-5              7.6.0-7
                            libcpuid 0.4.0.r39.g2f10315-1  0.4.1.r6.g7a0701d-1
             vte-notification-common             0.56.1-1             0.56.3-1
                   vte3-notification             0.56.1-1             0.56.3-1
                             xplayer              2.0.2-1              2.0.2-2
               debian-whois-mkpasswd                    -              5.4.2-2
                   game-devices-udev                    -                0.3-1


:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                           calamares              3.2.4-1              3.2.8-1
                       calamares-git3.2.9.r5938.5329b77df-13.2.9.r5955.b58bc964c-1
                         thunar-gtk3              1.8.4-7              1.8.6-1
                    xfce4-panel-gtk3             4.13.4-4             4.13.5-1
                  xfce4-session-gtk3            4.13.1-10             4.13.2-1
                 xfce4-settings-gtk3            4.13.5-15             4.13.6-1
                         xfconf-gtk3             4.13.6-2             4.13.7-1
                      xfdesktop-gtk3             4.13.3-4             4.13.4-1
                          xfwm4-gtk3          4.13.1-14.2             4.13.2-1
1 Like

Kernel 4.19.45-1 (shows as 4.19.16-1 in MSM) will not boot. No messages (yes I removed quiet to make sure) and no logs, it just causes my laptop to reboot.

Kernel 4.14.121-1 starts OK.

inxi -Fxxxz

System: Host: Laptop1 Kernel: 4.14.121-1-MANJARO i686 bits: 32 compiler: gcc v: 8.3.0 Desktop: N/A wm: xfwm4
dm: LightDM 1.28.0 Distro: Manjaro Linux
Machine: Type: Laptop System: Acer product: Aspire 5610 v: V3.60 serial: Chassis: type: 10 serial:
Mobo: Acer model: Grapevine serial: BIOS: Acer v: 3.60 date: 08/12/2008
Battery: ID-1: BAT1 charge: 504.4 Wh condition: 504.4/44.4 Wh (1136%) volts: 12.1/11.1 model: SONY GC86503SY90
type: Li-ion serial: N/A status: Full
CPU: Topology: Dual Core model: Intel T2050 bits: 32 type: MCP arch: M Yonah rev: 8 L2 cache: 2048 KiB
flags: nx pae sse sse2 sse3 bogomips: 6386
Speed: 798 MHz min/max: 800/1600 MHz Core speeds (MHz): 1: 798 2: 798
Graphics: Device-1: Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics vendor: Acer Incorporated ALI
driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:27a2
Display: x11 server: X.org 1.20.4 driver: intel unloaded: modesetting alternate: fbdev,vesa
resolution:
OpenGL: renderer: Mesa DRI Intel 945GM x86/MMX/SSE2 v: 1.4 Mesa 19.0.4 direct render: Yes
Audio: Device-1: Intel NM10/ICH7 Family High Definition Audio vendor: Acer Incorporated ALI driver: snd_hda_intel
v: kernel bus ID: 00:1b.0 chip ID: 8086:27d8
Sound Server: ALSA v: k4.14.121-1-MANJARO
Network: Device-1: Intel PRO/Wireless 3945ABG [Golan] Network driver: iwl3945 v: in-tree:s port: 5420 bus ID: 05:00.0
chip ID: 8086:4222
IF: wlp5s0 state: up mac:
Device-2: Broadcom and subsidiaries BCM4401-B0 100Base-TX vendor: Acer Incorporated ALI driver: b44 v: 2.0
port: 5420 bus ID: 06:01.0 chip ID: 14e4:170c
IF-ID-1: eth0 state: up speed: 100 Mbps duplex: full mac:
Drives: Local Storage: total: 74.53 GiB used: 50.29 GiB (67.5%)
ID-1: /dev/sda vendor: Hitachi model: HTS541680J9SA00 size: 74.53 GiB speed: serial:
rev: C70P scheme: GPT
Partition: ID-1: / size: 9.62 GiB used: 5.83 GiB (60.6%) fs: ext4 dev: /dev/sda2
ID-2: /home size: 51.80 GiB used: 44.43 GiB (85.8%) fs: ext4 dev: /dev/sda4
ID-3: swap-1 size: 1.97 GiB used: 32.8 MiB (1.6%) fs: swap dev: /dev/sda5
Sensors: System Temperatures: cpu: 46.0 C mobo: 46.0 C
Fan Speeds (RPM): N/A
Info: Processes: 123 Uptime: 6m Memory: 992.9 MiB used: 534.6 MiB (53.8%) Init: systemd v: 242 Compilers: gcc: 8.3.0
Shell: bash v: 5.0.7 running in: xfce4-terminal inxi: 3.0.34

grub.cfg

DO NOT EDIT THIS FILE

It is automatically generated by grub-mkconfig using templates

from /etc/grub.d and settings from /etc/default/grub

BEGIN /etc/grub.d/00_header

insmod part_gpt
insmod part_msdos
if [ -s $prefix/grubenv ]; then
load_env
fi
if [ "${next_entry}" ] ; then
set default="${next_entry}"
set next_entry=
save_env next_entry
set boot_once=true
else
set default="${saved_entry}"
fi

if [ x"${feature_menuentry_id}" = xy ]; then
menuentry_id_option="--id"
else
menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
set saved_entry="${prev_saved_entry}"
save_env saved_entry
set prev_saved_entry=
save_env prev_saved_entry
set boot_once=true
fi

function savedefault {
if [ -z "${boot_once}" ]; then
saved_entry="${chosen}"
save_env saved_entry
fi
}

function load_video {
if [ x$feature_all_video_module = xy ]; then
insmod all_video
else
insmod efi_gop
insmod efi_uga
insmod ieee1275_fb
insmod vbe
insmod vga
insmod video_bochs
insmod video_cirrus
fi
}

set menu_color_normal=light-gray/black
set menu_color_highlight=green/black

if [ x$feature_default_font_path = xy ] ; then
font=unicode
else
insmod part_gpt
insmod ext2
set root='hd0,gpt2'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,gpt2' --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2 1bd8be84-98e6-4c45-83c7-cba15a92f235
else
search --no-floppy --fs-uuid --set=root 1bd8be84-98e6-4c45-83c7-cba15a92f235
fi
font="/usr/share/grub/unicode.pf2"
fi

if loadfont $font ; then
set gfxmode=auto
load_video
insmod gfxterm
fi
terminal_input console
terminal_output gfxterm
if [ x$feature_timeout_style = xy ] ; then
set timeout_style=menu
set timeout=5

Fallback normal timeout code in case the timeout_style feature is

unavailable.

else
set timeout=5
fi

END /etc/grub.d/00_header

BEGIN /etc/grub.d/01_menu_auto_hide

if [ "${boot_success}" = "1" -o "${boot_indeterminate}" = "1" ]; then
set last_boot_ok=1
else
set last_boot_ok=0
fi

Reset boot_indeterminate after a successful boot

if [ "${boot_success}" = "1" ] ; then
set boot_indeterminate=0

Avoid boot_indeterminate causing the menu to be hidden more then once

elif [ "${boot_indeterminate}" = "1" ]; then
set boot_indeterminate=2
fi
set boot_success=0
save_env boot_success boot_indeterminate

if [ x$feature_timeout_style = xy ] ; then
if [ "${menu_show_once}" ]; then
unset menu_show_once
save_env menu_show_once
set timeout_style=menu
set timeout=60
elif [ "${menu_auto_hide}" -a "${last_boot_ok}" = "1" ]; then
set orig_timeout_style=${timeout_style}
set orig_timeout=${timeout}
if [ "${fastboot}" = "1" ]; then
# timeout_style=menu + timeout=0 avoids the countdown code keypress check
set timeout_style=menu
set timeout=0
else
set timeout_style=hidden
set timeout=1
fi
fi
fi

END /etc/grub.d/01_menu_auto_hide

BEGIN /etc/grub.d/10_linux

menuentry 'Manjaro Linux' --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-1bd8be84-98e6-4c45-83c7-cba15a92f235' {
savedefault
load_video
insmod gzio
insmod part_gpt
insmod ext2
set root='hd0,gpt2'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,gpt2' --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2 1bd8be84-98e6-4c45-83c7-cba15a92f235
else
search --no-floppy --fs-uuid --set=root 1bd8be84-98e6-4c45-83c7-cba15a92f235
fi
linux /boot/vmlinuz-4.19-i686 root=UUID=1bd8be84-98e6-4c45-83c7-cba15a92f235 rw quiet resume=UUID=7e79fc4d-89df-43bf-9b97-709a58586d58
initrd /boot/intel-ucode.img /boot/initramfs-4.19-i686.img
}
submenu 'Advanced options for Manjaro Linux' $menuentry_id_option 'gnulinux-advanced-1bd8be84-98e6-4c45-83c7-cba15a92f235' {
menuentry 'Manjaro Linux (Kernel: 4.19.45-1-MANJARO x32)' --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.19.45-1-MANJARO x32-advanced-1bd8be84-98e6-4c45-83c7-cba15a92f235' {
savedefault
load_video
insmod gzio
insmod part_gpt
insmod ext2
set root='hd0,gpt2'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,gpt2' --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2 1bd8be84-98e6-4c45-83c7-cba15a92f235
else
search --no-floppy --fs-uuid --set=root 1bd8be84-98e6-4c45-83c7-cba15a92f235
fi
linux /boot/vmlinuz-4.19-i686 root=UUID=1bd8be84-98e6-4c45-83c7-cba15a92f235 rw quiet resume=UUID=7e79fc4d-89df-43bf-9b97-709a58586d58
initrd /boot/intel-ucode.img /boot/initramfs-4.19-i686.img
}
menuentry 'Manjaro Linux (Kernel: 4.19.45-1-MANJARO x32 - fallback initramfs)' --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.19.45-1-MANJARO x32-fallback-1bd8be84-98e6-4c45-83c7-cba15a92f235' {
load_video
insmod gzio
insmod part_gpt
insmod ext2
set root='hd0,gpt2'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,gpt2' --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2 1bd8be84-98e6-4c45-83c7-cba15a92f235
else
search --no-floppy --fs-uuid --set=root 1bd8be84-98e6-4c45-83c7-cba15a92f235
fi
linux /boot/vmlinuz-4.19-i686 root=UUID=1bd8be84-98e6-4c45-83c7-cba15a92f235 rw quiet resume=UUID=7e79fc4d-89df-43bf-9b97-709a58586d58
initrd /boot/initramfs-4.19-i686-fallback.img
}
menuentry 'Manjaro Linux (Kernel: 4.14.121-1-MANJARO x32)' --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.14.121-1-MANJARO x32-advanced-1bd8be84-98e6-4c45-83c7-cba15a92f235' {
savedefault
load_video
insmod gzio
insmod part_gpt
insmod ext2
set root='hd0,gpt2'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,gpt2' --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2 1bd8be84-98e6-4c45-83c7-cba15a92f235
else
search --no-floppy --fs-uuid --set=root 1bd8be84-98e6-4c45-83c7-cba15a92f235
fi
linux /boot/vmlinuz-4.14-i686 root=UUID=1bd8be84-98e6-4c45-83c7-cba15a92f235 rw quiet resume=UUID=7e79fc4d-89df-43bf-9b97-709a58586d58
initrd /boot/intel-ucode.img /boot/initramfs-4.14-i686.img
}
menuentry 'Manjaro Linux (Kernel: 4.14.121-1-MANJARO x32 - fallback initramfs)' --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.14.121-1-MANJARO x32-fallback-1bd8be84-98e6-4c45-83c7-cba15a92f235' {
load_video
insmod gzio
insmod part_gpt
insmod ext2
set root='hd0,gpt2'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,gpt2' --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2 1bd8be84-98e6-4c45-83c7-cba15a92f235
else
search --no-floppy --fs-uuid --set=root 1bd8be84-98e6-4c45-83c7-cba15a92f235
fi
linux /boot/vmlinuz-4.14-i686 root=UUID=1bd8be84-98e6-4c45-83c7-cba15a92f235 rw quiet resume=UUID=7e79fc4d-89df-43bf-9b97-709a58586d58
initrd /boot/initramfs-4.14-i686-fallback.img
}
}

END /etc/grub.d/10_linux

BEGIN /etc/grub.d/20_linux_xen

END /etc/grub.d/20_linux_xen

BEGIN /etc/grub.d/30_os-prober

menuentry 'Manjaro Linux (18.0.4) (on /dev/sda3)' --class manjarolinux --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-simple-d1e58154-5687-4971-93c9-2924b0dbc372' {
savedefault
insmod part_gpt
insmod ext2
set root='hd0,gpt3'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,gpt3' --hint-bios=hd0,gpt3 --hint-efi=hd0,gpt3 --hint-baremetal=ahci0,gpt3 d1e58154-5687-4971-93c9-2924b0dbc372
else
search --no-floppy --fs-uuid --set=root d1e58154-5687-4971-93c9-2924b0dbc372
fi
linux /boot/vmlinuz-4.19-i686 root=UUID=d1e58154-5687-4971-93c9-2924b0dbc372 rw quiet resume=UUID=7e79fc4d-89df-43bf-9b97-709a58586d58
initrd /boot/intel-ucode.img /boot/initramfs-4.19-i686.img
}
submenu 'Advanced options for Manjaro Linux (18.0.4) (on /dev/sda3)' $menuentry_id_option 'osprober-gnulinux-advanced-d1e58154-5687-4971-93c9-2924b0dbc372' {
menuentry 'Manjaro Linux (on /dev/sda3)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-4.19-i686--d1e58154-5687-4971-93c9-2924b0dbc372' {
savedefault
insmod part_gpt
insmod ext2
set root='hd0,gpt3'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,gpt3' --hint-bios=hd0,gpt3 --hint-efi=hd0,gpt3 --hint-baremetal=ahci0,gpt3 d1e58154-5687-4971-93c9-2924b0dbc372
else
search --no-floppy --fs-uuid --set=root d1e58154-5687-4971-93c9-2924b0dbc372
fi
linux /boot/vmlinuz-4.19-i686 root=UUID=d1e58154-5687-4971-93c9-2924b0dbc372 rw quiet resume=UUID=7e79fc4d-89df-43bf-9b97-709a58586d58
initrd /boot/intel-ucode.img /boot/initramfs-4.19-i686.img
}
menuentry 'Manjaro Linux (Kernel 4.19.44-1-MANJARO x32) (on /dev/sda3)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-4.19-i686--d1e58154-5687-4971-93c9-2924b0dbc372' {
savedefault
insmod part_gpt
insmod ext2
set root='hd0,gpt3'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,gpt3' --hint-bios=hd0,gpt3 --hint-efi=hd0,gpt3 --hint-baremetal=ahci0,gpt3 d1e58154-5687-4971-93c9-2924b0dbc372
else
search --no-floppy --fs-uuid --set=root d1e58154-5687-4971-93c9-2924b0dbc372
fi
linux /boot/vmlinuz-4.19-i686 root=UUID=d1e58154-5687-4971-93c9-2924b0dbc372 rw quiet resume=UUID=7e79fc4d-89df-43bf-9b97-709a58586d58
initrd /boot/intel-ucode.img /boot/initramfs-4.19-i686.img
}
menuentry 'Manjaro Linux (Kernel 4.19.44-1-MANJARO x32 - fallback initramfs) (on /dev/sda3)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-4.19-i686--d1e58154-5687-4971-93c9-2924b0dbc372' {
savedefault
insmod part_gpt
insmod ext2
set root='hd0,gpt3'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,gpt3' --hint-bios=hd0,gpt3 --hint-efi=hd0,gpt3 --hint-baremetal=ahci0,gpt3 d1e58154-5687-4971-93c9-2924b0dbc372
else
search --no-floppy --fs-uuid --set=root d1e58154-5687-4971-93c9-2924b0dbc372
fi
linux /boot/vmlinuz-4.19-i686 root=UUID=d1e58154-5687-4971-93c9-2924b0dbc372 rw quiet resume=UUID=7e79fc4d-89df-43bf-9b97-709a58586d58
initrd /boot/initramfs-4.19-i686-fallback.img
}
menuentry 'Manjaro Linux (Kernel 4.14.120-1-MANJARO x32) (on /dev/sda3)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-4.14-i686--d1e58154-5687-4971-93c9-2924b0dbc372' {
savedefault
insmod part_gpt
insmod ext2
set root='hd0,gpt3'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,gpt3' --hint-bios=hd0,gpt3 --hint-efi=hd0,gpt3 --hint-baremetal=ahci0,gpt3 d1e58154-5687-4971-93c9-2924b0dbc372
else
search --no-floppy --fs-uuid --set=root d1e58154-5687-4971-93c9-2924b0dbc372
fi
linux /boot/vmlinuz-4.14-i686 root=UUID=d1e58154-5687-4971-93c9-2924b0dbc372 rw quiet resume=UUID=7e79fc4d-89df-43bf-9b97-709a58586d58
initrd /boot/intel-ucode.img /boot/initramfs-4.14-i686.img
}
menuentry 'Manjaro Linux (Kernel 4.14.120-1-MANJARO x32 - fallback initramfs) (on /dev/sda3)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-4.14-i686--d1e58154-5687-4971-93c9-2924b0dbc372' {
savedefault
insmod part_gpt
insmod ext2
set root='hd0,gpt3'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,gpt3' --hint-bios=hd0,gpt3 --hint-efi=hd0,gpt3 --hint-baremetal=ahci0,gpt3 d1e58154-5687-4971-93c9-2924b0dbc372
else
search --no-floppy --fs-uuid --set=root d1e58154-5687-4971-93c9-2924b0dbc372
fi
linux /boot/vmlinuz-4.14-i686 root=UUID=d1e58154-5687-4971-93c9-2924b0dbc372 rw quiet resume=UUID=7e79fc4d-89df-43bf-9b97-709a58586d58
initrd /boot/initramfs-4.14-i686-fallback.img
}
menuentry 'Memory Tester (memtest86+) (on /dev/sda3)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/memtest86+/memtest.bin--d1e58154-5687-4971-93c9-2924b0dbc372' {
savedefault
insmod part_gpt
insmod ext2
set root='hd0,gpt3'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,gpt3' --hint-bios=hd0,gpt3 --hint-efi=hd0,gpt3 --hint-baremetal=ahci0,gpt3 d1e58154-5687-4971-93c9-2924b0dbc372
else
search --no-floppy --fs-uuid --set=root d1e58154-5687-4971-93c9-2924b0dbc372
fi
linux /boot/memtest86+/memtest.bin
}
}

Other OS found, undo autohiding of menu unless menu_auto_hide=2

if [ "${orig_timeout_style}" -a "${menu_auto_hide}" != "2" ]; then
set timeout_style=${orig_timeout_style}
set timeout=${orig_timeout}
fi

END /etc/grub.d/30_os-prober

BEGIN /etc/grub.d/40_custom

This file provides an easy way to add custom menu entries. Simply type the

menu entries you want to add after this comment. Be careful not to change

the 'exec tail' line above.

END /etc/grub.d/40_custom

BEGIN /etc/grub.d/41_custom

if [ -f ${config_directory}/custom.cfg ]; then
source ${config_directory}/custom.cfg
elif [ -z "${config_directory}" -a -f $prefix/custom.cfg ]; then
source $prefix/custom.cfg;
fi

END /etc/grub.d/41_custom

BEGIN /etc/grub.d/60_memtest86+

if [ "${grub_platform}" == "pc" ]; then
menuentry "Memory Tester (memtest86+)" --class memtest86 --class gnu --class tool {
search --fs-uuid --no-floppy --set=root --hint-ieee1275='ieee1275//disk@0,gpt2' --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2 1bd8be84-98e6-4c45-83c7-cba15a92f235
linux16 /boot/memtest86+/memtest.bin
}
fi

END /etc/grub.d/60_memtest86+

2 Likes

MATE 1.22.1:

:: Different sync package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                         btrfs-progs           4.20.2-1.0              5.1-1.0
                           nfs-utils            2.3.3-1.1            2.3.4-1.0
                            nfsidmap            2.3.3-1.1            2.3.4-1.0


:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                                bird            2.0.3-1.0            2.0.4-1.0
                         flashplugin       32.0.0.156-1.0       32.0.0.192-1.0
                            inkscape           0.92.4-3.0           0.92.4-5.0
                          libmagick6        6.9.10.27-1.0        6.9.10.46-1.0
                               libuv           1.29.0-1.0           1.29.1-1.0
                                 mpd           0.21.8-1.0           0.21.9-1.0
                        pepper-flash       32.0.0.156-1.0       32.0.0.192-1.0
                        python-cairo           1.18.0-1.4           1.18.1-1.0
                        python-evdev            1.1.2-2.1            1.2.0-1.0
                       python2-cairo           1.18.0-1.5           1.18.1-1.0
                               tslib             1.19-1.0             1.20-1.0


:: Different sync package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                             arduino          1:1.8.9-1.0          1:1.8.9-3.0
                            engrampa           1.22.0-1.1           1.22.1-1.0
                                 eom           1.22.0-1.0           1.22.1-1.0
                              erlang           21.3.2-1.1             22.0-1.0
                          erlang-nox           21.3.2-1.1             22.0-1.0
                     erlang-unixodbc           21.3.2-1.1             22.0-1.0
                               giada           0.15.4-1.0           0.15.4-3.0
                                hugo           0.55.5-1.0           0.55.6-1.0
                          kio-gdrive            1.2.5-2.0            1.2.6-1.0
                             kubectl           1.14.1-2.0           1.14.2-1.0
         libpam-google-authenticator             1.05-1.4             1.06-1.0
                               marco           1.22.0-1.0           1.22.1-1.0
                           mate-calc           1.22.0-1.0           1.22.1-1.0
                 mate-control-center           1.22.0-1.0           1.22.1-1.0
                        mate-desktop           1.22.0-1.0           1.22.1-1.0
                          mate-media           1.22.0-1.0           1.22.1-1.0
                        mate-netbook           1.22.0-1.0           1.22.1-1.0
                          mate-panel           1.22.0-1.0           1.22.1-1.0
                  mate-power-manager           1.22.0-1.0           1.22.1-1.0
                    mate-screensaver           1.22.0-1.0           1.22.1-1.0
                 mate-sensors-applet           1.22.0-1.0           1.22.1-1.0
                 mate-system-monitor           1.22.0-1.0           1.22.1-1.0
                       mate-terminal           1.22.0-1.0           1.22.1-1.0
                          mate-utils           1.22.0-1.0           1.22.1-1.0
                      nginx-mainline          1.15.12-1.0           1.17.0-1.0
                               pluma           1.22.0-1.0           1.22.1-1.0
                               redis            5.0.4-1.0            5.0.5-1.0
                            ruby-ffi           1.11.0-1.0           1.11.1-1.0
                            smplayer           19.1.0-1.0           19.5.0-1.0
                          uncrustify           0.68.1-1.0           0.69.0-1.0
                                 urh            2.5.7-1.0            2.6.0-1.0
                       libjamiclient                    -         20190503-1.0
1 Like

KERNELS!!!!

*cough* I mean kernels:

:: Different overlay package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                            linux316            3.16.67-1            3.16.68-1
                    linux316-headers            3.16.67-1            3.16.68-1
                            linux414           4.14.121-1           4.14.122-1
                    linux414-headers           4.14.121-1           4.14.122-1
                            linux419            4.19.45-1            4.19.46-1
                    linux419-headers            4.19.45-1            4.19.46-1
                             linux49            4.9.178-1            4.9.179-1
                     linux49-headers            4.9.178-1            4.9.179-1


:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                        linux316-zfs            0.7.13-67              0.8.0-0
                        linux318-zfs           0.7.13-140              0.8.0-0
                  linux414-acpi_call            1.1.0-121            1.1.0-122
                   linux414-bbswitch              0.8-121              0.8-122
                linux414-broadcom-wl     6.30.223.271-121     6.30.223.271-122
                linux414-ndiswrapper             1.61-121             1.61-122
               linux414-nvidia-340xx          340.107-121          340.107-122
               linux414-nvidia-390xx          390.116-121          390.116-122
                      linux414-r8168         8.047.01-121         8.047.01-122
                  linux414-rt3562sta       2.4.1.1_r4-121       2.4.1.1_r4-122
                   linux414-tp_smapi             0.41-121             0.41-122
                linux414-vhba-module         20190410-121         20190410-122
   linux414-virtualbox-guest-modules            6.0.8-121            6.0.8-122
    linux414-virtualbox-host-modules            6.0.8-121            6.0.8-122
                        linux414-zfs           0.7.13-121            0.8.0-122
                  linux419-acpi_call             1.1.0-45             1.1.0-46
                   linux419-bbswitch               0.8-45               0.8-46
                linux419-broadcom-wl      6.30.223.271-45      6.30.223.271-46
                linux419-ndiswrapper              1.61-45              1.61-46
               linux419-nvidia-340xx           340.107-45           340.107-46
               linux419-nvidia-390xx           390.116-45           390.116-46
                   linux419-nvidiabl              0.88-45              0.88-46
                      linux419-r8168          8.047.01-45          8.047.01-46
                   linux419-tp_smapi              0.41-45              0.41-46
                linux419-vhba-module          20190410-45          20190410-46
   linux419-virtualbox-guest-modules             6.0.8-45             6.0.8-46
    linux419-virtualbox-host-modules             6.0.8-45             6.0.8-46
                        linux419-zfs            0.7.13-45             0.8.0-46
                         linux44-zfs           0.7.13-180              0.8.0-0
                   linux49-acpi_call            1.1.0-178            1.1.0-179
                    linux49-bbswitch              0.8-178              0.8-179
                 linux49-broadcom-wl     6.30.223.271-178     6.30.223.271-179
                    linux49-catalyst    1:15.201.1151-178    1:15.201.1151-179
                 linux49-ndiswrapper             1.61-178             1.61-179
                linux49-nvidia-340xx          340.107-178          340.107-179
                linux49-nvidia-390xx          390.116-178          390.116-179
                       linux49-r8168         8.047.01-178         8.047.01-179
                   linux49-rt3562sta       2.4.1.1_r4-178       2.4.1.1_r4-179
                    linux49-tp_smapi             0.41-178             0.41-179
                 linux49-vhba-module         20161009-178         20161009-179
    linux49-virtualbox-guest-modules            6.0.8-178            6.0.8-179
     linux49-virtualbox-host-modules            6.0.8-178            6.0.8-179
                         linux49-zfs           0.7.13-178            0.8.0-179
                              polkit  0.115+24+g5230646-1            0.116-1.1
                            zfs-dkms             0.7.12-1              0.8.0-0
                           zfs-utils             0.7.12-1              0.8.0-0


:: Different overlay package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
               gnome-terminal-fedora             3.32.1-1             3.32.2-1
                     kvantum-manjaro             0.13.1-1             0.13.2-2
                                 tlp            1.2.1-1.0            1.2.2-1.1
                             tlp-rdw            1.2.1-1.0            1.2.2-1.1
1 Like

Same for me. 4.19.45 doesn't boot on Intel 740 CPU and 4.14.121 have still weird problem with connecting bluetooth devices. Bluetooth.service seem active and working.

Also discovered a problem with SMPlayer.
/usr/bin/mplayer: error while loading shared libraries: libcdio.so.18: cannot open shared object file: No such file or directory
/usr/lib/libcdio.so.19 is presented in system instead.

Epiphany and mplayer are needed to be updated/recompiled against libicuuc.so.64 and libcdio.so.19 respectively.

Kernel 4.19.46-1 (which still shows as 4.19.16-1 in MSM) will not boot. Like kernel 4.19.45-1 No messages or logs, it just causes my laptop to reboot. If it helps, I have noticed that they both get as far as the WiFi LED coming on before they reboot.

Kernel 4.14.122-1 starts OK.

A sync which includes a rebuilt mplayer.

I suspect upstream's epiphany build will be "falling foul" of SSE2 support being required for Webkit. It will probably need to be rebuilt with -march=pentium4 rather than -march=i686.

:: Different sync package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                                dbus          1.12.12-1.0          1.12.14-1.0
                           dbus-docs          1.12.12-1.0          1.12.14-1.0
                               glib2           2.60.2-1.0           2.60.3-1.0
                          glib2-docs           2.60.2-1.0           2.60.3-1.0
                                krb5           1.16.1-1.3           1.16.2-1.0
                             libssh2            1.8.1-1.0            1.8.2-1.0


:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                            alsa-lib            1.1.8-1.0            1.1.9-1.0
                        alsa-plugins            1.1.8-1.3            1.1.9-2.0
                          alsa-utils            1.1.8-1.2            1.1.9-1.0
                   black-hole-solver           0.24.0-1.0            1.0.0-1.0
                        cups-filters           1.22.5-2.0           1.23.0-1.0
                             ethtool            1:5.0-1.0            1:5.1-1.0
                                 gdb            8.2.1-3.1              8.3-1.0
                          gdb-common            8.2.1-3.0              8.3-1.0
                            harfbuzz            2.4.0-2.0            2.5.0-1.0
                        harfbuzz-icu            2.4.0-2.1            2.5.0-1.0
                          irqbalance            1.5.0-2.0            1.6.0-1.0
                          kitinerary          19.04.1-1.0          19.04.1-2.0
                             libpqxx            6.2.5-1.0            6.4.4-1.0
                   libreoffice-still            6.1.5-2.0            6.1.6-1.0
               libreoffice-still-sdk            6.1.5-2.0            6.1.6-1.0
                         libwbclient           4.10.3-1.0           4.10.4-1.0
                            mencoder            38125-4.3            38139-1.0
                             mplayer            38125-4.3            38139-1.0
                         openconnect           1:8.02-1.1           1:8.03-1.0
                                 php            7.3.5-1.0            7.3.5-1.1
                          php-apache            7.3.5-1.0            7.3.5-1.1
                             php-cgi            7.3.5-1.0            7.3.5-1.1
                           php-dblib            7.3.5-1.0            7.3.5-1.1
                           php-embed            7.3.5-1.0            7.3.5-1.1
                         php-enchant            7.3.5-1.0            7.3.5-1.1
                             php-fpm            7.3.5-1.0            7.3.5-1.1
                              php-gd            7.3.5-1.0            7.3.5-1.1
                            php-imap            7.3.5-1.0            7.3.5-1.1
                            php-intl            7.3.5-1.0            7.3.5-1.1
                            php-odbc            7.3.5-1.0            7.3.5-1.1
                           php-pgsql            7.3.5-1.0            7.3.5-1.1
                          php-phpdbg            7.3.5-1.0            7.3.5-1.1
                          php-pspell            7.3.5-1.0            7.3.5-1.1
                            php-snmp            7.3.5-1.0            7.3.5-1.1
                          php-sodium            7.3.5-1.0            7.3.5-1.1
                          php-sqlite            7.3.5-1.0            7.3.5-1.1
                            php-tidy            7.3.5-1.0            7.3.5-1.1
                             php-xsl            7.3.5-1.0            7.3.5-1.1
                            portmidi              217-6.2              217-7.0
                          postgresql             11.2-3.0             11.3-1.0
                     postgresql-docs             11.2-3.0             11.3-1.0
                     postgresql-libs             11.2-3.0             11.3-1.0
              postgresql-old-upgrade             10.6-2.0             10.8-1.0
            prometheus-node-exporter           0.17.0-2.0           0.18.0-1.0
                          qt5-webkit   5.212.0alpha2-28.15.212.0alpha2+156+g95401fe3908-1.0
                               samba           4.10.3-1.0           4.10.4-1.0
                           smbclient           4.10.3-1.0           4.10.4-1.0


:: Different sync package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
               aarch64-linux-gnu-gdb            8.2.1-2.1              8.3-1.0
                      acpi_call-dkms          1.1.0-211.0          1.1.0-217.0
               android-file-transfer              3.7-2.1              3.8-1.0
                   arm-none-eabi-gdb            8.2.1-2.0              8.3-1.0
                               aubio            0.4.9-3.0            0.4.9-3.1
                             avr-gdb            8.2.1-2.1              8.3-1.0
                                axel           2.17.1-1.0           2.17.3-1.0
                         broadcom-wl    6.30.223.271-98.0   6.30.223.271-104.0
                              chrony              3.4-1.0              3.5-1.0
                               cjdns             20.2-1.4             20.3-1.0
                             curator            5.6.0-1.3            5.7.6-1.0
                     deepin-anything            0.0.9-1.0            0.1.0-2.0
                deepin-anything-dkms            0.0.9-1.0            0.1.0-2.0
                 deepin-image-viewer           1.3.13-1.0           1.3.15-1.0
                        deepin-movie       1:3.2.22.1-1.0         1:3.2.23-1.0
              deepin-qt-dbus-factory            1.1.1-2.0            1.1.2-1.0
               deepin-qt5dxcb-plugin            1.2.0-1.0            1.2.1-1.0
               deepin-system-monitor            1.5.0-1.0            1.5.2-1.0
                     deepin-terminal          3.2.3.1-1.0            3.2.4-1.0
                                 dmd        1:2.085.0-1.0        1:2.086.0-1.0
                            dmd-docs        1:2.085.0-1.0        1:2.086.0-1.0
                             dtkcore         1:2.0.13-1.0         1:2.0.14-1.0
                       elasticsearch            7.0.1-1.0            7.1.0-1.0
                          emscripten          1.38.31-1.0          1.38.32-1.0
                                gmtk            1.0.9-5.1            1.0.9-5.2
                                  go         2:1.12.4-1.1         2:1.12.5-1.0
                              go-pie         2:1.12.4-1.1         2:1.12.5-1.0
                             haproxy            1.9.6-1.1            1.9.8-1.0
                               hydra              8.8-2.0              9.0-1.0
                    iio-sensor-proxy              2.6-1.0              2.7-2.0
                            iptstate            2.2.6-2.0            2.2.6-3.0
                                kodi             17.6-9.2             18.2-3.0
        kodi-addon-audioencoder-flac          1:1.1.0-2.0         1:2.0.1-11.0
        kodi-addon-audioencoder-lame          1:1.2.0-2.0         1:2.0.1-11.0
      kodi-addon-audioencoder-vorbis          1:1.1.0-2.0         1:2.0.1-11.0
         kodi-addon-audioencoder-wav          1:1.1.0-2.0         1:2.0.1-11.0
      kodi-addon-peripheral-joystick            1.3.4-1.1            1.4.7-6.0
    kodi-addon-screensaver-asteroids          1:1.1.2-2.0          1:2.3.0-3.0
   kodi-addon-screensaver-biogenesis          1:1.1.0-2.0          1:2.2.2-3.0
    kodi-addon-screensaver-greynetic          1:1.1.0-2.0          1:2.2.1-3.0
 kodi-addon-screensaver-matrixtrails          1:1.1.0-2.0          1:2.2.1-3.0
     kodi-addon-screensaver-pingpong          1:1.1.0-2.0          1:2.1.1-6.0
         kodi-addon-screensaver-pyro          1:1.1.0-2.0          1:3.0.0-3.0
        kodi-addon-screensaver-stars          1:1.1.0-2.0          1:2.1.2-3.0
   kodi-addon-visualization-projectm          1:1.2.1-2.0          1:2.2.0-3.0
  kodi-addon-visualization-shadertoy          1:1.1.5-2.0         1:1.1.10-3.0
   kodi-addon-visualization-spectrum          1:1.1.4-2.1         1:2.0.3-10.0
   kodi-addon-visualization-waveform          1:1.1.0-2.0          1:2.0.1-9.0
                            kodi-dev             17.6-9.2             18.2-3.0
                   kodi-eventclients             17.6-9.2             18.2-3.0
            kodi-tools-texturepacker             17.6-9.2             18.2-3.0
                              libasl           0.1.7-13.0           0.1.7-13.1
                           libphobos        1:2.085.0-1.0        1:2.086.0-1.0
                           libratbag          0.9.905-1.0          0.9.905-2.0
                            logstash            7.0.1-1.0            7.1.0-1.0
                          metasploit           5.0.18-1.0           5.0.22-1.0
                            minikube            1.0.1-1.0            1.1.0-1.0
                       nginx-mod-njs            0.3.1-2.0            0.3.2-1.0
                         opencascade            7.3.0-4.0         7.3.0_p3-1.0
                             pcurses                4-6.1                4-8.0
                            pdfcrack             0.16-2.1             0.17-1.0
                            pgadmin4              4.4-1.0              4.6-1.0
                           playerctl            2.0.2-1.0            2.0.2-2.0
                   powerdns-recursor           4.1.11-2.0           4.1.13-1.0
                        pulseeffects            4.6.0-1.0            4.6.1-1.0
                        python-aubio            0.4.9-3.0            0.4.9-3.1
        python-elasticsearch-curator            5.6.0-1.3            5.7.6-1.0
                        python-gmpy2          2.1.0a4-1.3          2.1.0b1-1.0
                       python-grpcio           1.19.1-1.0           1.21.0-1.0
                       python-plyvel            1.0.5-1.4            1.1.0-1.0
                     python-wxpython            4.0.4-5.0            4.0.5-3.0
                         python-yara            3.8.1-1.4           3.10.0-1.0
                       python2-aubio            0.4.9-3.0            0.4.9-3.1
                       python2-gmpy2          2.1.0a4-1.3          2.1.0b1-1.0
                      python2-plyvel            1.0.5-1.4            1.1.0-1.0
                        python2-yara            3.8.1-1.4           3.10.0-1.0
                             radare2            3.4.1-1.0            3.5.1-1.0
                      radare2-cutter            1.8.1-2.0            1.8.2-1.0
               riscv64-linux-gnu-gdb            8.2.1-2.0              8.3-1.0
                              skopeo           0.1.35-1.0           0.1.36-1.0
                    sonic-visualiser            3.2.1-1.0              3.3-1.0
                       sqlitebrowser           3.11.1-1.0           3.11.2-1.0
                        supertuxkart              1.0-3.0              1.0-4.0
                           terraform          0.11.14-1.0           0.12.0-1.0
                               uwsgi           2.0.18-1.2           2.0.18-1.3
                    uwsgi-plugin-cgi           2.0.18-1.2           2.0.18-1.3
                    uwsgi-plugin-jvm           2.0.18-1.2           2.0.18-1.3
                  uwsgi-plugin-lua51           2.0.18-1.2           2.0.18-1.3
                   uwsgi-plugin-mono           2.0.18-1.2           2.0.18-1.3
               uwsgi-plugin-notfound           2.0.18-1.2           2.0.18-1.3
                    uwsgi-plugin-php           2.0.18-1.2           2.0.18-1.3
                   uwsgi-plugin-psgi           2.0.18-1.2           2.0.18-1.3
                   uwsgi-plugin-pypy           2.0.18-1.2           2.0.18-1.3
                 uwsgi-plugin-python           2.0.18-1.2           2.0.18-1.3
                uwsgi-plugin-python2           2.0.18-1.2           2.0.18-1.3
                   uwsgi-plugin-rack           2.0.18-1.2           2.0.18-1.3
                 uwsgi-plugin-webdav           2.0.18-1.2           2.0.18-1.3
                 uwsgi-plugin-zabbix           2.0.18-1.2           2.0.18-1.3
                              waybar            0.6.5-1.0            0.6.6-1.0
                       wireshark-cli            3.0.1-1.0            3.0.2-1.0
                        wireshark-qt            3.0.1-1.0            3.0.2-1.0
                          xwallpaper            0.4.1-1.0            0.5.0-1.0
                   zathura-pdf-mupdf            0.3.4-1.0            0.3.4-2.0
                     pantheon-camera                    -            1.0.4-1.0

and MESA 19.0.5:

:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                   libreoffice-fresh              6.2.3-2                    -
               libreoffice-fresh-sdk              6.2.3-2                    -
                   libreoffice-still              6.1.6-1                    -
               libreoffice-still-sdk              6.1.6-1                    -


:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                           intel-tbb           2019.5-1.0           2019.6-1.0
                      kdevelop-pg-qt            2.1.0-2.1            2.2.0-1.0
                   libreoffice-fresh            6.2.0-3.0            6.2.4-1.0
               libreoffice-fresh-sdk            6.2.0-3.0            6.2.4-1.0
                   libva-mesa-driver           19.0.4-1.0           19.0.5-1.0
                              maxima           5.42.2-1.0           5.42.2-2.0
                                mesa           19.0.4-1.0           19.0.5-1.0
                          mesa-vdpau           19.0.4-1.0           19.0.5-1.0
                                mutt           1.11.4-1.1           1.12.0-1.0
                         opencl-mesa           19.0.4-1.0           19.0.5-1.0
                           portaudio  190600_20161030-4.0         1:19.6.0-5.0
                      python-twisted           18.9.0-1.3           19.2.0-1.0
                     python2-twisted           18.9.0-1.3           19.2.0-1.0
                               rygel           0.38.0-1.0           0.38.1-1.0
                                sbcl           1.4.16-1.0            1.5.2-1.0
                              thunar            1.8.6-1.0            1.8.6-2.0
                        vulkan-intel           19.0.4-1.0           19.0.5-1.0
                       vulkan-radeon           19.0.4-1.0           19.0.5-1.0


:: Different sync package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                             alembic           1.7.10-1.2           1.7.11-1.0
                                borg            1.1.8-1.2           1.1.10-1.0
                         deepin-kwin            0.0.6-1.0            0.0.7-2.0
                   deepin-screenshot           4.1.11-1.0            4.2.0-1.0
                           emacs-nox             26.1-1.1             26.2-1.0
                              erlang             22.0-1.0           22.0.1-1.0
                          erlang-nox             22.0-1.0           22.0.1-1.0
                     erlang-unixodbc             22.0-1.0           22.0.1-1.0
                                 fio             3.13-1.0             3.14-1.0
                       gitlab-runner          11.10.0-1.1          11.11.0-1.0
                           glbinding            3.0.2-2.0            3.1.0-2.0
                       gsmartcontrol            1.1.3-1.2            1.1.3-2.0
                               gsoap           2.8.83-1.1           2.8.84-1.0
                               kitty           0.13.3-1.0           0.14.0-1.0
                       libimagequant           2.12.2-1.0           2.12.3-1.0
                         libutf8proc            2.3.0-1.0            2.4.0-1.0
                               minio       2019.04.04-1.0       2019.05.14-1.0
                              mumble          1.2.19-13.0         1.3.0rc1-2.0
                              murmur          1.2.19-13.0         1.3.0rc1-3.0
                             netdata           1.14.0-1.0           1.15.0-1.0
                            pngquant           2.12.2-1.0           2.12.3-1.0
                         qbittorrent            4.1.5-2.2            4.1.6-1.0
                     qbittorrent-nox            4.1.5-2.2            4.1.6-1.0
                            qjackctl            0.5.7-1.0            0.5.8-1.0
                           texstudio          2.12.14-1.0          2.12.16-1.0
                              rspamd                    -            1.9.3-2.0
1 Like

Are you booting without nosplash quiet? Can you boot into a TTY, e.g. tag a 3 at the end of the GRUB boot line?

Edit:

Interestingly, I've just found that a VM won't boot with 4.19.46 but will with 4.14.122 (but my EeePC 901 hardware is fine).

Not sure what has changed in the kernel since 4.19.43 (?) but I'm going to try removing some patches (e.g. BFQ) to see if anything helps my VM.

4.19.46-1.0 excludes the PKGBUILD's BFQ patch and Aufs4 patches. This boots on my VM.

:: Different overlay package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                            linux419            4.19.46-1          4.19.46-1.0
                    linux419-headers            4.19.46-1          4.19.46-1.0

Also another rebuild of extramodules as vboxsf failed to load in the VM...

:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                  linux419-acpi_call             1.1.0-46           1.1.0-46.0
                   linux419-bbswitch               0.8-46             0.8-46.0
                linux419-broadcom-wl      6.30.223.271-46    6.30.223.271-46.0
                linux419-ndiswrapper              1.61-46            1.61-46.0
               linux419-nvidia-340xx           340.107-46         340.107-46.0
               linux419-nvidia-390xx           390.116-46         390.116-46.0
                   linux419-nvidiabl              0.88-46            0.88-46.0
                      linux419-r8168          8.047.01-46        8.047.01-46.0
                   linux419-tp_smapi              0.41-46            0.41-46.0
                linux419-vhba-module          20190410-46        20190410-46.0
   linux419-virtualbox-guest-modules             6.0.8-46           6.0.8-46.0
    linux419-virtualbox-host-modules             6.0.8-46           6.0.8-46.0
                        linux419-zfs             0.8.0-46           0.8.0-46.0

Sorry for the delay getting back to you.

Yes, I was trying to boot without nosplash quiet.
No, trying to boot to TTY did not work.

:hugs: 4.19.46-1.0 boots for me. Hopefully it is OK for @mocambo too.

@jonathon Thanks for all your hard work.

1 Like

Grand.

I'll have a look at epiphany but otherwise I think it's about time for a snap to x32-stable.

Edit:

Rebuilt epiphany:

:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                            epiphany                    -         3.32.1.2-1.1

Version 3.32.2 won't build due to a dependency on webkit2gtk-4.0 >= 2.24.1, which is the version where SSE2 is now required.

1 Like