[Testing Update i686] 2019-03-27 - Kernels

update
testing
manjaro32
#1

A new set of updates to test.

First batch is kernels.


Available kernels

Series Version PAE
linux316 3.16.65 No
linux318 3.18.137 No
linux44 4.4.177 No
linux49 4.9.166 No
linux414 4.14.109 No
linux419 4.19.32 Yes

Current difference to x32-stable

This thread will track updates to x32-testing as they are snapped over from x32-unstable
This post has a full difference to x32-stable, updates will be posted below as they occur.

Full list will be available here.


Any problems?

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Is x32-testing ready to be moved to x32-stable?

This will inform the snap process; there is no set threshold.

Please vote on the “is it ready yet?” poll but only when you feel this set is tested enough, and has a sufficient number of changes compared to x32-stable.

  • No or Not yet
  • Yes, x32-testing should be snapped to x32-stable at this point
  • Other (post)

0 voters

0 Likes

#2

Known issues

0 Likes

#3

Known to-do

0 Likes

#4
:: Different overlay package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                            linux316            3.16.63-0            3.16.64-1
                    linux316-headers            3.16.63-0            3.16.64-1
                            linux414           4.14.108-1           4.14.109-1
                    linux414-headers           4.14.108-1           4.14.109-1
                            linux419            4.19.31-1            4.19.32-1
                    linux419-headers            4.19.31-1            4.19.32-1
                             linux49            4.9.165-1            4.9.166-1
                     linux49-headers            4.9.165-1            4.9.166-1


:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                  linux316-acpi_call           1.1.0-48.0             1.1.0-64
                linux316-broadcom-wl    6.30.223.271-27.0      6.30.223.271-64
                linux316-ndiswrapper            1.61-27.0              1.61-64
               linux316-nvidia-340xx          340.107-6.0           340.107-64
                      linux316-r8168        8.045.08-13.0          8.045.08-64
                  linux316-rt3562sta      2.4.1.1_r4-27.0        2.4.1.1_r4-64
                        linux316-spl             0.7.13-1            0.7.13-64
                linux316-vhba-module        20161009-27.0          20161009-64
   linux316-virtualbox-guest-modules            6.0.4-1.0             6.0.4-64
    linux316-virtualbox-host-modules            6.0.4-1.0             6.0.4-64
                        linux316-zfs             0.7.13-1            0.7.13-64
                  linux414-acpi_call            1.1.0-108            1.1.0-109
                   linux414-bbswitch              0.8-108              0.8-109
                linux414-broadcom-wl     6.30.223.271-108     6.30.223.271-109
                linux414-ndiswrapper             1.61-108             1.61-109
               linux414-nvidia-340xx          340.107-108          340.107-109
                      linux414-r8168         8.045.08-108         8.045.08-109
                  linux414-rt3562sta       2.4.1.1_r4-108       2.4.1.1_r4-109
                        linux414-spl           0.7.13-108           0.7.13-109
                   linux414-tp_smapi             0.41-108             0.41-109
                linux414-vhba-module         20161009-108         20161009-109
   linux414-virtualbox-guest-modules            6.0.4-108            6.0.4-109
    linux414-virtualbox-host-modules            6.0.4-108            6.0.4-109
                        linux414-zfs           0.7.13-108           0.7.13-109
                  linux419-acpi_call             1.1.0-31             1.1.0-32
                   linux419-bbswitch               0.8-31               0.8-32
                linux419-broadcom-wl      6.30.223.271-31      6.30.223.271-32
                linux419-ndiswrapper              1.61-31              1.61-32
               linux419-nvidia-340xx           340.107-31           340.107-32
                   linux419-nvidiabl              0.88-31              0.88-32
                      linux419-r8168          8.045.08-31          8.045.08-32
                        linux419-spl            0.7.13-31            0.7.13-32
                   linux419-tp_smapi              0.41-31              0.41-32
                linux419-vhba-module          20161009-31          20161009-32
   linux419-virtualbox-guest-modules             6.0.4-31             6.0.4-32
    linux419-virtualbox-host-modules             6.0.4-31             6.0.4-32
                        linux419-zfs            0.7.13-31            0.7.13-32
                   linux49-acpi_call            1.1.0-165            1.1.0-166
                    linux49-bbswitch              0.8-165              0.8-166
                 linux49-broadcom-wl     6.30.223.271-165     6.30.223.271-166
                 linux49-ndiswrapper             1.61-165             1.61-166
                linux49-nvidia-340xx          340.107-165          340.107-166
                       linux49-r8168         8.045.08-165         8.045.08-166
                   linux49-rt3562sta       2.4.1.1_r4-165       2.4.1.1_r4-166
                         linux49-spl           0.7.13-165           0.7.13-166
                    linux49-tp_smapi             0.41-165             0.41-166
                 linux49-vhba-module         20161009-165         20161009-166
    linux49-virtualbox-guest-modules            6.0.4-165            6.0.4-166
     linux49-virtualbox-host-modules            6.0.4-165            6.0.4-166
                         linux49-zfs           0.7.13-165           0.7.13-166
                   ndiswrapper-utils              1.61-84             1.61-166
                    rt3562sta-common       2.4.1.1_r4-115       2.4.1.1_r4-166


:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                              falkon            3.1.0-1.0            3.1.0-3.0
                            help2man           1.47.8-1.0          1.47.10-1.0
                             libxres            1.2.0-1.1            1.2.0-1.2
                       pulseaudio-qt            1.0.0-1.0            1.0.1-1.0
                            wxmaxima          19.01.3-1.0          19.03.1-1.0
                                rust                    -         1:1.33.0-1.0
                           rust-docs                    -         1:1.33.0-1.0


:: Different sync package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                      acpi_call-dkms          1.1.0-200.0          1.1.0-201.0
                             aws-cli         1.16.122-1.0         1.16.130-1.0
                         broadcom-wl    6.30.223.271-87.0    6.30.223.271-88.0
                     deepin-anything            0.0.4-1.2            0.0.4-2.0
                deepin-anything-dkms            0.0.4-1.2            0.0.4-2.0
                          drbd-utils            9.7.0-1.0            9.8.0-1.0
                              drupal           8.6.12-1.0           8.6.13-1.0
                           glusterfs            1:5.5-1.0            1:6.0-1.0
                         google-glog            0.3.5-2.0            0.4.0-1.0
                              kcptun         20190321-1.0         20190325-1.0
                          kdeconnect            1.3.3-1.1            1.3.4-1.0
                         kvantum-qt5          0.10.10-1.0           0.11.0-1.0
                           leptonica           1.77.0-1.0           1.78.0-1.0
                             libgiac         1.5.0.47-1.1         1.5.0.49-1.0
                         lsp-plugins            1.1.7-1.0            1.1.9-1.0
             nextcloud-app-bookmarks         1:0.16.2-1.0         1:0.16.3-1.0
                     python-autobahn           19.1.1-1.0           19.3.3-1.0
                        python-boto3          1.9.112-1.0          1.9.120-1.0
                     python-botocore         1.12.112-1.0         1.12.120-1.0
                       python-dnslib            0.9.9-1.0           0.9.10-1.0
                     python-flexmock           0.10.3-1.1           0.10.4-1.0
                        python-ldap3            2.5.2-1.0              2.6-1.0
                  python-pytest-mock           1.10.1-1.0           1.10.2-1.0
                       python2-boto3          1.9.112-1.0          1.9.120-1.0
                    python2-botocore         1.12.112-1.0         1.12.120-1.0
                    python2-flexmock           0.10.3-1.1           0.10.4-1.0
                       python2-ldap3            2.5.2-1.0              2.6-1.0
                 python2-pytest-mock           1.10.1-1.0           1.10.2-1.0
                      rocksndiamonds          4.1.1.0-1.0          4.1.2.0-1.0
                        ruby-msgpack            1.2.8-1.1            1.2.9-1.0
                                rust         1:1.32.0-1.0                    -
                           rust-docs         1:1.32.0-1.0                    -
                                skim            0.6.2-1.0            0.6.4-1.0
                             skrooge           2.18.0-2.0           2.18.0-3.0
                    telegram-desktop            1.6.1-1.0            1.6.2-1.0
                                wine              4.3-1.0              4.4-1.0
                        wine-staging              4.3-1.0              4.4-1.0
                                xcas         1.5.0.47-1.1         1.5.0.49-1.0
1 Like

#5

Latest updates come up the following error.

warning: cannot resolve "libidn2.so=0-32", a dependency of "gnutls"
warning: cannot resolve "libidn2.so=0-32", a dependency of "gnutls"
warning: cannot resolve "libidn2.so=0-32", a dependency of "gnutls"
warning: cannot resolve "libidn2.so=0-32", a dependency of "libpsl"
warning: cannot resolve "libidn2.so=0-32", a dependency of "libpsl"
warning: cannot resolve "libidn2.so=0-32", a dependency of "gnutls"
warning: cannot resolve "libidn2.so=0-32", a dependency of "libpsl"
:: The following packages cannot be upgraded due to unresolvable dependencies:
      gnutls  libpsl

:: Do you want to skip the above packages for this upgrade? [y/N] y
looking for conflicting packages...

Packages (46) audacious-plugins-3.10.1-2.1  cabextract-1.9.1-1.0
              cpupower-5.0-1.0  cups-2.2.11-1.0  dnsmasq-2.80-3.0
              giflib-5.1.8-1.0  gpgme-1.12.0-2.2  iputils-20180629.f6aac8d-4.2
              kcmutils-5.56.0-2.0  libcups-2.2.11-1.0  libieee1284-0.2.11-7.6
              libimobiledevice-1.2.0+87+g92c5462-1.4  liblouis-3.8.0-1.4
              libnm-1.14.7dev+3+g353743b99-1.0
              libnm-glib-1.14.7dev+3+g353743b99-1.0  libproxy-0.4.15-8.6
              libteam-1.28-2.4  libtorrent-rasterbar-1:1.1.12-1.2
              libxml2-2.9.9-1.2  libxslt-1.1.33-1.4  man-db-2.8.5-2.0
              nano-4.0-1.0  ndctl-64.1-2.0  net-snmp-5.8-2.4
              networkmanager-1.14.7dev+3+g353743b99-1.0  openvpn-2.4.7-1.0
              pcsclite-1.8.25-1.0  postgresql-libs-11.2-1.0
              python-cffi-1.12.2-1.1  python-cryptography-2.6.1-1.1
              python-keyutils-0.5-3.5  python-urwid-2.0.1-2.4
              python-yaml-3.13-2.4  python2-2.7.16-1.1  python2-cffi-1.12.2-1.1
              python2-cryptography-2.6.1-1.1  s-nail-14.9.13-2.1
              sqlite-3.27.2-1.0  subversion-1.11.1-1.3  wget-1.20.1-3.1
              xf86-video-amdgpu-19.0.1-1.0  xf86-video-ati-1:19.0.1-1.0
              xf86-video-intel-1:2.99.917+863+g6afed33b-1.1
              xorg-server-1.20.4-1.0  xorg-server-common-1.20.4-1.0
              xorg-server-xvfb-1.20.4-1.0

I have updated without gnutls & libpsl presently. However, this error needs to be resolved. Thanks

0 Likes

#6

I don’t think those packages are in x32-testing yet… I’ll re-sync x32-unstable and see if the other packages come in.

1 Like

#7

Thank you for uploading both these packages. However, the error still persists and so the Package Manager fails to prepare the transaction. Thanks

0 Likes

#8

Kernel 4.19.32 seems fine on my T100 (Cinnamon DE over XFCE32.) Bluez (5.50-6) is also working again, along with adobe flash and firefox 66.0.1. It’s snap-able for me. Many Thanks!

0 Likes

#9
0 Likes

closed #10
0 Likes