[Testing Update i686] 2019-02-27 to 03-13 - Kernels, systemd, KDE, LibreOffice Fresh, Chromium

update
testing
manjaro32

#21

Some more KDE… things.

:: Different sync package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                           e2fsprogs           1.44.6-1.0           1.45.0-1.0


:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                              attica           5.55.0-1.1           5.56.0-1.1
                               baloo           5.55.0-1.0           5.56.0-1.0
                            bluez-qt           5.55.0-1.1           5.56.0-1.0
                            efitools            1.8.1-1.1            1.9.2-1.0
                   ffnvcodec-headers         9.0.18.0-1.0         9.0.18.1-1.0
                         foomatic-db       3:20190301-1.0       3:20190312-1.0
                 foomatic-db-nonfree       3:20190301-1.0       3:20190312-1.0
            foomatic-db-nonfree-ppds       3:20190301-1.0       3:20190312-1.0
                    foomatic-db-ppds       3:20190301-1.0       3:20190312-1.0
                frameworkintegration           5.55.0-1.1           5.56.0-1.0
                         kactivities           5.55.0-1.1           5.56.0-1.0
                   kactivities-stats           5.55.0-1.1           5.56.0-1.0
                            karchive           5.55.0-1.1           5.56.0-1.0
                               kauth           5.55.0-1.1           5.56.0-1.0
                          kbookmarks           5.55.0-1.1           5.56.0-1.0
                            kcmutils           5.55.0-1.1           5.56.0-1.0
                             kcodecs           5.55.0-1.1           5.56.0-1.0
                         kcompletion           5.55.0-1.1           5.56.0-1.0
                             kconfig           5.55.0-1.1           5.56.0-1.0
                      kconfigwidgets           5.55.0-1.1           5.56.0-1.0
                         kcoreaddons           5.55.0-1.1           5.56.0-1.0
                              kcrash           5.55.0-1.1           5.56.0-1.0
                         kdbusaddons           5.55.0-1.1           5.56.0-1.0
                        kdeclarative           5.55.0-1.1           5.56.0-1.0
                                kded           5.55.0-1.0           5.56.0-1.0
                     kdesignerplugin           5.55.0-1.0           5.56.0-1.0
                               kdesu           5.55.0-1.1           5.56.0-1.0
                           kdewebkit           5.55.0-1.0           5.56.0-1.0
                              kdnssd           5.55.0-1.1           5.56.0-1.0
                           kdoctools           5.55.0-1.2           5.56.0-1.0
                          kemoticons           5.55.0-1.1           5.56.0-1.0
                       kfilemetadata           5.55.0-1.0           5.56.0-1.0
                        kglobalaccel           5.55.0-1.1           5.56.0-1.0
                          kguiaddons           5.55.0-1.1           5.56.0-1.1
                           kholidays         1:5.55.0-1.1         1:5.56.0-1.0
                               ki18n           5.55.0-1.1           5.56.0-1.0
                         kiconthemes           5.55.0-1.1           5.56.0-1.0
                           kidletime           5.55.0-1.1           5.56.0-1.0
                       kimageformats           5.55.0-1.0           5.56.0-1.0
                               kinit           5.55.0-1.0           5.56.0-1.0
                                 kio           5.55.0-1.1           5.56.0-1.0
                           kirigami2           5.55.0-1.1           5.56.0-2.0
                         kitemmodels           5.55.0-1.1           5.56.0-1.0
                          kitemviews           5.55.0-1.1           5.56.0-1.0
                         kjobwidgets           5.55.0-1.1           5.56.0-1.0
                                 kjs           5.55.0-1.1           5.56.0-1.0
                            kjsembed           5.55.0-1.1           5.56.0-1.0
                           knewstuff           5.55.0-1.1           5.56.0-1.0
                      knotifications           5.55.0-1.1           5.56.0-1.0
                            kpackage           5.55.0-1.1           5.56.0-1.0
                              kparts           5.55.0-1.1           5.56.0-1.0
                           kplotting           5.55.0-1.0           5.56.0-1.0
                                kpty           5.55.0-1.1           5.56.0-1.0
                            kservice           5.55.0-1.1           5.56.0-1.0
                        ktextwidgets           5.55.0-1.1           5.56.0-1.0
                     kunitconversion           5.55.0-1.1           5.56.0-1.0
                             kwallet           5.55.0-1.1           5.56.0-1.0
                            kwayland           5.55.0-1.1           5.56.0-1.0
                      kwidgetsaddons           5.55.0-1.1           5.56.0-1.0
                       kwindowsystem           5.55.0-1.1           5.56.0-1.0
                             kxmlgui           5.55.0-1.1           5.56.0-1.0
                                 ldb          1:1.4.3-1.3          1:1.4.6-1.0
                             librsvg        2:2.44.13-1.4        2:2.44.13-1.5
                  libva-vdpau-driver            0.7.4-3.1            0.7.4-4.0
                         libwbclient            4.9.4-2.0            4.9.5-1.0
                       libxcomposite            0.4.4-3.1            0.4.5-1.0
                          libxcursor           1.1.15-1.1            1.2.0-1.0
                          libxdamage            1.1.4-3.1            1.1.5-1.0
                            lua-lpeg            1.0.1-2.1            1.0.2-1.0
                          lua51-lpeg            1.0.1-2.1            1.0.2-1.0
                          lua52-lpeg            1.0.1-2.1            1.0.2-1.0
                     modemmanager-qt           5.55.0-1.1           5.56.0-1.0
                   networkmanager-qt           5.55.0-1.1           5.56.0-1.0
                              prison           5.55.0-1.1           5.56.0-1.0
                  qqc2-desktop-style           5.55.0-1.0           5.56.0-1.0
                                   r            3.5.2-2.1            3.5.3-1.0
                               samba            4.9.4-2.1            4.9.5-1.0
                         sbsigntools            0.9.1-1.1            0.9.2-1.0
                           smbclient            4.9.4-2.1            4.9.5-1.0
                               solid           5.55.0-1.1           5.56.0-1.0
                              sonnet           5.55.0-1.1           5.56.0-1.0
                         syndication           5.55.0-1.0           5.56.0-1.0
                 syntax-highlighting           5.55.0-1.1           5.56.0-1.0
                              talloc           2.1.14-1.4           2.1.16-1.0
                                 tdb           1.3.16-1.4           1.3.18-1.0
                              tevent         1:0.9.37-1.4         1:0.9.39-1.0
                        threadweaver           5.55.0-1.1           5.56.0-1.0


:: Different sync package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                         aj-snapshot            0.9.8-1.1            0.9.9-1.0
                             aws-cli         1.16.117-1.0         1.16.122-1.0
                deepin-network-utils            0.0.9-1.0            0.1.0-1.0
                                 dtc            1.4.6-1.0            1.5.0-1.0
                                fltk          1.3.4.2-3.1            1.3.5-1.0
                           fltk-docs          1.3.4.2-3.1            1.3.5-1.0
                               fstrm            0.4.0-1.2            0.5.0-1.0
                         gnome-latex           3.30.2-1.1           3.32.0-1.0
                              gpxsee              7.3-1.0              7.4-1.0
                          libmanette            0.2.1-1.2            0.2.2-1.0
                       livewallpaper        0.5.0.333-1.0        0.5.0.333-2.0
                      magnum-plugins          2018.10-1.0          2019.01-1.0
                                mxml             2.12-1.2              3.0-1.0
              nextcloud-app-contacts            3.0.3-1.0            3.0.5-1.0
                              polyml            5.7.1-2.1              5.8-1.0
                      python-awkward           0.8.10-1.0           0.8.11-1.0
                        python-boto3          1.9.107-1.0          1.9.112-1.0
                     python-botocore         1.12.107-1.0         1.12.112-1.0
                      python-certifi       2018.11.29-1.0         2019.3.9-1.0
            python-flask-marshmallow            0.9.0-1.0           0.10.0-1.0
                   python-hypothesis            4.9.0-1.0           4.10.0-1.0
                 python-phonenumbers           8.10.6-1.0           8.10.7-1.0
                        python-redis           2.10.6-2.0            3.2.0-1.1
                       python2-boto3          1.9.107-1.0          1.9.112-1.0
                    python2-botocore         1.12.107-1.0         1.12.112-1.0
                     python2-certifi       2018.11.29-1.0         2019.3.9-1.0
                  python2-hypothesis            4.9.0-1.0           4.10.0-1.0
                python2-phonenumbers           8.10.6-1.0           8.10.7-1.0
                       python2-redis           2.10.6-2.0            3.2.0-1.1
                            qjackctl            0.5.5-1.0            0.5.6-1.0
                            qsampler            0.5.3-1.0            0.5.4-1.0
                              qsynth            0.5.4-2.0            0.5.5-1.0
                             qxgedit            0.5.2-1.1            0.5.3-1.0
                           retro-gtk           0.16.0-1.1           0.16.1-1.0
                  ruby-cairo-gobject            3.3.2-1.0            3.3.3-1.0
                           ruby-gdk3            3.3.2-1.0            3.3.3-1.0
                    ruby-gdk_pixbuf2            3.3.2-1.0            3.3.3-1.0
                           ruby-gio2            3.3.2-1.0            3.3.3-1.0
          ruby-gobject-introspection            3.3.2-1.0            3.3.3-1.0
                           ruby-gtk2            3.3.2-1.0            3.3.3-1.0
                        ruby-msgpack            1.2.7-1.0            1.2.8-1.0
                          ruby-pango            3.3.2-1.0            3.3.3-1.0
                                sway           0.15.2-3.0              1.0-3.0
                              sysdig           0.24.2-1.0           0.24.2-2.0
                           terraform          0.11.12-1.0          0.11.13-1.0
                                 tlp              1.1-1.1              1.2-1.0
                             tlp-rdw              1.1-1.1              1.2-1.0
                          unrealircd            4.2.1-1.0            4.2.2-1.0
                             wlroots            0.4.1-1.0            0.5.0-1.0
                              xdebug         2.7.0rc2-1.0            2.7.0-1.0
                               xfmpc            0.2.3-3.0           0.2.90-1.0
                             yoshimi           1.5.10-2.1         1.5.10.2-1.0
                     yubikey-manager            2.0.0-1.0            2.1.0-1.0
                  yubikey-manager-qt            1.1.0-1.0            1.1.1-1.0

#22

Something is wrong with NetworkManager. After suspend-resume cycle system can’t handle DNS queries. Ping works, web surfing using ip addresses works.
Problem is gone after computer restart and appears again after suspend-resume cycle.


#23

Another sync is needed to complete the KDE5 Framework packages upgrade to 5.56 - they’re already there in arch32.

Other than that, I think KDE is ready for x32-stable.


#24

“suspend” to disk or ram??


#25

This should be the last of them:

:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                           bluedevil         1:5.15.2-1.0         1:5.15.3-1.0
                              breeze           5.15.2-1.1           5.15.3-1.0
                         breeze-grub           5.15.2-1.0           5.15.3-1.0
                          breeze-gtk           5.15.2-1.0           5.15.3-1.0
                            discover           5.15.2-1.0           5.15.3-1.0
                             drkonqi           5.15.2-1.0           5.15.3-1.0
                   kactivitymanagerd           5.15.2-1.0           5.15.3-1.0
                         kdecoration           5.15.2-1.1           5.15.3-1.0
                     kdelibs4support           5.55.0-1.1           5.56.0-1.0
                            kdevelop            5.3.2-1.0            5.3.2-2.0
                           kdoctools           5.56.0-1.0           5.56.0-2.0
                             kgamma5           5.15.2-1.0           5.15.3-1.0
                               khtml           5.55.0-1.1           5.56.0-1.0
                         kinfocenter           5.15.2-1.0           5.15.3-1.0
                        kmediaplayer           5.55.0-1.0           5.56.0-1.0
                       knotifyconfig           5.55.0-1.1           5.56.0-1.0
                             kpeople           5.55.0-1.1           5.56.0-1.0
                               kross           5.55.0-1.1           5.56.0-1.0
                             krunner           5.55.0-1.1           5.56.0-1.0
                             kscreen           5.15.2-1.0           5.15.3-1.0
                       kscreenlocker           5.15.2-1.1           5.15.3-1.0
                         ksshaskpass           5.15.2-1.0           5.15.3-1.0
                           ksysguard           5.15.2-1.0           5.15.3-1.0
                         ktexteditor           5.55.0-1.1           5.56.0-1.0
                         kwallet-pam           5.15.2-1.0           5.15.3-1.0
                kwayland-integration           5.15.2-1.0           5.15.3-1.0
                                kwin           5.15.2-1.1           5.15.3-1.0
                             kwrited           5.15.2-1.0           5.15.3-1.0
                       kxmlrpcclient           5.55.0-1.0           5.56.0-1.0
                             libebml            1.3.6-1.1            1.3.7-1.0
                          libkscreen           5.15.2-1.1           5.15.3-1.0
                        libksysguard           5.15.2-1.0           5.15.3-1.0
                         libmatroska            1.4.9-1.1            1.5.0-1.0
                               milou           5.15.2-1.1           5.15.3-1.0
                      mkvtoolnix-cli           31.0.0-1.0           32.0.0-1.0
                      mkvtoolnix-gui           31.0.0-1.0           32.0.0-1.0
                              okteta         1:0.25.5-1.1         1:0.26.0-1.0
                              oxygen           5.15.2-1.1           5.15.3-1.0
          plasma-browser-integration           5.15.2-1.0           5.15.3-1.0
                    plasma-framework           5.55.0-1.1           5.56.0-3.0
                  plasma-integration           5.15.2-1.0           5.15.3-1.0
                          plasma-sdk           5.15.2-1.0           5.15.3-1.0
         plasma-workspace-wallpapers           5.15.2-1.0           5.15.3-1.0
                    polkit-kde-agent           5.15.2-1.0           5.15.3-1.0
                             purpose           5.55.0-1.1           5.56.0-1.0
                        python-cairo           1.18.0-1.1           1.18.0-1.2
                       python2-cairo           1.18.0-1.1           1.18.0-1.2
                            sddm-kcm           5.15.2-1.0           5.15.3-1.0
                        user-manager           5.15.2-1.0           5.15.3-1.0
              xdg-desktop-portal-kde           5.15.2-1.0           5.15.3-1.0


:: Different sync package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                                cgns            3.3.1-7.0            3.4.0-1.0
                       deepin-topbar            0.6.2-1.0            0.6.2-2.0
                               glava            1.6.0-1.0            1.6.3-1.0
                           musescore            3.0.4-1.0            3.0.5-1.0
                             netdata           1.12.1-1.0           1.12.2-1.0
                   npm-check-updates            3.0.4-1.0            3.0.5-1.0
                    pyopencl-headers       1:2018.2.2-1.2       1:2018.2.5-1.0
                    python-cysignals           1.10.0-1.0           1.10.1-1.0
                       python-psutil            5.5.0-1.1            5.6.0-1.0
                    python-pykeepass            3.0.3-1.0            3.0.3-2.0
                     python-pyopencl       1:2018.2.2-1.2       1:2018.2.5-1.0
                       python-pytest            4.3.0-1.0            4.3.1-1.0
                   python2-cysignals           1.10.0-1.0           1.10.1-1.0
                      python2-psutil            5.5.0-1.1            5.6.0-1.0
                      python2-pytest            4.3.0-1.0            4.3.1-1.0
                             unbound            1.9.0-1.0            1.9.1-1.0

#26

Good old Debian and their amazing maintainers providing patches to keep things building:

:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                            chromium                    -       73.0.3683.75-0

#27

Dont know why, but latest systemd build strongly requires resolving DNSSEC queries, which are not supported by my ISP. So disabling DNSSEC in systemd-resolv fixes my problem.
Thanks for attention ! :smile:


#28

Weird how it works on first boot though - systemd should also fall back if DNSSEC isn’t supported by the DNS server…

Anyhow, I’m pushing over to x32-stable now. :slight_smile:


#29

I had also dnsmasq installed (which i have removed now), probably it helped to resolve DNS at boot and doesn’t do it after suspend-resume.


#30

Big KDE VM update applied successfully, no issues after a couple of minutes usage.


closed #31