[Testing Update i686] 2018-12-19 to 2019-01-25 - Systemd, Kernels, LibreOffice Fresh, Readline, Firefox

update
testing
manjaro32

#61

That should have been fixed by the rebuilt systemd package 240.191-1.0. :confused:


#62

I have been ignoring systemd as it breaks lightdm for me (see post 18 above), I will give it another go.

OK - systemd package 240.191-1.0 solves the libidn2.so.0 problem but it does still break lightdm. I tried replacing dbus with dbus-x11 but without success.

I have currently uninstalled lightdm, lightdm-locker and lightdm-gtk-greeter so that I can at least login and startx manually.


#63

178 package update … holding breath … success!

Only issue …

warning: cannot resolve "firefox>=64.0.2", a dependency of "firefox-i18n-en-us"
:: The following package cannot be upgraded due to unresolvable dependencies:
      firefox-i18n-en-us

:: Do you want to skip the above package for this upgrade? [y/N] y
Name            : firefox
Version         : 64.0-0
Name            : firefox-i18n-en-us
Version         : 64.0-0
Depends On      : firefox>=64.0

#64

I haven’t got Firefox to build yet - the PKGBUILD has switched from GCC to Clang and it runs out of memory (and the various tricks I’ve used for other things haven’t worked so far…).


#65

This is weird. systemd shouldn’t be breaking LightDM, and it works on my VM and EeePC901.

What hardware do you have?


#66

Hardware details.

inxi -Fx
  flags: nx pae sse sse2 sse3 bogomips: 6385 
  Speed: 798 MHz min/max: 800/1600 MHz Core speeds (MHz): 1: 799 2: 807 
Graphics:
  Device-1: Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics 
  vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
  Display: tty server: X.org 1.20.3 driver: intel unloaded: modesetting 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel 945GM x86/MMX/SSE2 v: 1.4 Mesa 18.3.1 
  direct render: Yes 
Audio:
  Device-1: Intel NM10/ICH7 Family High Definition Audio 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  bus ID: 00:1b.0 
  Sound Server: ALSA v: k4.19.15-1-MANJARO 
Network:
  Device-1: Intel PRO/Wireless 3945ABG [Golan] Network driver: iwl3945 
  v: in-tree:ds port: 5420 bus ID: 05:00.0 
  IF: wlp5s0 state: up mac: 00:18:de:ab:89:05 
  Device-2: Broadcom and subsidiaries BCM4401-B0 100Base-TX 
  vendor: Acer Incorporated ALI driver: b44 v: 2.0 port: 5420 
  bus ID: 06:01.0 
  IF-ID-1: eth0 state: up speed: 100 Mbps duplex: full 
  mac: <> 
Drives:
  Local Storage: total: 74.53 GiB used: 47.48 GiB (63.7%) 
  ID-1: /dev/sda vendor: Hitachi model: HTS541680J9SA00 size: 74.53 GiB 
Partition:
  ID-1: / size: 9.62 GiB used: 6.23 GiB (64.8%) fs: ext4 dev: /dev/sda2 
  ID-2: /home size: 51.80 GiB used: 41.09 GiB (79.3%) fs: ext4 
  dev: /dev/sda4 
  ID-3: swap-1 size: 1.97 GiB used: 166.2 MiB (8.2%) fs: swap dev: /dev/sda5 
Sensors:
  System Temperatures: cpu: 38.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 141 Uptime: 1h 11m Memory: 921.9 MiB used: 328.2 MiB (35.6%) 
  Init: systemd Compilers: gcc: 8.2.1 Shell: bash v: 5.0.0 inxi: 3.0.28

Dump appears to be in lightdm-gtk-greeter.

Details from log

Process 736 (lightdm-gtk-gre) of user 620 dumped core.

Stack trace of thread 736:
#0 0x00000000b7157b25 n/a (libglib-2.0.so.0)
#1 0x00000000b714c230 g_log_default_handler (libglib-2.0.so.0)
#2 0x00000000b7157d7d g_logv (libglib-2.0.so.0)
#3 0x00000000b7157f55 g_log (libglib-2.0.so.0)
#4 0x00000000b713e67a g_thread_new (libglib-2.0.so.0)
#5 0x00000000b715ea1e n/a (libglib-2.0.so.0)
#6 0x00000000b715ea7a n/a (libglib-2.0.so.0)
#7 0x00000000b71138d7 g_unix_signal_source_new (libglib-2.0.so.0)
#8 0x00000000b71163ef g_unix_signal_add_full (libglib-2.0.so.0)
#9 0x00000000b7116463 g_unix_signal_add (libglib-2.0.so.0)
#10 0x0000000000465145 main (lightdm-gtk-greeter)
#11 0x00000000b6cb3a49 __libc_start_main (libc.so.6)
#12 0x00000000004677f5 _start (lightdm-gtk-greeter)

Tried just installing lightdm but it still fails:

systemctl

● lightdm.service - Light Display Manager
Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Wed 2019-01-16 12:29:37 GMT; 1min 54s ago
Docs: man:lightdm(1)
Process: 789 ExecStart=/usr/bin/lightdm (code=exited, status=1/FAILURE)
Main PID: 789 (code=exited, status=1/FAILURE)

Jan 16 12:29:37 Laptop1 systemd[1]: lightdm.service: Main process exited, code=exited, status=1/FAILURE
Jan 16 12:29:37 Laptop1 systemd[1]: lightdm.service: Failed with result ‘exit-code’.
Jan 16 12:29:37 Laptop1 systemd[1]: Failed to start Light Display Manager.
Jan 16 12:29:37 Laptop1 systemd[1]: lightdm.service: Service RestartSec=100ms expired, scheduling restart.
Jan 16 12:29:37 Laptop1 systemd[1]: lightdm.service: Scheduled restart job, restart counter is at 5.
Jan 16 12:29:37 Laptop1 systemd[1]: Stopped Light Display Manager.
Jan 16 12:29:37 Laptop1 systemd[1]: lightdm.service: Start request repeated too quickly.
Jan 16 12:29:37 Laptop1 systemd[1]: lightdm.service: Failed with result ‘exit-code’.
Jan 16 12:29:37 Laptop1 systemd[1]: Failed to start Light Display Manager.


#67

…core dumps whenever I attempt to log out…


#68

Unleash da inxi porn beast … :grin:


#69

Would it be worth downgrading glib2 for testing???

UPDATE: NOT A GOOD THING TO TRY!!!


#70

Didn’t this happen & was circumvented in the recent past also???


#71

That’s fine, up until you hit the 32-bit memory limit of 3GB. :wink:

Yes; different compilers need different tweaks. The Firefox PKGBUILD switched from GCC to Clang, hence the “old” tricks no longer work.


#72

Ah … of course … :man_facepalming:


#73

Another sizeable update in the search of a buildable Firefox and fixed systemd:

:: Different overlay package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                          libsystemd          240.191-1.0            240.275-1
                            linux414            4.14.93-1            4.14.94-1
                    linux414-headers            4.14.93-1            4.14.94-1
                            linux419            4.19.15-1            4.19.16-1
                    linux419-headers            4.19.15-1            4.19.16-1
                             linux44            4.4.170-0            4.4.171-0
                     linux44-headers            4.4.170-0            4.4.171-0
                             linux49            4.9.150-1            4.9.151-1
                     linux49-headers            4.9.150-1            4.9.151-1
                             systemd          240.191-1.0            240.275-1
                  systemd-resolvconf          240.191-1.0            240.275-1
                  systemd-sysvcompat          240.191-1.0            240.275-1


:: Different sync package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                                bash            5.0.0-1.3            5.0.0-1.4
                                gawk            4.2.1-2.2            4.2.1-2.3
                                gdbm           1.18.1-2.1           1.18.1-2.3
                             libldap           2.4.46-2.1           2.4.47-1.0
                          libsystemd           240.34-2.0           240.34-3.4
                                lvm2         2.02.183-2.2         2.02.183-2.4
                            openldap           2.4.46-2.1           2.4.47-1.0
                                sudo           1.8.26-2.0           1.8.27-1.0
                             systemd           240.34-3.1           240.34-3.4
                  systemd-resolvconf           240.34-2.0           240.34-3.4
                  systemd-sysvcompat           240.34-2.0           240.34-3.4
                                 tar             1.31-1.0             1.31-2.0
                          util-linux           2.33.1-2.2           2.33.1-2.3
                            xfsprogs           4.19.0-2.2           4.19.0-2.3


:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                           calamares              3.2.3-4              3.2.3-5
                       calamares-git3.2.4.r5223.903291301-13.2.4.r5241.067ca1611-1
                  linux414-acpi_call             1.1.0-75             1.1.0-76
                   linux414-bbswitch               0.8-75               0.8-76
                linux414-broadcom-wl      6.30.223.271-75      6.30.223.271-76
                linux414-ndiswrapper              1.61-75              1.61-76
               linux414-nvidia-340xx           340.107-34           340.107-35
               linux414-nvidia-390xx            390.87-20            390.87-21
                      linux414-r8168          8.045.08-63          8.045.08-64
                  linux414-rt3562sta        2.4.1.1_r4-75        2.4.1.1_r4-76
                        linux414-spl             0.7.12-4             0.7.12-5
                   linux414-tp_smapi              0.41-75              0.41-76
                linux414-vhba-module          20161009-75          20161009-76
                        linux414-zfs             0.7.12-4             0.7.12-5
                  linux419-acpi_call             1.1.0-12           1.1.0-12.0
                   linux419-bbswitch               0.8-12             0.8-12.0
                linux419-broadcom-wl      6.30.223.271-12    6.30.223.271-12.0
                linux419-ndiswrapper              1.61-12            1.61-12.0
               linux419-nvidia-340xx           340.107-12         340.107-12.0
                   linux419-nvidiabl              0.88-12            0.88-12.0
                      linux419-r8168          8.045.08-12        8.045.08-12.0
                        linux419-spl             0.7.12-4           0.7.12-4.0
                   linux419-tp_smapi              0.41-12            0.41-12.0
                linux419-vhba-module          20161009-12        20161009-12.0
   linux419-virtualbox-guest-modules              6.0.0-4            6.0.0-4.0
    linux419-virtualbox-host-modules              6.0.0-4            6.0.0-4.0
                        linux419-zfs             0.7.12-4           0.7.12-4.0
                   linux44-acpi_call          1.1.0-117.0          1.1.0-117.1
                 linux44-broadcom-wl    6.30.223.271-87.0    6.30.223.271-87.1
                 linux44-ndiswrapper            1.61-85.0            1.61-85.1
                       linux44-r8168        8.045.08-39.0        8.045.08-39.1
                   linux44-rt3562sta      2.4.1.1_r4-85.0      2.4.1.1_r4-85.1
                         linux44-spl           0.7.12-1.0           0.7.12-1.1
                 linux44-vhba-module        20161009-85.0        20161009-85.1
                         linux44-zfs           0.7.12-1.0           0.7.12-1.1
                   linux49-acpi_call            1.1.0-109            1.1.0-110
                    linux49-bbswitch              0.8-109              0.8-110
                 linux49-broadcom-wl     6.30.223.271-109   6.30.223.271-110.1
                    linux49-catalyst    1:15.201.1151-109    1:15.201.1151-110
                 linux49-ndiswrapper             1.61-107             1.61-108
                linux49-nvidia-340xx           340.107-28           340.107-29
                linux49-nvidia-390xx            390.87-17            390.87-18
                       linux49-r8168          8.045.08-49          8.045.08-50
                   linux49-rt3562sta       2.4.1.1_r4-107       2.4.1.1_r4-108
                         linux49-spl             0.7.12-2             0.7.12-3
                    linux49-tp_smapi             0.41-109             0.41-110
                 linux49-vhba-module         20161009-107         20161009-108
                         linux49-zfs             0.7.12-2             0.7.12-3
                   ndiswrapper-utils              1.61-75              1.61-76
                    rt3562sta-common       2.4.1.1_r4-107       2.4.1.1_r4-108
                         thunar-gtk3              1.8.2-8              1.8.2-9
                      xfdesktop-gtk3            4.13.2-13            4.13.2-14
                            linux419                    -            4.19.16-1
                    linux419-headers                    -            4.19.16-1


:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                     accountsservice0.6.54+2+g204a4ab-1.00.6.54+2+g204a4ab-2.0
                               avahi  0.7+16+g1cc2b8e-2.2  0.7+18+g1b5f401-1.0
                                  bc           1.07.1-3.2           1.07.1-3.3
                               boost           1.68.0-2.1           1.69.0-1.0
                          boost-libs           1.68.0-2.1           1.69.0-1.0
                               dmapi             2.2.12-2           2.2.12-3.0
                               ekiga           4.0.1-31.0           4.0.1-32.0
                 extra-cmake-modules           5.53.0-1.0           5.54.0-1.0
                               finch           2.13.0-5.0           2.13.0-5.1
                             flatpak            1.1.2-1.0            1.1.3-2.0
                     flatpak-builder            1.0.1-1.0            1.0.2-1.0
                                 gdm           3.30.2-1.0           3.30.2-2.0
               gnome-online-accounts           3.30.0-1.0           3.30.1-1.0
                             gsfonts         20180524-1.0         20180524-2.0
                                gvfs           1.38.1-1.11.38.1+8+ge4eec2bc-1.0
                            gvfs-afc           1.38.1-1.11.38.1+8+ge4eec2bc-1.0
                            gvfs-goa           1.38.1-1.11.38.1+8+ge4eec2bc-1.0
                         gvfs-google           1.38.1-1.11.38.1+8+ge4eec2bc-1.0
                        gvfs-gphoto2           1.38.1-1.11.38.1+8+ge4eec2bc-1.0
                            gvfs-mtp           1.38.1-1.11.38.1+8+ge4eec2bc-1.0
                            gvfs-nfs           1.38.1-1.11.38.1+8+ge4eec2bc-1.0
                            gvfs-smb           1.38.1-1.11.38.1+8+ge4eec2bc-1.0
                                js60           60.4.0-1.0           60.4.0-2.0
                             libcmis            0.5.2-1.0            0.5.2-2.0
                              libgdm           3.30.2-1.0           3.30.2-2.0
                          libisoburn            1.5.0-2.1            1.5.0-2.2
                            libixion           0.14.1-1.0           0.14.1-2.0
                         libkolabxml            1.1.6-9.2           1.1.6-10.0
                            liborcus           0.14.1-1.0           0.14.1-2.0
                      libphonenumber           8.10.1-1.0           8.10.1-2.0
                              libpst           0.6.72-1.0           0.6.72-2.0
                         libpst-docs           0.6.72-1.0           0.6.72-2.0
                           libpurple           2.13.0-5.0           2.13.0-5.1
                   libreoffice-fresh            6.1.4-1.0            6.1.4-2.0
               libreoffice-fresh-sdk            6.1.4-1.0            6.1.4-2.0
                             libteam             1.28-1.0             1.28-2.0
                libtorrent-rasterbar         1:1.1.11-1.0         1:1.1.11-2.0
                             libxml2            2.9.8-8.2            2.9.8-8.3
                                licq           1.8.2-21.1           1.8.2-22.0
                           mercurial            4.8.1-1.0            4.8.2-1.0
                               meson           0.49.0-1.0           0.49.0-2.0
                      mkvtoolnix-cli           30.1.0-1.0           30.1.0-2.0
                      mkvtoolnix-gui           30.1.0-1.0           30.1.0-2.0
      mobile-broadband-provider-info         20170310-2.0         20190116-1.0
                                nasm          2.13.03-1.2             2.14-1.0
          networkmanager-openconnect            1.2.4-3.1            1.2.4-4.0
              networkmanager-openvpn            1.8.8-1.0            1.8.8-2.0
                 networkmanager-pptp            1.2.8-1.0            1.2.8-2.0
                 networkmanager-vpnc            1.2.6-1.1            1.2.6-2.0
                              ostree           2018.9-1.0           2019.1-1.0
                              pidgin           2.13.0-5.0           2.13.0-5.1
                           qtcreator            4.8.0-2.0            4.8.1-1.0
                               rtkit  0.11+8+ge0a51fe-1.1 0.11+10+g493a135-1.0
                    source-highlight           3.1.8-17.2           3.1.8-18.0
                              spglib           1.11.2-1.0         1.11.2.1-1.0
                      totem-plparser3.26.1+2+gb7f36dd-1.0           3.26.2-1.0
                      xdg-dbus-proxy            0.1.0-1.1            0.1.1-1.0
                           zxing-cpp            1.0.2-1.0            1.0.3-1.0


:: Different overlay package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                            cinnamon            4.0.8-1.0            4.0.9-1.3
                 deepin-desktop-base       3:2018.10.29-1       3:2019.01.16-1
                                inxi             3.0.28-1             3.0.30-1
             manjaro-budgie-settings           20190103-1           20190119-1
                        palemoon-bin             28.2.2-1             28.3.0-1
                    palemoon-i18n-ar             28.2.2-1             28.3.0-1
                    palemoon-i18n-bg             28.2.2-1             28.3.0-1
                    palemoon-i18n-cs             28.2.2-1             28.3.0-1
                    palemoon-i18n-da             28.2.2-1             28.3.0-1
                    palemoon-i18n-de             28.2.2-1             28.3.0-1
                    palemoon-i18n-el             28.2.2-1             28.3.0-1
                 palemoon-i18n-en-gb             28.2.2-1             28.3.0-1
                 palemoon-i18n-es-ar             28.2.2-1             28.3.0-1
                 palemoon-i18n-es-es             28.2.2-1             28.3.0-1
                 palemoon-i18n-es-mx             28.2.2-1             28.3.0-1
                    palemoon-i18n-fi             28.2.2-1             28.3.0-1
                    palemoon-i18n-fr             28.2.2-1             28.3.0-1
                    palemoon-i18n-gl             28.2.2-1             28.3.0-1
                    palemoon-i18n-hr             28.2.2-1             28.3.0-1
                    palemoon-i18n-hu             28.2.2-1             28.3.0-1
                    palemoon-i18n-id             28.2.2-1             28.3.0-1
                    palemoon-i18n-is             28.2.2-1             28.3.0-1
                    palemoon-i18n-it             28.2.2-1             28.3.0-1
                    palemoon-i18n-ja             28.2.2-1             28.3.0-1
                    palemoon-i18n-kn             28.2.2-1             28.3.0-1
                    palemoon-i18n-ko             28.2.2-1             28.3.0-1
                    palemoon-i18n-nl             28.2.2-1             28.3.0-1
                    palemoon-i18n-pl             28.2.2-1             28.3.0-1
                 palemoon-i18n-pt-br             28.2.2-1             28.3.0-1
                 palemoon-i18n-pt-pt             28.2.2-1             28.3.0-1
                    palemoon-i18n-ro             28.2.2-1             28.3.0-1
                    palemoon-i18n-ru             28.2.2-1             28.3.0-1
                    palemoon-i18n-sk             28.2.2-1             28.3.0-1
                    palemoon-i18n-sl             28.2.2-1             28.3.0-1
                    palemoon-i18n-sr             28.2.2-1             28.3.0-1
                 palemoon-i18n-sv-se             28.2.2-1             28.3.0-1
                    palemoon-i18n-tl             28.2.2-1             28.3.0-1
                    palemoon-i18n-tr             28.2.2-1             28.3.0-1
                    palemoon-i18n-uk             28.2.2-1             28.3.0-1
                    palemoon-i18n-vi             28.2.2-1             28.3.0-1
                 palemoon-i18n-zh-cn             28.2.2-1             28.3.0-1
                 palemoon-i18n-zh-tw             28.2.2-1             28.3.0-1
                                rust                    -           1:1.32.0-0
                           rust-docs                    -           1:1.32.0-0


:: Different sync package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                                 0ad            a23.1-1.0            a23.1-2.0
               aarch64-linux-gnu-gcc            8.2.0-2.1            8.2.0-3.0
                      acpi_call-dkms          1.1.0-184.0          1.1.0-185.0
                            adriconf              1.3-5.0              1.3-6.0
                             aegisub           3.2.2-31.0           3.2.2-32.0
                               amule            11004-3.1            11004-4.0
                     arduino-builder            1.4.1-1.0            1.4.3-1.0
                           asciinema            2.0.1-2.0            2.0.2-1.0
                                atop            2.3.0-3.0            2.4.0-1.0
                             aws-cli          1.16.84-1.0          1.16.89-1.0
                         bitcoin-cli           0.16.3-1.0           0.16.3-2.0
                      bitcoin-daemon           0.16.3-1.0           0.16.3-2.0
                          bitcoin-qt           0.16.3-1.0           0.16.3-2.0
                          bitcoin-tx           0.16.3-1.0           0.16.3-2.0
                             blender17:2.79.b.git4.2c0c1f49-2.017:2.79.b.git4.2c0c1f49-3.0
                         broadcom-wl    6.30.223.271-71.0    6.30.223.271-72.0
                                btfs             2.18-4.0             2.18-5.0
                              bwm-ng            0.6.1-3.1            0.6.2-1.0
                              cclive           0.9.3-18.0           0.9.3-19.0
                        cdemu-daemon            3.2.1-1.1            3.2.1-2.0
                                cgal             4.13-1.0             4.13-2.0
                           cpp-hocon            0.2.1-1.0            0.2.1-2.0
                      cryptominisat5            5.6.6-1.0            5.6.6-2.0
                deepin-anything-arch            0.0.3-4.0            0.0.3-5.0
                              drupal            8.6.5-1.0            8.6.7-1.0
                          easystroke           0.6.0-19.1           0.6.0-20.0
                               eclib         20180815-3.0         20180815-4.0
                              embree            3.3.0-1.0            3.4.0-1.0
                             esptool            2.5.1-1.0              2.6-1.0
                                 fff              1.0-1.0              1.2-1.0
                            frogatto           1.3.1-27.0           1.3.1-28.0
                            gearmand           1.1.18-4.0           1.1.18-5.0
                               glob2         0.9.4.4-36.0         0.9.4.4-37.0
                             gnucash              3.4-1.0              3.4-2.0
                            gnuradio         3.7.13.4-4.0         3.7.13.4-5.0
                  gnuradio-companion         3.7.13.4-4.0         3.7.13.4-5.0
                 gnuradio-fcdproplus           3.7.5-14.0           3.7.5-15.0
                      gnuradio-iqbal          0.37.2-30.0          0.37.2-31.0
                    gnuradio-osmosdr           0.1.4-28.0           0.1.4-29.0
                        gnustep-base           1.25.1-4.0           1.26.0-1.0
                         go-ethereum           1.8.20-1.0           1.8.21-1.0
                               gpick         0.2.6rc1-4.0         0.2.6rc1-5.0
                                gqrx           2.11.5-2.0           2.11.5-3.0
                               gsoap           2.8.66-1.1           2.8.75-1.0
                           guitarix2           0.37.3-2.1           0.37.3-3.0
                               hugin         2018.0.0-6.0         2018.0.0-7.0
                         innoextract              1.7-2.2              1.7-3.0
                                 kea         1.4.0.P1-5.0         1.4.0.P1-6.0
               kvantum-theme-materia         20181225-1.0         20190117-1.0
                          leatherman            1.5.3-1.0            1.5.3-2.0
                              ledger            3.1.1-9.1           3.1.1-10.0
                              libasl           0.1.7-12.1           0.1.7-13.0
                            libbloom                1.4-1              1.5-1.0
                             librime          1:1.3.2-1.0          1:1.3.2-2.0
                              libuhd         3.13.0.1-2.1         3.13.0.1-3.0
                             liburcu           0.10.1-1.2           0.10.2-1.0
                             libvolk              1.4-2.1              1.4-3.0
                             linssid              3.6-2.1              3.6-3.0
                              lolcat          99.9.11-1.2          99.9.11-2.0
                            lucene++           3.0.7-14.1           3.0.7-15.0
                        luminancehdr           2.5.1-13.1           2.5.1-14.0
                              mapnik           3.0.21-2.0           3.0.21-3.0
                              marisa            0.2.5-2.3            0.2.5-3.0
                         materia-kde         20181225-1.0         20190117-1.0
                                  mc           4.8.21-1.1           4.8.22-1.0
                         mcollective           2.12.4-1.0           2.12.4-2.0
                       mod_passenger            6.0.0-2.0            6.0.0-3.0
                         mupen64plus             2.5-12.0             2.5-13.0
                             ncmpcpp            0.8.2-6.1            0.8.2-7.0
                           neovim-qt           0.2.11-1.0           0.2.12-1.0
                 nginx-mod-passenger            6.0.0-2.0            6.0.0-3.0
                         openimageio           1.8.17-1.0           1.8.17-2.0
                              openmw           0.44.0-5.0           0.44.0-6.0
                            openscad      2015.03.03-18.1      2015.03.03-19.0
                 openshadinglanguage           1.9.10-3.1           1.9.10-4.0
                             openvdb            6.0.0-1.0            6.0.0-2.0
                             pamixer           1.3.1-10.1           1.3.1-11.0
                           passenger            6.0.0-2.0            6.0.0-3.0
                          performous             1.1-18.0             1.1-19.0
                         perl-marisa            0.2.5-2.3            0.2.5-3.0
                              pingus           0.7.6-25.0           0.7.6-26.0
                              poedit            1:2.2-2.1            1:2.2-3.0
                              povray        2:3.7.0.8-1.0        2:3.7.0.8-2.0
                            powerdns            4.1.5-2.0            4.1.5-3.0
                   powerdns-recursor            4.1.8-1.0            4.1.8-2.0
                        pulseeffects            4.4.5-1.0            4.4.6-2.0
                           pulseview            0.4.1-1.0            0.4.1-2.0
                              puppet            6.1.0-1.0            6.1.0-2.0
                 python-aioresponses            0.5.1-1.0            0.5.2-1.0
                      python-awkward            0.7.1-1.0            0.7.2-1.0
                        python-boto3           1.9.74-1.0           1.9.79-1.0
                     python-botocore          1.12.74-1.0          1.12.79-1.0
                    python-cysignals            1.8.1-1.0            1.9.0-1.0
                  python-entrypoints            0.2.3-3.0              0.3-1.0
                      python-etesync            0.5.6-1.0            0.6.0-1.0
                        python-flaky            3.5.2-1.0            3.5.3-1.0
                   python-hyperframe            5.1.0-2.0            5.2.0-1.0
                   python-hypothesis            4.0.0-1.0            4.0.1-1.0
                    python-jellyfish            0.6.1-2.0            0.7.1-1.0
               python-jsonrpc-server            0.1.0-1.0            0.1.2-1.0
             python-jsonrpclib-pelix            0.3.2-1.0            0.4.0-1.0
              python-language-server           0.21.4-1.0           0.21.5-1.0
                       python-pillow            5.3.0-1.0            5.4.1-1.0
                python-process-tests            2.0.0-2.0            2.0.1-1.0
                     python-pynamodb            3.3.2-1.0            3.3.3-1.0
                python-pytest-forked              0.2-2.0            1.0.1-1.0
                 python-pytest-xdist           1.25.0-1.0           1.26.0-1.0
                        python-pyzmq           17.1.0-1.1           17.1.2-1.0
                    python-reportlab           3.5.12-1.0           3.5.13-1.0
                  python-ruamel-yaml          0.15.84-1.0          0.15.85-1.0
               python-setuptools-scm            3.1.0-1.0            3.2.0-1.0
                    python-texttable            1.5.0-1.0            1.6.0-1.0
                          python-tox            3.6.1-1.0            3.7.0-1.0
                    python-typed-ast            1.1.1-1.0            1.2.0-1.0
                      python-unicorn            1.0.1-5.1            1.0.1-6.0
                     python-waitress            1.1.0-2.0            1.2.0-1.0
                       python2-boto3           1.9.74-1.0           1.9.79-1.0
                    python2-botocore          1.12.74-1.0          1.12.79-1.0
                     python2-cypari2            2.0.2-1.0            2.0.3-1.0
                   python2-cysignals            1.8.1-1.0            1.9.0-1.0
                 python2-entrypoints            0.2.3-3.0              0.3-1.0
                       python2-exiv2           0.3.2-19.1           0.3.2-20.0
                       python2-flaky            3.5.2-1.0            3.5.3-1.0
                  python2-hyperframe            5.1.0-2.0            5.2.0-1.0
                  python2-hypothesis            4.0.0-1.0            4.0.1-1.0
              python2-jsonrpc-server            0.1.0-1.0            0.1.2-1.0
            python2-jsonrpclib-pelix            0.3.2-1.0            0.4.0-1.0
             python2-language-server           0.21.4-1.0           0.21.5-1.0
                      python2-marisa            0.2.5-2.3            0.2.5-3.0
                  python2-matplotlib            2.2.3-3.0            2.2.3-4.0
                      python2-pillow            5.3.0-1.0            5.4.1-1.0
               python2-process-tests            2.0.0-2.0            2.0.1-1.0
               python2-pytest-forked              0.2-2.0            1.0.1-1.0
                python2-pytest-xdist           1.25.0-1.0           1.26.0-1.0
                       python2-pyzmq           17.1.0-1.1           17.1.2-1.0
                   python2-reportlab           3.5.12-1.0           3.5.13-1.0
              python2-setuptools-scm            3.1.0-1.0            3.2.0-1.0
                       python2-tagpy          2013.1-15.1          2013.1-16.0
                   python2-texttable            1.5.0-1.0            1.6.0-1.0
                         python2-tox            3.6.1-1.0            3.7.0-1.0
                     python2-unicorn            1.0.1-5.1            1.0.1-6.0
                    python2-waitress            1.1.0-2.0            1.2.0-1.0
                         qbittorrent            4.1.5-1.0            4.1.5-2.0
                     qbittorrent-nox            4.1.5-1.0            4.1.5-2.0
                                qtox           1.16.3-6.1           1.16.3-7.0
                                repo           1.13.1-2.0           1.13.2-1.0
                                rink0.4.3.r8.g0db3f4d-2.0            0.4.4-1.0
                    ruby-addressable            2.5.2-3.0            2.5.2-4.0
                          ruby-async           1.10.3-1.0           1.10.3-2.0
                      ruby-async-dns            1.2.0-1.0            1.2.0-2.0
                       ruby-async-io           1.16.3-1.0           1.16.3-2.0
                            ruby-atk            3.3.0-1.0            3.3.1-1.0
                          ruby-cairo           1.16.2-1.0           1.16.2-2.0
                  ruby-cairo-gobject            3.3.0-1.0            3.3.1-1.0
                       ruby-diff-lcs              1.3-2.0              1.3-3.0
                       ruby-em-proxy            0.1.9-4.0            0.1.9-5.0
                   ruby-eventmachine            1.2.7-1.1            1.2.7-2.0
                        ruby-faraday           0.15.4-1.0           0.15.4-2.0
             ruby-faraday-middleware           0.12.2-2.0           0.12.2-3.0
                    ruby-gdk_pixbuf2            3.3.0-1.0            3.3.1-1.0
                           ruby-gio2            3.3.0-1.0            3.3.1-1.0
                          ruby-glib2            3.3.0-1.0            3.3.1-1.0
          ruby-gobject-introspection            3.3.0-1.0            3.3.1-1.0
                          ruby-gpgme           2.0.16-1.0           2.0.16-2.0
                           ruby-gtk2            3.3.0-1.0            3.3.1-1.0
          ruby-jekyll-sass-converter            1.5.2-1.0            1.5.2-2.0
                       ruby-kramdown           1.17.0-1.0           1.17.0-2.0
                       ruby-mail-gpg            0.4.0-1.0            0.4.0-2.0
                       ruby-manpages            0.6.1-1.1            0.6.1-2.0
                         ruby-marisa            0.2.5-2.3            0.2.5-3.0
                      ruby-mercenary            0.3.6-2.0            0.3.6-3.0
                     ruby-multi_json           1.13.1-1.0           1.13.1-2.0
                 ruby-multipart-post            2.0.0-2.0            2.0.0-3.0
       ruby-native-package-installer            1.0.6-2.0            1.0.6-3.0
                      ruby-nats-pure            0.5.0-1.1            0.5.0-2.0
                       ruby-net-ping            2.0.5-1.0            2.0.5-2.0
                       ruby-packetfu           1.1.13-2.0           1.1.13-3.0
                          ruby-paint            2.0.1-2.0            2.0.1-3.0
                          ruby-pango            3.3.0-1.0            3.3.1-1.0
                             ruby-pg            1.0.0-1.1            1.0.0-2.0
                     ruby-pkg-config            1.3.1-1.1            1.3.1-2.0
                       ruby-polyglot            0.3.5-5.0            0.3.5-6.0
                   ruby-power_assert            1.1.3-1.0            1.1.3-2.0
                  ruby-public_suffix            3.0.3-1.0            3.0.3-2.0
                           ruby-rack            2.0.5-1.1            2.0.5-2.0
                ruby-rack-protection            2.0.3-1.0            2.0.3-2.0
                        ruby-rainbow            3.0.0-3.0            3.0.0-4.0
                           ruby-rake           12.3.1-1.0           12.3.1-3.0
                          ruby-rouge            3.3.0-1.0            3.3.0-2.0
                          ruby-rspec            3.8.0-1.1            3.8.0-2.0
                     ruby-rspec-core            3.8.0-1.0            3.8.0-2.0
             ruby-rspec-expectations            3.8.1-1.1            3.8.1-2.0
                    ruby-rspec-mocks            3.8.0-1.0            3.8.0-2.0
                  ruby-rspec-support            3.8.0-1.0            3.8.0-2.0
                        ruby-rubydns            2.0.2-2.0            2.0.2-3.0
                      ruby-safe_yaml            1.0.4-3.0            1.0.4-4.0
                           ruby-sass            3.7.2-1.0            3.7.2-2.0
                ruby-semantic_puppet            1.0.2-1.0            1.0.2-2.0
                          ruby-stomp            1.4.4-3.0            1.4.4-4.0
                 ruby-term-ansicolor            1.6.0-1.1            1.6.0-2.0
                      ruby-test-unit            3.2.9-1.0            3.2.9-2.0
                           ruby-thin            1.7.2-2.1            1.7.2-3.0
                           ruby-thor           0.20.0-2.0           0.20.0-3.0
                           ruby-tilt            2.0.8-2.0            2.0.8-3.0
                           ruby-tins           1.16.3-1.1           1.16.3-2.0
                      ruby-titlecase 0.1.1+13+1d6b4f7-2.0 0.1.1+13+1d6b4f7-3.0
                        ruby-treetop           1.6.10-1.1           1.6.10-2.0
                        ruby-trollop            2.1.3-1.0            2.1.3-2.0
                 ruby-unicorn-engine            1.0.1-5.1            1.0.1-6.0
                           ruby-yard           0.9.14-1.0           0.9.14-2.0
                             schroot          1.6.10-20.1          1.6.10-21.0
                   shadowsocks-libev            3.2.0-3.0            3.2.3-1.0
                             snapper            0.8.1-2.0            0.8.1-3.0
                           soapyosmo            0.2.5-1.0            0.2.5-2.0
                            soapyuhd            0.3.4-3.2            0.3.4-4.0
                              spring            104.0-4.0            104.0-5.0
                         springlobby            0.267-2.1            0.267-3.0
                                sssd            2.0.0-1.2            2.0.0-2.0
                       supercollider           3.10.0-2.0           3.10.0-3.0
                            supertux            0.6.0-1.0            0.6.0-2.0
                             toxcore          1:0.2.8-1.0          1:0.2.9-1.0
                              trojan            1.9.0-1.0            1.9.0-2.0
                          unarchiver           1.10.1-5.0           1.10.1-6.0
                             unicorn            1.0.1-5.1            1.0.1-6.0
                               uwsgi         2.0.17.1-6.0         2.0.17.1-7.0
                    uwsgi-plugin-cgi         2.0.17.1-6.0         2.0.17.1-7.0
                    uwsgi-plugin-jvm         2.0.17.1-6.0         2.0.17.1-7.0
                  uwsgi-plugin-lua51         2.0.17.1-6.0         2.0.17.1-7.0
                   uwsgi-plugin-mono         2.0.17.1-6.0         2.0.17.1-7.0
               uwsgi-plugin-notfound         2.0.17.1-6.0         2.0.17.1-7.0
                    uwsgi-plugin-php         2.0.17.1-6.0         2.0.17.1-7.0
                   uwsgi-plugin-psgi         2.0.17.1-6.0         2.0.17.1-7.0
                   uwsgi-plugin-pypy         2.0.17.1-6.0         2.0.17.1-7.0
                 uwsgi-plugin-python         2.0.17.1-6.0         2.0.17.1-7.0
                uwsgi-plugin-python2         2.0.17.1-6.0         2.0.17.1-7.0
                   uwsgi-plugin-rack         2.0.17.1-6.0         2.0.17.1-7.0
                 uwsgi-plugin-webdav         2.0.17.1-6.0         2.0.17.1-7.0
                 uwsgi-plugin-zabbix         2.0.17.1-6.0         2.0.17.1-7.0
                         vapoursynth            R45.1-1.0            R45.1-1.1
                               vigra          1.11.1-14.0          1.11.1-15.0
                           vigra-doc          1.11.1-14.0          1.11.1-15.0
                  vim-airline-themes    r1279.4b7f77e-1.0    r1321.3bfe1d0-1.0
                virtualbox-guest-iso            6.0.0-1.0            6.0.2-1.0
                             wesnoth           1.14.5-3.0           1.14.5-4.0
                           widelands              19-15.0              19-16.0
                      wireguard-arch     0.0.20181218-2.0     0.0.20181218-3.0
                                  wt            4.0.5-1.0            4.0.5-2.0
                             you-get         0.4.1193-1.0         0.4.1205-1.0
                          youtube-dl       2019.01.10-1.0       2019.01.17-1.0
                              zeromq            4.3.0-1.0            4.3.1-1.0
                                 znc            1.7.1-6.0            1.7.1-7.0
                               bliss                    -             0.73-1.0
                              rfdump                    -              1.6-3.0

“Good” news is that LightDM segfaults are a known issue: https://bugs.archlinux32.org/index.php?do=details&task_id=60


#74

Seems this update has multiple issues in one and most fixed already :wink: Looking good so far :stuck_out_tongue:


#75

Just to see if it makes any difference, here’s a rebuilt lightdm and qt5-base:

:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                            qt5-base             5.12.0-0           5.12.0-2.9
                      liblightdm-qt4                    -         1:1.28.0-1.0
                      liblightdm-qt5                    -         1:1.28.0-1.0
                             lightdm                    -         1:1.28.0-1.0
             qt5-xcb-private-headers                    -           5.12.0-2.9

#76

Smooth as butter KDE VM update, no issues experienced.

Although … there were spectre vulnerability errors thrown during boot process.

Jan manjaro32-vm kernel: Spectre V2 : System may be vulnerable to spectre v2
Jan manjaro32-vm kernel: Spectre V2 : System may be vulnerable to spectre v2
Jan manjaro32-vm kernel: Spectre V2 : System may be vulnerable to spectre v2

#77

I’m not sure how accurate that will be from within a VM… could you check the output of spectre-meltdown-checker for both the VM and the host?


#78

Spectre Checker on the host says cpu is vulnerable to all three variants, then list all three variants as mitigated (Spectre 1, Spectre 2 and Meltdown).

Spectre Checker on the guest says cpu is vulnerable to all three variants, then lists the two spectre variants as mitigated but vulnerable to Meltdown as Page Table Isolation is not enabled and active.

Using a different method of comparison, which includes additional vulnerabilities.

grep . /sys/devices/system/cpu/vulnerabilities/*

Host.

/sys/devices/system/cpu/vulnerabilities/l1tf:Mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
/sys/devices/system/cpu/vulnerabilities/meltdown:Mitigation: PTI
/sys/devices/system/cpu/vulnerabilities/spec_store_bypass:Mitigation: Speculative Store Bypass disabled via prctl and seccomp
/sys/devices/system/cpu/vulnerabilities/spectre_v1:Mitigation: __user pointer sanitization
/sys/devices/system/cpu/vulnerabilities/spectre_v2:Mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB fillingaded

Guest.

/sys/devices/system/cpu/vulnerabilities/l1tf:Vulnerable
/sys/devices/system/cpu/vulnerabilities/meltdown:Vulnerable
/sys/devices/system/cpu/vulnerabilities/spec_store_bypass:Vulnerable
/sys/devices/system/cpu/vulnerabilities/spectre_v1:Mitigation: __user pointer sanitization
/sys/devices/system/cpu/vulnerabilities/spectre_v2:Mitigation: Full generic retpoline, STIBP: disabled, RSB filling - vulnerable module loaded

So three unmitigated vulnerabilities in guest, I assume this is vbox related.

Are these mitigated in bare metal i686 systems?


#79

I don’t know. The thing with most i686 CPUs is that they’re not affected in the first place:

/sys/devices/system/cpu/vulnerabilities/l1tf:Not affected
/sys/devices/system/cpu/vulnerabilities/meltdown:Not affected
/sys/devices/system/cpu/vulnerabilities/spec_store_bypass:Not affected
/sys/devices/system/cpu/vulnerabilities/spectre_v1:Not affected
/sys/devices/system/cpu/vulnerabilities/spectre_v2:Not affected

#80

Good news from upstream: extra/lightdm: hotfix for FS32#60 :smile: