[Testing Update i686] 2018-12-11 to 16 - KDE framework, Thunderbird, WINE

update
testing
manjaro32

#21

Downgrading Mesa didn’t help, but at least it didn’t break using 4.18! That does seem to be the right neighborhood though, something in the graphics stack.


#22

I was able to boot once into 4.19.12, but next restart failed. So running pacman -Syyuu hasn’t helped so far. I’ve tried nomodeset, i915.modeset=0, nosplash, building a kernel without bootsplash patches, booting to tty + startx, downgrading mesa, linux-firmware, systemd. This is probably only affecting my device, a baytrail with UEFI32. Older kernels work fine and 4.19 used to boot fine. What I see when I boot is the manufacturer’s logo and then gibberish (a few lines of what should be text as mangled pixels) and then a hung system. Hard reset recovers.

inxi

Here is the first difference between 4.18 (which works) and 4.19 when it fails. (Xorg.log) xfree86 seems to allow 4.18 to boot normally…

[     4.468] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[     4.470] (II) xfree86: Adding drm device (/dev/dri/card0)

The drm device is significant. I have no idea why kernel series starts to matter this week.

4.19 xorg.log.0

[    16.133] 
X.Org X Server 1.20.2
X Protocol Version 11, Revision 0
[    16.133] Build Operating System: Linux Arch Linux
[    16.133] Current Operating System: Linux LapLet 4.19.12-1-T100MJ #28 SMP Sat Dec 22 12:24:51 MST 2018 i686
[    16.133] Kernel command line: audit=0 clocksource=tsc tsc=reliable intel reboot=pci,force systemd.gpt_auto=0 BOOT_IMAGE=/boot/vmlinuz-4.19-i686 root=UUID=6d3375ff-6d06-4332-800b-a3098aa3d3fe rw inte_idle.max_cstate=1 tsc=reliable clocksource=tsc reboot=pci,force systemd.gpt_auto=0 audit=0 nosplash nomodeset resume=UUID=23efaf3d-73dc-4dc5-8603-5e5ad736ef49
[    16.133] Build Date: 18 October 2018  07:38:20PM
[    16.133]  
[    16.133] Current version of pixman: 0.36.0
[    16.133] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    16.133] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    16.134] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Dec 22 13:02:03 2018
[    16.134] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    16.134] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    16.134] (==) No Layout section.  Using the first Screen section.
[    16.134] (==) No screen section available. Using defaults.
[    16.134] (**) |-->Screen "Default Screen Section" (0)
[    16.134] (**) |   |-->Monitor "<default monitor>"
[    16.135] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[    16.135] (==) Automatically adding devices
[    16.135] (==) Automatically enabling devices
[    16.135] (==) Automatically adding GPU devices
[    16.135] (==) Automatically binding GPU devices
[    16.135] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    16.135] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[    16.135] 	Entry deleted from font path.
[    16.135] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[    16.135] 	Entry deleted from font path.
[    16.135] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[    16.135] 	Entry deleted from font path.
[    16.135] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
[    16.135] 	Entry deleted from font path.
[    16.135] (==) FontPath set to:
	/usr/share/fonts/misc,
	/usr/share/fonts/TTF
[    16.135] (==) ModulePath set to "/usr/lib/xorg/modules"
[    16.135] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    16.135] (II) Module ABI versions:
[    16.135] 	X.Org ANSI C Emulation: 0.4
[    16.135] 	X.Org Video Driver: 24.0
[    16.135] 	X.Org XInput driver : 24.1
[    16.135] 	X.Org Server Extension : 10.0
[    16.139] (++) using VT number 7

[    16.139] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    16.145] (--) PCI:*(0@0:2:0) 8086:0f31:1043:1a0d rev 13, Mem @ 0x90000000/4194304, 0x80000000/268435456, I/O @ 0x00001000/8, BIOS @ 0x????????/131072
[    16.145] (II) LoadModule: "glx"
[    16.147] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    16.152] (II) Module glx: vendor="X.Org Foundation"
[    16.152] 	compiled for 1.20.2, module version = 1.0.0
[    16.152] 	ABI class: X.Org Server Extension, version 10.0
[    16.153] (==) Matched intel as autoconfigured driver 0
[    16.153] (==) Matched modesetting as autoconfigured driver 1
[    16.153] (==) Matched fbdev as autoconfigured driver 2
[    16.153] (==) Matched vesa as autoconfigured driver 3
[    16.153] (==) Assigned the driver to the xf86ConfigLayout
[    16.153] (II) LoadModule: "intel"
[    16.153] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    16.153] (II) Module intel: vendor="X.Org Foundation"
[    16.153] 	compiled for 1.20.3, module version = 2.99.917
[    16.153] 	Module class: X.Org Video Driver
[    16.154] 	ABI class: X.Org Video Driver, version 24.0
[    16.154] (II) LoadModule: "modesetting"
[    16.154] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    16.155] (II) Module modesetting: vendor="X.Org Foundation"
[    16.155] 	compiled for 1.20.2, module version = 1.20.2
[    16.155] 	Module class: X.Org Video Driver
[    16.155] 	ABI class: X.Org Video Driver, version 24.0
[    16.155] (II) LoadModule: "fbdev"
[    16.155] (WW) Warning, couldn't open module fbdev
[    16.155] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    16.155] (II) LoadModule: "vesa"
[    16.156] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    16.156] (II) Module vesa: vendor="X.Org Foundation"
[    16.156] 	compiled for 1.20.1, module version = 2.4.0
[    16.156] 	Module class: X.Org Video Driver
[    16.156] 	ABI class: X.Org Video Driver, version 24.0
[    16.156] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[    16.157] (II) intel: Driver for Intel(R) HD Graphics
[    16.157] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[    16.157] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[    16.157] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    16.157] (II) VESA: driver for VESA chipsets: vesa
[    18.151] intel: waited 2020 ms for i915.ko driver to load
[    18.162] (EE) open /dev/dri/card0: No such file or directory
[    18.162] (WW) Falling back to old probe method for modesetting
[    18.162] (EE) open /dev/dri/card0: No such file or directory
[    18.162] (EE) Screen 0 deleted because of no matching config section.
[    18.163] (II) UnloadModule: "modesetting"
[    18.163] (II) Loading sub module "vbe"
[    18.163] (II) LoadModule: "vbe"
[    18.163] (II) Loading /usr/lib/xorg/modules/libvbe.so
[    18.164] (II) Module vbe: vendor="X.Org Foundation"
[    18.164] 	compiled for 1.20.2, module version = 1.1.0
[    18.164] 	ABI class: X.Org Video Driver, version 24.0
[    18.164] (II) Loading sub module "int10"
[    18.164] (II) LoadModule: "int10"
[    18.165] (II) Loading /usr/lib/xorg/modules/libint10.so
[    18.165] (II) Module int10: vendor="X.Org Foundation"
[    18.165] 	compiled for 1.20.2, module version = 1.0.0
[    18.166] 	ABI class: X.Org Video Driver, version 24.0
[    18.166] (II) VESA(0): initializing int10
[    18.167] (WW) VESA(0): Unable to retrieve all of segment 0x0C0000.
[    18.167] (II) VESA(0): No legacy BIOS found -- trying PCI
[    18.167] (EE) VESA(0): Cannot read V_BIOS (5) Input/output error
[    18.167] (II) UnloadModule: "vesa"
[    18.167] (II) UnloadSubModule: "int10"
[    18.167] (II) Unloading int10
[    18.168] (II) UnloadSubModule: "vbe"
[    18.168] (II) Unloading vbe
[    18.168] (EE) Screen(s) found, but none have a usable configuration.
[    18.168] (EE) 
Fatal server error:
[    18.168] (EE) no screens found(EE) 
[    18.168] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[    18.168] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    18.168] (EE) 
[    18.194] (EE) Server terminated with error (1). Closing log file.

4.18 xorg.log.0

[     4.458] 
X.Org X Server 1.20.2
X Protocol Version 11, Revision 0
[     4.458] Build Operating System: Linux Arch Linux
[     4.458] Current Operating System: Linux LapLet 4.18.16-12-T100MJ #8 SMP PREEMPT Tue Oct 23 12:00:09 MST 2018 i686
[     4.458] Kernel command line: audit=0 clocksource=tsc tsc=reliable intel reboot=pci,force systemd.gpt_auto=0 ipv6.disable=1  BOOT_IMAGE=/boot/vmlinuz-4.18-i686 root=UUID=6d3375ff-6d06-4332-800b-a3098aa3d3fe rw inte_idle.max_cstate=1 tsc=reliable clocksource=tsc reboot=pci,force systemd.gpt_auto=0 audit=0 quiet resume=UUID=23efaf3d-73dc-4dc5-8603-5e5ad736ef49
[     4.458] Build Date: 18 October 2018  07:38:20PM
[     4.458]  
[     4.458] Current version of pixman: 0.36.0
[     4.458] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[     4.458] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     4.459] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Dec 22 18:57:02 2018
[     4.460] (==) Using config directory: "/etc/X11/xorg.conf.d"
[     4.460] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[     4.463] (==) No Layout section.  Using the first Screen section.
[     4.463] (==) No screen section available. Using defaults.
[     4.463] (**) |-->Screen "Default Screen Section" (0)
[     4.463] (**) |   |-->Monitor "<default monitor>"
[     4.463] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[     4.464] (==) Automatically adding devices
[     4.464] (==) Automatically enabling devices
[     4.464] (==) Automatically adding GPU devices
[     4.464] (==) Automatically binding GPU devices
[     4.464] (==) Max clients allowed: 256, resource mask: 0x1fffff
[     4.465] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[     4.465] 	Entry deleted from font path.
[     4.465] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[     4.465] 	Entry deleted from font path.
[     4.465] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[     4.465] 	Entry deleted from font path.
[     4.465] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
[     4.465] 	Entry deleted from font path.
[     4.465] (==) FontPath set to:
	/usr/share/fonts/misc,
	/usr/share/fonts/TTF
[     4.465] (==) ModulePath set to "/usr/lib/xorg/modules"
[     4.465] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[     4.465] (II) Module ABI versions:
[     4.465] 	X.Org ANSI C Emulation: 0.4
[     4.465] 	X.Org Video Driver: 24.0
[     4.465] 	X.Org XInput driver : 24.1
[     4.465] 	X.Org Server Extension : 10.0
[     4.467] (++) using VT number 7

[     4.468] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[     4.470] (II) xfree86: Adding drm device (/dev/dri/card0)
[     4.481] (--) PCI:*(0@0:2:0) 8086:0f31:1043:1a0d rev 13, Mem @ 0x90000000/4194304, 0x80000000/268435456, I/O @ 0x00001000/8, BIOS @ 0x????????/131072
[     4.481] (II) LoadModule: "glx"
[     4.487] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[     4.505] (II) Module glx: vendor="X.Org Foundation"
[     4.505] 	compiled for 1.20.2, module version = 1.0.0
[     4.505] 	ABI class: X.Org Server Extension, version 10.0
[     4.505] (==) Matched intel as autoconfigured driver 0
[     4.505] (==) Matched modesetting as autoconfigured driver 1
[     4.505] (==) Matched fbdev as autoconfigured driver 2
[     4.505] (==) Matched vesa as autoconfigured driver 3
[     4.505] (==) Assigned the driver to the xf86ConfigLayout
[     4.505] (II) LoadModule: "intel"
[     4.506] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[     4.512] (II) Module intel: vendor="X.Org Foundation"
[     4.512] 	compiled for 1.20.3, module version = 2.99.917
[     4.512] 	Module class: X.Org Video Driver
[     4.512] 	ABI class: X.Org Video Driver, version 24.0
[     4.512] (II) LoadModule: "modesetting"
[     4.512] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[     4.516] (II) Module modesetting: vendor="X.Org Foundation"
[     4.516] 	compiled for 1.20.2, module version = 1.20.2
[     4.516] 	Module class: X.Org Video Driver
[     4.516] 	ABI class: X.Org Video Driver, version 24.0
[     4.516] (II) LoadModule: "fbdev"
[     4.516] (WW) Warning, couldn't open module fbdev
[     4.516] (EE) Failed to load module "fbdev" (module does not exist, 0)
[     4.516] (II) LoadModule: "vesa"
[     4.517] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[     4.518] (II) Module vesa: vendor="X.Org Foundation"
[     4.518] 	compiled for 1.20.1, module version = 2.4.0
[     4.518] 	Module class: X.Org Video Driver
[     4.518] 	ABI class: X.Org Video Driver, version 24.0
[     4.518] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[     4.519] (II) intel: Driver for Intel(R) HD Graphics
[     4.519] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[     4.519] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[     4.519] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[     4.519] (II) VESA: driver for VESA chipsets: vesa
[     4.552] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20180514
[     4.552] (II) intel(0): SNA compiled from 2.99.917-855-g746ab3bb
[     4.554] (WW) Falling back to old probe method for modesetting
[     4.555] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics
[     4.555] (--) intel(0): CPU: x86, sse2, sse3, ssse3, sse4.1, sse4.2; using a maximum of 4 threads
[     4.555] (II) intel(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[     4.555] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[     4.555] (==) intel(0): RGB weight 888
[     4.555] (==) intel(0): Default visual is TrueColor
[     4.556] (II) intel(0): Output DSI1 has no monitor section
[     4.556] (**) intel(0): Found backlight control interface intel_backlight (type 'raw') for output DSI1
[     4.556] (II) intel(0): Enabled output DSI1
[     4.556] (II) intel(0): Output DP1 has no monitor section
[     4.556] (II) intel(0): Enabled output DP1
[     4.556] (II) intel(0): Output HDMI1 has no monitor section
[     4.557] (II) intel(0): Enabled output HDMI1
[     4.557] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[     4.557] (II) intel(0): Output VIRTUAL1 has no monitor section
[     4.557] (II) intel(0): Enabled output VIRTUAL1
[     4.557] (--) intel(0): Output DSI1 using initial mode 1920x1200 on pipe 0
[     4.557] (==) intel(0): TearFree disabled
[     4.557] (==) intel(0): Using gamma correction (1.0, 1.0, 1.0)
[     4.557] (==) intel(0): DPI set to (96, 96)
[     4.557] (II) Loading sub module "dri3"
[     4.557] (II) LoadModule: "dri3"
[     4.557] (II) Module "dri3" already built-in
[     4.557] (II) Loading sub module "dri2"
[     4.557] (II) LoadModule: "dri2"
[     4.557] (II) Module "dri2" already built-in
[     4.557] (II) Loading sub module "present"
[     4.557] (II) LoadModule: "present"
[     4.557] (II) Module "present" already built-in
[     4.557] (II) UnloadModule: "modesetting"
[     4.557] (II) Unloading modesetting
[     4.558] (II) UnloadModule: "vesa"
[     4.558] (II) Unloading vesa
[     4.563] (II) intel(0): SNA initialized with Baytrail (gen7) backend
[     4.564] (==) intel(0): Backing store enabled
[     4.564] (==) intel(0): Silken mouse disabled
[     4.564] (II) intel(0): HW Cursor enabled
[     4.566] (==) intel(0): DPMS enabled
[     4.567] (==) intel(0): Display hotplug detection enabled
[     4.567] (II) intel(0): [DRI2] Setup complete
[     4.567] (II) intel(0): [DRI2]   DRI driver: i965
[     4.567] (II) intel(0): [DRI2]   VDPAU driver: va_gl
[     4.568] (II) intel(0): direct rendering: DRI2 DRI3 enabled
[     4.568] (II) intel(0): hardware support for Present enabled
[     4.568] (II) Initializing extension Generic Event Extension
[     4.568] (II) Initializing extension SHAPE
[     4.569] (II) Initializing extension MIT-SHM
[     4.570] (II) Initializing extension XInputExtension
[     4.571] (II) Initializing extension XTEST
[     4.572] (II) Initializing extension BIG-REQUESTS
[     4.573] (II) Initializing extension SYNC
[     4.573] (II) Initializing extension XKEYBOARD
[     4.574] (II) Initializing extension XC-MISC
[     4.575] (II) Initializing extension SECURITY
[     4.575] (II) Initializing extension XFIXES
[     4.576] (II) Initializing extension RENDER
[     4.577] (II) Initializing extension RANDR
[     4.578] (II) Initializing extension COMPOSITE
[     4.578] (II) Initializing extension DAMAGE
[     4.579] (II) Initializing extension MIT-SCREEN-SAVER
[     4.580] (II) Initializing extension DOUBLE-BUFFER
[     4.580] (II) Initializing extension RECORD
[     4.581] (II) Initializing extension DPMS
[     4.581] (II) Initializing extension Present
[     4.582] (II) Initializing extension DRI3
[     4.582] (II) Initializing extension X-Resource
[     4.582] (II) Initializing extension XVideo
[     4.583] (II) Initializing extension XVideo-MotionCompensation
[     4.583] (II) Initializing extension GLX
[     4.643] (II) AIGLX: Loaded and initialized i965
[     4.643] (II) GLX: Initialized DRI2 GL provider for screen 0
[     4.643] (II) Initializing extension XFree86-VidModeExtension
[     4.644] (II) Initializing extension XFree86-DGA
[     4.644] (II) Initializing extension XFree86-DRI
[     4.644] (II) Initializing extension DRI2
[     4.654] (II) intel(0): switch to mode 1920x1200@60.0 on DSI1 using pipe 0, position (0, 0), rotation normal, reflection none
[     4.662] (II) intel(0): Setting screen physical size to 507 x 317
[     4.767] (II) config/udev: Adding input device Video Bus (/dev/input/event2)
[     4.767] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[     4.768] (**) Video Bus: Applying InputClass "libinput keyboard catchall"
[     4.768] (**) Video Bus: Applying InputClass "system-keyboard"
[     4.768] (II) LoadModule: "libinput"
[     4.768] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[     4.775] (II) Module libinput: vendor="X.Org Foundation"
[     4.775] 	compiled for 1.20.3, module version = 0.28.1
[     4.775] 	Module class: X.Org XInput Driver
[     4.775] 	ABI class: X.Org XInput driver, version 24.1
[     4.775] (II) Using input driver 'libinput' for 'Video Bus'
[     4.775] (**) Video Bus: always reports core events
[     4.775] (**) Option "Device" "/dev/input/event2"
[     4.775] (**) Option "_source" "server/udev"
[     4.786] (II) event2  - Video Bus: is tagged by udev as: Keyboard
[     4.786] (II) event2  - Video Bus: device is a keyboard
[     4.786] (II) event2  - Video Bus: device removed
[snip...]

Need sleep, BBL. No urgency in that 4.14, 4.18 boot fine, but this is a regression that I’m not seeing in Mint with 4.19.12. The problem is outside the kernel as 4.19.5 and 4.19-rc8 used to boot but don’t anymore since updates this week. (Manjaro Cinnamon x32 and xfce x32)


#23

This might be a regression with the intel driver…


#24

Not much progress. For chuckles, I tried to build 4.20-i686 and it boots fine. 4.20 does not try to display the vendor logo, neither does 4.18.

I think what is happening is that 4.19 displays the vendor logo, but it does not successfully return video control to linux. Possibly another idiosyncrasy by ASUS. Is there a way to disable the vendor logo? The kernel arguments I’ve found seem to affect only the splash and I didn’t see anything obvious in the .config or make menuconfig.

I had one issue with the 4.20 build. After compiling everything, the headers failed to build with something like “can’t stat /arch/x86/kernel/macros.s”. I commented out that line in the PKGBUILD and was able to finish building 4.20. Macros.s is not in the other kernel series or in the source tree.


#25

Ah - yes. That sounds correct. I think the implementation of “smooth boot” might have some bugs, and might even be triggering the “no display” issue more widely on other systems (e.g. my Ryzen + AMDGPU laptop).

I’ll ping @philm in case this sounds like something to look at.

In the meantime, if we can find the kernel config item which enables this I can un-set it for i686 and see if that helps.


#26

One of my kernel arg experiments got the black display after the vendor logo. Usually I get the crushed text and colored pixels on the upper part of the screen, sometimes with the logo still showing.

Maybe the display control registers need to be reset after the logo display has finished.


#27

64 bit Cinnamon fresh install (linux 4.19.4) shows the manufacturer’s logo and then gets to the desktop. It still works after a 750MB update. Linux 4.20 also shows the logo.

Retesting the 32 bit version (after keeping up with the updates), linux 4.19.12 does boot to desktop, without the logo. So my issue of not booting with 4.19 x32 appears to be fixed. Thanks!

FWIW, the 64 bit installer ISO doesn’t support 32bit UEFI. The bootia32.efi file is missing (liveUSB won’t boot) and grub fails to install. The i386-efi files are missing. I hacked around the first, and used the grub from my 32 bit Manjaro install sudo update-grub to boot the new 64 bit install. Personally, I prefer the 32 bit version for this baytrail device…


closed #28

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.