[Testing Update i686] 2018-10-25 to 11-24 - The Pretty Much Everything™ Update

update
testing
manjaro32

#82

KDE?

Admittedly I’ve been updating a non booting VM since the first “everything” update sddm-qt issue, via chroot using the 17.0.6 KDE ISO, maybe that plays a part. IDK.

Anyway, the ova file imported fine, there are nearly 900 packages waiting to be installed, but I’ll hold off a little while methinks.


#83

Thanks for the tip. I excluded only x265. ffmpeg and all other updates have installed without a problem and ffmpeg dependent programs are working fine.
Very slight improvement on the sluggish kernel behavior but have noticed java script errors on this site too, of late with Pale moon.


#84

Me too!


#85

Kernels and sync:

:: Different overlay package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                            linux414            4.14.79-1            4.14.81-1
                    linux414-headers            4.14.79-1            4.14.81-1
                            linux419             4.19.1-1             4.19.2-1
                    linux419-headers             4.19.1-1             4.19.2-1
                             linux49            4.9.135-1            4.9.137-1
                     linux49-headers            4.9.135-1            4.9.137-1


:: Different sync package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                     ca-certificates         20180821-1.6         20181109-1.0
               ca-certificates-utils         20180821-1.6         20181109-1.0
                               mdadm             4.0-1.10              4.0-2.0
                                popt             1.16-9.3            1.16-10.0


:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                   linux414-bbswitch               0.8-64               0.8-65
                linux414-broadcom-wl      6.30.223.271-64      6.30.223.271-65
                linux414-ndiswrapper              1.61-64              1.61-65
               linux414-nvidia-340xx           340.107-23           340.107-24
               linux414-nvidia-390xx             390.87-9            390.87-10
                      linux414-r8168          8.045.08-52          8.045.08-53
                  linux414-rt3562sta        2.4.1.1_r4-64        2.4.1.1_r4-65
                   linux414-tp_smapi              0.41-64              0.41-65
                linux414-vhba-module          20161009-64          20161009-65
                  linux419-acpi_call              1.1.0-1            1.1.0-1.0
                   linux419-bbswitch                0.8-1              0.8-1.0
                linux419-broadcom-wl       6.30.223.271-1     6.30.223.271-1.0
                linux419-ndiswrapper               1.61-1             1.61-1.0
               linux419-nvidia-340xx            340.107-1          340.107-1.0
               linux419-nvidia-390xx             390.87-1           390.87-1.0
                   linux419-nvidiabl               0.88-1             0.88-1.0
                      linux419-r8168           8.045.08-1         8.045.08-1.0
                        linux419-spl             0.7.11-1           0.7.11-1.0
                   linux419-tp_smapi               0.41-1             0.41-1.0
                linux419-vhba-module           20161009-1         20161009-1.0
                        linux419-zfs             0.7.11-1           0.7.11-1.0
                    linux49-bbswitch              0.8-101              0.8-102
                 linux49-broadcom-wl     6.30.223.271-101     6.30.223.271-102
                 linux49-ndiswrapper              1.61-99             1.61-100
                linux49-nvidia-340xx           340.107-20           340.107-21
                linux49-nvidia-390xx             390.87-9            390.87-10
                       linux49-r8168          8.045.08-41          8.045.08-42
                   linux49-rt3562sta        2.4.1.1_r4-99       2.4.1.1_r4-100
                    linux49-tp_smapi             0.41-101             0.41-102
                 linux49-vhba-module          20161009-99         20161009-100
                   ndiswrapper-utils              1.61-64              1.61-65
                    rt3562sta-common        2.4.1.1_r4-99       2.4.1.1_r4-100


:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                               atkmm2.24.2+1+gf30b47f-2.1           2.28.0-1.0
                          atkmm-docs2.24.2+1+gf30b47f-2.1           2.28.0-1.0
                           bluedevil         1:5.14.0-1.0         1:5.14.3-1.2
                              breeze           5.14.0-1.0           5.14.3-1.6
                              cdrdao             1.2.3-10            1.2.4-1.0
                            discover           5.14.0-1.0           5.14.3-1.0
                             drkonqi           5.14.0-1.0           5.14.3-1.0
                             ethtool           1:4.18-1.2           1:4.19-1.0
                           evolution           3.28.5-1.0           3.30.2-1.0
                evolution-bogofilter           3.28.5-1.0           3.30.2-1.0
              evolution-spamassassin           3.28.5-1.0           3.30.2-1.0
                           farstream            0.2.8-1.1            0.2.8-2.0
                         gconf-sharp           2.24.2-5.1           2.24.2-6.0
                                gegl            0.4.8-1.2           0.4.12-1.0
                    gnome-icon-theme           3.12.0-4.2           3.12.0-5.0
           gnome-icon-theme-symbolic           3.12.0-4.2           3.12.0-5.0
                         gnome-shell3.30.0+37+g969eecb88-1.03.28.3+7+g721ce5403-1.0
                               gssdp            1.0.2-1.1            1.0.2-2.0
                            gupnp-av          0.12.10-1.1          0.12.10-2.0
                   kactivitymanagerd           5.14.0-1.0           5.14.3-1.0
                            kdevelop            5.2.4-2.0            5.3.0-1.0
                         kinfocenter           5.14.0-1.0           5.14.3-1.0
                             kscreen           5.14.0-1.0           5.14.3-1.0
                       kscreenlocker           5.14.0-1.0           5.14.3-1.0
                         ksshaskpass           5.14.0-1.0           5.14.3-1.0
                           ksysguard           5.14.0-1.0           5.14.3-1.0
                                kwin           5.14.0-1.0           5.14.3-1.0
                             kwrited           5.14.0-1.0           5.14.3-1.0
                          libcryptui3.12.2+24+gd5e5bc59-13.12.2+41+gf29d1d37-2.0
                          liblangtag            0.6.2-1.1            0.6.2-2.0
                           libnotify            0.7.7-1.2            0.7.7-2.0
                            liboauth 1.0.3+9+g11e9461-2.2 1.0.3+9+g11e9461-3.0
                         libpst-docs           0.6.71-3.0           0.6.71-4.3
                               libuv           1.23.2-1.0           1.24.0-1.0
                               libxi            1.7.9-1.1            1.7.9-2.0
                            libxml++ 3.0.1+4+g2af973f-2.1 3.0.1+4+g2af973f-3.0
                       libxml++-docs 3.0.1+4+g2af973f-2.1 3.0.1+4+g2af973f-3.0
                              libxpm           3.5.12-1.2           3.5.12-2.0
                             libxtst            1.2.3-1.1            1.2.3-2.0
                               libxv           1.0.11-1.1           1.0.11-2.0
                          libzapojit0.0.3+11+g840627d-2.10.0.3+11+g840627d-3.0
                               milou           5.14.0-1.0           5.14.3-1.0
      mobile-broadband-provider-info         20170310-1.2         20170310-2.0
                            net-snmp              5.8-1.0              5.8-1.1
                              oxygen           5.14.0-1.0           5.14.3-1.0
                            php-snmp           7.2.11-3.0           7.2.11-3.1
          plasma-browser-integration           5.14.0-1.0           5.14.3-1.0
                  plasma-integration           5.14.0-1.0           5.14.3-1.0
                          plasma-sdk           5.14.0-1.0           5.14.3-1.0
              plasma-wayland-session           5.13.5-1.0           5.14.0-1.0
                           qwtplot3d            0.2.7-9.1           0.2.7-10.0
                                sane           1.0.27-2.0           1.0.27-2.1
                                sbcl           1.4.11-1.0           1.4.13-1.0
                            sddm-kcm           5.14.0-1.0           5.14.3-1.0
                                 sdl           1.2.15-9.1          1.2.15-10.0
                            sdl2_ttf             2.0.14-1           2.0.14-2.0
                             sdl_ttf             2.0.11-4           2.0.11-5.0
                shared-color-targets            0.1.7-1.1            0.1.7-2.0
                           shiboken2           5.11.1-2.0           5.11.2-2.0
                               speex            1.2.0-1.1            1.2.0-2.0
                startup-notification             0.12-5.1             0.12-6.0
                               t1lib            5.1.2-6.2            5.1.2-7.0
                  ttf-bitstream-vera            1.10-11.1            1.10-12.0
                        user-manager           5.14.0-1.0           5.14.3-1.0
                               whois            5.3.2-2.0            5.4.0-1.0
              xdg-desktop-portal-kde           5.14.2-1.0           5.14.3-1.0
                           zeitgeist  1.0+1+g1bcc8585-1.1  1.0+1+g1bcc8585-2.0


:: Different sync package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                                aide               0.16-1             0.16-2.0
                             alembic            1.7.8-2.0            1.7.9-1.0
                             almanah           0.11.1-8.0           0.11.1-8.1
                              beaver            0.4.1-4.1            0.4.1-5.0
                         bluez-tools            0.2.0-1.2            0.2.0-2.0
                               botan            2.8.0-1.0            2.8.0-2.0
                              byzanz          0.3.0.1-3.1          0.3.0.1-4.0
                              catdoc             0.95-1.2             0.95-2.0
                              chntpw           140201-2.1           140201-3.0
                         coin-or-cgl          0.59.10-1.1          0.59.10-2.0
                         coin-or-clp          1.16.11-1.1          1.16.11-2.0
                        coin-or-csdp            6.2.0-1.1            6.2.0-2.0
                            collectd           5.8.0-11.0            5.8.1-1.0
                          contractor            0.3.2-1.1            0.3.4-2.0
                            cowpatty              4.6-8.2              4.6-9.0
                                ctpl            0.3.4-2.2            0.3.4-3.0
                               dante              1.4.2-1            1.4.2-2.0
                           darktable          2:2.4.4-2.0          2:2.4.4-2.1
                          deepin-api            3.5.0-2.0            3.7.0-1.0
                   deepin-boot-maker          2.0.4.6-1.0          2.0.4.8-1.0
                               detox            1.3.0-1.1            1.3.0-2.0
                                dsdp                5.8-2              5.8-3.0
                                  e3             2.82-1.1             2.82-2.0
                          elfkickers              3.1-1.1              3.1-2.0
                            epdfview            0.1.8-8.1           0.1.8-10.0
                       evolution-rss           0.3.95-4.0           0.3.95-4.1
                                 fio             3.11-1.0             3.12-1.0
                           freeimage           3.18.0-2.0           3.18.0-2.1
                            glew1.10             1.10.0-1           1.10.0-2.0
                     haskell-githash          0.1.2.0-7.0          0.1.2.0-8.0
                 haskell-hjsonschema          1.9.0-120.0          1.9.0-121.0
                        haskell-http       4000.3.12-79.0       4000.3.12-80.0
                   haskell-js-jquery          3.3.1-149.0          3.3.1-150.0
              haskell-math-functions          0.3.0.2-3.0          0.3.1.0-1.0
            haskell-mono-traversable         1.0.9.0-21.0         1.0.9.0-22.0
                          hexer-hobu            1.4.0-1.1            1.4.0-2.0
                            libesmtp            1.0.6-5.2            1.0.6-6.0
                             libgiac         1.4.9.71-2.0          1.5.0.3-1.0
                    libqtshadowsocks            2.1.0-3.1            2.1.0-4.3
                       libudev0-shim                1-2.1                1-3.0
                           limesuite          18.10.0-2.4          18.10.0-2.5
                               minio       2018.10.06-1.0       2018.11.06-1.0
                      notify-sharp-3            3.0.3-2.1            3.0.3-3.0
                                 npm            6.4.1-1.0            6.4.1-1.1
                                ogre           1.11.1-3.0           1.11.2-2.0
                         osm-gps-map            1.1.0-3.1            1.1.0-4.0
                            pdcurses              3.4-8.1              3.4-9.0
                            pgadmin4              3.4-1.0              3.5-1.0
                             postgis            2.4.4-4.0            2.5.0-1.0
                      python2-enum34            1.1.6-1.1            1.1.6-2.0
                         telegram-qt            0.1.0-2.2            0.1.0-2.3
                           ttf-droid         20121017-5.1         20121017-6.0
                      ttf-liberation             2.00.1-7           2.00.1-8.0
              ttf-ubuntu-font-family               0.83-3             0.83-4.0
                                 urh            2.4.1-1.0            2.4.2-1.0
                          virtualbox           5.2.20-1.0           5.2.22-1.0
                  virtualbox-ext-vnc           5.2.20-1.0           5.2.22-1.0
               virtualbox-guest-dkms           5.2.20-1.0           5.2.22-1.0
              virtualbox-guest-utils           5.2.20-1.0           5.2.22-1.0
          virtualbox-guest-utils-nox           5.2.20-1.0           5.2.22-1.0
                virtualbox-host-dkms           5.2.20-1.0           5.2.22-1.0
                      virtualbox-sdk           5.2.20-1.0           5.2.22-1.0
                       webkit2-sharp           2.10.9-1.1           2.10.9-2.0
                                xcas         1.4.9.71-2.0          1.5.0.3-1.0
                             xdotool     3.20160805.1-1.1     3.20160805.1-2.0
                               peony                    -            1.1.4-1.0
                              sdedit                    -         4.2beta8-1.0

Extramodule rebuilds:

:: Different overlay package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                          libsystemd            239.300-1            239.300-2
                             systemd            239.300-1            239.300-2
                  systemd-resolvconf            239.300-1            239.300-2
                  systemd-sysvcompat            239.300-1            239.300-2


:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
   linux316-virtualbox-guest-modules             5.2.20-1             5.2.22-1
    linux316-virtualbox-host-modules             5.2.20-1             5.2.22-1
                  linux318-acpi_call             1.1.0-65             1.1.0-66
                linux318-broadcom-wl      6.30.223.271-41      6.30.223.271-42
                linux318-ndiswrapper              1.61-41              1.61-42
               linux318-nvidia-340xx            340.107-8            340.107-9
               linux318-nvidia-390xx             390.87-4             390.87-5
                      linux318-r8168          8.045.08-20          8.045.08-21
                  linux318-rt3562sta        2.4.1.1_r4-41        2.4.1.1_r4-42
                        linux318-spl             0.7.11-2             0.7.11-3
                linux318-vhba-module          20161009-41          20161009-42
   linux318-virtualbox-guest-modules             5.2.20-1             5.2.22-2
    linux318-virtualbox-host-modules             5.2.20-1             5.2.22-2
                        linux318-zfs             0.7.11-2             0.7.11-3
                  linux414-acpi_call             1.1.0-64             1.1.0-65
                        linux414-spl             0.7.11-4             0.7.11-5
   linux414-virtualbox-guest-modules             5.2.20-3             5.2.22-2
    linux414-virtualbox-host-modules             5.2.20-3             5.2.22-2
                        linux414-zfs             0.7.11-4             0.7.11-5
   linux419-virtualbox-guest-modules             5.2.20-1             5.2.22-1
    linux419-virtualbox-host-modules             5.2.20-1             5.2.22-1
                   linux44-acpi_call            1.1.0-114            1.1.0-115
                 linux44-broadcom-wl      6.30.223.271-84      6.30.223.271-85
                 linux44-ndiswrapper              1.61-82              1.61-83
                linux44-nvidia-340xx           340.107-19           340.107-20
                linux44-nvidia-390xx             390.87-8             390.87-9
                       linux44-r8168          8.045.08-36          8.045.08-37
                   linux44-rt3562sta        2.4.1.1_r4-82        2.4.1.1_r4-83
                         linux44-spl             0.7.11-4             0.7.11-5
                 linux44-vhba-module          20161009-82          20161009-83
    linux44-virtualbox-guest-modules             5.2.20-2             5.2.22-2
     linux44-virtualbox-host-modules             5.2.20-2             5.2.22-2
                         linux44-zfs             0.7.11-4             0.7.11-5
                   linux49-acpi_call            1.1.0-101            1.1.0-102
                         linux49-spl             0.7.11-4             0.7.11-5
    linux49-virtualbox-guest-modules             5.2.20-2             5.2.22-2
     linux49-virtualbox-host-modules             5.2.20-2             5.2.22-2
                         linux49-zfs             0.7.11-4             0.7.11-5

#86

KDE still broken?


#87

Yep, sddm still segfaulting with qt library issue.


#88

Hope solved soon


#89

Hi guys. Just a simple question. I have a Manjaro 32 installation sets up in a stable branch. It is running perfectly in the machine since years ago, but I have the doubt of changing to the testing branch to have the latest updates. Do you think it’s worth it? I don’t know what to do…


#90

I am on x32-testing since its announcement for more than a year and I can say that it is fairly stable - I had only two issues since then: one during the upgrade from python 3.6 to 3.7 giving me problems with gdb for two weeks because it wasn’t updated accordingly; the other one is with this update causing sddm and plasma desktop to fail because of qt incompatibility. On either case, I was able to revert to x32-stable within hours.


#91

Another sync, another sddm rebuild:

:: Different sync package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
             ca-certificates-mozilla             3.39-1.5             3.40-2.0
                          ipw2100-fw              1.3-8.2              1.3-9.0
                          ipw2200-fw              3.1-6.2              3.1-7.0
                             libssh2            1.8.0-2.6            1.8.0-3.0
                                 nss             3.39-1.5             3.40-2.0
                          openresolv            3.9.0-1.5            3.9.0-2.0


:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                                sddm           0.18.0-1.2           0.18.0-1.3


:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                                 ant           1.10.5-1.0           1.10.5-1.1
                             ant-doc           1.10.5-1.0           1.10.5-1.1
                             cairomm           1.12.2-2.1           1.12.2-3.0
                        cairomm-docs           1.12.2-2.1           1.12.2-3.0
                            celestia            1.6.1-7.0            1.6.1-7.1
                            enscript            1.6.6-2.2            1.6.6-3.0
                       evolution-ews           3.28.5-1.0           3.30.2-1.0
                              ffcall             1.13-2.1             1.13-3.0
                              garcon              0.6.1-1            0.6.1-2.0
                        gconf-editor            3.0.1-4.1            3.0.1-5.0
                                ghex           3.18.3-1.1           3.18.3-2.0
                     gnome-alsamixer            0.9.7-3.1            0.9.7-4.0
                      gnome-calendar           3.28.2-1.0           3.30.1-1.0
                        gnome-common           3.18.0-2.1           3.18.0-3.0
                     gnome-doc-utils0.20.10+16+gc03cc09-1.20.20.10+16+gc03cc09-2.0
                        gnome-python          2.28.1-10.1          2.28.1-11.4
                   gnome-search-tool            3.6.0-3.1            3.6.0-4.0
                      gnome-tetravex3.22.0+4+g817dbf6-1.13.22.0+4+g817dbf6-2.0
                               gperf              3.1-1.2              3.1-2.0
                         gtk-engines           2.21.0-3.1           2.21.0-4.0
                            gtkglext           1.2.0-11.0           1.2.0-11.1
                                gvim         8.1.0374-1.0         8.1.0519-1.0
                             libidl2           0.8.14-4.1           0.8.14-5.0
                       libkeybinder3            0.3.2-1.1            0.3.2-2.0
                   libnetfilter_acct            1.0.3-1.2            1.0.3-2.0
                          libxfce4ui             4.12.1-2           4.12.1-3.0
                           mpdecimal            2.4.2-1.2            2.4.2-2.0
                              nfacct            1.0.2-1.2            1.0.2-2.0
                   python-setuptools         1:40.5.0-1.0         1:40.6.2-1.0
                       python2-gconf          2.28.1-10.1          2.28.1-11.4
                  python2-setuptools         1:40.5.0-1.0         1:40.6.2-1.0
                        qt-gstreamer              1.2.0-1            1.2.0-2.0
                signon-plugin-oauth2             0.24-1.1             0.24-2.0
                           signon-ui    0.17+20150611-1.1    0.17+20150611-2.0
                              sonata         1.6.2.1-13.1         1.6.2.1-14.0
                    telepathy-gabble           0.18.4-1.1           0.18.4-2.0
                        telepathy-qt            0.9.7-1.1            0.9.7-2.0
                     telepathy-salut              0.8.1-4            0.8.1-5.0
                            tftp-hpa              5.2-6.1              5.2-7.0
                       thunar-volman            0.8.1-2.1            0.8.1-3.0
                           truecrypt           1:7.1a-5.1           1:7.1a-6.0
                            uchardet            0.0.6-1.1            0.0.6-2.0
                                vice              3.2-1.0              3.2-1.1
                                 vim         8.1.0374-1.0         8.1.0519-1.0
                         vim-runtime         8.1.0374-1.0         8.1.0519-1.0
                                 vlc            3.0.4-6.0            3.0.4-6.1
                               xawtv   3.104+3+gc438af7-1            3.105-2.0
                     xcb-util-cursor            0.1.3-1.1            0.1.3-2.0
                            xcompmgr            1.1.7-2.1            1.1.7-3.0
                   xdg-user-dirs-gtk  0.10+9+g5b7efc6-1.1  0.10+9+g5b7efc6-2.0
                  xf86-input-vmmouse           13.1.0-3.1           13.1.0-4.0
                     xfce4-appfinder           4.12.0-4.1           4.12.0-5.0
               xfce4-cpugraph-plugin            1.0.5-4.1            1.0.5-5.0
               xfce4-datetime-plugin            0.7.0-1.1            0.7.0-2.0
                xfce4-fsguard-plugin            1.1.0-1.1            1.1.0-2.0
              xfce4-mailwatch-plugin            1.2.0-7.1            1.2.0-8.0
                    xfce4-mpc-plugin            0.5.0-1.1            0.5.0-2.0
                xfce4-netload-plugin            1.3.1-1.1            1.3.1-2.0
                  xfce4-notes-plugin            1.8.1-2.1            1.8.1-3.0
          xfce4-smartbookmark-plugin            0.5.0-1.1            0.5.0-2.0
             xfce4-systemload-plugin            1.2.1-1.1            1.2.1-2.0
               xfce4-time-out-plugin            1.0.2-2.1            1.0.2-3.0
                xfce4-wavelan-plugin            0.6.0-1.1            0.6.0-2.0
                               xmlto           0.0.28-2.2           0.0.28-3.0
                     xorg-fonts-misc            1.0.3-5.1            1.0.3-6.0
                          xorg-xauth           1.0.10-1.1           1.0.10-2.0
                       xorg-xconsole            1.0.7-1.1            1.0.7-2.0
                         xorg-xrandr            1.5.0-1.1            1.5.0-2.0


:: Different sync package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                        armagetronad        0.2.8.3.4-1.1        0.2.8.3.4-2.0
                             awesome              4.2-1.2              4.2-2.0
                             aws-cli          1.16.50-1.0          1.16.53-1.0
                       cabal-install          2.4.0.0-7.0          2.4.0.0-8.0
                                ccgo          0.3.6.5-3.1          0.3.6.5-4.0
                               cgrep         6.6.25-100.0         6.6.25-101.0
                        chromium-bsu           0.9.16-1.1           0.9.16-2.0
                         coin-or-cbc            2.9.9-1.1            2.9.9-2.0
                          coin-or-mp            1.8.3-5.2            1.8.3-6.0
                             cryptol           2.6.0-55.0           2.6.0-56.0
                                cuyo          1:2.1.0-3.1          1:2.1.0-4.0
                               darcs          2.14.1-83.0          2.14.1-84.0
                          deepin-api            3.7.0-1.0            3.8.0-1.0
                            fcgiwrap              1.1.0-4            1.1.0-5.0
                              fdupes          1:1.6.1-1.2          1:1.6.1-2.0
                          findnewest              0.3-1.2              0.3-2.0
                          galculator            2.1.4-3.1            2.1.4-4.0
                     galculator-gtk2            2.1.4-3.1            2.1.4-4.0
                               gdlmm            3.7.3-3.1            3.7.3-4.0
                           git-annex       7.20181105-5.0       7.20181105-6.0
                                gnac          0.2.4.1-5.1          0.2.4.1-6.0
                               gnubg         1.06.000-1.0         1.06.002-1.0
                            gpicview            0.2.5-3.1            0.2.5-4.0
                       gpicview-gtk3            0.2.5-3.1            0.2.5-4.0
                        gpscorrelate            1.6.2-2.1            1.6.2-3.0
                          gpx-viewer            0.4.0-1.1            0.4.0-2.0
                             guetzli            1.0.1-2.1            1.0.1-3.0
                           gxmessage            3.4.3-2.1            3.4.3-3.0
                haskell-authenticate          1.3.4-204.0          1.3.4-205.0
                         haskell-aws           0.20-112.0           0.20-113.0
              haskell-binary-conduit            1.3.1-5.0            1.3.1-6.0
                     haskell-conduit            1.3.1-8.0            1.3.1-9.0
               haskell-conduit-extra           1.3.0-70.0           1.3.0-71.0
                   haskell-criterion         1.5.2.0-11.0          1.5.3.0-2.0
          haskell-cryptohash-conduit          0.1.1-232.0          0.1.1-233.0
          haskell-cryptonite-conduit          0.2.2-126.0          0.2.2-127.0
                         haskell-dav          1.3.2-150.0          1.3.2-151.0
              haskell-deferred-folds            0.9.9-7.0            0.9.9-8.0
                   haskell-esqueleto  2.5.3.20180402-94.0  2.5.3.20180402-95.0
                        haskell-feed          1.0.1.0-1.0          1.0.1.0-2.0
                       haskell-foldl            1.4.5-7.0            1.4.5-8.0
                      haskell-hakyll        4.12.4.0-67.0        4.12.4.0-68.0
                       haskell-hasql         1.3.0.3-28.0         1.3.0.3-29.0
                  haskell-hasql-pool             0.5-28.0             0.5-29.0
           haskell-hasql-transaction             0.7-28.0             0.7-29.0
                    haskell-hopenpgp          2.7.4.1-6.0          2.7.4.1-7.0
                       haskell-hpack           0.31.1-3.0           0.31.1-4.0
                haskell-html-conduit            1.3.2-3.0            1.3.2-4.0
                haskell-http-conduit           2.3.2-76.0           2.3.2-77.0
                     haskell-libyaml          0.1.0.0-4.0          0.1.0.0-5.0
                haskell-monad-logger           0.3.30-3.0           0.3.30-4.0
                   haskell-monad-par         0.3.4.8-24.0         0.3.4.8-25.0
                    haskell-mustache          2.3.0-113.0          2.3.0-114.0
                  haskell-mwc-random         0.14.0.0-5.0         0.14.0.0-6.0
                  haskell-persistent           2.8.2-96.0           2.8.2-97.0
           haskell-persistent-sqlite           2.8.2-42.0           2.8.2-43.0
         haskell-persistent-template          2.5.4-122.0          2.5.4-123.0
            haskell-project-template        0.2.0.1-100.0        0.2.0.1-101.0
                       haskell-sandi            0.4.3-2.0            0.4.3-3.0
                         haskell-sbv            7.12-24.0            7.12-25.0
              haskell-servant-server       0.13.0.1-116.0       0.13.0.1-117.0
                       haskell-shake             0.17-8.0             0.17-9.0
             haskell-simple-sendfile          0.2.27-96.0          0.2.27-97.0
                  haskell-statistics        0.14.0.2-86.0        0.14.0.2-87.0
                       haskell-store        0.4.3.2-160.0        0.4.3.2-161.0
           haskell-tagstream-conduit        0.5.5.3-220.0        0.5.5.3-221.0
                haskell-text-builder            0.6.4-6.0            0.6.4-7.0
                      haskell-turtle           1.5.12-8.0           1.5.12-9.0
              haskell-wai-app-static        3.1.6.2-132.0        3.1.6.2-133.0
                 haskell-wai-conduit         3.0.0.4-81.0         3.0.0.4-82.0
          haskell-wai-handler-launch         3.0.2.4-92.0         3.0.2.4-93.0
                        haskell-warp          3.2.25-28.0          3.2.25-29.0
                    haskell-warp-tls        3.2.4.3-111.0        3.2.4.3-112.0
                 haskell-xml-conduit         1.8.0.1-16.0         1.8.0.1-17.0
                  haskell-xml-hamlet           0.5.0-75.0           0.5.0-76.0
                        haskell-yaml         0.11.0.0-4.0         0.11.0.0-5.0
                       haskell-yesod          1.6.0-158.0          1.6.0-159.0
                  haskell-yesod-auth            1.6.5-9.0           1.6.5-10.0
                  haskell-yesod-core          1.6.8.1-7.0          1.6.8.1-8.0
               haskell-yesod-default          1.2.0-425.0          1.2.0-426.0
                  haskell-yesod-form            1.6.3-8.0            1.6.3-9.0
            haskell-yesod-persistent         1.6.0.1-12.0         1.6.0.1-13.0
                haskell-yesod-static          1.6.0.1-6.0          1.6.0.1-7.0
                  haskell-yesod-test         1.6.5.1-13.0         1.6.5.1-14.0
                           hedgewars        0.9.24.1-73.0        0.9.24.1-74.0
                             hindent           5.2.7-48.0           5.2.7-49.0
                             hledger          1.11.1-12.0          1.11.1-13.0
                         hledger-api          1.11.1-20.0          1.11.1-21.0
                          hledger-ui          1.11.1-17.0          1.11.1-18.0
                         hledger-web          1.11.1-32.0          1.11.1-33.0
                               hlint          2.1.10-43.0          2.1.10-44.0
                              hoogle       5.0.17.3-122.0       5.0.17.3-123.0
                      hopenpgp-tools          0.21.2-59.0          0.21.2-60.0
                      ibus-sunpinyin         3.0.0rc1-3.1         3.0.0rc1-4.0
                             jbigkit              2.1-3.1              2.1-4.0
                              julius          4.4.2.1-1.1          4.4.2.1-3.0
                          kchmviewer              7.7-3.1              7.7-4.0
                              kdesvn              2.0.0-2            2.0.0-3.0
                           keepassx2            2.0.3-1.1            2.0.3-2.0
                             klavaro             3.03-1.1             3.03-2.0
                             l3afpad      0.8.18.1.11-2.1      0.8.18.1.11-3.0
                             libaacs            0.9.0-1.2            0.9.0-2.0
                              libasr            1.0.2-2.1            1.0.2-3.0
                    libdbusmenu-glib          16.04.0-2.1          16.04.0-3.0
                    libdbusmenu-gtk2          16.04.0-2.1          16.04.0-3.0
                    libdbusmenu-gtk3          16.04.0-2.1          16.04.0-3.0
                         libunibreak              4.0-1.1              4.0-2.0
                        light-locker            1.8.0-1.2            1.8.0-2.0
                            lollypop          0.9.610-1.0          0.9.612-1.0
                                lshw          B.02.18-2.1          B.02.18-3.0
                            lua-sdl2       v2.0.5_6.0-1.1       v2.0.5_6.0-2.0
                        lxappearance            0.6.3-1.1            0.6.3-2.0
                   lxappearance-gtk3            0.6.3-1.1            0.6.3-2.0
                 lxappearance-obconf            0.2.3-1.1            0.2.3-2.0
            lxappearance-obconf-gtk3            0.2.3-1.1            0.2.3-2.0
                             lxinput            0.3.5-1.1            0.3.5-2.0
                        lxinput-gtk3            0.3.5-1.1            0.3.5-2.0
                         lxmenu-data            0.1.5-1.2            0.1.5-2.0
                             lxmusic            0.4.7-1.1            0.4.7-2.0
                        lxmusic-gtk3            0.4.7-1.1            0.4.7-2.0
                        lxpanel-gtk3            0.9.3-1.2            0.9.3-2.0
                             lxrandr            0.3.1-1.1            0.3.1-2.0
                        lxrandr-gtk3            0.3.1-1.1            0.3.1-2.0
                           lxsession          1:0.5.3-1.1          1:0.5.3-2.0
                      lxsession-gtk3          1:0.5.3-1.1          1:0.5.3-2.0
                mate-applet-streamer           0.3.10-2.1           0.3.10-3.0
                      megaglest-data             3.13.0-1           3.13.0-2.0
                           mktorrent              1.1-2.1              1.1-3.0
                      moneymanagerex            1.3.3-2.1            1.3.3-3.0
                  monitoring-plugins              2.2-2.1              2.2-4.0
                         mp3splt-gtk            0.9.2-2.1            0.9.2-3.0
                                  mx1.4.7+13+g24efb0cc-1.11.4.7+13+g24efb0cc-2.0
             nextcloud-app-bookmarks         1:0.14.0-1.0         1:0.14.2-1.0
                              nodejs           11.1.0-1.1           11.1.0-1.2
                 notification-daemon           3.20.0-1.1           3.20.0-2.0
                          notify-osd0.9.35+16.04.20160415-1.10.9.35+16.04.20160415-2.0
                   npm-check-updates           2.14.2-1.0           2.14.3-1.0
                                 p0f            3.09b-1.2            3.09b-2.0
                              pandoc              2.4-1.0              2.4-2.0
                     pandoc-citeproc         0.14.8.1-1.0         0.14.8.1-2.0
                     pandoc-crossref         0.3.3.0-33.0         0.3.3.0-34.0
                          parcellite            1.2.1-2.1            1.2.1-3.0
                                 pcb          1:4.1.2-1.1          1:4.1.3-1.0
                         perl-inline             0.80-2.1             0.80-3.0
                       perl-readonly             2.05-2.1             2.05-3.0
                    pidgin-libnotify            0.14-10.1            0.14-11.0
                pidgin-xmpp-receipts              0.8-1.1              0.8-2.0
                             ponymix                5-1.1                5-2.0
                           postgrest         0.5.0.0-65.0         0.5.0.0-66.0
                               pptpd            1.4.0-1.1            1.4.0-2.0
                               pympd           0.08.1-5.1           0.08.1-6.0
                        python-boto3           1.9.40-1.0           1.9.43-1.0
                     python-botocore          1.12.40-1.0          1.12.43-1.0
                        python-faker            0.9.2-1.0            1.0.0-1.0
                       python-pydoe2            1.1.1-1.0            1.1.2-1.0
                python-pytest-django            3.4.3-1.0            3.4.4-1.0
           python-pytest-localserver            0.4.1-2.0            0.5.0-1.0
                         python-wand            0.4.4-1.0            0.4.5-1.0
                   python-whitenoise              4.1-1.0            4.1.1-1.0
python2-backports.shutil_get_terminal_size            1.0.0-1.1            1.0.0-3.0
                       python2-boto3           1.9.40-1.0           1.9.43-1.0
                    python2-botocore          1.12.40-1.0          1.12.43-1.0
                       python2-cjson            1.2.1-1.1            1.2.1-2.2
                       python2-faker            0.9.2-1.0            1.0.0-1.0
                      python2-gnutls            3.0.0-1.1            3.0.0-2.0
                    python2-gtkglext            1.1.0-8.0            1.1.0-8.1
                    python2-pysqlite            2.8.3-1.1            2.8.3-2.0
               python2-pytest-django            3.4.3-1.0            3.4.4-1.0
          python2-pytest-localserver            0.4.1-2.0            0.5.0-1.0
                  python2-whitenoise              4.1-1.0            4.1.1-1.0
                                 qgo            2.1.0-5.1            2.1.0-6.0
                         qt5-systems   5.4.0.20160303-2.3   5.4.0.20160303-3.0
                     raw-thumbnailer            0.2.1-3.1            0.2.1-4.0
                            regexxer             0.10-7.1             0.10-8.0
                              retext            7.0.3-3.0            7.0.4-3.0
                             scratch          1.4.0.7-6.2          1.4.0.7-7.0
                          shellcheck           0.5.0-89.0          0.5.0-144.0
                              shhmsg            1.4.2-2.1            1.4.2-3.0
                              shhopt            1.1.7-3.1            1.1.7-4.0
                               slock              1.4-2.1              1.4-3.0
                         soapyrtlsdr            0.2.5-3.0            0.2.5-3.1
                            soapysdr            0.7.0-1.0            0.7.0-1.1
                             sshpass             1.06-1.1             1.06-2.0
                               stack           1.9.1-16.0           1.9.1-17.0
                          steadyflow            0.2.0-6.1            0.2.0-7.0
                     stylish-haskell         0.9.2.0-89.0         0.9.2.0-90.0
                        sugar-runner          0.110.0-1.1          0.110.0-2.0
                                surf              2.0-1.1              2.0-2.0
                          symmetrica              2.0-5.1              2.0-6.0
                       syncthing-gtk        1:0.9.4.2-1.0        1:0.9.4.3-1.0
                        systemdgenie           0.99.0-1.1           0.99.0-2.0
                              tabbed              0.6-2.1              0.6-3.0
                             tachyon           0.98.9-4.2           0.98.9-5.0
                      tamarin-prover          1.4.0-138.0          1.4.0-139.0
                             tcpflow            1.4.5-3.1            1.4.5-4.0
                            tcptrace            6.6.7-4.1            6.6.7-5.0
                     telepathy-morse            0.1.0-1.1            0.1.0-2.0
             tldp-howtos-html-single         20161114-1.1         20161114-2.0
                            torsocks            2.2.0-1.1            2.2.0-2.0
                         transset-df                6-5.1                6-6.0
                              tuxcmd           0.6.70-7.1           0.6.70-8.0
                               ucarp            1.5.2-6.1            1.5.2-7.0
                          unittestpp            2.0.0-1.1            2.0.0-2.0
                            uudeview          0.5.20-13.1          0.5.20-14.0
                               webfs            1.21-13.1            1.21-14.0
                                 wol            0.7.1-7.1            0.7.1-8.0
                         xautomation             1.09-2.1             1.09-3.0
                           xbindkeys            1.8.6-2.1            1.8.6-3.0
                              xboard            4.9.1-1.1            4.9.1-2.0
                                xchm             1.23-7.2             1.23-8.0
                              xmobar            0.27-49.0            0.27-50.0
                               xonsh            0.8.1-1.0            0.8.2-1.0
                             xplanet              1.3.1-1            1.3.1-2.0
                                xplc           0.3.13-7.1           0.3.13-8.0
                                xpra            2.3.4-1.0            2.4.1-1.0
                                xsel   1.2.0.20160929-1.1   1.2.0.20160929-2.0
                            xssstate              1.1-2.1              1.1-3.0
                         yabause-gtk             0.9.15-2           0.9.15-2.1
                                 zaz            1.0.0-7.1            1.0.0-8.0
                        python-baron                    -              0.8-1.0
                     python-redbaron                    -              0.8-1.0

#92

Then I think I could try testing branch as I’m not using plasma desktop, just Budgie Desktop :wink: Thanks!


#93

@jonathon @sueridgepipe I was able to reproduce the Qt incompatiblity error for sddm and kwin with FRESH install of archlinux32, which is very minimal and have only sddm and kwin packages explicitly installed after switching mirrorlist to the current branch.

So, I can confirm that the problem is with Qt builds from archlinux32!!

UPDATE:
ALL the qt plugins loaded by either program before segfaulting are up-to-date and linked against 5.11.2 as per their metadata; other qt libraries cannot be checked for version since they don’t include revision number in the library name but the owner packages of all of them have 5.11.2 version. WEIRD!!


#94

This should sort out the x265 soname incompatibility.

These steps should get you the rebuilt package:

sudo rm /var/cache/pacman/pkg/ffmpeg-1:4.1-1.1-i686.pkg.tar.xz
sudo pacman -Syu
sudo pacman -S ffmpeg
:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                              ffmpeg                    -            1:4.1-1.1


:: Different overlay package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE          x32-testing         x32-unstable
-------------------------------------------------------------------------------
                               copyq              3.5.0-2              3.7.0-1
         manjaro-application-utility                1.1-2                1.1-3
              manjaro-openbox-config           1.18.2-0.1           1.18.2-0.2
    manjaro-openbox-desktop-settings           1.18.2-0.1           1.18.2-0.2
                    matcha-gtk-theme           20181104-1           20181113-1
                    plane-icon-theme                    -                1.4-1

#95

As far as the Qt5 stuff goes, it looks like it’s coming down to qt5-webengine as the guilty package.

I’m trying to get a rebuild going but it’s taking a bit of time to work through the dependency chain (e.g. ffmpeg, above).


#96

“Tommy…tomorrow NEVER comes my boy!”


#97

This works just as predicted by you. Thanks


#98

Xcfe just updated without a problem… so problem solved on this DE.
Thanks for the great job @jonathon


#99

It’s not qt5-webengine.

I’m at a complete loss to explain the issue. I’ve locally rebuilt pretty much every qt5-* package and none of them help.

I can’t really snap this to stable with a pretty much broken KDE but it’s getting on towards a month since the last stable update. :sweat:


#100

I would like to help in any point. But I can’t figure how as I don’t have KDE running on my PC. I really want to keep Manjaro 32 alive at the stable branch as it keeps my machine working incredibly well. Thanks for all your efforts @jonathon. Keep the good work!!


#101

It seems that arhclinux32 guys diagnosed the problem recently on this thread:
https://bbs.archlinux32.org/viewtopic.php?id=2628

FINALLY!!