[Testing Update] 2024-05-14 - Linux Firmware, Mkinitcpio, PHP, Plymouth

Hello community, here we have another set of package updates.

Current Promotions

  • Find out all about our current Gaming Laptop the Hero with Manjaro pre-installed from Spain!
  • Protect your personal data, keep yourself safe with Surfshark VPN: 85% OFF + 2 mo. FREE

Recent News

Previous News
Finding information easier about Manjaro

Finding information easier about Manjaro always has been a topic that needed to be solved. With our new search we have put all Manjaro data accessible in one place and divided by sections so it makes it easier to digest: New Manjaro search engine is available | Blog


Notable Package Updates

  • Small fixes to Firmwares
  • mkinitcpio got updated to 39.1
  • php got renewed
  • updates to gitlab related packages
  • small updates to qt6
  • plymouth is again at 24.004.60
    • report possible issues with that version, especially if you use AMD or Nvidia hardware

A list of all package changes can be found here

Additional Info

Python 3.12 info

:information_source: You will need to rebuild any AUR Python packages that install files to site-packages or link to libpython3.11.so. :information_source:

Print a list of of packages that have files in /usr/lib/python3.11/ :

pacman -Qoq /usr/lib/python3.11/

Rebuild them all at once:*

pamac build $(pacman -Qoq /usr/lib/python3.11)

* Note that if any fail to build, you’ll have to rebuild what’s remaining one or a few at a time.

Use rebuild-detector to see if anything else needs to be rebuilt:

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcements topics are off-topic and will be flagged, moved or removed without warning.

For help with AUR packages, please create a new topic in AUR and a helpful volunteer may be able to assist you.

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.313
  • linux54 5.4.275
  • linux510 5.10.216
  • linux515 5.15.158
  • linux61 6.1.90
  • linux66 6.6.30
  • linux68 6.8.9
  • linux69 6.9.0
  • linux61-rt 6.1.83_rt28
  • linux66-rt 6.6.23_rt28
  • linux67-rt 6.7_rt6

Package Changes (Wed May 8 16:44:55 CEST 2024)

  • testing core x86_64: 12 new and 12 removed package(s)
  • testing extra x86_64: 85 new and 90 removed package(s)
  • testing multilib x86_64: 1 new and 1 removed package(s)
:: Different overlay package(s) in repository core x86_64

                             PACKAGE           2024-05-08           2024-05-14
                          mkinitcpio               38.1-1               39.1-2

:: Different sync package(s) in repository core x86_64

                             PACKAGE           2024-05-08           2024-05-14
                   linux-api-headers                6.7-1                6.8-1

:: Different overlay package(s) in repository extra x86_64

                             PACKAGE           2024-05-08           2024-05-14
                            chromium     124.0.6367.155-1                    -
                          hibernator                0.5-1                    -
                            plymouth         22.02.122-18          24.004.60-8
                  xorgproto-transfer            2019.12-1                    -

:: Different sync package(s) in repository extra x86_64

                             PACKAGE           2024-05-08           2024-05-14
                              argocd             2.10.8-1             2.11.0-1
                                arti              1.2.1-1              1.2.2-1
                     cargo-tarpaulin             0.29.1-1             0.29.2-1
                            chromium     124.0.6367.118-1     124.0.6367.155-1
                               cmake             3.29.2-1             3.29.3-1
                                 dnf             4.19.0-2             4.20.0-1
                                dolt          1:1.35.13-1           1:1.36.0-1
                             esbuild             0.20.2-1             0.21.0-1
                            fail2ban              1.1.0-3              1.1.0-4
                               gcc12             12.3.0-6                    -
                       gcc12-fortran             12.3.0-6                    -
                          gcc12-libs             12.3.0-6                    -
                              gitlab            16.11.1-1            16.11.2-1
                       gitlab-gitaly            16.11.1-1            16.11.2-1
                        gitlab-pages            16.11.1-1            16.11.2-1
                         gnome-shell             1:46.1-1             1:46.1-2
                    gnome-shell-docs             1:46.1-1             1:46.1-2
                                  go           2:1.22.2-1           2:1.22.3-1
                           hyprpaper              0.6.0-4              0.7.0-1
                             jujutsu             0.17.0-4             0.17.1-1
                            keycloak             24.0.3-1             24.0.4-1
                        link-grammar             5.12.3-3             5.12.3-4
                          metasploit              6.4.6-1              6.4.7-1
                               minio         2024.05.01-1         2024.05.07-1
                     nodejs-lts-iron            20.12.2-1            20.13.0-1
                                 npm             10.5.2-1             10.7.0-1
            nvidia-container-toolkit             1.15.0-1             1.15.0-2
                            onefetch             2.20.0-3             2.21.0-1
                             osbuild                117-1                118-1
                            pcsclite              2.2.0-4              2.2.1-1
                                 php              8.3.6-1              8.3.7-1
                          php-apache              8.3.6-1              8.3.7-1
                             php-cgi              8.3.6-1              8.3.7-1
                           php-dblib              8.3.6-1              8.3.7-1
                           php-embed              8.3.6-1              8.3.7-1
                         php-enchant              8.3.6-1              8.3.7-1
                             php-fpm              8.3.6-1              8.3.7-1
                              php-gd              8.3.6-1              8.3.7-1
                          php-legacy             8.2.18-1             8.2.19-1
                   php-legacy-apache             8.2.18-1             8.2.19-1
                      php-legacy-cgi             8.2.18-1             8.2.19-1
                    php-legacy-dblib             8.2.18-1             8.2.19-1
                    php-legacy-embed             8.2.18-1             8.2.19-1
                  php-legacy-enchant             8.2.18-1             8.2.19-1
                      php-legacy-fpm             8.2.18-1             8.2.19-1
                       php-legacy-gd             8.2.18-1             8.2.19-1
                     php-legacy-odbc             8.2.18-1             8.2.19-1
                    php-legacy-pgsql             8.2.18-1             8.2.19-1
                   php-legacy-phpdbg             8.2.18-1             8.2.19-1
                   php-legacy-pspell             8.2.18-1             8.2.19-1
                     php-legacy-snmp             8.2.18-1             8.2.19-1
                   php-legacy-sodium             8.2.18-1             8.2.19-1
                   php-legacy-sqlite             8.2.18-1             8.2.19-1
                     php-legacy-tidy             8.2.18-1             8.2.19-1
                      php-legacy-xsl             8.2.18-1             8.2.19-1
                            php-odbc              8.3.6-1              8.3.7-1
                           php-pgsql              8.3.6-1              8.3.7-1
                          php-phpdbg              8.3.6-1              8.3.7-1
                          php-pspell              8.3.6-1              8.3.7-1
                            php-snmp              8.3.6-1              8.3.7-1
                          php-sodium              8.3.6-1              8.3.7-1
                          php-sqlite              8.3.6-1              8.3.7-1
                            php-tidy              8.3.6-1              8.3.7-1
                             php-xsl              8.3.6-1              8.3.7-1
                     plasma-firewall              6.0.4-1              6.0.4-2
                      python-astroid              3.1.0-5              3.2.0-1
           python-conway-polynomials                0.9-2               0.10-1
                    python-fakeredis             2.22.0-3             2.23.0-1
                       python-igraph             0.11.4-2             0.11.5-1
             python-pycrdt-websocket             0.13.3-1             0.13.4-1
                           python-uv             0.1.39-1             0.1.41-1
                                 qbs              2.3.0-1              2.3.1-1
                            qt6-base              6.7.0-5              6.7.0-6
             qt6-xcb-private-headers              6.7.0-5              6.7.0-6
                           qtcreator             13.0.0-1             13.0.1-1
                     qtcreator-devel             13.0.0-1             13.0.1-1
                              remind              4.3.6-1              4.3.7-1
                      signal-desktop              7.7.0-1              7.8.0-1
                           syncthing             1.27.6-1             1.27.7-1
                  syncthing-discosrv             1.27.6-1             1.27.7-1
                  syncthing-relaysrv             1.27.6-1             1.27.7-1
                                  uv             0.1.39-1             0.1.41-1
                              vector             0.37.1-1             0.38.0-1
                            wasmtime             20.0.1-1             20.0.2-1
                              waybar             0.10.2-2             0.10.3-1
                     add-determinism                    -              0.2.0-1

:: Different sync package(s) in repository multilib x86_64

                             PACKAGE           2024-05-08           2024-05-14
                      lib32-pcsclite              2.1.0-1              2.2.0-1
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)
0 voters

Check if your mirror has already synced:

1 Like

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2024-05-14

No plasma interface with kernel 6.9 + Nvidia gpu + Wayland

If you encouter a black screen with no inteface after login in, it’s probably a problem with simpledrm loading.

To solve it add nvidia_drm.fbdev=1 to /etc/default/grub
in the line begining with GRUB_CMDLINE_LINUX=" .
Verify that you also have nvidia_drm.modeset=1 in the same line.
Then exec sudo update-grub

Also, verify that you have nvidia_drm in /etc/mkinitcpio.conf in the MODULES= or HOOKS= line.
Exemple :

MODULES=(nvidia nvidia_modeset nvidia_uvm nvidia_drm)

If it was not present, then run sudo mkinitcpio -P after adding it.


Qemu: MacOS is not bootable with 9.0

Due to a bug MacOS is not bootable with 9.0: [9.0.0] qemu breaks mac os vm (#2334) · Issues · QEMU / QEMU · GitLab
Workaround: remove virtio-serial and org.qemu.guest_agent.0 from libvirt XML until bug will be fixed.


The default KDE Plasma session has been changed to X11

As of Plasma 6, KDE decided to make Wayland the default. However, since issues were discovered, we have reverted the default to X11. Users are free to choose whichever works best for them.


Konsole font rendering issue

if you use manjaro-zsh-config on Plasma 6,
please check your Font settings in Konsole:

Konsole: Open Settings → Edit Current Profile → Appearance,
click Select Font and select MesloLGS NF Regular.


Plasma 6 issues with Manjaro themes & tools

Prepare for a Plasma 6 release (#2) · Issues · Release plan / KDE · GitLab

DKMS fails for v4l2loopback on 6.8 kernel

DKMS fails for v4l2loopback on 6.8 kernel (#2) · Issues · Arch Linux / Packaging / Packages / v4l2loopback · GitLab

New version of kvantum does not support QT5 theme

Install new package kvantum-qt5 for QT5 theme support
required for manjaro-settings-manager and audacious

pamac install kvantum-qt5

If Theme shows wrong colors:

cd $HOME; ln -s .profile .xprofile

Manjaro-settings-manager has light theme instead of dark

issues with auto-mount of ntfs filesystem using Kernel 6.8

The kernel changed default ntfs driver from FUSE one to ntfs3.
These two are not fully compatible, mainly as far as mount options go. If you have custom mount options in the fstab (or any other application, such as VeraCrypt) they need to be changed.

Mount fails with: Device or resource busy
DMesg reports: Can't open blockdev

Migrate your mount options. For me the changes were:

  • allow_otherumask=000
  • default_permissions → [drop]
  • user_id=1000uid=1000
  • group_id=1000gid=1000


gnome-keyring: ssh component is not included

ssh component is not included (#3) · Issues · Arch Linux / Packaging / Packages / gnome-keyring · GitLab

Previous testing threads:

1 Like

I just uptated my kernel to 6.9.0-1.
This one seem to have problem with kde under wayland (and NVIDIA GPU) :
Trying to login bring a “no inteface black screen”, and trying to launch (through konsole) some plasma app (like systemsettings or plasma-systemmonitor) bring a core dump of “kwin-wayland” (multiple time until it go back to login screen).

So far, my investigation is showing that kwin-wayland and the other problematic app try to acces some non existing files, like this :

  • MESA-LOADER: failed to open simpledrm: /usr/lib/dri/simpledrm_dri.so
  • MESA-LOADER: failed to open evdi: /usr/lib/dri/evdi_dri.so

Workaround : login under X11 or start with kernel 6.8.9-3


sudo mhwd-kernel -i linux69

:: Synchronising package databases...
 core is up to date
 extra is up to date
 multilib is up to date
resolving dependencies...
looking for conflicting packages...

Packages (1) linux69-6.9.0-1

Total Download Size:   105.83 MiB
Total Installed Size:  139.46 MiB

Normally I’d see linux69-r8168 in the package list here as well but this time it’s not present. I’m guessing I still need to wait a bit more before installing linux69.

I think I have the same issue.

When I login using this kernel on Wayland my screens stay black, flicker a little and then I am able to open for example a terminal via the Ctrl + Alt + T shortcut but essentially there are no desktop elements present (opening windows via the terminal still works though, and they can still be snapped while holding Ctrl - I’m writing this while being in that session).

No clue if this is helpful but this is my journalctl (journalctl --since yesterday > out.log) in which I first open a X11 session (no problems) and then logout and open a Wayland session (Ctrl + F: unknown[1831]: Now starting Wayland session): journalctl_boot.log · GitHub

1 Like

linux69-r8168 8.053.00-0.1 is coming along shortly.


Looks like it’s this again!

Just add nvidia-drm.fbdev=1 to the kernel cmdline, it fixed it for me!


microcode is back again in mkinitcpio.conf

That kinda fixed it for me. The first time I rebooted it crashed the whole PC, when I restarted the PC and then accidentally logged in again using a Wayland session it just worked like in the previous kernels. :+1:

(I updated the line GRUB_CMDLINE_LINUX="nvidia_drm.modeset=1 to GRUB_CMDLINE_LINUX="nvidia_drm.modeset=1 nvidia-drm.fbdev=1" in the file /etc/default/grub and ran sudo update-grub before restarting)

This fixed it for me too.

Note : I edited the Known issues and solutions Post with it.
I hope that i did not miss something and that i formatted it correctly.

Problems with kernel 6.9, wayland and nvidia drivers were resolved after making adjustements to grub and mkinitcpio from the guide.

1 Like

On the 14th I received an update with the kernel and plymouth.
Installed and got errors, one of which doesn’t appear in the image I’m going to share, which has to do with something similar to zdt or ztd. the rest of the errors are in this image that I captured now when reinstalling the system. On the 14th I got a black screen, both with the latest kernel and the LTS version.another error: WARNING: consolefont: no font found in configuration. If I restart I am left without a system again.

Since the latest testing update I’ve not been able to switch on bluetooth at all. Not even through a good ol’ restart.

sudo systemctl start bluetooth yields no output and does not resolve the issue.


Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 2109:2822 VIA Labs, Inc. USB2.0 Hub             
Bus 001 Device 003: ID 27c6:60c2 Shenzhen Goodix Technology Co.,Ltd. Goodix USB2.0 MISC
Bus 001 Device 004: ID 048d:8910 Integrated Technology Express, Inc. ITE Device
Bus 001 Device 005: ID 2537:1081 Norelsys NS1081
Bus 001 Device 006: ID 0e8d:0608 MediaTek Inc. Wireless_Device
Bus 001 Device 007: ID 0b95:1790 ASIX Electronics Corp. AX88179 Gigabit Ethernet
Bus 001 Device 008: ID 14cd:8601 Super Top 4-Port hub
Bus 001 Device 009: ID 291a:8388 Anker Innovations Limited. Anker USB-C Hub Device 
Bus 001 Device 010: ID 3384:4216 System76 USB4216 Smart Hub
Bus 001 Device 011: ID 3384:0001 System76 Launch Configurable Keyboard (launch_1)
Bus 001 Device 012: ID 1ea7:0064 SHARKOON Technologies GmbH 2.4GHz Wireless rechargeable vertical mouse [More&Better]
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 0c45:6362 Microdia Integrated Camera
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 007 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
[   18.746113] Bluetooth: Core ver 2.22
[   18.746130] NET: Registered PF_BLUETOOTH protocol family
[   18.746131] Bluetooth: HCI device and connection manager initialized
[   18.746134] Bluetooth: HCI socket layer initialized
[   18.746136] Bluetooth: L2CAP socket layer initialized
[   18.746139] Bluetooth: SCO socket layer initialized
[   18.939209] bluetooth hci0: Direct firmware load for mediatek/BT_RAM_CODE_MT7961_1a_2_hdr.bin failed with error -2
[   18.939213] Bluetooth: hci0: Failed to load firmware file (-2)
[   18.939215] Bluetooth: hci0: Failed to set up firmware (-2)
[   18.939216] Bluetooth: hci0: HCI Enhanced Setup Synchronous Connection command is advertised, but not supported.
[   19.044405] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   19.044409] Bluetooth: BNEP filters: protocol multicast
[   19.044414] Bluetooth: BNEP socket layer initialized

Booting into Linux 6.8 resolves the above issue. It seems 6.9 fails to load the bluetooth driver for my machine.

During boot I see the following message (verbose boot mode);

running early hook [udev]
running hook [udev]
Triggering uevents…
    4.206443] hub 8-0:1.0: config failed, hub doesn't have any ports! (err -19)

I’m not sure if this is supposed to be about my USB devices, but they’re all working. Linux 6.9, 7900XTX GPU, 7800X3D, Gigabyte B650 mobo

Seems roughly correct for DRM KMS.

The thing is the option is experimental so its not necessarily advisable.
Especially on driver versions below 550.

But it can be helpful for a number of things as also shown in this other thread:

(maybe many nvidia users do not notice a missing tty. :sweat_smile:)

But anyways more in depth information is at the archwiki:


Please do not post images of text, use copy+paste and proper formatting.

From what I can make out there are no errors visible in that terminal window (yay for terminal transparency - it makes the contents all the more harder to read :frowning: )

1 Like

Why was KMS forcefully added to my mkinitcpio.conf without my consent?
Is there a known issue, or system component, which required this hook to be sneaked in with a script in this way?
I dont see anything related to this on the mkinitcpio 39.1 changelog, the announcement, nor the wiki post.
I havent had the time to do much research, but I am genuinely interested in an answer.

Its been default in arch for some time and manjaro both adopted and did the forced sed because it reduces (but does not eliminate) the amount of blackscreens that plymouth produces.
It would have been in a pacnew for however long, but I guess it was ignored by users enough and deemed necessary enough to ‘force apply’.
Not my reasoning, but I’m pretty sure thats how it went.


ah… it’s good to know i was right to ignore it. i can remove it. plymouth is always the first thing i rip out.

kms does a lot more than just ‘fix’ plymouth.
Its just the reason that spurred the manjaro team to want it.

I have always made sure to enable KMS, and early at that. In general it can lead to better power efficiency and performance etc. With some possible slight slower boot time.
(read: negligible to the point of almost not being worth mentioning)
There are some edge cases where KMS might produce funny results.
But my summation is roughly that - if it doesnt result in any noticeable breakage then its desirable to have enabled/configured.