[Testing Update] 2023-10-21 - Kernels, GNOME 45, VirtualBox, KDE, Thunderbird

I have all *5 packages in place. The problem is that some packages like okular-23.08 is not in the repo for some reason, or several other still depends on the “old” non *5 packages. Anyway if you don’t have any useful suggestions please stop wasting other people time with your comments.

I encountered a similar issue, but I encountered it on Manjaro ARM. After downloading the latest PKGBUILD for Okular and compiling and installing the package, I still had issues with the installation of the packages: pamac-tray-icon-plasma, sddm-breath-theme, and manjaro-settings-manager.

By the way, has the sddm-breath-theme package been deprecated? Are there any alternatives? It seems that there is no package named sddm-breath2-theme.

I try to understand an issue only you seemed to have here on this thread. If you’re too soft skinned to handle a simple question, similar to you, I suggest you don’t come on the internet.

I can confirm that, now when I shutdown I hear a big “clung” and my 8TB HDD speeds down “audibly”.
No error found in journal.

However I can notice now a different behavior on an “issue” I noticed before when waking up the computer from sleep.

Before I always had this error when waking up computer:

oct. 21 17:11:26 omano-nvme kernel: ata2: softreset failed (1st FIS failed)

But now when waking up I get:

oct. 22 11:50:07 omano-nvme kernel: ata2.00: VERIFY failed (err_mask=0x4)
oct. 22 11:50:07 omano-nvme kernel: ata2.00: revalidation failed (errno=-5)

The HDD doesn’t seem to have an issue though after waking up it works. But the sound it makes when shutting down is kinda “scary” in a way, as described by Gavenga.

//EDIT: continued discussion here When shutting down PC, all mechanical hard-disks run down hard - #12 by omano

1 Like

This is exactly what i get!! Both the 4TiB Archiv-disk and the Windoz-User-Disk react as described…
EDIT: solution in above Omano thread!

Had to remove latte-dock-git and a bunch of AUR packages (plasma plugins, plasma themes) because of that update, but it still stopped because of kpeoplevcard.

The package kpeoplevcard is needed by kdeconnect, so the update conflicts with packages from Manjaro repos.

I’ll try to update with downgrade, as suggested above.

EDIT: Yeah, the -Syyuu option worked, update is proceeding now.

I wonder, if the latte-dock-git can be compiled with the newer named packages? Latte-dock from repo doesn’t have all options that git version has, and those additional options are a must.

EDIT 2: The update wasn’t successful, because of:

python-charset-normalizer: /usr/bin/normalizer

which is already in the system. I have no idea what this normalizer is. Hmm… Pacman says that this file doesn’t belong to any package.

EDIT 3: I renamed the package manually and… it literally vanished… No idea what happened, but of course, the update reinstated it again, so no biggie.

Today’s update is very problematic and needs to be smoothed out till it goes into stable.

I checked the latte-dock-git and it tries to get the missing old packages from AUR… no, thanks.

RIP Latte-Dock, you will be greatly missed :cry: !

Try to edit PKGBUILD and replace those build dependencies it wants with their renamed siblings (e.g. plasma-framework to plasma-framework5, and so on). I had no need in removing latte-dock in order to apply the update, it wasn’t hit by that. However I had to rebuild lightly-git with altered PKGBUILD like I described above. It works.

1 Like

I don’t use latte-dock-git, but i can generally recommend just invoking pacman’s --assume-installed switch for the ‘missing’ dependencies. It worked for me in all cases (basket, waterfox-classic-kpe, octopi-notifier-frameworks) - as it probably should, since the packages content hasn’t really changed, merely their names. Though editing the PKGBUILD like suggested above might be the cleaner way.

Manjaro Team take note: octopi-notifier-frameworks (from extra) misses knotifications.