[Testing Update] 2023-05-20 - KDE Frameworks, Python, Haskell, Wine

Hello community,

Another testing branch update with some usual package updates for you.

Recent News:

  • Manjaro, like many other open-source projects, relies on the generosity of its community through donations and corporate sponsorships to support its growth and development. These donations are essential in covering the various expenses incurred in the operations of the project such as server costs, software development tools, infrastructure expenses, training, flying people to events or conferences and the salaries of key developers. With the help of these donations, Manjaro is able to secure the necessary financial stability that allows the project to continuously improve and remain active. If you love Manjaro, consider to donate!
  • As you might have seen some of our team were able to attend FOSDEM 2023 and the conference proved to be incredibly productive for us. See our blog post for more.
Previous News
Finding information easier about Manjaro

Finding information easier about Manjaro always has been a topic that needed to be solved. With our new search we have put all Manjaro data accessible in one place and divided by sections so it makes it easier to digest: New Manjaro search engine is available | Blog


Notable Package Updates:

  • KDE Frameworks got updated to 5.106.0
  • Wine is at 8.8
  • Usual KDE-git, Python and Haskell updates

Additional Info

:information_source: You will need to rebuild any AUR Python packages that install files to site-packages or link to libpython3.10.so. :information_source:

Print a list of of packages that have files in /usr/lib/python3.10/ :

pacman -Qoq /usr/lib/python3.10/

Rebuild them all at once:*

pamac build $(pacman -Qoq /usr/lib/python3.10)

* Note that if any fail to build, you’ll have to rebuild what’s remaining one or a few at a time.

Use rebuild-detector to see if anything else needs to be rebuilt:

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.283
  • linux54 5.4.243
  • linux510 5.10.180
  • linux515 5.15.112
  • linux61 6.1.29
  • linux62 6.2.16 [EOL]
  • linux63 6.3.3
  • linux62-rt 6.2.0_rt3
  • linux63-rt 6.3.1_rt13

Package Changes (Fri May 19 08:26:21 CEST 2023)

  • testing community x86_64: 1152 new and 1138 removed package(s)
  • testing core x86_64: 19 new and 19 removed package(s)
  • testing extra x86_64: 168 new and 171 removed package(s)
  • testing kde-unstable x86_64: 254 new and 254 removed package(s)
  • testing multilib x86_64: 11 new and 11 removed package(s)

A list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2023-05-20


Updating Python packages (read *before* you do the system update, if possible)

Short version, for experienced users:
[HowTo] Re-install packages after a Python upgrade (short version)

Long version with full details:
[HowTo] After a Python interpreter upgrade, reinstall non-working Python packages

Many applications (firefox, thunderbird, etc) slow to start on desktops other than Gnome

There is a bug with xdg-desktop-portal-gnome (more details here).

Workaround for gtk-based desktops (including Xfce)
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-gtk
Workaround for KDE
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-kde
Workaround for Lxqt
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-lxqt
Workaround for desktops using hyprland
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-hyprland
Workaround for desktops using wlroots
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-wlr

      GDM slow to start after at-spi2-core 2.48.1-1 upgrade Fixed with at-spi2-core 2.48.2-1


Info about recent GRUB changes

[Unstable Update] 2023-02-17 - Plasma 5.27 LTS, GNOME, Python - #51 by philm

Info about recent NVIDIA packaging changes

[Testing Update] 2023-03-25 - Kernels, Firefox, Deepin, GNOME, NVIDIA, Wine - #42 by philm


Possible kernel fs block code regression in 6.2.3 umounting usb drives

With kernel 6.2.3 when you simply plug in a usb external drive, mount it and umount it, then the journal has a kernel Oops. A bug report, that includes the journal output was submitted at. https://bugzilla.kernel.org/show_bug.cgi?id=217174 Discussion can be found here: Re: Possible kernel fs block code regression in 6.2.3 umounting usb drives — Linux Stable Kernel Updates

kernel 5.15.99+ Black/empty screen during boot with i915 Intel gfx. No ways to do anything

Seems there is a regression introduced with 5.15.99 kernel update: [i915]drm:add_taint_for_CI [i915]] CI tainted:0x9 by intel_gt_init+0xae/0x2d0 [i915] (#8284) · Issues · drm / intel · GitLab. My thoughts here: [Testing Update] 2023-03-11 - Kernels, Mesa 22.3.7, Phosh, LibreOffice 7.4.6 - #31 by philm


Switch to the base-devel meta package requires manual intervention

2023-02-12 - Robin Candau

On February 2nd, the base-devel package group has been replaced by a meta package of the same name.
If you installed the base-devel package group prior to this date, explicitly re-install it to get the new base-devel package installed on the system:

pacman -Syu base-devel

Arch Linux - News: Switch to the base-devel meta package requires manual intervention


Very slow shutdown when using KDE Plasma Wayland

The issue is sddm that can not be finished until the default timeout 90 sec.
The solution: Install sddm-git

The known bug reports:

PHP 8.2 update and introduction of legacy branch

2023-01-13 - Pierre Schmitz

The php packages have been updated to the latest version 8.2. In addition to this, a new set of php-legacy packages have been introduced. These will follow the oldest but still actively supported PHP branch. This enables users to install the latest version but also introduces the option to use third party applications that might rely on an older version. Both branches will be kept up to date following our rolling release model. php and php-legacy can be installed at the same time as the latter uses a -legacy suffix for its binaries and configuration files.

In addition to this, the php7 packages have been removed as they reached end of life. The imap extension will no longer be provided as it relies on the c-client library which has been abandoned for many years.

Arch Linux - News: PHP 8.2 update and introduction of legacy branch


Some games like Dota 2 are freezing

The issue is caused by update libx11 1.8.3-4
The solution: Upgrade to libx11 1.8.3-5

VLC crashes when playing a video file

It looks like there has been a regression introduced with the new version of libva (2.17.0), which is used by VLC media player. If you get the following error when executing vlc in a terminal:

libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)

you may try to change the Output option in Preferences > Video to VDPAU output instead of Automatic (or whatever value it had been set to before).

Downgrading the libva package from 2.17.0-1 to 2.16.0-1 may also work, but it is a more short-term workaround that should not be kept for too long, as sooner or later, the older package won’t be compatible with the other packages. Consider to do the solution above first.


pacman-mirrors was temporarily renamed to manjaro-mirrors (the changes were reverted)

This was done to avoid confusion with an AUR / WSL package with the same name and avoid possible breakage. It should be a seamless transition.

Rename project (#183) · Issues · Applications / pacman-mirrors · GitLab


KDE Wayland sometimes hangs with mesa 22.3.1 and AMD GPU


dbus-x11 demoted to AUR

dbus-x11 was installed out of the box on some flavors of Manjaro as of a year ago, but is no longer needed. If you have it installed, please replace it with dbus using the following:

sudo pacman -Syu dbus
XFCE becomes unusable if libxfce4ui-nocsd is still installed

XFCE Classic project became obsolete with the 4.18 series and is no longer required. If you still have it installed, please replace it with the normal package:

sudo pacman -S libxfce4ui


python-cairo 1.23.0-2 update requires manual intervention

The python-cairo package prior to version 1.23.0-2 was missing the compiled python module. This has been fixed in 1.23.0-2, so the upgrade will need to overwrite the untracked pyc file that was created. If you receive this error

python-cairo: /usr/lib/python3.10/site-packages/cairo/__pycache__/__init__.cpython-310.pyc exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/python3.10/site-packages/cairo/__pycache__/\*

to perform the upgrade.


Pop Shell issues with Xorg session with Mutter 43.1 (fixed with mutter 43.1-1.0)

Gnome 43 (X11) GTK4 windows failed to render · Issue #1541 · pop-os/shell · GitHub

Window actors call update_stage_views() without allocation after non-interactive resize on X11 (#6054) · Issues · GNOME / gnome-shell · GitLab


signature from "Manjaro Build Server <build_at_manjaro_dot_org>" is unknown trust

Seems our signing key for our Build Server had the 2022-10-28 as expire date set when generated. This is now fixed for chroot builds and fresh as also current existing installs via manjaro-keyring 20221028-4 Simply update your system to get that package, which got pushed to all our branches.


Kernel 6.1-rc# might break backlight control on old/weird laptops


Firefox 106.0 may have issues with screen sharing on GNOME with Wayland


Nvidia 3060RTX cards may have issues with the 515.76 driver (fixed with 520.56.06)
Removing python2 from the repositories

2022-09-23 - Jelle van der Waa

Python 2 went end of life January 2020. Since then we have been actively cutting down the number of projects depending on python2 in our repositories, and we have finally been able to drop it from our distribution. If you still have python2 installed on your system consider removing it and any python2 package.

If you still require the python2 package you can keep it around, but please be aware that there will be no security updates. If you need a patched package please consult the AUR, or use an unofficial user repository.*

Arch Linux - News: Removing python2 from the repositories

* Note: Unofficial user repositories are not supported

This also marks the last sync before the Big Bang at Arch Linux


When I execute the checkrebuild command I get the following output:

foreign	zoom

Do I need to do something to fix Zoom?


zoom is a binary package, there’s nothing to rebuild. See a related upstream issue: For some (binary) packages a rebuild is always recommended · Issue #13 · maximbaz/rebuild-detector · GitHub

1 Like

Thank you!

Hi @cscs and @2old4gaming .

The issue with kwalletmanager5 is still there, even after the latest update.
It seems that it invokes kcmshell5 kwalletconfig5 instead of kcmshell5 kcm_kwallet5:

$ kwalletmanager5 
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
Could not find module 'kwalletconfig5'. See kcmshell5 --list for the full list of modules.

Had to reinstall the Nvidia drivers to get Steam to recognize my 3050ti, but that’s pretty much become standard procedure every update lately.

Lutris stopped working after the update giving me this error, when launched from the terminal:

Traceback (most recent call last):
  File "/usr/bin/lutris", line 52, in <module>
    from lutris.gui.application import Application  # pylint: disable=no-name-in-module
ModuleNotFoundError: No module named 'cairo'

I downgraded lutris (0.5.13-1 => 0.5.12-4) as a workaround for now.
Using sudo downgrade lutris
Edit: Can confirm that 0.5.13-2 fixed it! Thx @Yochanan !

Fixed with lutris 0.5.13-2.


A post was split to a new topic: VKD3D 2.9 bricks all DX12 games on Lutris 0.5.12


@Kerail and myself are both running into an issue with the live usb freezing during boot.

The common factor between both of our cases are:

CPU: Ryzen 7 7X00 X
MB: Gigabyte B650 AORUS ELITE AX ATX AM5 Motherboard
GPU: GeForce RTX 4070

Both of us currently have windows installed (myself on another nvme) and the freezing of the live boot breaks the networking on windows. We were recommended by @stephane to report here. Hopefully this is the correct thread to report it in

I doubt that your issue has something to do with this update thread, as most of these packages are not in the stable branch yet. Having an own thread for that topic is the better way. So the suggestion to post it here is more or less wrong @gstroot


The pop-extension for the gnome-shell has issues since the update to the version in testing (gnome-shell-extension-pop-shell-1.2.0+293+gb5accce-1).

Many windows are rendered much to large, so that the buttons are out of the screen area and cannot be reached. Also some window-content on the right is not visible. Also other graphical issues occur.

I don’t know if this is related to the gnome upgrade, but downgrading the extension to the version in stable solved the issues.

the new version seems to work well again. Not sure what did the trick. I did a random sequence of (de-)activations / re-logins / uninstalls / reinstalls and do not know what was important.

I’m not sure what’s causing that. When it happens, double-click on the titlebar a couple times to maximize / unmaximize the window.

A post was split to a new topic: Quick Settings Menu misaligned

lutris 0.5.13-5 does not install because of missing dependency: python-moddb.

Downgrade to 0.5.12-4.1 coming along shortly, I’ve just pulled 0.5.13-5 from the testing repo. I pushed it by mistake.

After updating I got kernel 6.3.4. Is the announcement page not up-to-date?

They are also in stable Branch. I guess the Kernel updates delivered all branches because of this issue in 6.3.3 XFS Metadata Corruption On Linux 6.3 Tracked Down To One Missing One-Line Patch - Phoronix