[Testing Update] 2023-05-13 - Kernels, Firefox, LibreOffice Still, KDE-git, Python

More people may use displaycal in manjaro stable, especially if they care about screen calibration (like photographers)
I may have got around for few time (since it’s not an app i launch everyday), but i got a hint with “pip check”
And yes, i did get some trouble to rebuild some AUR package (python-pep517 and python-sip4) but the guide j77h did post helped me, even if i needed to reinstall some package removed by the procedure.

1 Like

Why not use the supported Flatpak package? DisplayCAL | Flathub

To better integrate app in the distribution, i generally go the path : distro package > AUR > Flatpak > snap.

I once got some trouble with template file of an flatpak app, that i wanted to modify with another app.


That’s close to my preference too, but I prefer to manually install to /opt if the upstream project offers it’s own distro neutral release(think blender or godot for an example). IMO ideally the distro repo should only offer system utilities and such. Things that should be in shares/system resources. Not end user applications(optionals).

What i saw so far, it isn’t native. Have you tried to run it with an other proton version or proton ge? Also using steam runtime or native makes differences sometimes. Or try to run it with x11 or wayland… mostly in such cases i get the game to run again with switching around the possibilities… but sometimes it only helps to wait for another update :wink:

System Info (quick)

OS: Manjaro Linux x86_64
Kernel: 6.3.3-1-MANJARO
Resolution: 3840x2160
DE: Xfce 4.18
WM: Xfwm4
CPU: AMD Ryzen 5 3600 (12) @ 3.600GHz
GPU: NVIDIA GeForce GTX 1060 3GB
Memory: 5.89GiB / 31.25GiB (18%)
GPU Driver: NVIDIA 530.41.03
CPU Usage: 0%
Disk (/): 86G / 144G (64%)

I’m getting lot of errors warnings in Firefox when I run it from command line (this one but in hundreds)

[Child 47271, Main Thread] WARNING: JSWindowActorChild::SendRawMessage (Conduits, ConduitClosed) not sent: !CanSend() || !mManager || !mManager->CanSend(): file /build/firefox/src/firefox-113.0.1/dom/ipc/jsactor/JSWindowActorChild.cpp:57

…to the point that it started slowing things down (due to the excessive logging). To test go to Youtube (that triggers a dozen errs per page).

Problem is showing in both 113.0.1 and

Once I downgrade to 112.0.2 (FF forces me to create a new fresh profile) errors are gone.

Back to 113.0.1, with the new profile, and errors are back as well.
(I tried disabling all extensions, created new fresh profile and similar, seems unrelated. I didn’t ‘Refresh’ the FF fully as I didn’t have the time)

NOTE: I’ve searched online but nothing shows - similar errors are years old.
EDIT: errors are warnings actually :)

Is anyone else seeing the errors warnings?

Ever tested in terminal:

firefox -allow-downgrade

still the same, both
firefox --allow-downgrade
firefox --safe-mode
show errors, except that in safe mode there’s less of it seems

First thing I tried.

Haven’t relogged to try x11 yet, might be a wayland issue, maybe. Worth a try.

Can confirm (firefox) that i have the same warnings about errors!

1 Like

So some follow up. Oddly 1 restart after the update wasn’t enough. On the second restart after update I got the game to launch but the rest of system was wholly unusable. KDE was constantly freezing. All the panels/bars and the desktop were graying out. Did a hard reset via power button and 3rd try’s the charm.

Doesn’t really make any sense what-so-ever to me but it’s working fine now. :confused:

1 Like