[Testing Update] 2023-05-11 - Python 3.11, GCC 13, GNOME 44.1, KDE Plasma 5.27.5

It’s fixed with qgnomeplatform-qt5 qgnomeplatform-qt6 0.9.1-2 coming along shortly.


With this update, my personal desktop backgrounds aren’t shown anymore and the right click menu on the desktop doesn’t work anymore.

Caveat for Wayland is not relevant for Xfce

To remove old cached data and retain browsing history; saved passwords and bookmarks, go to Firefox page about:support and click Refresh Firefox…

1 Like

Because I already have this update on unstable, am I allowed to vote if I have no issues?

Anyone seeing any lag after logging in (post-GDM)? It seems when I boot up, or unlock my screen, my whole system locks up for a few seconds.

Anyone else seeing this lag / lock-up / freeze issue? Thanks.

1 Like

I have an issue: gnome-shell’s theme seems to be no longer customizable:

I’m forced to use the default Adwaita theme and not the one I had before.

I too had the impression that it took more than usual from entering the password to having an operational desktop, but I’ve started the system only once. I’ll pay attention when I reboot.

After a second reboot, this problem has gone away. I can select a custom shell theme again.

1 Like

That’s two issues you’re talking about here when in reality you didn’t check anything (being under “the impression” of something is irrelevant in this thread). Do not report or talk about issues if you didn’t even reboot or confirm there is an actual issue.

I had already re-booted once, obviously. I’m not so stupid to report an issue after a major update without re-booting. Happy that a second reboot solved the issue (which wasn’t obvious).

Consider being nicer to other users. Cheers.


khal and ikhal are working again! \o/

fixed it.



Thanks Philm, The firefox delay issue has been resolved thanks to your advice.

I inform you that I always restart the computer whenever there are updates, I did it on 05/2023/11 and today too.

I still can’t open the file manager, despite having followed the suggestion of lectrode, it didn’t have the expected results.

1 Like

hamster-time-tracker failed to start with Python 3.11. It is a known upstream bug and should be fixed with the next release. See the above link for a workaround.

Nerd Fonts changed the naming scheme so I had to edit configuration of some applications where Nerd fonts are used.

I’m having the same issue with valgrind as mentioned here:


If I run $ valgrind -v ls I get:

==16025== Memcheck, a memory error detector
==16025== Copyright (C) 2002-2022, and GNU GPL'd, by Julian Seward et al.
==16025== Using Valgrind-3.20.0-5147d671e4-20221024 and LibVEX; rerun with -h for copyright info
==16025== Command: ls
--16025-- Valgrind options:
--16025--    -v
--16025-- Contents of /proc/version:
--16025--   Linux version 6.1.26-1-MANJARO (builduser@fv-az377-398) (gcc (GCC) 12.2.1 20230201, GNU ld (GNU Binutils) 2.40) #1 SMP PREEMPT_DYNAMIC Wed Apr 26 22:07:35 UTC 2023
--16025-- Arch and hwcaps: AMD64, LittleEndian, amd64-cx16-lzcnt-rdtscp-sse3-ssse3-avx-avx2-bmi-f16c-rdrand-rdseed
--16025-- Page sizes: currently 4096, max supported 4096
--16025-- Valgrind library directory: /usr/lib/valgrind
--16025-- Reading syms from /usr/bin/ls
==16025== Downloading debug info for /usr/bin/ls...
--16025--   Considering /home/jw/.cache/debuginfod_client/34d542844982c2650c224cdebf7c8b856f361a1a/debuginfo ..
--16025--   .. CRC is valid
==16025== Successfully downloaded debug file for /usr/bin/ls
--16025-- Warning: cross-CU LIMITATION: some inlined fn names
--16025-- might be shown as UnknownInlinedFun
--16025-- Reading syms from /usr/lib/ld-linux-x86-64.so.2
==16025== Downloading debug info for /usr/lib/ld-linux-x86-64.so.2...
==16025== Server query failed: No such file or directory
--16025--    object doesn't have a symbol table

valgrind:  Fatal error at startup: a function redirection
valgrind:  which is mandatory for this platform-tool combination
valgrind:  cannot be set up.  Details of the redirection are:
valgrind:  A must-be-redirected function
valgrind:  whose name matches the pattern:      strlen
valgrind:  in an object with soname matching:   ld-linux-x86-64.so.2
valgrind:  was not found whilst processing
valgrind:  symbols from the object with soname: ld-linux-x86-64.so.2
valgrind:  Possible fixes: (1, short term): install glibc's debuginfo
valgrind:  package on this machine.  (2, longer term): ask the packagers
valgrind:  for your Linux distribution to please in future ship a non-
valgrind:  stripped ld.so (or whatever the dynamic linker .so is called)
valgrind:  that exports the above-named function using the standard
valgrind:  calling conventions for this platform.  The package you need
valgrind:  to install for fix (1) is called
valgrind:    On Debian, Ubuntu:                 libc6-dbg
valgrind:    On SuSE, openSuSE, Fedora, RHEL:   glibc-debuginfo
valgrind:  Note that if you are debugging a 32 bit process on a
valgrind:  64 bit system, you will need a corresponding 32 bit debuginfo
valgrind:  package (e.g. libc6-dbg:i386).
valgrind:  Cannot continue -- exiting now.  Sorry.

Upgrading to glibc 2.37-3 (from glibc 2.37-2, I’m on the stable Manjaro branch) fixes the issue as discussed here:

missing rebuild for

pacman -Si thunarx-python
Dépôt                    : community
Nom                      : thunarx-python
Version                  : 0.5.2-3
Description              : Thunarx Python Bindings
Architecture             : x86_64
URL                      : https://goodies.xfce.org/projects/bindings/thunarx-python
Licences                 : GPL
Groupes                  : --
Fournit                  : --
Dépend de                : thunar  python  python-gobject
Dépendances opt.         : --
Est en conflit avec      : --
Remplace                 : --
Taille du téléchargement : 38,81 KiB
Taille installée         : 182,75 KiB
Paqueteur                : Mark Wagie <mark@manjaro.org>
Compilé le               : dim. 30 janv. 2022 02:49:26
Validé par               : Somme MD5  Somme SHA-256  Signature

They were until they updated to at-spi2-core 2.48.2-1. :wink:


Done with 0.5.2-4.

I am on Xfce using dolphin as standard filemanager. After actual update dolphin is not able to open shortcuts to folders on xfce-desktop anymore.
Downgrade to version before actual update resolves the problem (dolphin 23.04.1-1 → 23.04.0-3).

Everything seems to be OK, unless I start any Proton Game. It shows CRITICAL Glib errors and crashes.

Since I have no idea at the moment what is happening, I probably restore my backup, because this update broke seriously something in the system.

I checked one native game, and it runs, but without a sound…, although system sounds are fine.

Curious, there is no way to shut down steam client. It shows:

Thread "CJobMgr::m_WorkThreadPool:2" (ID 2253) failed to shut down

I had to finish all the processes manually…