[Testing Update] 2023-03-08 - Kernels, Wine, Systemd, KDE-Git, Python, Haskell

Hello community,

Another testing branch update with some usual package updates for you.

Recent News:

  • Manjaro, like many other open-source projects, relies on the generosity of its community through donations and corporate sponsorships to support its growth and development. These donations are essential in covering the various expenses incurred in the operations of the project such as server costs, software development tools, infrastructure expenses, training, flying people to events or conferences and the salaries of key developers. With the help of these donations, Manjaro is able to secure the necessary financial stability that allows the project to continuously improve and remain active. If you love Manjaro, consider to donate!
  • As you might have seen some of our team were able to attend FOSDEM 2023 and the conference proved to be incredibly productive for us. See our blog post for more.
Previous News
Finding information easier about Manjaro

Finding information easier about Manjaro always has been a topic that needed to be solved. With our new search we have put all Manjaro data accessible in one place and divided by sections so it makes it easier to digest: New Manjaro search engine is available | Blog


Notable Package Updates:

  • Most of our Kernels got updated
    • Note: 6.0 kernel series got removed. Consider to either update to 6.1 LTS or 6.2 series.
  • Wine is now at 8.3
  • Systemd got updated to 252.7
  • Usual KDE-git, Python and Haskell updates

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

Info about GNOME 43

GNOME 43 is here! :partying_face:

New in Manjaro GNOME:

Lonely leftover orphan packages that have been removed from the Arch / Manjaro repositories:

  • adwaita-maia
  • dynamic-wallpaper-editor
  • firefox-gnome-theme-maia
  • gtkhash-nautilus
    (Not compatible with Nautilus 43)
  • manjaro-dynamic-wallpaper
  • manjaro-gdm-tweak
  • nautilus-terminal
    (Not compatible with Nautilus 43 & EOL)

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.275
  • linux54 5.4.234
  • linux510 5.10.171
  • linux515 5.15.97
  • linux61 6.1.15
  • linux62 6.2.2
  • linux515-rt 5.15.94_rt59
  • linux60-rt 6.0.5_rt14

Package Changes (Wed Mar 8 00:10:54 CET 2023)

  • testing community x86_64: 1239 new and 1216 removed package(s)
  • testing core x86_64: 26 new and 28 removed package(s)
  • testing extra x86_64: 137 new and 150 removed package(s)
  • testing kde-unstable x86_64: 220 new and 220 removed package(s)
  • testing multilib x86_64: 17 new and 19 removed package(s)

A detailed list of all package changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2023-03-08


Switch to the base-devel meta package requires manual intervention

2023-02-12 - Robin Candau

On February 2nd, the base-devel package group has been replaced by a meta package of the same name.
If you installed the base-devel package group prior to this date, explicitly re-install it to get the new base-devel package installed on the system:

pacman -Syu base-devel

Arch Linux - News: Switch to the base-devel meta package requires manual intervention


Very slow shutdown when using KDE Plasma Wayland

The issue is sddm that can not be finished until the default timeout 90 sec.
The solution: Install sddm-git

The known bug reports:

PHP 8.2 update and introduction of legacy branch

2023-01-13 - Pierre Schmitz

The php packages have been updated to the latest version 8.2. In addition to this, a new set of php-legacy packages have been introduced. These will follow the oldest but still actively supported PHP branch. This enables users to install the latest version but also introduces the option to use third party applications that might rely on an older version. Both branches will be kept up to date following our rolling release model. php and php-legacy can be installed at the same time as the latter uses a -legacy suffix for its binaries and configuration files.

In addition to this, the php7 packages have been removed as they reached end of life. The imap extension will no longer be provided as it relies on the c-client library which has been abandoned for many years.

Arch Linux - News: PHP 8.2 update and introduction of legacy branch


Some games like Dota 2 are freezing

The issue is caused by update libx11 1.8.3-4
The solution: Upgrade to libx11 1.8.3-5

VLC crashes when playing a video file

It looks like there has been a regression introduced with the new version of libva (2.17.0), which is used by VLC media player. If you get the following error when executing vlc in a terminal:

libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)

you may try to change the Output option in Preferences > Video to VDPAU output instead of Automatic (or whatever value it had been set to before).

Downgrading the libva package from 2.17.0-1 to 2.16.0-1 may also work, but it is a more short-term workaround that should not be kept for too long, as sooner or later, the older package won’t be compatible with the other packages. Consider to do the solution above first.


pacman-mirrors was temporarily renamed to manjaro-mirrors (the changes were reverted)

This was done to avoid confusion with an AUR / WSL package with the same name and avoid possible breakage. It should be a seamless transition.

Rename project (#183) · Issues · Applications / pacman-mirrors · GitLab


KDE Wayland sometimes hangs with mesa 22.3.1 and AMD GPU


dbus-x11 demoted to AUR

dbus-x11 was installed out of the box on some flavors of Manjaro as of a year ago, but is no longer needed. If you have it installed, please replace it with dbus using the following:

sudo pacman -Syu dbus
XFCE becomes unusable if libxfce4ui-nocsd is still installed

So far XFCE Classic project hasn’t updated yet to 4.18 series. We pushed 4.17.0 version of the package, but don’t know if that helps in that situation. It is recommended to install the regular libxfce4ui package to avoid issues and comment on this issue: libxfce4ui 4.18.0 released · Issue #15 · Xfce-Classic/libxfce4ui-nocsd · GitHub


python-cairo 1.23.0-2 update requires manual intervention

The python-cairo package prior to version 1.23.0-2 was missing the compiled python module. This has been fixed in 1.23.0-2, so the upgrade will need to overwrite the untracked pyc file that was created. If you receive this error

python-cairo: /usr/lib/python3.10/site-packages/cairo/__pycache__/__init__.cpython-310.pyc exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/python3.10/site-packages/cairo/__pycache__/\*

to perform the upgrade.


Pop Shell issues with Xorg session with Mutter 43.1 (fixed with mutter 43.1-1.0)

Gnome 43 (X11) GTK4 windows failed to render · Issue #1541 · pop-os/shell · GitHub

Windows not updated after non-interactive resize on X11 (#6054) · Issues · GNOME / gnome-shell · GitLab


signature from "Manjaro Build Server <build_at_manjaro_dot_org>" is unknown trust

Seems our signing key for our Build Server had the 2022-10-28 as expire date set when generated. This is now fixed for chroot builds and fresh as also current existing installs via manjaro-keyring 20221028-4 Simply update your system to get that package, which got pushed to all our branches.


Kernel 6.1-rc# might break backlight control on old/weird laptops


Firefox 106.0 may have issues with screen sharing on GNOME with Wayland


Nvidia 3060RTX cards may have issues with the 515.76 driver (fixed with 520.56.06)
Removing python2 from the repositories

2022-09-23 - Jelle van der Waa

Python 2 went end of life January 2020. Since then we have been actively cutting down the number of projects depending on python2 in our repositories, and we have finally been able to drop it from our distribution. If you still have python2 installed on your system consider removing it and any python2 package.

If you still require the python2 package you can keep it around, but please be aware that there will be no security updates. If you need a patched package please consult the AUR, or use an unofficial user repository.*

Arch Linux - News: Removing python2 from the repositories

* Note: Unofficial user repositories are not supported


Changes with Back In Time packages
  • backintime has been renamed to backintime-qt
  • backintime-cli has been renamed to backintime

After replacing backintime-cli with backintime, you will need to install backintime-qt manually if you want the Qt frontend installed again.


electron12, electron13, electron14 & electron16 have been dropped to the AUR

Unsupported Electron packages have been dropped from the official repos to the AUR. They no longer receive security updates and nothing in the repos depend on them.

If you have AUR packages depending on those versions, install the binary version from the AUR to replace them; i.e., electron16-bin.

See FS#75490 - electron12, electron13, electron14, electron16 are unsupported and vulnerable packages

End of Support for 15.x.y and 16.x.y

Electron 15.x.y and 16.x.y has reached end-of-support. As per Electron’s new 8-week cadence, we were supporting the latest four versions of Electron until May 2022. With this Electron 19 release, we’ll return to supporting the latest three major versions, as well as the alpha, beta, and nightly releases.

Release electron v19.0.0 · electron/electron · GitHub

Thanks for another update!

Did you mean “6.1 LTS or 6.2 series”?

Thank you, the lead seemed hopeful, albeit to no avail. I’ve tried (including with today’s Testing-Branch update); changing monitor refresh rate, Kernel versions 6.1.x, 6.2.x, downgrading mesa, disabling any GPU acceleration in Steam, uninstalling mesa-vdpau/lib32-mesa-vdpau…I’ll save further details and maybe try to post a ticket there.

You may also take a look at https://nonfree.eu/ if you need some codecs for your amdgpu card …

1 Like

I switched my KDE (X11) to testing branch (Wayland). Most of things worked great. But I had 2 issues:

  • The Bluetooth always turnes off after login. I can use my Bluetooth mouse at login screen. But once login, the Bluetooth becomes off.
  • The OpenVPN profile I added to Network doesn’t survive reboot. It gets removed and I have to add it again.

For me, it was on before the update, and after the update and a restart is still on. It looks like I don’t have this issue. I’m also on Wayland.
It may be a config issue on your side.

After the restart, it took quite long to see the desktop (spinner on splash was displayed in this time). Hopefully, it’s a one time event.

The update of gtk-4 to version 1:4.10.0-2 causes that in gnome-control-center’s audio section the input and output dropdown menus won’t be shown. I have that behaviour on two different systems.

In your bluetooth settings, do you have it set to enable on login?

It’s fixed with gtk4 1:4.10.0-3 and will be along shortly.

1 Like

I can confirm that everything is back to normal with gtk4 1:4.10.0-3.

It’s default to “Enable” in Manjaro. Anyway I set it explicitly, Bluetooth still goes offline after login.


I just switched from stable to testing branch.
The transition went fine except for mpv which doesn’t play audio from youtube videos. (Seems to be a ytdlp issue, hopefully it will be fixed in next version)
The fix is to add this lua script in ~/.config/mpv/scripts and use --ytdl=no when launching mpv.

Switched to testing for 6.2 to see if it fixes my ‘amdgpu ring gfx timeout’ issues and for Plasma 5.27 update. No issues thus far.

Only ran into one application issue with CoreCtrl.
After system sleep/wake up it no longer loads automatic application profiles. A manual profile loads just fine, it’s the automatic profiles and detection that don’t work. Restarting CoreCtrl fixes the issue for the session. On stable CoreCtrl works without this issue.

I’ll check in a bit to see how it does when on 6.1.

I’ve returned back to stable branch (Kernel 6.12, Plasma 26.5, X11) on my working laptop and everything work perfectly again. Bluetooth off is easy to handle with just 1 click, but re-importing VPN profile on every rebooting is just too much to live with.

Who confirms if you have this issue when using AMD CPU and Kernel 5.15 or 6+ :point_down: ?


That doesn’t sound good, again a kernel update you have to skip ^^
is there already a patch for it?

I don’t find if there is the path.
My new motherboard Gigabyte X570S has the new thermal sensor “PCT0” ACPI. Its temperature is probably higher than default 17 °C.

Check $ watch sensors

Adapter: ACPI interface
temp1:        +16.8°C  (crit = +30°C)
temp2:        +16.8°C  (crit = +30°C)
temp3:        +16.8°C  (crit = +30°C)

The default value of thermal zone 17 C is not good idea.

Which temperatures are read out there? It can’t be the CPU.

Of course not CPU, but that is ACPI inside the motherboard.