[Testing Update] 2023-03-03 - KDE Gear 22.12.3, Deepin, Mauikit, LibreOffice 7.5.1, Steam, Python, Haskell

Hello community,

Another testing branch update with some usual package updates for you.

Recent News:

Previous News
Finding information easier about Manjaro

Finding information easier about Manjaro always has been a topic that needed to be solved. With our new search we have put all Manjaro data accessible in one place and divided by sections so it makes it easier to digest: New Manjaro search engine is available | Blog


Notable Package Updates:

  • Plasma got some additional fixes on top of 5.27.2
  • KDE Gear 22.12.3 mostly gained fixes for ark, kate and kdenlive
  • Deepin added some smaller updates and fixes to their packages
  • Mauikit 2.2.2 got released
  • Libreoffice 7.5.1 added major improvements to their dark mode
  • Steam Client got updated to
  • Usual Python and Haskell updates

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

Info about GNOME 43

GNOME 43 is here! :partying_face:

New in Manjaro GNOME:

Lonely leftover orphan packages that have been removed from the Arch / Manjaro repositories:

  • adwaita-maia
  • dynamic-wallpaper-editor
  • firefox-gnome-theme-maia
  • gtkhash-nautilus
    (Not compatible with Nautilus 43)
  • manjaro-dynamic-wallpaper
  • manjaro-gdm-tweak
  • nautilus-terminal
    (Not compatible with Nautilus 43 & EOL)

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.274
  • linux54 5.4.233
  • linux510 5.10.170
  • linux515 5.15.96
  • linux60 6.0.19 [EOL]
  • linux61 6.1.14
  • linux62 6.2.1
  • linux515-rt 5.15.94_rt59
  • linux60-rt 6.0.5_rt14

Package Changes (Fri Mar 3 04:56:06 CET 2023)

  • testing community x86_64: 780 new and 780 removed package(s)
  • testing core x86_64: 2 new and 2 removed package(s)
  • testing extra x86_64: 388 new and 388 removed package(s)
  • testing kde-unstable x86_64: 50 new and 22 removed package(s)
  • testing multilib x86_64: 2 new and 2 removed package(s)

A detailed list of all package changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2023-03-03


Switch to the base-devel meta package requires manual intervention

2023-02-12 - Robin Candau

On February 2nd, the base-devel package group has been replaced by a meta package of the same name.
If you installed the base-devel package group prior to this date, explicitly re-install it to get the new base-devel package installed on the system:

pacman -Syu base-devel

Arch Linux - News: Switch to the base-devel meta package requires manual intervention


Very slow shutdown when using KDE Plasma Wayland

The issue is sddm that can not be finished until the default timeout 90 sec.
The solution: Install sddm-git

The known bug reports:

PHP 8.2 update and introduction of legacy branch

2023-01-13 - Pierre Schmitz

The php packages have been updated to the latest version 8.2. In addition to this, a new set of php-legacy packages have been introduced. These will follow the oldest but still actively supported PHP branch. This enables users to install the latest version but also introduces the option to use third party applications that might rely on an older version. Both branches will be kept up to date following our rolling release model. php and php-legacy can be installed at the same time as the latter uses a -legacy suffix for its binaries and configuration files.

In addition to this, the php7 packages have been removed as they reached end of life. The imap extension will no longer be provided as it relies on the c-client library which has been abandoned for many years.

Arch Linux - News: PHP 8.2 update and introduction of legacy branch


Some games like Dota 2 are freezing

The issue is caused by update libx11 1.8.3-4
The solution: Upgrade to libx11 1.8.3-5

VLC crashes when playing a video file

It looks like there has been a regression introduced with the new version of libva (2.17.0), which is used by VLC media player. If you get the following error when executing vlc in a terminal:

libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)

you may try to change the Output option in Preferences > Video to VDPAU output instead of Automatic (or whatever value it had been set to before).

Downgrading the libva package from 2.17.0-1 to 2.16.0-1 may also work, but it is a more short-term workaround that should not be kept for too long, as sooner or later, the older package won’t be compatible with the other packages. Consider to do the solution above first.


pacman-mirrors was temporarily renamed to manjaro-mirrors (the changes were reverted)

This was done to avoid confusion with an AUR / WSL package with the same name and avoid possible breakage. It should be a seamless transition.

Rename project (#183) · Issues · Applications / pacman-mirrors · GitLab


KDE Wayland sometimes hangs with mesa 22.3.1 and AMD GPU


dbus-x11 demoted to AUR

dbus-x11 was installed out of the box on some flavors of Manjaro as of a year ago, but is no longer needed. If you have it installed, please replace it with dbus using the following:

sudo pacman -Syu dbus
XFCE becomes unusable if libxfce4ui-nocsd is still installed

So far XFCE Classic project hasn’t updated yet to 4.18 series. We pushed 4.17.0 version of the package, but don’t know if that helps in that situation. It is recommended to install the regular libxfce4ui package to avoid issues and comment on this issue: libxfce4ui 4.18.0 released · Issue #15 · Xfce-Classic/libxfce4ui-nocsd · GitHub


python-cairo 1.23.0-2 update requires manual intervention

The python-cairo package prior to version 1.23.0-2 was missing the compiled python module. This has been fixed in 1.23.0-2, so the upgrade will need to overwrite the untracked pyc file that was created. If you receive this error

python-cairo: /usr/lib/python3.10/site-packages/cairo/__pycache__/__init__.cpython-310.pyc exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/python3.10/site-packages/cairo/__pycache__/\*

to perform the upgrade.


Pop Shell issues with Xorg session with Mutter 43.1 (fixed with mutter 43.1-1.0)

Gnome 43 (X11) GTK4 windows failed to render · Issue #1541 · pop-os/shell · GitHub

Windows not updated after non-interactive resize on X11 (#6054) · Issues · GNOME / gnome-shell · GitLab


signature from "Manjaro Build Server <build_at_manjaro_dot_org>" is unknown trust

Seems our signing key for our Build Server had the 2022-10-28 as expire date set when generated. This is now fixed for chroot builds and fresh as also current existing installs via manjaro-keyring 20221028-4 Simply update your system to get that package, which got pushed to all our branches.


Kernel 6.1-rc# might break backlight control on old/weird laptops


Firefox 106.0 may have issues with screen sharing on GNOME with Wayland


Nvidia 3060RTX cards may have issues with the 515.76 driver (fixed with 520.56.06)
Removing python2 from the repositories

2022-09-23 - Jelle van der Waa

Python 2 went end of life January 2020. Since then we have been actively cutting down the number of projects depending on python2 in our repositories, and we have finally been able to drop it from our distribution. If you still have python2 installed on your system consider removing it and any python2 package.

If you still require the python2 package you can keep it around, but please be aware that there will be no security updates. If you need a patched package please consult the AUR, or use an unofficial user repository.*

Arch Linux - News: Removing python2 from the repositories

* Note: Unofficial user repositories are not supported


Changes with Back In Time packages
  • backintime has been renamed to backintime-qt
  • backintime-cli has been renamed to backintime

After replacing backintime-cli with backintime, you will need to install backintime-qt manually if you want the Qt frontend installed again.


electron12, electron13, electron14 & electron16 have been dropped to the AUR

Unsupported Electron packages have been dropped from the official repos to the AUR. They no longer receive security updates and nothing in the repos depend on them.

If you have AUR packages depending on those versions, install the binary version from the AUR to replace them; i.e., electron16-bin.

See FS#75490 - electron12, electron13, electron14, electron16 are unsupported and vulnerable packages

End of Support for 15.x.y and 16.x.y

Electron 15.x.y and 16.x.y has reached end-of-support. As per Electron’s new 8-week cadence, we were supporting the latest four versions of Electron until May 2022. With this Electron 19 release, we’ll return to supporting the latest three major versions, as well as the alpha, beta, and nightly releases.

Release electron v19.0.0 · electron/electron · GitHub

By chance we discovered that the touchscreen on our Acer Spin 3 now works. I’d given up long ago on it working and my daughter happened to wipe something from the screen and told me the UI reacted and I confirmed by closing her browser on her (lol don’t worry, she could ‘Restore Previous Session’) so I’ve no idea when it started working.

Otherwise; Acer Spin 3, Acer Spin 5, desktop i7-8700K w/ 6800XT all updated fine. :+1:t4:

1 Like

After this update fragments would start with an error in the application stating that there was no write acces to the downloads folder. Setting the downloads folder in settings did not solve this and would pop again. The client complained about no being able to connect to a service. The internal transmission webservice did run tho. Starting fragments in the terminal yielded this error:

ERROR transmission_client::client > Unable to parse json: invalid type: boolean `true`, expected i32 at line 1 column 63045
[2023-03-04 11:57:46.629] ERR torrent-metainfo.cc:630 no bencoded data to parse (84) (/build/transmission/src/transmission-4.0.1/libtransmission/torrent-metainfo.cc:630)
[2023-03-04 11:57:46.629] ERR torrent-metainfo.cc:630 no bencoded data to parse (84) (/build/transmission/src/transmission-4.0.1/libtransmission/torrent-metainfo.cc:630)

I solved this by removing the settings in ~/.config/fragments essentially forcing a clean start and return to defaults. Fragments behaves like I’m used to again. Fragments was not updated (last update to 2.1-1 was 17-01-2023) but the dependency transmission-cli was upgraded from 3.00-6 to 4.0.1-2 and this could explain the issue.

1 Like

I have an ASUS TUF D4 WIFI Z690 motherboard.
After the update to the testing branch (from stable) the wifi was not working anymore.
My guess is that the hardware was not recognized because it didn’t even had the wifi checks in the Network window (see image)

After reverting to the stable branch the motherboard returned to work properly.

100% reproducible (for me) amdgpu crash. X11, Wayland, Kernel 6.2.1-2, 6.1.14-1. i7-8700K, Radeon 6800XT.

I often use ProtonDB and update my profile’s system specs copied from Steam (Official Repository, with or without GPU acceleration in Steam Settings) > Help > System Information, Ctrl+A, Ctrl+C, switch to Firefox (110.0.1), go to my Profile page, paste, wait a few moments…amdgpu driver crash. The screen turns black, comes back to a frozen screen in Wayland and I have to force shut down. X11 brings me to the login screen where I can successfully attempt to login again, shut down, etc.

journalctl --since=today yields about nine chunks of the following at the time of crash;

Mar 06 22:34:41 username1 kernel: amdgpu 0000:03:00.0: amdgpu: [mmhub] page fault (src_id:0 ring:40 vmid:1 pasid:32799, for process i386-linux-gnu- pid 3853 thread i386-linux:cs0 pid 3854)
Mar 06 22:34:41 username1 kernel: amdgpu 0000:03:00.0: amdgpu:   in page starting at address 0x0000800100769000 from client 0x12 (VMC)
Mar 06 22:34:41 username1 kernel: amdgpu 0000:03:00.0: amdgpu: MMVM_L2_PROTECTION_FAULT_STATUS:0x00141651
Mar 06 22:34:41 username1 kernel: amdgpu 0000:03:00.0: amdgpu:          Faulty UTCL2 client ID: VCN0 (0xb)
Mar 06 22:34:41 username1 kernel: amdgpu 0000:03:00.0: amdgpu:          MORE_FAULTS: 0x1
Mar 06 22:34:41 username1 kernel: amdgpu 0000:03:00.0: amdgpu:          WALKER_ERROR: 0x0
Mar 06 22:34:41 username1 kernel: amdgpu 0000:03:00.0: amdgpu:          PERMISSION_FAULTS: 0x5
Mar 06 22:34:41 username1 kernel: amdgpu 0000:03:00.0: amdgpu:          MAPPING_ERROR: 0x0
Mar 06 22:34:41 username1 kernel: amdgpu 0000:03:00.0: amdgpu:          RW: 0x1

As I write this, I’ve been able to Cut, Paste to/from; Kate, Konsole, Firefox in preparation without a problem. If I posted too much code, I apologize.

I can not reproduce this issue. But I read your error log:

It seems your system used the process i386-linux-gnu that I do not have. i386 is for 32bit system.
Can you check what is the output of $ pacman -Qo i386-linux-gnu ?

I had something similar even before this update on 6.2 kernel.

error: No package owns i386-linux-gnu

Are you thinking there might be some 32bit libraries I might want to uninstall?

I only found this at the upstream gitlab issue tracker: amdgpu 0000:0b:00.0: amdgpu: [mmhub] page fault after logging into GNOME desktop (#2384) · Issues · drm / amd · GitLab Maybe take a look and see if it is similar for you. You can also try to use older kernels if 6.2 is not working for you.