[Testing Update] 2022-12-22 - Kernels, Systemd, Thunderbird, Breath Theme

Hello community,

Another testing branch update with some usual package updates for you.

Recent News:

Notable Package Updates:

  • Some Kernels got updated
  • Systemd is now at 252.4
  • We updated our Breath theming and provided the new wallpaper North
  • Thunderbird got renewed to 102.6.1
  • Usual KDE-git, Haskell and Python updates

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

Info about GNOME 43

GNOME 43 is here! :partying_face:

New in Manjaro GNOME:

Lonely leftover orphan packages that have been removed from the Arch / Manjaro repositories:

  • adwaita-maia
  • dynamic-wallpaper-editor
  • firefox-gnome-theme-maia
  • gtkhash-nautilus
    (Not compatible with Nautilus 43)
  • manjaro-dynamic-wallpaper
  • manjaro-gdm-tweak
  • nautilus-terminal
    (Not compatible with Nautilus 43 & EOL)

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.269
  • linux54 5.4.228
  • linux510 5.10.161
  • linux515 5.15.85
  • linux60 6.0.15
  • linux61 6.1.1
  • linux515-rt 5.15.79_rt54
  • linux60-rt 6.0.5_rt14

Package changes (Thu Dec 22 02:27:37 CET 2022)

  • testing community x86_64: 1157 new and 1151 removed package(s)
  • testing core x86_64: 20 new and 20 removed package(s)
  • testing extra x86_64: 79 new and 144 removed package(s)
  • testing kde-unstable x86_64: 113 new and 113 removed package(s)
  • testing multilib x86_64: 10 new and 10 removed package(s)

A list of all package changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2022-12-22

pacman-mirrors was temporarily renamed to manjaro-mirrors (changed has been reverted)

This was done to avoid confusion with an AUR / WSL package with the same name and avoid possible breakage. It should be a seamless transition.

Rename project (#183) · Issues · Applications / pacman-mirrors · GitLab


KDE Wayland sometimes hangs with mesa 22.3.1 and AMD GPU


dbus-x11 demoted to AUR

dbus-x11 was installed out of the box on some flavors of Manjaro as of a year ago, but is no longer needed. If you have it installed, please replace it with dbus using the following:

sudo pacman -Syu dbus
XFCE becomes unusable if libxfce4ui-nocsd is still installed

So far XFCE Classic project hasn’t updated yet to 4.18 series. We pushed 4.17.0 version of the package, but don’t know if that helps in that situation. It is recommended to install the regular libxfce4ui package to avoid issues and comment on this issue: libxfce4ui 4.18.0 released · Issue #15 · Xfce-Classic/libxfce4ui-nocsd · GitHub


python-cairo 1.23.0-2 update requires manual intervention

The python-cairo package prior to version 1.23.0-2 was missing the compiled python module. This has been fixed in 1.23.0-2, so the upgrade will need to overwrite the untracked pyc file that was created. If you receive this error

python-cairo: /usr/lib/python3.10/site-packages/cairo/__pycache__/__init__.cpython-310.pyc exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/python3.10/site-packages/cairo/__pycache__/\*

to perform the upgrade.


Pop Shell issues with Xorg session with Mutter 43.1 (fixed with mutter 43.1-1.0)

Gnome 43 (X11) GTK4 windows failed to render · Issue #1541 · pop-os/shell · GitHub

Windows not updated after non-interactive resize on X11 (#6054) · Issues · GNOME / gnome-shell · GitLab


signature from "Manjaro Build Server <build_at_manjaro_dot_org>" is unknown trust

Seems our signing key for our Build Server had the 2022-10-28 as expire date set when generated. This is now fixed for chroot builds and fresh as also current existing installs via manjaro-keyring 20221028-4 Simply update your system to get that package, which got pushed to all our branches.


Kernel 6.1-rc# might break backlight control on old/weird laptops


Firefox 106.0 may have issues with screen sharing on GNOME with Wayland


Nvidia 3060RTX cards may have issues with the 515.76 driver (fixed with 520.56.06)
Removing python2 from the repositories

2022-09-23 - Jelle van der Waa

Python 2 went end of life January 2020. Since then we have been actively cutting down the number of projects depending on python2 in our repositories, and we have finally been able to drop it from our distribution. If you still have python2 installed on your system consider removing it and any python2 package.

If you still require the python2 package you can keep it around, but please be aware that there will be no security updates. If you need a patched package please consult the AUR, or use an unofficial user repository.*

Arch Linux - News: Removing python2 from the repositories

* Note: Unofficial user repositories are not supported


Changes with Back In Time packages
  • backintime has been renamed to backintime-qt
  • backintime-cli has been renamed to backintime

After replacing backintime-cli with backintime, you will need to install backintime-qt manually if you want the Qt frontend installed again.


electron12, electron13, electron14 & electron16 have been dropped to the AUR

Unsupported Electron packages have been dropped from the official repos to the AUR. They no longer receive security updates and nothing in the repos depend on them.

If you have AUR packages depending on those versions, install the binary version from the AUR to replace them; i.e., electron16-bin.

See FS#75490 - electron12, electron13, electron14, electron16 are unsupported and vulnerable packages

End of Support for 15.x.y and 16.x.y

Electron 15.x.y and 16.x.y has reached end-of-support. As per Electron’s new 8-week cadence, we were supporting the latest four versions of Electron until May 2022. With this Electron 19 release, we’ll return to supporting the latest three major versions, as well as the alpha, beta, and nightly releases.

– This is due to an AUR / WSL package to avoid confusion and possible breakage. It should be a seamless transition.Release electron v19.0.0 · electron/electron · GitHub


element-desktop dependency error (fixed with 1.11.4)
error: failed to prepare transaction (could not satisfy dependencies)
:: installing electron (20.0.0-1) breaks dependency 'electron19' required by element-desktop
```[details=pacman-mirrors has been renamed to manjaro-mirrors]

This is due to an AUR / WSL package to avoid confusion and possible breakage. It should be a seamless transition.


The upstream package was already flagged out of date (it needs to be rebuilt against latest electron).

Workaround for now:

sudo pacman -Syy electron electron19 --asdeps
sudo pacman -Su



Glibc 2.36 update will break EasyAntiCheat within Proton (should be fixed with glibc 2.36-2)

Temporary workaround for now is to use the flatpak version of steam:

sudo pacman -S flatpak --needed --noconfirm
sudo flatpak install com.valvesoftware.Steam -y

You can use flatseal (another flatpak app) to grant it access to your existing game library so you don’t have to re-download your games (add the game library install path under “Other files” under “Filesystem”).

sudo flatpak install com.github.tchx84.Flatseal -y

For advanced users (not recommended by us): patched glibc and lib32-glibc are available here. They remove the commit that broke EAC.


Fixed: Pamac shows archlinux-keyring (20220713-2) and manjaro-keyring (20220514-2) as orphans
sudo pacman -D --asexplicit archlinux-keyring manjaro-keyring

Resolved: w/ base 3-2 Revert changes:

sudo pacman -D --asdeps archlinux-keyring manjaro-keyring


wxWidgets 3.2 update may need manual intervention

Packages have been renamed from wxgtk- to wxwidgets-. The GTK2 frontend is no longer provided. If you have wxgtk2 installed, the upgrade will fail with:

In such case, uninstall wxgtk2 first and then proceed with the upgrade.


Linux518: could not insert 'amd_pstate': No such device

With Kernel 5.18.11 there was added a regression to AMD P-State driver preventing it from loading.


Wireplumber 0.4.11 may crash for GDM users

Currently there is an issue with 0.4.11 and GDM crashing on boot-up. More in the upstream bugtracker issue: wireplumber segfault: system boot and could see in my dmesg (#305) · Issues · PipeWire / wireplumber · GitLab


Locale file changes

C.UTF8 locale is now included in glibc:

Credits @diabonas for this change. Systemd wants us to include C.UTF8 by default and it seems the locale may be in included by glibc upstream in the future. To fix building and avoid nasty fixing in devtools, we include the locale in the package. See systemd/systemd#23252 (comment) FS#74864 : [systemd] >= 251 breaks devtools' locale

There is a pacsave for /etc/locale.conf as it has been removed from the filesystem package.

UPDATE: With filesystem 2022.06.08-2, it will automatically restore /etc/locale.conf if it did not already exist.
Uploading: image.png…

There is a pacnew for /etc/locale.gen. Please review it and regenerate your locale if necessary.

Yes there was 1 small issue. Login screen didn’t show up on my main monitor. Luckily it did on my other 2 monitors.

All seemed well but couldn’t paste from KeePassXC. Now removed wayland-protocols, opposite what I’d previously done, and not only does Copy/Pasting with KeePassXC work again, the KDE Wayland notification hang appears to have gone away. Might anyone else with amdgpu confirm that removing this Orphaned package resolves said issue(s)?

1 Like


Did you install wl-clipboard ?

…for awhile now (I’ve had it installed).

I removed all orphaned packages including wayland-protocol, but I have no issue with KeePassXC.

What is the version of mesa?

Ironically, reinstalling wayland-protocols initially allowed Copy/Paste to work again, now removing it worked.

I’ve mesa 22.3.1-1 I just tried the notify-send "test" multiple times and still see no issues.

New change added to the wiki post:

EDIT: The change has been reverted.

1 Like

This wrote over my /etc/pacman-mirrors.conf But not a big problem, because it also copied over the pevious config to /etc/pacman-mirrors.conf.pacsave. So I just have to copy it back. Just mentioning. I found out about it because of all the messages about newer local packages than on the repos when testing one more update just to see if there was any change with the new manjaro-mirrors package.

Strange results for me,

  • Impossible to update with yay > “Can’t retrieve some packages”, so I’ve rebooted.
  • Retry updating with yay > OK. Then, Reboot.
  • After login, black screen with only cursor… (This was happened 1 time in the past.) So, Reboot again.
  • The system tells me there’s lot of update on Stable branch, but I’was on Testing !
  • Reset the branch to testing, then everything seems ok.

Has the branch changed due to remplacement of pacman-mirrors to manjaro-mirrors ?

Thanks, Merry Christmas to all of you :wink:

1 Like

When I run an update with pacman -Syu nothing happens. When I try with yay it says “yay: error while loading shared libraries: /usr/lib/libalpm.so.13: file too short”. The kernel kcm on KDE is empty. Doesn’t seem the renaming of pacman-mirrors went smoothly. Not sure how to update now or update mirrors.

/usr/lib/libalpm.so.13 belongs to pacman package. Try to reinstall it.
If pacman command isn’t working, you can try manually extracting the latest version from your package cache and replacing it by hand.
If that wouldn’t work either open a new thread for that problem.

1 Like

Looks like smth went wrong (maybe you ran out of disk space?) during a previous install.
When this happens, try:

pacman -Qo "<your-broken-file>"

It will tell you which package that file belongs to. Then, reinstall the package.
But this obviously cannot work when the broken file is needed by pacman itself, like when it’s the pacman package or one of its dependencies to have gone lost. Fortunately, pacman is statically built, exactly in order to mitigate this risk.

If pacman is affected and you have a package copy inside /var/cache/pacman/pkg, try extracting it with unzstd.

If you haven’t, hopefully you can wget it from your mirror and then extract it.

1 Like

hi, After updating pacman-mirrors to core/manjaro-mirrors it says:

warning: sddm-breath-theme: local (22.0.0-2) is newer than community (21.3.0-4)
warning: systemd: local (252.4-2) is newer than core (252.3-1)
warning: systemd-libs: local (252.4-2) is newer than core (252.3-1)
warning: systemd-sysvcompat: local (252.4-2) is newer than core (252.3-1)

the output of pacman-mirrors -G is testing

Any hints?

You’ve a newer version installed. It’ll update when a newer version is released.

I had the same but in my case my branch had been switched from testing to stable.