[Testing Update] 2022-04-02 - Kernels, Mesa, Plasma 5.24.4, Deepin, LibreOffice, PipeWire, Wine 7.5

You do know you can change your vote?

Update works fine. Thanks!

The only bad thing is, that with kernel version 5.17.1 the network-module (in my case r8168) is still missing.
Can i do something on my own?

Edit: installed a package from the AUR called “r8168-dkms” - works for now - but still strange, that it’s suddenly missing from the kernel.

1 Like

With this recent testing update ( no matter which kernel 4.9, 5.10, 5.16 ) the Xfce “auto-mounting” device icons do not work with “exfat” formatted devices.
Although it works correct with kernel 5.17 …

Despite working manually via simple mount in shell, the error reports:

Failed to mount “label1”
Error mounting /de/sdd1 at /run/media/user/label1 : unknown filesystem type exfat

I known that the detail belongs to the udisk2 , but how can I start to solve this ?

Just as a note using more recent Kernels (5.16 & 5.17) my WiFi adapter QCA9377 (kernel driver: ath10k_pci) has ran slower at times. Adding to my GRUB Kernel boot command: “ath10k_core.skip_otp=y ath10k_core.nohwcrypt=1” seems to have increase my performance using my WiFi adapter

I just experienced a hard-freeze while closing out the new version of Signal (5.37.0-1.) I’d advise caution while using this app.

some journalctl spam
kernel: Fixing recursive fault but reboot is needed!
kernel: BUG: scheduling while atomic: signal-desktop/16905/0x00000000
kernel: Modules linked in: uvcvideo videobuf2_vmalloc snd_usb_audio videobuf2_memops videobuf2_v4l2 videobuf2_common snd_usbmidi_lib videodev snd_rawmidi snd_seq_devic>
kernel:  i2c_smbus snd mei_me mei soundcore nvidia(POE) video wmi mac_hid acpi_pad fuse crypto_user ip_tables x_tables ext4 crc32c_generic crc16 mbcache jbd2 xhci_pci >
kernel: CPU: 2 PID: 16905 Comm: signal-desktop Tainted: P S    D    OE     5.17.1-3-MANJARO #1 c9242a592d494bee9c6cffbc288adf97c7b0452a

Ethernet LAN connection does not work in Linux Kernel 5.17, but no error in journactl, it looks like that LAN is disabled.


  • Switch back to Linux Kernel 5.16 that works fine.
  • Or install r8168-dkms for Linux Kernel 5.17 (I did not try it)

I guess it is related to the issue of Kernel. Try switching to a different Kernel.

Ok guys, r8168 module for kernel 5.17 is finally available to install from the official repos.

1 Like

gnome-online-accounts forgot all the secrets/passwords/tokens for google accounts after upgrading 3.40.1-1 → 3.44.0-1. For me the solution was to enter the login details.


This could be the default ‘you have to enter your passwords again for reason x’ but 4 accounts at the same time is curious.
From the journal I can find these entries for all accounts:

goa-daemon[1386]: secret_password_lookup_sync() returned NULL
goa-daemon[1386]: /org/gnome/OnlineAccounts/Accounts/account_[number]: Setting AttentionNeeded to TRUE because EnsureCredentials() failed with: No credentials found in the keyring (goa-error-quark, 4)

and these after entering the password:

goa-daemon[1386]: /org/gnome/OnlineAccounts/Accounts/account_[number]: Setting AttentionNeeded to FALSE because EnsureCredentials() succeded

Vulkan library updates are still broken in regard to FBC (namely the changes introduced in lib32-vulkan-icd-loader-1.3.207-1 vulkan-headers-1:1.3.207-1 vulkan-icd-loader-1.3.207-1 vulkan-tools-1.3.207-1). This has been discussed in NVFBC no longer working in Arch Linux: Invalid external buffer capabilities · Issue #511 · keylase/nvidia-patch · GitHub.

For anyone who needs FBC with current vulkan libraries, running

sed -i 's/\xc7\x84\x24\xfc\x01\x00\x00\x00\x00\x40\x00/\xc7\x84\x24\xfc\x01\x00\x00\x00\x10\x40\x00/' "libnvidia-fbc.so.${pkgver}"
fixes the issue, as discussed in the github issue page (second to last comment)

What is NVFBC?
Tried to search for it, but it’s only mentioned in articles overfilled with technical, specified jargon.
Does it do anything for an average player with Nvidia card?

Framebuffer compression it
s specific usage is for energy-saving.

So if it’s not working, then Nvidia users playing Proton games will use up more power?

@Astalacoucougnasse and @michaldybczak framebuffer capture, not framebuffer compression. effectively the same way shadowplay works on windows

Has anyone tested Wine 7.5 or Lutris? Is everything working again?

What do you mean “again”? Did 7.4 not work for you? Describe more please.

There was a small update today. Crda package has been replaced by wireless-regdb, no errors after update.

A post was split to a new topic: Firefox sometimes crashes

After the second update (with xorg-xkbcomp, …) my Gnome doesn’t login anymore. With root or a new user i can login. Tried also to disable the extensions (with gsettings set org.gnome.shell disable-user-extensions true to disable all extension and do a startx) and to start with a other kernel, but no, it’s stuck and throw me every time back to the login screen (with some message that i must logout me the user). I think i remember a time ago, that there was the same problem on gnome, but unfortunately i can’t remember the solution… somebody experience the same problem or know a solution? Have also tried both wayland and xorg - same behavior…
Oh, and someone else has also a lot of crashes lately with evolution? (tried to disable the extensions, but looks like that’s not it)

renaming ~/.config/dconf/user does for first the trick to login again, but also all configs are gone…
found this:

Wild guess, try to find how to disable extension if you use some, it may be possible from command line to do that.