[Testing Update] 2022-03-12 - Kernels, KDE, LibreOffice, Kodi, Qt5, Mozilla, NetworkManager, Pipewire

Hello community,

Another testing branch update with some usual updates for you.

Starting from $469 - Our MiniPC with Manjaro KDE preinstalled! Check it out

  • Most of our Kernels got updated
  • CuteFish got renewed to 0.8
  • LibreOffice is at 7.3.1 and 7.2.6
  • Systemd is renewed to 250.4
  • KDE Plasma is now at 5.24.3
  • KDE Apps (Gear) got renewed to 21.12.3
  • Kodi is at 19.4
  • Qt5 got an official update after one year and is now at 5.15.3 including the regular KDE patch-sets
  • Thunderbird got updated to 91.7.0
  • Firefox is at 98.0
  • NetworkManager 1.36 got it’s first point-release
  • Pipewire is at 0.3.48

:information_source: You may need to rebuild any AUR packages that install files to site-packages … :information_source:

You may need to rebuild any Python packages you’ve installed from the AUR. To get a list of them, you can run:

pacman -Qoq /usr/lib/python3.9

And to rebuild them all at once with an AUR helper such as yay, you can do:

yay -S $(pacman -Qoq /usr/lib/python3.9) --answerclean All

But if any of the packages don’t work with Python 3.10 yet, this might fail halfway through and you’ll have to do rebuild the remaining ones one or a few at a time.

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux49 4.9.306
  • linux414 4.14.271
  • linux419 4.19.233
  • linux54 5.4.184
  • linux510 5.10.105
  • linux515 5.15.28
  • linux516 5.16.14
  • linux517 5.17-rc7
  • linux515-rt 5.15.27_rt35
  • linux516-rt 5.16.2_rt19

Package Updates (Sat Mar 12 09:47:08 CET 2022)

  • testing community x86_64: 2028 new and 2011 removed package(s)
  • testing core x86_64: 67 new and 60 removed package(s)
  • testing extra x86_64: 864 new and 1050 removed package(s)
  • testing kde-unstable x86_64: 334 new and 334 removed package(s)
  • testing multilib x86_64: 65 new and 65 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

1 Like

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!


New warnings when building the fallback initcpio - Possibly missing firmware for module: bfa, qed, qla1280, qla2xxx

That’s due to the recent changes to the linux-firmware package. Note these are warnings, not errors. You only need those firmwares if you have Mellanox Spectrum switches, Marvell devices, Qualcomm SoCs, Cavium LiquidIO server adapters, QLogic devices and Broadcom NetXtreme II 10Gb ethernet adapters. if you have that hardware you can install linux-firmware-qlogic to get rid of those warnings. If you do not have that hardware you can safely ignore those warnings.

pamac install linux-firmware-qlogic


Python packages from PIP and AUR - how to upgrade them - detailed instructions

Read this post.

I got this message when launching some Qt5 dépendant apps (Digikam, kde-connect and Calibre at least) :
“Cannot mix incompatible Qt library (5.15.2) with this library (5.15.3)
Abandon (core dumped)”


all is ok ( Amd 5600x + Nvidia 970 gtx ) + youtube(1080p) + steam ( opengl or protonDB 7.0 )

only this messages

systemd-udevd[388]: Configuration file /usr/lib/udev/rules.d/77-mm-fibocom-port-types.rules is marked executable. Please remove executable permission bits. Proceeding m-port-types.rules is marked executable. Please remove executable permission bits. Proceeding anyway
gst-plugin-scan[1102]: type name '-a-png-encoder-pred' contains invalid characters
gst-plugin-scan[1102]: g_type_set_qdata: assertion 'node != NULL' failed
gst-plugin-scan[1102]: g_type_set_qdata: assertion 'node != NULL' failed
gst-plugin-scan[1102]: type name '-a-png-encoder-pred' contains invalid characters
gst-plugin-scan[1102]: g_type_set_qdata: assertion 'node != NULL' failed
gst-plugin-scan[1102]: g_type_set_qdata: assertion 'node != NULL' failed

It seams that QT5 was upgraded from 5.15.2 to 5.15.3 but all related apps where not rebuilt against this new version wich seems to be incompatible.
VLC, Smplayer, Digikam, kde-connect, Calibre, Kpat and I think, many other apps built with QT5 are in this case
Help!!! WTF are u doing there!!!

I found something: pyside2-tools stayed on 5.15.2 version wich is not compatible with QT5 5.15.3.
The pblm is that FreeCad needs it.
So, for the moment I removed FreeCad and pyside-tools and everything works properly.
The only thing I can do is to wait for an update of these package. :frowning:

But kdeconnect does not show me the error message.


I see, it has not been update since 2020.

1 Like

After updating, I’m getting a warning in Steam that integrated graphics are used. Judging from the performance of the game, I believe it. This is the output I’m getting from prime-run glxinfo | grep “OpenGL renderer”:

X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  152 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  50
  Current serial number in output stream:  51

Generated on 2022-03-12 17:22:1647102135

#################### inxi -Fxzc0 ########################

  Kernel: 5.16.14-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.2.0 Desktop: KDE Plasma 5.24.3
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 82NL v: Legion 5 15IMH6 serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40700 WIN serial: <superuser required> UEFI: LENOVO
    v: G8CN10WW date: 04/26/2021
  ID-1: BAT0 charge: 59.1 Wh (100.0%) condition: 59.1/60.0 Wh (98.5%) volts: 17.2 min: 15.4
    model: Celxpert L19C4PC0 status: Full
  Device-1: hidpp_battery_0 model: Logitech G305 Lightspeed Wireless Gaming Mouse
    charge: 55% (should be ignored) status: Discharging
  Info: 6-core model: Intel Core i5-10500H bits: 64 type: MT MCP arch: Comet Lake rev: 2 cache:
    L1: 384 KiB L2: 1.5 MiB L3: 12 MiB
  Speed (MHz): avg: 3346 high: 4200 min/max: 800/4500 cores: 1: 3735 2: 4015 3: 4200 4: 2897
    5: 3201 6: 4134 7: 1993 8: 2565 9: 4200 10: 3196 11: 3415 12: 2607 bogomips: 60014
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Lenovo driver: i915 v: kernel
    bus-ID: 00:02.0
  Device-2: NVIDIA GA107BM [GeForce RTX 3050 Ti Mobile] vendor: Lenovo driver: nvidia v: 510.54
    bus-ID: 01:00.0
  Device-3: Acer Integrated Camera type: USB driver: uvcvideo bus-ID: 1-6:2
  Display: x11 server: X.Org v: driver: X: loaded: modesetting,nvidia unloaded: nouveau
    gpu: i915 resolution: 1920x1080~165Hz
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.3.7 direct render: Yes
  Device-1: Intel Comet Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel v: kernel
    bus-ID: 00:1f.3
  Device-2: NVIDIA vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 01:00.1
  Sound Server-1: ALSA v: k5.16.14-1-MANJARO running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.48 running: yes
  Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169
    v: kernel port: 3000 bus-ID: 07:00.0
  IF: enp7s0 state: down mac: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:6
  Report: rfkill ID: hci0 rfk-id: 4 state: up address: see --recommends
  Local Storage: total: 1.38 TiB used: 234.16 GiB (16.6%)
  ID-1: /dev/nvme0n1 vendor: Micron model: MTFDHBA512TDV size: 476.94 GiB temp: 34.9 C
  ID-2: /dev/sda vendor: Seagate model: ST1000LM024 HN-M101MBB size: 931.51 GiB
  ID-1: / size: 427.07 GiB used: 58.74 GiB (13.8%) fs: btrfs dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 568 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1
  ID-3: /home size: 427.07 GiB used: 58.74 GiB (13.8%) fs: btrfs dev: /dev/nvme0n1p2
  ID-4: /var/log size: 427.07 GiB used: 58.74 GiB (13.8%) fs: btrfs dev: /dev/nvme0n1p2
  ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) file: /swap/swapfile
  System Temperatures: cpu: 44.0 C pch: 43.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 347 Uptime: 12m Memory: 15.49 GiB used: 3.07 GiB (19.8%) Init: systemd Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: 1340 Client: KDE Plasma v: 5.24.3 inxi: 3.3.13

Same issue, with RSS Guard and JetBrains Toolbox.

1 Like

I flagged it out of date. Let’s see when Arch is updating it.

Edit: seems there is no newer version than 5.15.2: pyside/pyside-tools.git - Sub-module of pyside-setup, containing tools

Also FreeCAD works without issues …

We don’t see any issues with those applications. Did you reboot your system?

vlc working just fine here…

1 Like

Just really weird case. What I have done yesterday was just the last update, then all apps related to QT5 were not working and I had the message (Cannot mix incompatible Qt library (5.15.2) with this library (5.15.3)) . I removed the only thing that was on 5.15.2 version on my system (pyside2-tools) and all dependancies including FreeCad.
At this step, everything was working fine (exept Freecad :slight_smile: )
Reading our posts I decided this morning to reinstall FreeCad and all his dependancies (including pyside2-tools-5.15.2)
Everything works fine :o !!!

Simply reboot your system next time…


I did obviously at first time. There was kernel and Mesa updates. So i did several useless reboot.
Do U think I’m stupid?

Be aware, Firefox 98 has a bug in RDD sandboxing that kills vaapi based video decoding (on facebook, youtube, etc), and because of that your .mozilla/firefox/Crash Reports/pending/ folder will be filled with GB’s of unsent crash reports.

More info here: https://forum.manjaro.org/t/firefox-can-no-longer-play-video/105050/9
And here: https://bugzilla.mozilla.org/show_bug.cgi?id=1751363

*the solution is to deactivate vaapi in about:config (media.ffmpeg.vaapi.enabled) while they not fix this bug.


Hello, I can’t launch Qutebrowser and KeepassXC since the update.

Here’s the message i get with qutebrowser : CRITICAL: Cannot mix incompatible Qt library (5.15.2) with this library (5.15.3) Fatal Python error: Aborted
Here’s the one i get with keepassxc : Cannot mix incompatible Qt library (5.15.2) with this library (5.15.3) [1] 5705 IOT instruction (core dumped) keepassxc

I’m on Manjaro i3.
Yes, I did reboot the system. Any solutions? Thanks.

Remove pyside2-tools

Thanks for your answer! I don’t have this package installed on my system though.

KeepassXC works without problem on my system.

Bis repetita
Same problem on a second computer
When I launche any QT5 apps I get this message:
“Cannot mix incompatible Qt library (5.15.2) with this library (5.15.3)
Abandon (core dumped)”
I tried to do the same as for the first computer (removed pyside2) but it doesn’t work this time.
I tried to reboot several time as well. Useless.
Anyone has an idea?

EDIT: I had qt5-styleplugins from AUR package.
Removed then rebuilt and all is OK now


Seems like I also had a problem with qt5-styleplugins! I didn’t even remember that I had this package installed.
Thanks for updating your post and letting us know!

1 Like