[Testing Update] 2022-02-06 - Kernels, Pamac, Cleanups

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


New issues:

Python packages from PIP and AUR - how to upgrade them - detailed instructions

Read this post.

freetype2 update might result in font characters becoming squares

Don’t worry, a relogin to your UI should fix it. We recommend to do the update in a TTY. Affected UIs so far: Gnome, Phosh, Cinnamon.

compiz packages like compiz-easy-patch got dropped from our repositories.

compiz packages like compiz-easy-patch got dropped from our repositories. Due to protobuf update you may need to rebuild that package locally on your end. Compiz-easy-patch removed from repos

Announcement for PipeWire users

Re-enable any per-user enabled pipewire-media-session.service manually:

You should re-enable any per-user pipewire-media-session.service manually to establish a new service alias for pipewire-session-manager.service added with 0.3.38.

systemctl --user enable pipewire-media-session

See the PipeWire Release Notes for more info

New warnings when building the fallback initcpio - Possibly missing firmware for module: bfa, qed, qla1280, qla2xxx

That’s due to the recent changes to the linux-firmware package. Note these are warnings, not errors. You only need those firmwares if you have Mellanox Spectrum switches, Marvell devices, Qualcomm SoCs, Cavium LiquidIO server adapters, QLogic devices and Broadcom NetXtreme II 10Gb ethernet adapters. if you have that hardware you can install linux-firmware-qlogic to get rid of those warnings. If you do not have that hardware you can safely ignore those warnings.

pamac install linux-firmware-qlogic


Older Issues

OS prober does not run and add other operating systems*

To restore, please execute: echo GRUB_DISABLE_OS_PROBER=false|sudo tee -a /etc/default/grub && sudo update-grub

For more information, see opening post in [Stable Update] 2021-03-08.

Nvidia card owners
  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      
      If proprietary drivers don't fix everything, please click the ► at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually
      • remove all nVidia related drivers and applications:
        pacman --remove nvidia*
        
      • Note which applications are being removed and keep them handy in a list
      • Install the driver first:
        mhwd --install video-hybrid-XXX-nvidia-prime
        
        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)
      • reboot and see if you at least get a screen.
      • Install all the other applications from your handy list that you still need one by one.
      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually
      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:
        inxi --admin --verbosity=7 --filter --no-host --width
        

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: Graphics & Display - Manjaro Linux Forum or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Due to a bug in the AMD drivers, please try the following first:

For GRUB:

  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot
Possible 2 Min delay on shutdown with Gnome
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      [Service]
      Type=notify
      Slice=-.slice
      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
      
    • Click this link For more information

Touchpad on a ThinkPad stops working

Restart again, please.

$PKGNAME warning: directory permissions differ on $Directoryname

followed by:

Filesystem: NNN package MMM

  • The solution:

    sudo chmod MMM DirectoryName
    

    Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.

Python 3.9 Requires Rebuilds

Instructions for quickly and easily rebuilding affected AUR packages:

# Install yay
sudo pacman -S --needed --noconfirm yay

# Rebuild AUR python packages
yay -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-packages")
libtraceevent>=5.9-1 update requires manual intervention

2020-10-23 - Sébastien Luttringer

The libtraceevent package prior to version 5.9-1 was missing a soname link. This has been fixed in 5.9-1, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

libtraceevent: /usr/lib/libtraceevent.so.1 exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/libtraceevent.so.1

to perform the upgrade.

Arch Linux - News: libtraceevent>=5.9-1 update requires manual intervention

OpenVPN connection times out

Workaround: downgrade openvpn (2.5.0-1 => 2.4.9-2).
For a proper solution follow this bug report on Arch Linux: FS#68480 : [openvpn] running unprivileged with iproute no longer working

PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I've some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

HI all,
I don’t know from how much time, but I saw that on my mirrorlist was only one server.
Then I tried to update it, and this was the result:

sudo pacman-mirrors --fasttrack                                                                                                                                                      1 ✘  1m 35s  
[sudo] password di xxx: 
::INFO Downloading mirrors from Manjaro
::INFO => Mirror pool: https://repo.manjaro.org/mirrors.json
::INFO => Mirror status: https://repo.manjaro.org/status.json
::INFO Using custom mirror file
::INFO Querying mirrors - This may take some time
  1.617 United_Kingdom : http://manjaro.mirrors.uk2.net/
::INFO Writing mirror list
::United_Kingdom  : http://manjaro.mirrors.uk2.net/testing/$repo/$arch
::INFO Mirror list generated and saved to: /etc/pacman.d/mirrorlist

Only the uk server was reached and inserted in the mirrorlist.

I noticed line ::INFO Using custom mirror file, then I searched the custom file that I never created.
I found and removed it:

sudo rm /var/lib/pacman-mirrors/custom-mirrors.json

Then I was able to update my mirrorlist file properly.
This is not related to this update, I don’t know when it happened but I think could be helpful for someone.

2 posts were split to a new topic: How to merge new /etc/fonts/fonts.conf.pacnew

this is expected, you configured pacman-mirrors to use custom mirror pool, reinitialize it if you want the default mirror pool. Check WIKI.

B450 Tomahawk MAX, Ryzen 5 5600X, kernel 5.16.7 here.

After reboot from updating in tty2 i got:

lut 07 08:29:50 tomek-pc kernel: mce: [Hardware Error]: CPU 3: Machine Check: 0 Bank 5: bea0000001000108
lut 07 08:29:50 tomek-pc kernel: mce: [Hardware Error]: TSC 0 ADDR ffffffae5a7292 MISC d012000100000000 SYND 4d000000 IPID 500b000000000 
lut 07 08:29:50 tomek-pc kernel: mce: [Hardware Error]: PROCESSOR 2:a20f10 TIME 1644222588 SOCKET 0 APIC 6 microcode a201016

However system booted to plasma desktop. I rebooted again and there were no such errors, system works now. Does anybody knows what this is?

  • Update firmware of the motherboard
  • Try to enable XMP (Set optimized frequency for RAM) in BIOS setting. It does not crash for me.
    or
  • Disable PBO in BIOS setting.
1 Like
  1. I have the latest UEFI for this mobo
  2. I have manually overclocked RAM, however TM5 test in windows has been passed without errors.
  3. I would rather not - it will cut performance.

I will try to run some cpu torture tests.

nothing wild …
Update from (date) 04.02 to 06.02 causes conky problems for me

before the update (oldpic)

after the update

installed / updated / and possible causes?! pure assumption / dangerous half-knowledge from me :thinking:

lua-luv           1.42.0_1-1           1.43.0_0-1
lua51-luv           1.42.0_1-1           1.43.0_0-1
lua52-luv           1.42.0_1-1           1.43.0_0-1
lua53-luv           1.42.0_1-1           1.43.0_0-1
luajit      2.0.5-3 2.1.0.beta3.r384.g1d7b5029-1

fontconfig          2:2.13.94-2          2:2.13.96-1
lib32-fontconfig          2:2.13.94-1          2:2.13.96-1

etc/fonts/conf.d/

lrwxrwxrwx 1 root root   60  7. Feb 08:09 11-lcdfilter-default.conf -> /usr/share/fontconfig/conf.default/11-lcdfilter-default.conf
...
lrwxrwxrwx 1 root root   50  7. Feb 08:09 48-spacing.conf -> /usr/share/fontconfig/conf.default/48-spacing.conf
Desktop Xfce
Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel, plank
    wm: xfwm 4.16.1 vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux
    base: Arch Linux

to reproduce

/lines/conkyrc
conky.config = {
-- original author https://github.com/Chamrosh/lines-conky
-- modified by Lila-Kuh
background = false,
update_interval = 1.0,
cpu_avg_samples = 2,
net_avg_samples = 2,
override_utf8_locale = true,
double_buffer = true,
no_buffers = true,
text_buffer_size = 2048,
temperature_unit = 'celsius',
own_window_class = 'Conky',
own_window = true,
own_window_type = 'desktop',
own_window_transparent = true,
own_window_argb_visual = true,
own_window_argb_value = 255,
own_window_colour = '000000',
own_window_hints = 'undecorated,sticky,skip_taskbar,skip_pager,below',
border_inner_margin = 0,
border_outer_margin = 0,
minimum_height = 500,
minimum_width = 256,
maximum_width = 450,
alignment = 'top_right',
gap_x = -0,
gap_y = 40,
draw_shades = false,
draw_outline = false,
draw_borders = false,
draw_graph_borders = false,
default_color = 'gray',
default_shade_color = 'red',
default_outline_color = 'green',
use_xft = true,
font = 'dejavu code:size=12',
xftalpha = 0,
uppercase =false,
default_color = 'FFFFFF',
}
conky.text = [[
#leet chars: ┤┤└└┴┴┐┐││┘┘┌┌├├┬┬┼┼┴┴── ││ ▽▼△▲▵▴▾▿
${alignr} ┌──
${alignr} │    
${alignr} ${sysname}
${alignr} │    
${alignr} Time ──┤    
${alignr} │       │    
${alignr} time ──┤       │    
${alignr} ${time %H:%M:%S} ──┘        │       │    
${alignr} │       │    
${alignr} date ──┤       │    
${alignr} ${time %A %d %b %Y} ──┘        │       │    
${alignr} │       │    
${alignr} uptime ──┘       │    
${alignr} $uptime ──┘                 │    
${alignr} │    
${alignr} ${nodename} ──┘    
${alignr} │             
${alignr} kernel ──┤             
${alignr} $machine ──┤        │             
${alignr} ${kernel} ──┘        │             
${alignr} │             
${alignr} o-system ──┤             
${alignr} ${exec lsb_release -sd | tr -d '"'} ──┤        │             
${alignr} ${exec lsb_release -src} ──┘        │             
${alignr} │             
${alignr} battery ──┘             
${alignr} ${battery_short BAT1} ──┤                       
${alignr} ${execi 10 sensors | grep in0 | tr -d 'in0:'} ──┘                       
${voffset -493}${alignr} ──┐    ┌─────────────────────────────────          
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    │                                                                            
${alignr}     │    └───────────────────────────────────┐    
]]

Linked:

1 Like

you’re seeing changed fonts because there are changes to

/usr/share/fontconfig/conf.avail/60-latin.conf

in the new version. not a fan, myself.

edit it and change lines 8, 21, and 38 to put the deja vu version first in the lists again.

3 Likes

If you want to test your RAM (in Linux) do a Mprime Large FTT test, any error would most likely indicate RAM issue.

1 Like

I hadn’t updated the Chromebook for a couple of Testing updates, this still applies. On the computers on which I’d already done this (for the previous Testing release) installed fine.

Thank you.

There is another scenario where CPU binning and AGESA have created a lottery where processor idle handling drops lower (voltage/clock) than can keep the CPU stable and throw an MCE… i.e. under-clocking/volting too far for your silicon (binning). Originally learned @ Ryzen - ArchWiki under “Random Reboots” in the “Troubleshooting” section.

You can read about the fun I’ve had @ System auto-rebooted... mce: [Hardware Error] in dmesg related to CPU … and the Cole’s notes about what BIOS options I’ve played with (after updating to AGESA 1.2.0.2):

  1. Power Idle Control = Typical current idle
  2. Curve Optimizer = +4 on all cores (noting if +4 doesn’t yield good results, step up slowly/incrementally to +8 if required)
  3. “Global C-State Control = AUTO” => Disabled
  4. switching IOMMU from “AUTO” => “enabled"

Since applying the +4 CO on all cores I had an MCE error once that was related to ECC memory (Not sure why I got an MCE error related to ECC when my RAM is not ECC) which I don’t have. So I’m thinking I might undo that and try AGESA 1.2.0.3b… but am leery about beta AGESA versions (letter suffix after the version number). Odd thing is, I’ve only had a total of 3 MCE errors in 7-8 months (including the ECC one that did not reboot my system)… so troubleshooting it is a bit of a needle in a haystack… made more fun by the forever evolving kernels and AMD microcode.

A recent MSI thread I read that I think supports the under-clocking/volting idea is @ https://forum-en.msi.com/index.php?threads/am4-troubleshooting-faq-thread.288349/

Expand for quote

Problem : When setting the core voltage or overclocking the CPU, once in Windows/Linux the CPU appears to get stuck in a lower power state?
Solution : There really isn’t one at this time. The best we can suggest doing is leaving the VCore set to AUTO, and setting your multiplier to 37 or 38 to overclock for now.
The general consensus is that the issue is a problem with the AGESA code and some lots of CPU’s and that’s what causes the problem. Why do I think this? Because users have switched boards/brands, kept the same CPU, and the problem followed the CPU to the new board. That tells me it’s not just an “MSI” problem, and that it’s also related to the CPU as well since those same boards with a different CPU also will run at the rated and expected speeds.
EDIT: It appears that the most recent BIOS’s for most boards should have a fix in them to fix the CPU underclocking issue right now…Just as an FYI.

I think the EDIT in the quote may be talking about the new 1.2.0.5 AGESA, but I’ve also noticed MSI moderators talking about avoiding AGESA 1.2.0.5 BIOS’s until AMD fixes AGESA 1.2.0.5 issues… however, one MSI moderator commented that some users are having issues with AGESA 1.2.0.5 and recommended flashing back to an older BIOS @ problem with MSI MEG X570 Unify after BIOS update | MSI Global English Forum

Expand for quote

There seems to be a Problem with 1.2.0.5 for some users can you please roll back to BIOS 7C35vAA AGESA 1.2.0.3b

Some user felt that they had great experience with the “AB3” beta BIOS which also had AGESA 1.2.0.3b:

I can have a try, but I’m really sure, that the BIOS version 7C35vAA will work like the BIOS version 7C35vAB3 too, because the 7C35vAB3 use ComboAM4PIV2 1.2.0.3c. And with the BIOS version 7C35vAB3 I do not have any issues.
But you can be right, because BIOS versions 7C35vAB and 7C35vAC1 switched to ComboAm4v2PI 1.2.0.5, like you can see in the attachments with the official change logs from MSI.

So honestly, I think the fix comes at some point after AMD delivers whatever fixes AGESA 1.2.0.5.

1 Like

With this update, gnome freezes right after login and I have the following error in the logs:

Oct 25 08:50:59 my-pc gnome-shell[2418]: Unhandled promise rejection. To suppress this warning, add an error handler to your promise chain with .catch() or a try-catch block around your await expression. Stack trace of the failed promise:
                                           _seekStatusNotifierItems/<@/usr/share/gnome-shell/extensions/appindicatorsupport@rgcjonas.gmail.com/statusNotifierWatcher.js:145:1
                                           _seekStatusNotifierItems@/usr/share/gnome-shell/extensions/appindicatorsupport@rgcjonas.gmail.com/statusNotifierWatcher.js:145:21
                                           async*AppIndicatorsStatusNotifierWatcher@/usr/share/gnome-shell/extensions/appindicatorsupport@rgcjonas.gmail.com/statusNotifierWatcher.js:57:14
                                           maybeEnableAfterNameAvailable@/usr/share/gnome-shell/extensions/appindicatorsupport@rgcjonas.gmail.com/extension.js:54:33
                                           enable@/usr/share/gnome-shell/extensions/appindicatorsupport@rgcjonas.gmail.com/extension.js:59:5
                                           _callExtensionEnable@resource:///org/gnome/shell/ui/extensionSystem.js:167:32
                                           _enableAllExtensions/<@resource:///org/gnome/shell/ui/extensionSystem.js:601:22
                                           _enableAllExtensions@resource:///org/gnome/shell/ui/extensionSystem.js:600:37
                                           _sessionUpdated@resource:///org/gnome/shell/ui/extensionSystem.js:628:18
                                           _emit@resource:///org/gnome/gjs/modules/core/_signals.js:114:47
                                           _sync@resource:///org/gnome/shell/ui/sessionMode.js:197:14
                                           popMode@resource:///org/gnome/shell/ui/sessionMode.js:165:14
                                           _continueDeactivate@resource:///org/gnome/shell/ui/screenShield.js:534:30
                                           deactivate/<@resource:///org/gnome/shell/ui/screenShield.js:525:44
                                           finish@resource:///org/gnome/shell/gdm/authPrompt.js:604:13
                                           finish@resource:///org/gnome/shell/ui/unlockDialog.js:871:26
                                           deactivate@resource:///org/gnome/shell/ui/screenShield.js:525:26
                                           ScreenShield/</<@resource:///org/gnome/shell/ui/screenShield.js:109:57
                                           _emit@resource:///org/gnome/gjs/modules/core/_signals.js:114:47
                                           _convertToNativeSignal@resource:///org/gnome/gjs/modules/core/overrides/Gio.js:152:19

Managed to work around it by disabling extensions from the cli using:

gsettings set org.gnome.shell disable-user-extensions true

Mmmh:
“Global C-State Control = AUTO” => Disabled
boiles the CPU => Tccd1 (when disabled) stays at 50°C
enabled: 40°C

I’m not the first, nor last, to mention disabling one or more C-states sometimes helps issues… for example, I’ve seen many recommendation to set C5 as the max because C6 has been so problematic.

My experience in disabling C-states was maybe a ~3C change (although I might be confusing my experience with the CO +4 change)… so I suspect my HSF may be more up to the cooling challenge that some others. And 50C is definitely not boiling a CPU.

All I’m doing is sharing some of what I’ve uncovered… and at the end of the day it is going to be up to each person to weigh the pro’s and con’s of any change as they determine what’s right for them. If the choice came down to (a) MCE errors @ 40C or (b) no MCE errors @ 50C… I know which I’d choose.

did you contacted the author of appindicatorsupport extension?

1 Like

Not yet, there’s something weird going on, when I re-enable extensions but disable that particular one, the error still happens :confused: . Wanted to trial it a bit more before reporting…

Hibernate fails to work for me after this update. Trying to get some more data / logs, but thought I would post and ask if anyone else is seeing this issue in the meantime?

Try disabling Dash to dock,
That worked for me.

1 Like