[Testing Update] 2021-12-26 - Kernels, Mesa, Cutefish, Systemd 250, Firefox, Thunderbird, Wine 7.0rc1

Remove the acpi_call and install this Arch Linux - acpi_call-dkms 1.2.2-1 (any)

The Kernel modules will load correctly then…

But later if the Manjaro Developer Team have a solution for this revert back to the extramodules provided by Manjaro.:

1 Like

A post was split to a new topic: Problem when upgrading opencl-amd package

Thank you very much, it works now! Kudos for you. I also installed dkms version of vhba-module and r8168. So it is generally better to install dkms versions of kernel modules?

Where do I see what version of python I am using?

type python in your console

Or without starting a Python shell, just python --version. :wink:

    ~/Documents  python --version                                                                                                                                   INT ✘ 
Python 3.10.1

~/Documents /usr/lib/python3.10/python -m pip freeze -l > pip_list_3.10.txt                                                                                        
zsh: no such file or directory: /usr/lib/python3.10/python


There is no such file (let alone an executable) in the python package. The executable lives in /usr/bin.

Thanks @freggel.doe, that did it!

That should never been the solution. If one of our extramodules is broken it needs to be reported to us. Based on the last CI build that 1.2.2-2 should work for 5.15.11-1 kernel: Release 5.15.11-1 · manjaro-kernels/linux515 · GitHub

But based on the logs there is some issue:

validating keys: 
gpg: directory '/build/.gnupg' created
gpg: keybox '/build/.gnupg/pubring.kbx' created
==> Making package: linux515-acpi_call 1.2.2-2 (Wed 22 Dec 2021 12:19:12 PM UTC)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading acpi_call-1.2.2.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100   141  100   141    0     0    660      0 --:--:-- --:--:-- --:--:--   661

100 12403    0 12403    0     0  27404      0 --:--:-- --:--:-- --:--:-- 27404
==> Validating source files with sha256sums...
    acpi_call-1.2.2.tar.gz ... Passed
==> Extracting sources...
  -> Extracting acpi_call-1.2.2.tar.gz with bsdtar
==> Starting build()...
make -C /lib/modules/5.11.0-1022-azure/build M=/build/linux515-acpi_call/src/acpi_call-1.2.2 modules
make[1]: *** /lib/modules/5.11.0-1022-azure/build: No such file or directory.  Stop.
make: *** [Makefile:8: default] Error 2
==> ERROR: A failure occurred in build().



Jap, you right I will update my comment with your point

So it was rebuilt by Bernhard locally, maybe with chrootbuild, which seem to took the host Kernel again. So we have to see why that module is doing that … Will push a tested revision 3 to the repos. Also the dkms package is part of the community repo of Manjaro.


So linux515-acpi_call and linux514-acpi_call got fixed so far. Others will follow shortly …


Then i will reinstall it.

But if we are talking about modules - vhba module for kernel 5.16 can’t be built:

tomek@tomek-pc ~/K/vhba-module (master)> makepkg
==> Tworzenie pakietu: linux516-vhba-module 20211023-0.1 (pon, 27 gru 2021, 11:01:18)
==> Sprawdzanie zależności potrzebnych do uruchomienia...
==> Sprawdzanie zależności potrzebnych do budowy...
==> Pobieranie źródeł...
  -> Pobieranie vhba-module-20211023.tar.xz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   384  100   384    0     0    799      0 --:--:-- --:--:-- --:--:--   800
100   365  100   365    0     0    494      0 --:--:-- --:--:-- --:--:--     0
100 16144  100 16144    0     0  15950      0  0:00:01  0:00:01 --:--:-- 15950
  -> Znaleziono 60-vhba.rules
==> Sprawdzanie plików source za pomocą sha256sums...
    vhba-module-20211023.tar.xz ... Zgadza się
    60-vhba.rules ... Zgadza się
==> Rozpakowywanie źródeł...
  -> Rozpakowywanie vhba-module-20211023.tar.xz za pomocą bsdtar
==> Rozpoczynanie prepare()...
==> Rozpoczynanie build()...
make -C /usr/lib/modules/5.16.0-1-MANJARO/build M=/home/tomek/KOMPILACJE/vhba-module/src/vhba-module-20211023 modules
make[1]: Wejście do katalogu '/usr/lib/modules/5.16.0-1-MANJARO/build'
  CC [M]  /home/tomek/KOMPILACJE/vhba-module/src/vhba-module-20211023/vhba.o
/home/tomek/KOMPILACJE/vhba-module/src/vhba-module-20211023/vhba.c: In function ‘vhba_queuecommand’:
/home/tomek/KOMPILACJE/vhba-module/src/vhba-module-20211023/vhba.c:492:12: error: ‘struct scsi_cmnd’ has no member named ‘scsi_done’
  492 |         cmd->scsi_done(cmd);
      |            ^~
/home/tomek/KOMPILACJE/vhba-module/src/vhba-module-20211023/vhba.c: In function ‘vhba_ctl_write’:
/home/tomek/KOMPILACJE/vhba-module/src/vhba-module-20211023/vhba.c:827:18: error: ‘struct scsi_cmnd’ has no member named ‘scsi_done’
  827 |         vcmd->cmd->scsi_done(vcmd->cmd);
      |                  ^~
/home/tomek/KOMPILACJE/vhba-module/src/vhba-module-20211023/vhba.c: In function ‘vhba_ctl_release’:
/home/tomek/KOMPILACJE/vhba-module/src/vhba-module-20211023/vhba.c:953:18: error: ‘struct scsi_cmnd’ has no member named ‘scsi_done’
  953 |         vcmd->cmd->scsi_done(vcmd->cmd);
      |                  ^~
make[2]: *** [scripts/Makefile.build:287: /home/tomek/KOMPILACJE/vhba-module/src/vhba-module-20211023/vhba.o] Błąd 1
make[1]: *** [Makefile:1846: /home/tomek/KOMPILACJE/vhba-module/src/vhba-module-20211023] Błąd 2
make[1]: Opuszczenie katalogu '/usr/lib/modules/5.16.0-1-MANJARO/build'
make: *** [Makefile:14: modules] Błąd 2
==> BŁĄD: Wystąpił błąd w build().

My USB mouse breaks after my Manjaro switched to to 5.10.88-1 kernel.
I had t switch back to 5.9.16-1 for now. Please let me know if anybody have a fix. (Other usb mouse I have work, only one of them doesn’t with this new kernel, I also tried 5.15.11 and didn’t work)

Sidenote: Python was updated to 3.10.1 without warning, it wasn’t nice to delete the old python3.9 files which broke some of my things, had to install it again on AUR.

This was noted in big letters in our first post …


And in the first post of the previous update as well


The way i understand it, pip keeps a cache of what it installed,
and ‘pip freeze’ lists only what pip itself installed. (I could be wrong.)
And pamac installs only from Manjaro repos and AUR, not pip. (I could be wrong.)

So if ‘pip freeze’ and some ‘pacman -Q’ command (i don’t remember which flags to use) both show the same package name, then it was probably installed twice.

In situations like this, use ‘pip remove pkg’ before the python upgrade.

The general point is: don’t install anything with pip until you are sure that the repos and AUR don’t have what you want, and then if you do install it with pip, keep it a bit separate from system python with the ‘–user’ flag.

The reason is that it’s easier to manage upgrades of system and AUR packages,
and files installed by pip can cause pacman to fail,
because it needs to overwrite files that it did not put there itself.
(You solve that easily by deleting them yourself, or passing --overwrite to pacman,
but it’s better not to cause this conflict to begin with.)

I’ve added some clarification to the wiki post (in parentheses) :

sudo pip freeze > pip_list_sudo.txt (to list packages in system python)
pip freeze --user > pip_list_user.txt (to list packages in your user space)
/path/to/<venv_name>/python -m pip freeze -l > pip_list_<venv_name>.txt (for virtual environments only)

(A couple of days ago I wrote an article for wiki.manjaro.org about this,
but it’s still pending moderation, or got lost.)

That command doesn’t make much sense, because:

  • -l is only for virtual environments.
  • /path/to/python -m pip is only for avoiding system python/pip
    (or being absolutely certain which version of pip you are calling)

If you don’'t have any virtual environments, or other python versions,
you need only the 1st two commands, exactly as given:

  • sudo pip freeze > pip_list_sudo.txt
  • pip freeze --user > pip_list_user.txt

Also, if you’ve already upgraded to 3.10,
you won’t find what you’re looking for.
You needed to list what was in 3.9, but now you can’t,
because the python3.9 executable and its pip no longer exist.

You can still view the 3.9 ‘site-packages’ directories, at

  • /usr/lib/python3.9/site-packages/
  • $HOME/.local/lib/python3.9/site-packages/

There’s nothing there to show you which packages were installed by pip,
but you can remind yourself what you had in 3.9
and might need to install again in 3.10
(install via pacman/pamac/AUR if possible, not pip)