[Testing Update] 2021-08-16 - Kernels, KDE Frameworks, KDE Gear, Wine, KDE-git, Python

I had the same. I suspect that pamac claims that in this location should be only a symlink to a file located elsewhere. Instead, there is already the library file at that location. However, I’m also unsure if this is something wrong in this case. When I check usr/lib there are symlink pairs, meaning: there is a library file and its symlink, all in the same location.
I guess, we can create symlinks for those, and it won’t hurt anything. However, I don’t know how to do that. The usual command:

ln -s file file

is returning that the file already exists. So how one creates the symlink to a file in the same location as it is done with many libs?

1 Like

During update I got this warning:

/usr/bin/grub-probe: attention: unknown device type nvme0n1.

It happens that nvme0n1 is my new, main SSD on which the system is located. Should I be worried? Is there anything to do to make this device known?

This is “expected”. You can fix it by removing the memtest file (still looking for it) responsible for generating the GRUB entry.

//EDIT: you can uninstall the package memtest86+ for proper removal or delete the file /etc/grub.d/60_memtest86+ manually.


Remove /etc/grub.d/60_memtest86+ or just ignore it.


Removing the executable permissions for that file (e.g. sudo chmod 644 /etc/grub.d/60_memtest86+) also worked for me. This might be handy in case one decides to install Memtest86+ in the future, but I think including the file with the Memtest86+ package instead of the base Manjaro system would avoid the “unknown device” message in the first place for those who don’t have that package installed.

kinit is showing as a new orphan (for me). But it just got an update, and was formerly required by dolphin and konsole among others. It seems too important to remove?

Sure enough something may be afoot:


1 Like

I had no problem after removing it.

For me, pacman -Qtdq shows the following orphans:


Are these safe to remove?

Arch report seems to apply to me. Can’t open Konsole via Dolphin if kinit is not installed. Dunno if Konsole itself has features requiring it.

It seems Dolphin’s search no longer crashes, though. Still happens, worked once by chance, I guess.

Edit: Also, Display Configuration once again uses proper icons for orientation with Breath2 theme. Those were “unknown file” icons for a good while. This might’ve taken place on 13th already, but only noticed it now.

Memtest86+ does not work if UEFI-Installation, therefor GRUb ignores it (not in menu)
but complains - someone may know why…


Thanks for pointing that out as I must’ve forgotten to mention about it earlier. I do have Memtest86+ installed in my desktop system and Manjaro booting through UEFI, but Memtest doesn’t show up in GRUB and sudo update-grub does find it.

An EFI compatible one is available I think in the repos, never installed and used it as Memtest is the kind of tool you may need once in your computer’s life.

@acarasimon96 I think the issue with MBR Memtest is that its script can not handle NVME devices, the EFI one should. though, but seems to require manual operation after the package is installed to complete the installation in your GRUB.

//EDIT: from the look of it, its script is calling a function is_path_readable_by_grub from /usr/share/grub/grub-mkconfig_lib and I think this is what generates the error for NVME devices. That’s my guess by quickly looking at /etc/grub.d/60_memtest86+


I use a regular 2.5" SATA SSD in my desktop, but I do have a NVMe drive on my laptop. Both drives use a GPT partition scheme and boot throught UEFI. However, I used the minimal ISO image (which didn’t come with Memtest86+ preinstalled) to install Manjaro on the laptop, whereas I used the full ISO image on my desktop.

The tray icon is TOO BIG!, after the update it booms about 50% larger.

What setting do you have for the icon size (right click the little up arrow)?

- [ ] small
- [x] Scale with Panel height

If I choose small it will be like this: (wider but not smaller)

I think I remember you have 200% scaling settings enabled? That may mess things up. If I select small, icons are small and don’t get wider spaces in between. I select adjust to Panel height, it scales properly to the Panel height.

small: https://i.imgur.com/lwgbprQ.png
auto adjust: https://i.imgur.com/fg0wYIu.png

1 Like

Thank you for remember that, the original size (I use a Pahvo-rc-20210806 ISO) looks like this where I use small as default:

It will actually go bigger if I choose “Scale with Panel height”

I think the main problem is that the “small” icon actually oversized by 200% and seems like “pushing the panel/taskbar from inside” which looks very uncomfortable.

I think so.

Quick tip/side note: If you have the time in your hands, I recommend you give these packages a look through the pamac interface and read their descriptions. Therefore if something goes wrong you will have a better idea of what might have caused it. Packagers very rarely screw up package dependencies, but it has happened. This is also a very good way of getting to know your very own linux box and how it works. Later on in life you will find yourself with much more control over your machine, which is the point of linux.