[Testing Update] 2021-04-01 - Kernels, Gnome 40 Apps, Mesa 21.0.1, Kernels, Browsers

The packages were renamed:

Thank you @Yochanan.

Should I then Mark as explicitly installed the new en_gb and en_us packages to reflect how the uppercase versions were, and to lose the orphan status of en_gb?

Yes, seems logical, eh? :wink:

1 Like

Hello, last info I am able to gather on my own regarding the fact that I end up with no working GUI after this Update is:

it’s mutter-3.38.4-2 package which is killing it. Updated everything but this and have a working system.

1 Like

Using the linux511 kernel with an AMD RX5700XT card is causing constant firefox tab crashes, and sometimes full browser crashes. Tried downgrading firefox to no avail, but using the linux510 kernel works fine. I’m guessing the amdgpu module is acting up again.

try this solution, it worked for me.

you cat try this solution and report to devs if it works

1 Like

Thanks. I actually did this an another laptop and forgot that I didn’t on the one in question.

I have and had early KMS enabled since first setup. (thus was on befor running into GDM chickened out)

cat /etc/mkinitcpio.conf
# vim:set ft=sh
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(piix ide_disk reiserfs)
MODULES=(intel_agp i915)

# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries

# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way.  This is useful for config files.

# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
##   This setup specifies all modules in the MODULES setting above.
##   No raid, lvm2, or encrypted root is needed.
#    HOOKS=(base)
##   This setup will autodetect all modules for your system and should
##   work as a sane default
#    HOOKS=(base udev autodetect block filesystems)
##   This setup will generate a 'full' image which supports most systems.
##   No autodetection is done.
#    HOOKS=(base udev block filesystems)
##   This setup assembles a pata mdadm array with an encrypted root FS.
##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
#    HOOKS=(base udev block mdadm encrypt filesystems)
##   This setup loads an lvm2 volume group on a usb device.
#    HOOKS=(base udev block lvm2 filesystems)
##   NOTE: If you have /usr on a separate partition, you MUST include the
#    usr, fsck and shutdown hooks.
#HOOKS=(base udev autodetect modconf block keyboard keymap encrypt openswap resume filesystems fsck)
HOOKS=(base udev autodetect modconf block keyboard keymap encrypt resume filesystems fsck)

# Use this to compress the initramfs image. By default, gzip compression
# is used. Use 'cat' to create an uncompressed image.

# Additional options for the compressor

is there any problem with spectre-meltdown-checker since it is back to version 0.43?

I think we’re dealing with different roots of the issue. Maybe it would be best to open up a new thread, because there probably aren’t as many people stopping by here who might have a clue what’s wrong with your booting process.

EDIT: Did you try the latest unstable update with gnome-shell and gdm at version 40?

Yes - switched to unstable and the result is the same grey - I cant continue - screen.
I also opened a new topic as suggested:

Ps: right now I am downloading the dev image of gnome next to see if that boots, and than try and compare my and the image config…

1 Like

You have to download the regular gnome image from stable-staging branch and compare that. gnome-next is using unstable and Gnome 40 shell.

1 Like

I pushed mutter-3.38.4-2.1 with reenabling sysprof to see if that fixes issues with Gnome sessions.

No, it just missed the testing snap apparently. I just pushed 0.44 again.

ok thank you :slightly_smiling_face:

I updated today the first time after approx. two months 520 packages, from kernel 5.10.13 to 5.10.26, everything went fine, only some new pacnews I will take care on the next days. Thanks for such an amazingly stable rolling release distro! :heart_eyes:

Some is still totally broken with gnome. Will remove our overlays and check if we can get a fresh ISO booting up.

1 Like

here is a new gnome testing ISO:

1 Like

Hi I dont know if it has been mentioned before but for me mesa 21.0.1
breaks VA-API recording on OBS studio, i have a RX 6800.
the only thing i found searching is this.