[Testing Update] 2021-02-05 - Kernels, Gnome 40-Alpha, KDE Apps 20.12.2, Systemd, Mesa, LibreOffice 7.1

Thx for the feedback mate.

Another set of updated packages:

BoxIt memo

User philip created a snapshot of branch ‘unstable’ to ‘testing’.

  • testing community x86_64: 2 new and 2 removed package(s)
  • testing extra x86_64: 1 new and 1 removed package(s)
:: Different overlay package(s) in repository community x86_64

                             PACKAGE              testing             unstable
                               brave            1.19.84-1            1.19.92-1
                          brave-beta            1.20.78-1            1.21.44-1

:: Different overlay package(s) in repository extra x86_64

                             PACKAGE              testing             unstable
               linux510-nvidia-390xx           390.138-15           390.141-15
1 Like

This update broke the clock module from py3status, a status bar replacement for i3wm. Downgrading from 3.32 to 3.31 fixes the clock.

Edit: This will be fixed with the next version.

gnome-shell-dev shows as 3.37 on my system…

pacman -Ss gnome-shell-dev
community/gnome-shell-dev 3.29.2+3426+g40877d174-2 (gnome-next)
    Next generation desktop shell

Did you update your mirrors?

EDIT: gnome-shell-dev 3.37 is an orphaned aur package…

I think, for now to test the next gnome-shell one is supposed to download the dev build ISO and test it there.

My gnome-terminal does not work. It simply will not launch. I tried to launch it with Xfce terminal, and this is what I got:

_p9k_init_params:72: character not in range                                     
manjaro% gnome-terminal 
# Locale not supported by C library.
# 	Using the fallback 'C' locale.
# Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: Timeout was reached

Even when running xfce terminal, many characters are not displayed correctly. e.g. neofetch:

_p9k_init_params:72: character not in range                                     
manjaro% neofetch
�������������������������������miroslav@manjaro ������  ������������������������
�������������������������������---------------- ������  ������������������������
�������������������������������OS: Manjaro Linux x86_64 ������������������������
�������������������������������Host: Aspire V3-575G V1.18 ����������������������
������������������������       Kernel: 5.11.0-1-MANJARO ����
������������������������  �����Uptime: 44 mins ���  ������������������������
������������������������  �����Packages: 1382 (pacman), 6 (flatpak), 4 (snap) 
������������������������  �����Shell: zsh 5.8 ����  ������������������������
������������������������  �����Resolution: 1920x1080 �����������������������
������������������������  �����DE: GNOME 3.38.3 ��  ������������������������
������������������������  �����WM: Mutter ��������  ������������������������
������������������������  �����WM Theme: Matcha-dark-aliz ������������������
������������������������  �����Theme: Matcha-dark-aliz [GTK2/3] ������������
������������������������  �����Icons: Papirus-Dark-Maia [GTK2/3] �����������
                               Terminal: xfce4-terminal 
                               Terminal Font: Monospace 12 
                               CPU: Intel i5-6200U (4) @ 2.800GHz 
                               GPU: NVIDIA GeForce 940M 
                               GPU: Intel Skylake GT2 [HD Graphics 520] 
                               Memory: 2899MiB / 15876MiB

EDIT: Fixed by running

I was looking in stable… got in and it took me about 10 minutes to decide I didn’t like it! For me it needs dash to dock or dash to panel functionality…Of course most of the extensions don’t work yet so might try again when it is released.

1 Like

Had a locale error, all locale’s where commented out, not sure why/how. Fixed it.


When updating a Fresh Gnome VM to the test branch using :
sudo pacman-mirrors --api --set-branch testing && sudo pacman -Syyu

(16/31) Warn about old perl modules
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LANG = "en_US.utf8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

Solved using:
[root tip] Troubleshooting locale errors

$ locale-gen                                                                                                               
Generating locales...
Generation complete.
$ localectl                                                                                                          
   System Locale: LANG=en_US.utf8
       VC Keymap: us
      X11 Layout: us
$ cat /etc/locale.gen | grep 'en_US'                                                                                      
#  en_US ISO-8859-1
#  en_US.UTF-8 UTF-8
#en_US.UTF-8 UTF-8  
#en_US ISO-8859-1 
$ sudo sed -i '/en_US.UTF-8/s/^#//g' /etc/locale.gen              
sudo locale-gen                                                                                                             
Generating locales...
  en_US.UTF-8... done
  en_US.UTF-8... done
Generation complete.

Does this config need updating to?

$ cat /etc/locale.conf                                                                                                      

The same happened to me on one machine but not the other. Both running GNOME. ¯\_(ツ)_/¯


You have always cairo dock:

1 Like

I had the same problem. Solved uncommenting my locale in /etc/locale.gen and rebuilding.

1 Like

When will the KDE Plasma be updated and linux 5.10 supported?

Plasma 5.21 will be released on February 16. Linux 5.10.13 is available in testing already.

1 Like

As usual:

==> Building image from preset: /etc/mkinitcpio.d/linux510.preset: 'default'
  -> -k /boot/vmlinuz-5.10-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.10-x86_64.img
==> Starting build: 5.10.13-2-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [systemd]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [filesystems]
==> ERROR: module not found: `nvidia_uvm'

I know that this is due to this problem:

   # Fix compile problem with 5.10
    # FATAL: modpost: GPL-incompatible module nvidia-uvm.ko uses GPL-only symbol 'radix_tree_preloads'

But as the compile error mentioned in that comment, does not occur anymore, it looks like the patch for removing nvidia-uvm from the linux510-nvidia390xx package is no longer required.

After the latest update, my manjaro kde testing is lagging, processes are running half slow doing any system operation, and browsing became horribly lagging in any browser I use (FF, Chromium & Falkon).
I have 2 other distributions in this same Dell Inspiron 5459 sdd drive and they just keep working good in processing speed and browsing… very weird.


Host: manjaro
Kernel: 5.9.16-1-MANJARO x86_64 bits: 64
Desktop: KDE Plasma 5.20.5
Distro: Manjaro Linux
Type: Laptop System: Dell
product: Inspiron 5459 v: N/A
Mobo: Dell model: 0TNRDT v: A00
UEFI [Legacy]: Dell v: 1.7.0
date: 05/10/2019
ID-1: BAT0 charge: 28.1 Wh
condition: 28.1/41.4 Wh (68%)
Info: Dual Core model: Intel Core i5-6200U
bits: 64 type: MT MCP L2 cache: 3 MiB
Speed: 400 MHz min/max: 400/2800 MHz
Core speeds (MHz): 1: 400 2: 400 3: 400
4: 400
Device-1: Intel Skylake GT2 [HD Graphics
driver: i915 v: kernel
Device-2: Microdia Integrated Webcam HD
type: USB driver: uvcvideo
Display: x11 server: X.Org 1.20.10 driver:
loaded: intel unloaded: modesetting
s-res: 1366x768
OpenGL: renderer: Mesa Intel HD Graphics
520 (SKL GT2)
v: 4.6 Mesa 20.3.4
Device-1: Intel Sunrise Point-LP HD Audio
driver: snd_hda_intel
Sound Server: ALSA v: k5.9.16-1-MANJARO
Device-1: Intel Wireless 3160
driver: iwlwifi
IF: wlp1s0 state: up
mac: f4:06:69:ac:99:73
Device-2: Realtek RTL810xE PCI Express
Fast Ethernet
driver: r8169
IF: enp2s0 state: down
mac: 18:db:f2:4f:b3:b5
Device-3: Qualcomm Atheros AR9271 802.11n
type: USB driver: ath9k_htc
IF: wlp0s20f0u3 state: down
mac: f8:d1:11:1b:95:68
Device-1: Intel Bluetooth wireless
type: USB driver: btusb
Message: Required tool hciconfig not
installed. Check --recommends
Local Storage: total: 447.13 GiB
used: 33.15 GiB (7.4%)
ID-1: /dev/sda vendor: SanDisk
model: Ultra II 480GB size: 447.13 GiB
ID-1: / size: 191.25 GiB
used: 33.15 GiB (17.3%) fs: ext4
dev: /dev/sda3
ID-1: swap-1 type: file size: 3.55 GiB
used: 0 KiB (0.0%) file: /swapfile
System Temperatures: cpu: 38.0 C
mobo: 36.0 C sodimm: SODIMM C
Fan Speeds (RPM): cpu: 0
Processes: 160 Uptime: 56m
Memory: 3.55 GiB used: 1.57 GiB (44.3%)
Shell: Zsh inxi: 3.3.01

I am unfortunately experiencing major instability issues and crashes with Libreoffice 7.1 (the libreoffice-fresh package). I have not been able to pin down the reason, but experience slowdowns with the UI, freezing of the UI, and random crashes. It also sometimes does not respect the gnome pop-shell extension and will simply maximize the take the whole screen, no matter what is already displayed. No other application has similar issues. None of these problems occurred prior to this release.

I uninstalled and switched to libreoffice-still (7.0.x line) and all these issues have gone away.

I still can’t make it work with other locale. I’m using es_AR, first with some locale errors but now it’s seems working good, besides gnome-terminal with that error and Manjaro in English and trying to change the names of Download folder (currently in Spanish).

locale -a

Tools / Options / View /
disable: use hardware acceleration