[Testing Update] 2020-12-31 - Kernels, Mesa, XFCE 4.16, Deepin, Haskell, Python

Hello community,

Another testing branch update with some usual updates for you. Remember that we expect possible breakage of your system with this update!

Let’s celebrate 2021 with a preview of Ornara! #stayhome, #staysafe, #stayhealthy

  • Firefox got updated to 84.0.1
  • XFCE got its major 4.16 release
  • Mesa is now at 20.3.2
  • Mass-Rebuild against ICU
  • Qt4 got removed
  • Other regular upstream updates

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest Manjaro Ornara 21.0 preview release! KDE, XFCE and Gnome

Our current supported kernels

  • linux44 4.4.249
  • linux49 4.9.249
  • linux414 4.14.213
  • linux419 4.19.164
  • linux54 5.4.86
  • linux59 5.9.16 [EOL]
  • linux510 5.10.4
  • linux54-rt 5.4.84_rt47
  • linux59-rt 5.9.1_rt19

Packages Changes (Thu Dec 31 11:49:13 CET 2020)

  • testing community x86_64: 1510 new and 1485 removed package(s)
  • testing core x86_64: 27 new and 24 removed package(s)
  • testing extra x86_64: 436 new and 519 removed package(s)
  • testing multilib x86_64: 15 new and 9 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Python 3.9 Requires Rebuilds

Instructions for quickly and easily rebuilding affected AUR packages:

# Install yay
sudo pacman -S --needed --noconfirm yay

# Rebuild AUR python packages
yay -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-packages")

Older Issues

libtraceevent>=5.9-1 update requires manual intervention

2020-10-23 - Sébastien Luttringer

The libtraceevent package prior to version 5.9-1 was missing a soname link. This has been fixed in 5.9-1, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

libtraceevent: /usr/lib/libtraceevent.so.1 exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/libtraceevent.so.1

to perform the upgrade.


OpenVPN connection times out.

Workaround: donwgrade openvpn (2.5.0-1 => 2.4.9-2).
For a proper solution follow this bug report on Arch Linux: FS#68480 : [openvpn] running unprivileged with iproute no longer working

PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

Hi, I upgraded to the latest packages.
The xfce Status Tray plugin exits with a core dump (thus, currently no status icons are visible):
Process 5720 (panel-6-systray) of user 1000 dumped core.

                                           Stack trace of thread 5720:
                                           #0  0x00007f91fa3fce63 g_variant_iter_loop (libglib-2.0.so.0 + 0x9ce63)
                                           #1  0x00007f91fb0f4e12 n/a (libsystray.so + 0x14e12)
                                           #2  0x00007f91fa5b10f4 n/a (libgio-2.0.so.0 + 0xa10f4)
                                           #3  0x00007f91fa5b5639 n/a (libgio-2.0.so.0 + 0xa5639)
                                           #4  0x00007f91fa61820d n/a (libgio-2.0.so.0 + 0x10820d)
                                           #5  0x00007f91fa5b10f4 n/a (libgio-2.0.so.0 + 0xa10f4)
                                           #6  0x00007f91fa5b5639 n/a (libgio-2.0.so.0 + 0xa5639)
                                           #7  0x00007f91fa60a340 n/a (libgio-2.0.so.0 + 0xfa340)
                                           #8  0x00007f91fa5b10f4 n/a (libgio-2.0.so.0 + 0xa10f4)
                                           #9  0x00007f91fa5b1129 n/a (libgio-2.0.so.0 + 0xa1129)
                                           #10 0x00007f91fa3b2a84 g_main_context_dispatch (libglib-2.0.so.0 + 0x52a84)
                                           #11 0x00007f91fa4069b1 n/a (libglib-2.0.so.0 + 0xa69b1)
                                           #12 0x00007f91fa3b1fd3 g_main_loop_run (libglib-2.0.so.0 + 0x51fd3)
                                           #13 0x00007f91faaf922f gtk_main (libgtk-3.so.0 + 0x1e122f)
                                           #14 0x0000559496038337 main (wrapper-2.0 + 0x3337)
                                           #15 0x00007f91fa1b8152 __libc_start_main (libc.so.6 + 0x28152)
                                           #16 0x000055949603848e _start (wrapper-2.0 + 0x348e)

Does anyone have an idea of how to get this functionality running?

Currently optimus-manager does not work for me. Just came from stable (after reinstalling KDE). Switching worked fine on stable, but now it doesn’t (switching worked fine yesterday).
The error I get is

The nvidia module does not seem to be available for for the kurrent kernel. It is likely the Nvidia driver was not properly installed. GPU switching will probably fail. Continue anyway?

I have changed optimus-manager from repo to optimus-manager-git from AUR, but no luck in having it switch for the time being.
I am currently on kernel 5.10, will check kernel 5.9

Switching using optimus-manager works like a charm on kernel 5.9 for me, not 5.10 (which is sad because 5.9 is close to EOL).

Won’t anything break during the upgrade? I look forward to hearing your stories.

With this update, is solved this issue?

Best regards and happy new year!! :santa:

1 Like

Going through the pacman.log I noticed this:

[2020-12-31T14:33:50+0000] [ALPM-SCRIPTLET] optimus-manager : disabling optimus-manager.service

So maybe that is the culprit on kernel 5.10. Will reboot and go into kernel 5.10, enable the service and see what is what.

Was worth the try, but unsuccessful. Still no switching on kernel 5.10.


Why 20.1? Maybe 21.1? It will release in 2021.

yay vbox works with kernel 5.10 :wink:

nothing break for me
xfce 4.16 french language


what can we use instead of a Orage (dropped from the repos)?
it still works but probably not for long.

Having issues with timeshift since the update. Every reboot hangs with the error

Failed unmounting /run/timeshift/backup

Timeshift is still making backups but it is not showing todays backup in the gui even though the backup exists. Anyone else with the issue ?

Which mode, btrfs or rsync?

rsync. I’ve just uninstalled timeshift and reinstalled ,it gave me a message about upgrading another package on the reinstall. I’ve just done a manual backup and that’s now showing in timeshift so fingers crossed its just a package that didn’t get updated

Ok. Pardon me if my head was stuck in the sand, but what is ornara?

good question

It’s a planet you… noobs :rofl:


Whoah i donno about that
That looks interesting :blush:
And… yeah i am a little pigeon noob

1 Like

Looks like a nvidia driver incompatibility/bug with the kernel to me rather than an optimus-manager thing. Both seem rather not-ready for prime yet, for example 5.10.4 is still on Arch testing repo. Others have problems with Nvidia’s Prime as well, like


and other problems if you take a look at bugs.archlinux.org