[Testing Update] 2020-12-22 - Kernels, Pamac 10.0.1, Firefox-Beta, Nvidia, KDE-git

Sorry, I am already back on KDE (should have mentioned that), so no need for gdm-prime now and I am using sddm. Using the terminal shows no errors, just the that the change wasn’t possible and refers to the log. Only happening on kernel 5.10 for the moment.

Go through optimus-manager setup guide again and check everything. Something on your side is misconfigured or missing. Maybe some additional graphical libs or other related packages needs to be installed?
Anyway, the issue is most probably on your end, so the good news is, you can fix it, the bad is, you have to do it yourself.

I have gone through the docs at least 3 times already… reinstalled optimus-manager at least 2x going carefully through the steps… no luck so far… (have checked /etc/sddm.conf)

I will find this… will just take some time.

Interesting, both DisplayCommand and DisplayStopCommand lines are missing from sddm.conf. Not sure if that is relevant becasue we are supposed to add a # in front of it. BUT it makes me wonder if something else is missing from that file.





ServerArguments=-nolisten tcp

Isn’t it the same error?

Regarding gdm-prime - there was a bug in optimus manager when running with gdm-prime version 3.38. This big was fixed already and it is implemented on AUR optimus-manager-git (it still was not updated in the Manjaro repositories, even though I contacted the package maintainer).

Maybe, but I did notice that SessionCommand=/usr/share/sddm/scripts/Xsession while according to sddm.conf: sddm display manager configuration - Linux Man Pages (5) the default should be /etc/X11/xinit/Xsession. I am currently not sure about this, but it is a difference. Will check the live iso later and check what sddm.conf there says.

This is similar, but in my case, switching works fine on kernel 5.9xx, but not at all on kernel 5.10xx. Suspend doesn’t seem to have anything to do with it at all.

Hi guys, this evening Pamac 10.0.2 was available, I updated it and I had 3 AUR app to update: Brave, Mega Sync and Zoom.
I was able to update Zoom in few seconds but not Brave and Mega.
Maybe there is a problem with these app.

1 Like

Hi all

A couple of days ago pamac 10.0.1-1.0 was made it to the stable branch too.
I guess it’s safe to upgrade. (or wait for the 10.0.2 - for some last minute bugs fixed)
I don’t know

Gnome seems to be taking a long time to load after login. Looking at the journal the hangup seems to be here:
Dec 23 10:24:35 aethan-ms7921 systemd[872]: Started Multimedia Service.
Dec 23 10:24:34 aethan-ms7921 systemd[872]: Started Portal service (GTK+/GNOME implementation).
Dec 23 10:24:34 aethan-ms7921 dbus-daemon[895]: [session uid=1000 pid=895] Successfully activated service ‘org.freedesktop.impl.portal.desktop.gtk’
Dec 23 10:24:28 aethan-ms7921 systemd[872]: Starting Portal service (GTK+/GNOME implementation)…
Dec 23 10:24:28 aethan-ms7921 dbus-daemon[895]: [session uid=1000 pid=895] Activating via systemd: service name=‘org.freedesktop.impl.portal.desktop.gtk’ unit='xdg-desktop-p>
Dec 23 10:24:28 aethan-ms7921 systemd[872]: Started flatpak document portal service.
Where starting gtk+/gnome implementation is taking 6 seconds, any ideas?

Edit: However this isn’t the only issue as the whole boot from login is taking about 20s, also doing things is sluggish, and trying to watch a youtube video is stuttery with the error:
ACPI Error: AE_NOT_FOUND, while evaluating GPE method [_L09] (20200925/evgpe-511)

Solution: Downgrading to linux59 fixed the issues, which says that the lastest 5.10 is causing an issue (as the previous 5.10.1 was working fine)

Anyone else here having this issue?

$ pamac build onedrive-abraunegg
Cloning onedrive-abraunegg build files...
Checking onedrive-abraunegg dependencies...
cp: cannot stat '/var/lib/pacman/sync/*.files': No such file or directory
Segmentation fault (core dumped)

Whereas the GUI simply crashes.

I couldn’t update Brave from AUR too.

1 Like

It’s fine if those lines are missing. They are not part of the default config. Manjaro added them and that was creating the issue for optimus-manager.

Did you check the official documentation or my guide?

So it was the official repo optimus-manager that was the problem. Everything was done correct of my behalf, after all, switching worked like a charm on kernel 5.9. Switching to optimus-manager-git solved the issue.

1 Like

The same issue with AUR in Pamac 10.0.2-2 not showing any results

Same problem with Pamac 10 in stable branch. It doesn’t work with the GUI, but works from the command line.

yay -Syyu works…

No bluetooth with kernel 5.10 . I got an usb controller which is not listed in lsusb and
bluetoothctl list say “No controller available.”
Works fine under linux54

After the pamac update on 26th, clicking on the pamac-tray-icon-plasma tray icon brings up pamac with an empty view, like so:

Switching to “Installed” or “Updates” and back brings back the featured applications, as does selecting something under “Browse by” or “View”, and going back.
Launching pamac (or “Add/Remove Software”) through other means, such as krunner, does not cause this visual glitch, and featured applications are visible right away.

Ye. Can’t wait: News – Xfce 4.16 released – Xfce

Nach pamac-upgrade:
aur.vala:60: Fehler beim Auflösen von »aur.archlinux.org«: Der Name oder der Dienst ist nicht bekannt

After pamac upgrade:
aur.vala: 60: Error resolving “aur.archlinux.org”: The name or the service is not known