[Testing Update] 2020-12-18 - Kernels, Mesa, Gstreamer, KDE Apps, KDE Framework, Libreoffice, Cinnamon, Haskell

Is it worth rolling back to pre “BREAKAGE EXPECTED” from Timeshift, to test again the Nvidia update process and transition to the new ‘rolling’ driver? Was there changes made to this process or is it the same?

I want to test it for this to be proper when it hits Stable, but rolling back if nothing has been donne is kinda ‘meh’.

new lines in /etc/default/grub:

+# Uncomment to ensure that the root filesystem is mounted read-only so that
+# systemd-fsck can run the check automatically
GRUB_ROOT_FS_RO=true

Should we enable this ?

Haven’t rebooted yet, but I was asked to run /usr/bin/cups-genppdupdate after upgrading gutenprint. It found nothing to update.
Also got a grub.pacnew, merged the new section about rooting the root filesystem as read-only.
But there’s one warning I’m not sure about. I got this after upgrading manjaro-zsh-config:

warning: directory permissions differ on /root/
filesystem: 750  package: 755

Which one should I match the permissions to?

750.
/root isn’t supposed to be readable for all…

The baloo_file error seems to have disappeared for me for now. I restarted manually with balooctl enable which worked initially, but then would eventually dump again. I also noticed I had a kdeinit5[103503]: inotify_add_watch(/boot/efi) failed: (Permission denied) entry just before, and changed fs.inotify.max_user_watches=204800 in /etc/sysctl.d/50-max-user-watches.conf as noted here Inotify_add_watch Permission denied.

Since my root’s home folder has never had a .zshrc, I guess I can just ignore this warning? Default shell for root is obviously bash, and might as well keep it that way for compatibility’s sake

A post was split to a new topic: Errors in rebuilding AUR python packages

Having same problem :slightly_frowning_face:

Upgrading to kernel ‘5.10.1-5’ solved this for me running on ‘Unstable’.

I still haven’t seen the baloo_file error return - guessing it was an issue with my indexed database. I somehow missed off in my previous post that after I manually restarted and had another core dump, I ran balooctl purge before balooctl enable which appears to have done the trick.

since the update before wofi launcher is not working (previous post here)

@bluewhale99, this depends on your fsck boot time checking mechanism, details of your options are explained here:
https://www.linuxsecrets.com/archlinux-wiki/wiki.archlinux.org/index.php/Fsck.html

1 Like

So if I understood correctly, I should remove fsck from my mkinitcpio.conf, since I have a pass value higher than 0 for my root partition inside fstab, and I have added that new argument to my grub file?

I’m reading this wiki page heavily sleep-deprived, so maybe I’m misinterpreting it…

Hello,
With the kernel 5.10 update this day, the wifi speed problem is solved.
Fred

I also see the issue with “grub is conflicting with grub-cutomizer”.

It’s as if nvidia-settings was conflicting with nvidia drivers or tlpui with tlp… or… grsync with rsync, or… you get the idea.

What is wrong?

1 Like

I think grub is meant to conflict with grub-customizer. Manjaro grub is already customised and using grub-customiser can lead to an unbootable system. It’s probably a safety precaution for people who don’t know what they are doing

Well nvidia-settings reports VSync status “off” with 5.10 (“on” with 5.9) so maybe it does :laughing:

I found it to be a moot argument that is repeated over and over. I’ve been using grub-customizer on Manjaro over 4 years and I have the same install. It never broke or caused any issues with grub. In fact, it was only fixing it, because during some updates Manjaro creates duplicate entries.

4 Likes