[Testing Update] 2020-11-26 - Kernels, Browsers, Maui-Apps, Pamac 10.0-Beta, Gnome, Mesa, Qt

Hello community,

Another testing branch update with some usual updates for you!

Get the book and the phone before #XMas! #stayhome, #staysafe, #stayhealthy

  • Most of our Kernels got renewed
  • Pamac has a new beta you may want to try out
  • Some more fixes to our Gnome packages
  • Qt got updated to 5.15.2
  • Lot of our Browsers got refreshed
  • Maui-Apps are now part of our regular upstream packages
  • Mesa is at 20.2.3

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest Manjaro Nibia 20.2 release candidate! KDE, XFCE and Gnome

Our current supported kernels

  • linux44 4.4.246
  • linux49 4.9.246
  • linux414 4.14.209
  • linux419 4.19.160
  • linux54 5.4.80
  • linux57 5.7.19 [EOL]
  • linux58 5.8.18 [EOL]
  • linux59 5.9.11
  • linux510 5.10-rc5
  • linux54-rt 5.4.78_rt44
  • linux59-rt 5.9.1_rt19

Packages Changes (Thu Nov 26 08:29:34 CET 2020)

  • testing community x86_64: 1147 new and 1123 removed package(s)
  • testing core x86_64: 24 new and 24 removed package(s)
  • testing extra x86_64: 359 new and 354 removed package(s)
  • testing multilib x86_64: 18 new and 18 removed package(s)

A detailed list of all changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

libtraceevent>=5.9-1 update requires manual intervention

2020-10-23 - Sébastien Luttringer

The libtraceevent package prior to version 5.9-1 was missing a soname link. This has been fixed in 5.9-1, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

libtraceevent: /usr/lib/libtraceevent.so.1 exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/libtraceevent.so.1

to perform the upgrade.


OpenVPN connection times out.

Workaround: donwgrade openvpn (2.5.0-1 => 2.4.9-2).
For a proper solution follow this bug report on Arch Linux: FS#68480 : [openvpn] running unprivileged with iproute no longer working

Older Issues

PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable org.cups.cupsd.service
systemctl enable org.cups.cupsd.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

opencascade74 and opencascade are in conflict. I have opencascade installed as a dependency required by freecad. How can I figure out what requires opencascade74?

Synchronizing package databases...                                                                                                                                                       
Error: Failed to prepare transaction:
conflicting dependencies:
- opencascade74 and opencascade are in conflict
Resolving dependencies...
Checking inter-conflicts...
Error: unresolvable package conflicts detected
Error: Failed to prepare transaction:
conflicting dependencies:
- opencascade74 and opencascade are in conflict

Strange effect after updating kernels:
at restart and/or shutdown “a lot of white text” is rolling down the screen.
In QJournalctl I find no reasonable reason.
Updated from linux59 10-1 (o.K.) to linux59 11-2 (not o.k.)
Updated from linux510 rc4 (o.k.) to linux510 rc5 (not o.k)

Maybe: Missing “quiet” in shutdown-script???

use yay -Sdd opencascade74 to replace opencascade by opencascade74

1 Like
$ pactree -ro opencascade74
1 Like

Heh that “dd” is savior :wink:
I had to reinstall mpv and use pulseaudio-pali instead of vanila pulseaudio :wink:

Weird, just refreshed my mirrors and checked for updates, but none were found (about 10 sec ago). Checking if I am not on testing branch.

Yeb, wasn’t on testing (even if I chose it in the installation option).

I got a following message, while updating via pacman:

Cups systemd socket and service files have been
renamed by upstream decision. Please make sure
to disable/reenable the services to your need.
hint: "pacman -Ql cups | grep systemd" and
"ls -lR /etc/systemd/ | grep cups"

I ran both, but I’m too much of a novice to understand what I should be looking for.

cups /usr/lib/systemd/
cups /usr/lib/systemd/system/
cups /usr/lib/systemd/system/cups-lpd.socket
cups /usr/lib/systemd/system/cups-lpd@.service
cups /usr/lib/systemd/system/cups.path
cups /usr/lib/systemd/system/cups.service
cups /usr/lib/systemd/system/cups.socket
lrwxrwxrwx 1 root root 43 kesä    8 15:14 org.cups.cupsd.path -> /usr/lib/systemd/system/org.cups.cupsd.path
lrwxrwxrwx 1 root root 46 kesä    8 15:14 org.cups.cupsd.service -> /usr/lib/systemd/system/org.cups.cupsd.service
lrwxrwxrwx 1 root root 45 kesä    8 15:14 org.cups.cupsd.socket -> /usr/lib/systemd/system/org.cups.cupsd.socket

I haven’t made any fundamental changes (to my knowledge, at least) since I installed Manjaro in June, so I should be ok(?)


cups is your printer service, and even if you don’t print things, it also does things like print to pdf file.

They renamed the cups units from cupsd to cups

Cups systemd socket and service files have been
renamed by upstream decision.

In my opinion those commands in the alert are confusingly out of order. So I’ll flip them:

The second command shows you the names of your old units, notice it says cupsd:

org.cups.cupsd.path -> /usr/lib/systemd/system/org.cups.cupsd.path
org.cups.cupsd.service -> /usr/lib/systemd/system/org.cups.cupsd.service
org.cups.cupsd.socket -> /usr/lib/systemd/system/org.cups.cupsd.socket

Then, the first command shows you the name of the new unit, notice it says cups:

cups /usr/lib/systemd/
cups /usr/lib/systemd/system/
cups /usr/lib/systemd/system/cups-lpd.socket
cups /usr/lib/systemd/system/cups-lpd@.service
> cups /usr/lib/systemd/system/cups.path
> cups /usr/lib/systemd/system/cups.service
> cups /usr/lib/systemd/system/cups.socket

So what we need to do, is stop and disable the old units, and enable (and optionally start) the new services, note though, if the old services are not running, the first two commands might give you an expected error that you can ignore, and you can omit the enable for the new unit.

sudo systemctl stop org.cups.cupsd.socket
sudo systemctl stop org.cups.cupsd.service
sudo systemctl stop org.cups.cupsd.path
sudo systemctl disable org.cups.cupsd.socket
sudo systemctl disable org.cups.cupsd.service
sudo systemctl disable org.cups.cupsd.path
sudo systemctl enable cups.service
sudo systemctl enable cups.socket
sudo systemctl enable cups.path

Notice how we had to be a bit more explicit with which service we are disabling, now I’m not super well versed with systemd, but simply, since those units were disowned, you have to use their long names.

Hope it helps!


All done! And as you suspected to possibly be the case, the socket and service were not loaded.


I just edited my post to address your .path, and note about the disabling the old services, that you need to use the long names.

I get this logs when I try to connect sony mdr1000x bluetooth headphones.

bluetoothd[317542]: src/service.c:btd_service_connect() a2dp-sink profile connect failed for XX:XX:XX:XX:XX:XX: Protocol not available
plasmashell[34975]: kf.bluezqt: PendingCall Error: "Protocol not available"

Solved; I just needed to install pulseaudio-modules-bt-git version and then pulseaudio -k.

Actually the path wasn’t loaded either, I somehow omitted it from that message…

make sure you are using the long names in the disable:

sudo systemctl disable org.cups.cupsd.socket
sudo systemctl disable org.cups.cupsd.service
sudo systemctl disable org.cups.cupsd.path

That’s probably why you saw as not loaded.

I did. They were there when I saw the message.

1 Like

my wayland is not recognizing the accent keys on my keyboard which is PT-BR. This happens both on the notebook and on the desktop.

The answer here depends on your DE, but generally, go to the settings look for keyboard settings, and add your keyboard.

If you have a US keyboard, and you want accents, you may need to use the English, but then look for Alt. International. As an example, these are the two options for gnome:

The update broke my laptop, right after the upgrade I rebooted. After reboot, I’m able to login but the screen hangs with the loading bar maybe stopping at around a fifth. I’m able to move the mouse around but that’s it. I had to downgrade to 5.8 and it works fine.

It seems that there’s a deadlock somewhere, as if waiting for a service maybe? I don’t get any apparent error though so it’s perplexing and I’m not able to launch a terminal either.

After attempting to install Pamac 10.0-Beta, I cannot launch pamac gui.

~ >>> pamac-manager                                                       [127]
pamac-manager: symbol lookup error: /usr/lib/libpamac-gtk.so: undefined symbol: pamac_transaction_get_build_files