[Testing Update] 2020-09-10 - Kernels, Password-Managers, MHWD, Pamac, VirtualBox, Gnome

my bet is on this patch or any other block patches of 5.8.8. If you start parted or fdisk in a terminal, no issues. Have to check partitionmanager.

2 Likes

I know its probably not related at all but the gnome disk utility still works fine so the gui from that can be used for people scared of the cli

1 Like

Ah, things took a step further. I could now install the Extension Pack 6.1.14 from the AUR successfully, which had failed previously. Not sure why. So the next steps are ahead - try to run a virtual machine under Linux 5.8 for the first time - in my case, Windows plus installing the Guest Additions.

So partitionmanager works. This means it is an issue with gparted. I can try my hunch and revert two patches regarding block to see if I’m right. Also it would be interesting if 5.4.64, which doesn’t have those patches still work. Will try that next.

[phil@development extra]$ partitionmanager
Could not load plugin for core backend  "" :  "The shared library was not found."
Loaded backend plugin:  "pmsfdiskbackendplugin"
Icon theme "breeze" not found.
Icon theme "breeze" not found.
"Using backend plugin: pmsfdiskbackendplugin (1)"
"Scanning devices..."
"Device found: ST1000DM003-1ER162"
unknown file system type  ""  on  "/dev/sda1"
"Partition ‘/dev/sda1’ is not properly aligned (first sector: 1.985, modulo: 1.985)."
"Device found: ST1000VX000-1ES162"
"Partition ‘/dev/sdb3’ is not properly aligned (last sector: 1.953.520.031, modulo: 416)."
"Scan finished."
3 Likes

Already checked - no issues on that one.

1 Like

Yep, it works:

[phil@development Schreibtisch]$ gparted
Unit \x2a.service does not exist, proceeding anyway.
Unit \x2a.service does not exist, proceeding anyway.
Unit \x2a.service does not exist, proceeding anyway.
GParted 1.1.0
configuration --enable-libparted-dmraid --enable-online-resize
libparted 3.3

So I’ll put my theory to test and revert those two patches.

3 Likes

No issues here so far. intel/nvidia prime, linux58 with i3wm

No issue with gparted on 5.8.6.1 if that matters.

Continuing on VirtualBox 6.1.14: Everything works fine now. Successfully ran my two virtual Windows machines (8.1 and 10).

Still no idea why the Extension Pack installation via VB GUI and VBoxManage did fail, cf. my posts above. The Extension Pack from the AUR worked - all set.

So I can cast my vote on this Testing Update - thanks to all devs for their great work!

Just an observation wrt this new forum, maybe you have been notified already. The voting section at the top is ordered differently depending on whether it shows the results or shows the vote. It reads "No issue - Issue solved myself - Issue unsolved" in the one case, and "No issue - Issue unsolved - Issue solved myself" in the other. :wink:

I got a gparted issue too:
[steph@Tour ~]$ gparted
Unit \xe2\x97\x8f.service does not exist, proceeding anyway.
Unit \xe2\x97\x8f.service does not exist, proceeding anyway.
Unit \xe2\x97\x8f.service does not exist, proceeding anyway.
GParted 1.1.0
configuration --enable-libparted-dmraid --enable-online-resize
libparted 3.3
La ou les partitions 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35, 36, 37, 38, 39, 40, 41, 42, 43, 44, 45, 46, 47, 48, 49, 50, 51, 52, 53, 54, 55, 56, 57, 58, 59, 60, 61, 62, 63, 64, 65, 66, 67, 68, 69, 70, 71, 72, 73, 74, 75, 76, 77, 78, 79, 80, 81, 82, 83, 84, 85, 86, 87, 88, 89, 90, 91, 92, 93, 94, 95, 96, 97, 98, 99, 100, 101, 102, 103, 104, 105, 106, 107, 108, 109, 110, 111, 112, 113, 114, 115, 116, 117, 118, 119, 120, 121, 122, 123, 124, 125, 126, 127, 128 ont été écrites sur /dev/sda, mais il est impossible d’informer le système des changements, sans doute à cause de leur utilisation. Ainsi, les anciennes partitions restent en usage. Vous devriez redémarrer maintenant avant d’effectuer d’autres changements.

Of course, I did reboot

[steph@Tour ~]$ inxi -b
System:
Host: Tour Kernel: 5.8.8-2-MANJARO x86_64 bits: 64 Desktop: Xfce 4.14.2 
Distro: Manjaro Linux 
Machine:
Type: Desktop Mobo: ASUSTeK model: PRIME B350M-A v: Rev X.0x 
serial: <superuser/root required> UEFI: American Megatrends v: 3803 
date: 01/22/2018 
CPU:
6-Core: AMD Ryzen 5 2600X type: MT MCP speed: 2659 MHz 
min/max: 2200/3600 MHz 
Graphics:
Device-1: AMD Baffin [Radeon RX 460/560D / Pro 
450/455/460/555/555X/560/560X] 
driver: amdgpu v: kernel 
Display: server: X.Org 1.20.9 driver: amdgpu,ati 
unloaded: modesetting,radeon resolution: 1920x1080~60Hz 
OpenGL: renderer: Radeon RX 560 Series (POLARIS11 DRM 3.38.0 
5.8.8-2-MANJARO LLVM 10.0.1) 
v: 4.6 Mesa 20.1.7 
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
driver: r8169 
Drives:
Local Storage: total: 791.83 GiB used: 83.65 GiB (10.6%) 
Info:
Processes: 327 Uptime: 3m Memory: 15.63 GiB used: 1.29 GiB (8.2%) 
Shell: Bash inxi: 3.1.05

The virtualbox issue is solved for me.
I had to explicitly download and update virtualbox-extensions to 6.1.14. Now it works fine.

But I have no clue why the AUR package was working without that step.

I reported the regression. We may need to git-bisect it. I try another hunch …

6 Likes

Open Terminal login as root run virtualbox and try again, sometimes it needs root rights don’t know why…

Good update no issues with Mikah 20.1. Thank you devs and all. :joy:

Yeah, it probably is as easy as that. I think VBoxManage needs root privs. When I ran it from my user account in a terminal, it asked for root credentials in that typical GUI box. I figured that was strange, but didn‘t think deeper to run it as “sudo VBoxManage“. It worked from the AUR. Will try with the next version of VB.

So the VirtualBox bust is over for me.

Yeah. Still a few little bugs, but now it is actually usable on wayland.

Fine update, pretty stable.
No issues on Gnome, 5.4 Kernel (all fine with gparted).

all got with linux54 I think we should update linux-latest(-*) meta Packages to go with linux58 Happen on next Testing Update
Had some problems with linux57 can’t boot with this, (mkinitcpio -P show errors on building the linux57 - reinstall resolved this problem.

And systemd has some problems to load some Virtulbox modules

Sep 13 13:41:09 Workstation systemd-modules-load[239]: Failed to find module 'vboxdrv'
Sep 13 13:41:09 Workstation systemd-modules-load[239]: Failed to find module 'vboxnetadp'
Sep 13 13:41:09 Workstation systemd-modules-load[239]: Failed to find module 'vboxnetflt'

No issues with:
linux54-virtualbox-host-modules 6.1.14-2
linux57-virtualbox-host-modules 6.1.14-1

Wait…
3.38 will be out September 16th
So… ?