[Testing Update] 2020-08-21 - Kernels, PAM, PAMBASE, KDE-git, Deepin, Pamac, Nvidia 450.66

If I enable systemd-homed service what will it do?

@merlock posted the link to the ArchBBS which contains the solution to prevent the log entries = It is save to remove /usr/lib/security/pam_systemd_home.so because it is an optional module for the pam stack. Masking the service is not sufficient because the log messages come from this module and not from the service.

I deleted /usr/lib/security/pam_systemd_home.so and it works fine. And for me, because I do not want to do this on every systemd update, I added a corresponding NoExtract line to /etc/pacman.conf:

NoExtract = usr/lib/security/pam_systemd_home.so

That will take care of it in the future.

4 Likes

With kernel 5.8 i still get complete system freeze when starting a VM in Virtual Box. Otherwise all good.

for me, akonadi / mysql doesn’t start after the update.

~/…/share/akonadi >>> akonadictl start [130]
org.kde.pim.akonadictl: Starting Akonadi Server…
org.kde.pim.akonadictl: done.
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
org.kde.pim.akonadiserver: Starting up the Akonadi Server…
org.kde.pim.akonadiserver: Failed to detect mysqld version!
org.kde.pim.akonadiserver: Could not start database server!
org.kde.pim.akonadiserver: executable: “/usr/bin/mysqld”
org.kde.pim.akonadiserver: arguments: ("–defaults-file=/home/termy/.local/share/akonadi/mysql.conf", “–datadir=/home/termy/.local/share/akonadi/db_data/”, “–socket=/run/user/1000/akonadi/mysql.socket”, “–pid-file=/run/user/1000/akonadi/mysql.pid”)
org.kde.pim.akonadiserver: process error: “execvp: Permission denied”

mysqld also didn’t start due to permissions, so i tried chmod -R 777 /var/lib/mysql, that way mysqld at least tries to start but yields somthing like

[ERROR] Could not open mysql.plugin table: “Table ‘mysql.plugin’ doesn’t exist”. Some plugins may be not loaded
2020-08-22 10:30:31 0 [Note] InnoDB: Loading buffer pool(s) from /var/lib/mysql/ib_buffer_pool
2020-08-22 10:30:31 0 [ERROR] InnoDB: Unable to lock ./mysql/innodb_index_stats.ibd error: 11
2020-08-22 10:30:31 0 [Note] InnoDB: Check that you do not already have another mysqld process using the same InnoDB data or log files.
2020-08-22 10:30:31 0 [ERROR] InnoDB: Operating system error number 11 in a file operation.
2020-08-22 10:30:31 0 [ERROR] InnoDB: Error number 11 means ‘Resource temporarily unavailable’

for several files.
I found various threads around the internet regarding mysql/mariadb/akonadi-updates, but none that had this specific issues (and none of the solutions there helped)
Anyone got any idea? Should i create a new thread or should i try downgrading mariadb and hope the second attempt works? ^^

3 Likes

Arch patched their 5.8 kernel to have a slightly better Virtualbox support, however this axes it on all other kernel series. So we wait for Oracle to release a proper version which works with all kernel series properly.

4 Likes

test with mask systemd-homed.service
let pam & lightdm still spam in log ( sudo is enough )

i removed /usr/lib/security/pam_systemd_home.so

Perfectly fine using other kernels for now, and i think is the best indeed to wait for that proper release. Thank you!

Thanks! I’ll let pacman bring in new ones, in case this error gets fixed.

I don’t really know why but I had a .pam_environment file in my home directory that wouldn’t let me log in.
The error just said “critical error - immediate abort”.
no problem (for now) after removing the file.

Installed the latest update and rebooted into black screen. I rebooted again and it booted up fine second time I’m not sure if this is anything but it was in my very long xsession

Summary

(nemo-desktop:1486): GLib-GObject-WARNING **: 14:13:31.058: …/glib/gobject/gsignal.c:2735: instance ‘0x558c0836bce0’ has no handler with id ‘297’
cinnamon-session[1231]: WARNING: t+43054.09128s: Playing logout sound ‘/usr/share/sounds/LinuxMint/stereo/logout.ogg’
cinnamon-session[1231]: WARNING: t+43054.15608s: Finished playing logout sound
cinnamon-session[1231]: WARNING: t+43054.15613s: Resuming logout sequence…
cinnamon-session[1231]: WARNING: t+43055.10814s: Requesting system shutdown…
cinnamon-session[1231]: WARNING: t+43055.10867s: Attempting to shutdown using systemd…
[+73:34:50.270][default][unixsignalhandler.cpp:96][info] Received signal 15 from pid 1
[+73:34:50.270][default][client.cpp:600][info] Exit due to SIGTERM
[+73:34:50.270][default][main.cpp:438][info] App is about to quit
[+73:34:50.270][jsonrpc][jsonrpc.cpp:322][info] Sending request QJsonValue(double, 3) to invoke RPC method “notifyClientDeactivate”
[+73:34:50.271][default][main.cpp:447][info] QGuiApplication has exited: 0
[+73:34:50.271][default][client.cpp:710][info] An exit notification is in progress, try to let it complete
[+73:34:50.271][default][unixsignalhandler.cpp:96][info] Received signal 1 from pid 1
Gdk-Message: 14:13:32.174: cinnamon-session: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.

[+73:34:50.316][jsonrpc][jsonrpc.cpp:418][info] Request 3 succeeded
[+73:34:50.422][default][warning] The X11 connection broke: I/O error (code 1)
XIO: fatal IO error 0 (Success) on X server “:0”
after 78650 requests (78627 known processed) with 0 events remaining.

Downgrading mariadb (including -clients and -libs) to 10.4.14 did bring akonadi back to a working state, so it definitely is the new version.
Running the upgrade-command mentioned in the pacman output didn’t work after re-upgrading.
Apparently i’m not the only one: Akonadi won't start after MariaDB update : kde
I’ve also noticed that running mysqld itself with the given arguments works without errors:

mysqld --defaults-file=/home/termy/.local/share/akonadi/mysql.conf --datadir=/home/termy/.local/share/akonadi/db_data/ --socket=/run/user/1000/akonadi/mysql.socket --pid-file=/run/user/1000/akonadi/mysql.pid [130]
2020-08-22 16:16:36 0 [Note] mysqld (mysqld 10.5.5-MariaDB) starting as process 8932 …

after that, akonadi starts up just fine.
i ran mariadb-upgrade /run/user/1000/akonadi/mysql.socket as mentioned in the reddit-post which did complete fine.
When killing mysql, stopping akonadi and then trying to start akonadi again, i’m back to the error org.kde.pim.akonadiserver: process error: “execvp: Permission denied”



I exclude the packages but Auto Login gets disabled after update and reboot

Revert to a stable snapshot and doing the update again without excluding the packages all fine now. No pacnew files

Only see the errors from PAM on journal:

Aug 23 12:40:11 Workstation lightdm[1965]: pam_systemd_home(lightdm-autologin:account): Failed to query user record: Unit dbus-org.freedesktop.home1.service not found.
Aug 23 12:40:11 Workstation systemd[1981]: pam_systemd_home(systemd-user:account): Failed to query user record: Unit dbus-org.freedesktop.home1.service not found.
Aug 23 12:42:13 Workstation polkit-agent-helper-1[2674]: pam_systemd_home(polkit-1:account): Failed to query user record: Unit dbus-org.freedesktop.home1.service not found.
Aug 23 12:42:47 Workstation sudo[2795]: pam_systemd_home(sudo:account): Failed to query user record: Unit dbus-org.freedesktop.home1.service not found.

Too much hassle, just enable systemd-homed.service. It has almost zero impact on system initialization process:

┬─[openm@reiwa:~]─[20:10:02]
╰─>$ systemd-analyze blame --no-pager |grep homed
 295ms systemd-homed.service
1 Like

for any command in sudo
we get 4 lines in log ( ligtdm , systemd , pam & sudo )

"for a (temporary) second copy of your home directory. "

I don’t think I have room for several terabytes of data :stuck_out_tongue:

don’t think I have room for several terabytes of data

Once upon a time:
computers had 16kb RAM and a Taperecorder for loading and saving Programs.
Luxus was: more than one Floppy Disk . Each 440kB doublesided.
http://www.cbmhardware.de/show.php?r=14&id=76/CBM%20PET%20und%20CBM%202001%20Serie#tape

I would be willing to do that but I have no idea about the impact. Will it leave my home directory alone or will it mess up my setup. My home is on an encrypted zfs dataset and I am afraid systemd will mess it up.

Upgraded and now running 5.8.2, Manjaro Gnome. Everything works except I cannot connect to my bluetooth headphones any longer. Had a similar problem with 5.8.1, which made me revert back to linux57. Has anyone fixed this bluetooth issue?