[Testing Update] 2020-05-21 - Kernels, Toolchain, Mesa, KDE Apps, Cinnamon, Browser

Packages (599)
...
Total Download Size: 1464.54 MiB
Total Installed Size: 4960.80 MiB
Net Upgrade Size: 31.49 MiB

"Oh, grandma! What a big update you have!" :girl:
"The better to keep you on the leading edge, my dear." :wolf:

Looks like all went fine here. Yay!

1 Like

Most likely kinfocenter doesn't play well with the new frameworks. However, this is already fixed in upcoming 5.19.0 release of Plasma. Also Arch won't fix it for current 5.18 series.

So I addressed the KDE-Developer from our end to see what is going on. His response:

Needs the debugging for sure. I suspect something regessed in kiconthemes or breeze icons. I'll have a look next week

7 Likes

as always I have to rebuild kernel with new gcc, as vbox compains about some error: incompatible gcc/plugin versions :wink:

edit:
manajro kernels are fine, only mine custom built obviously :stuck_out_tongue:

Can't blame them with 5.19 right around the corner.

1 Like

thanks for the info, is not a big problem, we cam happily survive :wink:

Xfce 4.14 + Nvidia 440xx + VirtualBox + youtube(vp9 1080p ) + Steam(openGl) Ok
remove shadow.pacnew ( it is empty )

Looks good here:
Manjaro awesome, testing, linux56.
Will report if I realize something's not working oc.

It's all Good. used "sudo pacman-mirrors -g && sudo pacman -Syyu" See specs:

bob@Manjaro-Testing~$ inxi-Fxz
[bob@Manjaro-Testing ~]$ inxi -Fxzc0
System:
  Host: Manjaro-Testing Kernel: 5.6.14-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 10.1.0 Desktop: Xfce 4.14.2 Distro: Manjaro Linux 
Machine:
  Type: Desktop System: Hewlett-Packard product: HP Compaq Elite 8300 SFF 
  v: N/A serial: <filter> 
  Mobo: Hewlett-Packard model: 3397 serial: <filter> UEFI: Hewlett-Packard 
  v: K01 v03.08 date: 04/10/2019 
Battery:
  Device-1: hidpp_battery_0 model: Logitech M570 charge: 100% 
  status: Discharging 
CPU:
  Topology: Quad Core model: Intel Core i7-3770 bits: 64 type: MT MCP 
  arch: Ivy Bridge rev: 9 L2 cache: 8192 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 54300 
  Speed: 1597 MHz min/max: 1600/3900 MHz Core speeds (MHz): 1: 1597 2: 1596 
  3: 1597 4: 1597 5: 1597 6: 1596 7: 1597 8: 1596 
Graphics:
  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: Gigabyte 
  driver: nvidia v: 440.82 bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.8 driver: nvidia 
  unloaded: modesetting,nouveau resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82 
  direct render: Yes 
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Device-2: NVIDIA GP107GL High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Sound Server: ALSA v: k5.6.14-1-MANJARO 
Network:
  Device-1: Intel 82579LM Gigabit Network vendor: Hewlett-Packard 
  driver: e1000e v: 3.2.6-k port: f040 bus ID: 00:19.0 
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: e000 
  bus ID: 03:00.0 
  IF: wlp3s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 931.52 GiB used: 27.73 GiB (3.0%) 
  ID-1: /dev/sda vendor: Western Digital model: WDS500G2B0A-00SM50 
  size: 465.76 GiB 
  ID-2: /dev/sdb vendor: Western Digital model: WDS500G2B0A-00SM50 
  size: 465.76 GiB 
Partition:
  ID-1: / size: 227.91 GiB used: 27.70 GiB (12.2%) fs: ext4 dev: /dev/sda5 
Sensors:
  System Temperatures: cpu: 43.0 C mobo: 29.8 C gpu: nvidia temp: 49 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 41% 
Info:
  Processes: 237 Uptime: 8m Memory: 15.58 GiB used: 853.6 MiB (5.3%) 
  Init: systemd Compilers: gcc: 10.1.0 Shell: bash v: 5.0.16 inxi: 3.0.37 

Huge update but everything is working as always. I`m using xfce kernel 5.6.14-1

Hello,

451 packages on my MacbookPro, 464 packages on my MacbookAir, and all is good.

Just a little "xmonad --recompile"

A little problem: the Aur bcwc-pcie-git package don't build on kernet 5.6, but no problem on kernel 5.4 LTS.

Fred

421 packages for me ... what should go wrong :wink: .... famous last words :wink:

EDIT: OK i'm back ... so everything went without issues :).

1 Like

I'm also experiencing the same.
(and I also don't care that much :wink: )

Hi, ms-office-online crashes whenever I click on any icon other than Outlook.
The errors are always referred to url_rules:

js: Uncaught NetworkError: Failed to execute 'send' on 'XMLHttpRequest': Failed to load 'https://browser.pipe.aria.microsoft.com/Collector/3.0/?qsp=true&content-type=application%2Fbond-compact-binary&client-id=NO_AUTH&sdk-version=AWT-Web-JS-1.6.1&x-apikey=<omissis>&client-time-epoch-millis=1590095195955'.
js: Uncaught TypeError: Cannot assign to read only property 'message' of object ''
Traceback (most recent call last):
  File "/usr/lib/python3.8/site-packages/JAK/WebEngine.py", line 118, in acceptNavigationRequest
    if self.config["url_rules"] and self.config['webview']["online"]:
KeyError: 'url_rules'
Aborted (core dumped)

3x xfce with Kernel5.6 fine .. thanks for your work!

:: Synchronisiere Paketdatenbanken...
 core                                                    168,7 KiB  4,84 MiB/s 00:00 [------------------------------------------------] 100%
 extra                                                     2,0 MiB  7,03 MiB/s 00:00 [------------------------------------------------] 100%
 community                                                 5,9 MiB  6,82 MiB/s 00:01 [------------------------------------------------] 100%
 multilib                                                192,9 KiB  6,98 MiB/s 00:00 [------------------------------------------------] 100%
:: Starte vollstƤndige Systemaktualisierung...
:: linux316-headers durch community/linux-lts-headers ersetzen? [J/n] j
:: linux55 durch community/linux-latest ersetzen? [J/n] j
:: linux55-headers durch community/linux-latest-headers ersetzen? [J/n] j
:: linux55-nvidia-440xx durch community/linux-latest-nvidia-440xx ersetzen? [J/n] j
Lƶse AbhƤngigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
Warnung: AbhƤngigkeits-Zyklus entdeckt:
Warnung: harfbuzz wird vor seiner AbhƤngigkeit freetype2 installiert werden
Warnung: AbhƤngigkeits-Zyklus entdeckt:
Warnung: lib32-harfbuzz wird vor seiner AbhƤngigkeit lib32-freetype2 installiert werden
Warnung: AbhƤngigkeits-Zyklus entdeckt:
Warnung: phonon-qt5-gstreamer wird vor seiner AbhƤngigkeit phonon-qt5 installiert werden

(335/422) Aktualisiere snapd                                                         [------------------------------------------------] 100%
Warnung: Verzeichnis-Berechtigungen unterscheiden sich fĆ¼r /etc/sudoers.d/
Dateisystem: 755  Paket: 750
(368/422) Aktualisiere samba                                                         [------------------------------------------------] 100%
Warnung: Verzeichnis-Berechtigungen unterscheiden sich fĆ¼r /etc/sudoers.d/
Dateisystem: 755  Paket: 750

Searching for an already installed AUR package and selecting the AUR tab on the left makes the remove button on the right side for the installed package unclickable in the pamac GUI. This doesn't happen when All or Installed tab is selected on the left side.

Everything else seems to be working fine so far. Thanks for this huge update :smiley:

Solves problem Could not find the program ā€˜konsoleā€™ error after Manjaro update. And everything goes well so far. :smiley:

1 Like

Blockquote

I think that if we are gonna replace a kernel with other because the original is EOL the best option is to replace with LTS I think, don't you think that? The people who " doesn't" mind with newer kernels are the people who usually doesn't need them(LTS more stability for them). IMHO

1 Like

linux55*

I disagree, in this instance especially because you would be downgrading their kernel to an older version. I think keeping them on the latest stable kernel is better in the long term.

That's the reason why I always go for the latest lts when I want a stable system. - My Manjaro cinnamon is on stable branch and with linux54 and linux419.

With Manjaro awesome I'm on testing branch, so I'd like the linux-latest + linux-latest-lts as a backup, if there might occur a bug caused by a kernel-update.

Forum kindly sponsored by