[Testing Update] 2020-03-23 - KDE-Git, Gnome, Python, Haskell

Hello community,

here is another Testing Update for you:


Our team is working hard to get the PinePhone OS working ...

Some feature-updates:

  • KDE-Git package updates
  • Small updates for Gnome 3.36.
  • Haskell and Python updates

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our current 19.0.2 ISOs and give us the needed feedback. You might also want to give our latest spin with NX-Desktop a try ...

As always we appreciate your input and feedback for the updates.


Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux316 3.16.82
  • linux44 4.4.217
  • linux49 4.9.217
  • linux414 4.14.174
  • linux419 4.19.112
  • linux54 5.4.27
  • linux55 5.5.11
  • linux56 5.6-rc6
  • linux419-rt 4.19.106_rt45
  • linux54-rt 5.4.26_rt17

Package Changes (Mon Mar 23 10:18:49 CET 2020)

  • testing community x86_64: 92 new and 94 removed package(s)
  • testing core x86_64: 1 new and 1 removed package(s)
  • testing extra x86_64: 21 new and 21 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-03-22           2020-03-23
-------------------------------------------------------------------------------
                    breeze-icons-git5.69.0.r1522.g214dcc72-15.69.0.r1524.g4959eb87-1
               gnome-terminal-fedora             3.34.2-1           3.36.0.1-1
                         kconfig-git5.69.0.r676.g43d4f12-15.69.0.r677.gec9522a-1
                     kcoreaddons-git5.69.0.r959.gd5a703a-15.69.0.r960.g9348039-1
                  kde-gtk-config-git5.18.80.r820.g73d26ed-15.18.80.r821.gcbf095d-1
                kdeplasma-addons-git5.18.80.r8313.ge85a96ce4-15.18.80.r8314.g8d5e1a0b5-1
                     kinfocenter-git5.18.80.r1657.g2789421-15.18.80.r1658.g1ecc6d8-1
                             kio-git5.69.0.r3836.g161a3aff-15.69.0.r3840.g86832ca0-1
                      knetattach-git5.18.80.r7500.g9f57c39b6-15.18.80.r7502.gfff5c0487-1
                  kwidgetsaddons-git5.69.0.r640.g861242b-15.69.0.r641.g2e9cace-1
                      libkscreen-git5.18.80.r1520.g990a50c-15.18.80.r1521.g2dd7441-1
      plasma-browser-integration-git5.18.80.r1018.gd136f301-15.18.80.r1019.g88e4480b-1
                  plasma-desktop-git5.18.80.r7500.g9f57c39b6-15.18.80.r7502.gfff5c0487-1
                      plasma-sdk-git5.18.80.r2162.g0eaec38-15.18.80.r2163.g60f1a6c-1
          plasma-wayland-session-git5.18.80.r8823.g715be958e-15.18.80.r8824.g86fd0f2f7-1
                plasma-workspace-git5.18.80.r8823.g715be958e-15.18.80.r8824.g86fd0f2f7-1
                              trizen               1.62-1               1.63-1
                   vte3-notification             0.58.2-1             0.60.0-2


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-03-22           2020-03-23
-------------------------------------------------------------------------------
                  aspnet-runtime-2.2       2.2.7.sdk109-1                    -
                      aspnet-runtime       3.1.2.sdk102-1       3.1.3.sdk103-1
                                 bat             0.12.1-1             0.13.0-1
                                byuu                  3-1                  4-1
                              catch2             2.11.1-1             2.11.3-1
                              ccache              3.7.7-1              3.7.8-1
                                cimg              2.8.2-1              2.8.4-1
                         dotnet-host       3.1.2.sdk102-1       3.1.3.sdk103-1
                  dotnet-runtime-2.2       2.2.7.sdk109-1                    -
                      dotnet-runtime       3.1.2.sdk102-1       3.1.3.sdk103-1
                      dotnet-sdk-2.2       2.2.7.sdk109-1                    -
                          dotnet-sdk       3.1.2.sdk102-1       3.1.3.sdk103-1
                         emby-server            4.3.1.0-4           4.4.0.40-1
               fcitx5-chinese-addons     0.0.0.20200321-1     0.0.0.20200323-1
                                  fd              7.4.0-2              7.5.0-1
                             freeciv              2.6.1-1              2.6.2-1
                           git-annex        8.20200309-25        8.20200309-29
                        haskell-dbus            1.2.7-105             1.2.10-1
               haskell-dbus-hslogger           0.1.0.1-12           0.1.0.1-15
                   haskell-esqueleto           3.3.1.1-34              3.3.2-1
                  haskell-fdo-notify            0.3.1-265            0.3.1-268
                haskell-generic-data           0.8.1.0-11           0.8.1.0-12
                       haskell-hasql              1.4.1-9              1.4.2-1
                  haskell-hasql-pool             0.5.1-74             0.5.1-75
           haskell-hasql-transaction            1.0.0.1-4            1.0.0.1-5
                      haskell-hjsmin           0.2.0.4-18           0.2.0.4-19
                    haskell-hopenpgp             2.9.4-43             2.9.4-44
                 haskell-ixset-typed                0.5-2                0.5-3
         haskell-language-javascript            0.7.0.0-2            0.7.1.0-1
                 haskell-megaparsec7              7.0.5-2                    -
                    haskell-safecopy            0.10.2-28            0.10.2-29
             haskell-servant-swagger             1.1.8-12             1.1.8-13
            haskell-show-combinators            0.1.1.0-4            0.2.0.0-1
             haskell-storable-record            0.0.4.1-3              0.0.5-1
              haskell-storable-tuple           0.0.3.3-69           0.0.3.3-70
                    haskell-swagger2               2.4-18                2.5-1
                haskell-yesod-static          1.6.0.1-343          1.6.0.1-344
                         hcxdumptool              6.0.1-1              6.0.2-1
                                helm              0.9.0-7                    -
                               higan                109-2                110-1
                         hledger-web             1.17.1-5             1.17.1-6
                      home-assistant            0.107.1-1            0.107.5-1
                              hoogle         5.0.17.15-17         5.0.17.15-18
                      hopenpgp-tools             0.23.1-3             0.23.1-4
                               idris            1.3.2-104            1.3.2-105
                  libretro-core-info              1.8.4-1              1.8.5-1
                                link              3.0.2-2                    -
                            lollypop             1.2.25-1             1.2.29-1
                              marked              0.8.1-1              0.8.2-1
                          phpmyadmin              5.0.1-1              5.0.2-1
                           postgrest            6.0.2-105            6.0.2-107
                        pulseeffects              4.7.1-2              4.7.2-1
                      python-blessed             1.17.2-1             1.17.3-1
                       python-btrees              4.7.0-1              4.7.1-1
                      python-pip-api             0.0.13-1             0.0.14-1
                       python-pygit2              1.1.1-1              1.1.1-2
                         python-rpy2              3.2.6-2              3.2.7-1
                     python-tabulate              0.8.6-1              0.8.7-1
                        python-txaio             20.1.1-1             20.3.1-1
                    python-xmlschema              1.1.1-1              1.1.2-1
           python-zope-configuration              4.3.1-3              4.4.0-1
                                qtox             1.16.3-7            1.16.3-10
                           retroarch              1.8.4-1              1.8.5-1
                           ruby-yard             0.9.14-3             0.9.24-1
                       supercollider             3.11.0-2             3.11.0-3
                      tamarin-prover            1.4.1-306            1.4.1-307
                             toxcore           1:0.2.10-1           1:0.2.11-1
                 ukui-control-center            1.1.7.1-3              2.0.1-1
                    ukui-screensaver             2.0.10-1             2.0.10-2
                               v2ray             4.22.1-2             4.23.0-1
         v2ray-domain-list-community       202003220637-1       202003221514-1
                       vim-gitgutter        636.ba049e7-1        671.0e509fb-1
                             wiznote              2.8.1-1              2.8.2-1
                              xmobar              0.33-14              0.33-17
                               yaegi              0.7.6-1              0.8.0-1
                      youtube-viewer            1:3.7.4-2            1:3.7.5-1
                         abletonlink                    -              3.0.2-3
                   haskell-optics-th                    -                0.2-1
                          helm-synth                    -              0.9.0-8
                        ukui-sidebar                    -              1.0.2-1


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-03-22           2020-03-23
-------------------------------------------------------------------------------
                      manjaro-system           20191210-4           20200323-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-03-22           2020-03-23
-------------------------------------------------------------------------------
                           asymptote               2.61-1               2.64-1
                              bcprov               1.61-1               1.64-1
                            cbindgen             0.13.1-1             0.13.2-1
                               gedit             3.36.0-1             3.36.1-1
                       gedit-plugins             3.36.1-1             3.36.2-1
                              glibmm             2.64.1-1             2.64.2-1
                         glibmm-docs             2.64.1-1             2.64.2-1
                              gmime3              3.2.6-1              3.2.7-1
                  gnome-disk-utility             3.36.0-1             3.36.1-1
                         imagemagick           7.0.10.1-1           7.0.10.2-2
                     imagemagick-doc           7.0.10.1-1           7.0.10.2-2
          kdsoap-ws-discovery-client        git20200316-1        git20200316-2
                           libbluray              1.1.2-1              1.2.0-1
                          libmagick6           6.9.11.0-1           6.9.11.2-1
                           memcached             1.5.19-1             1.5.20-1
                        ocaml-ctypes             0.16.0-2             0.17.1-1
                        ocaml-result                1.4-3                1.5-1
                             pangomm             2.42.1-1             2.42.1-2
                        pangomm-docs             2.42.1-1             2.42.1-2
              perl-ipc-system-simple               1.27-1               1.28-1
                       python2-isort              4.3.6-1              4.3.7-1

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

9 Likes

Known issues and solutions

HP Device Manager

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Older issues

Pamac stuck at "Preparing..."

Users have reported issues with the recent release candidate of Pamac 9.4.0 when initiating transactions, being stuck at "Preparing..." without being able to cancel the transaction and quit Pamac normally.

For now, it is recommended to use pacman to do package management until this issue is solved and Pamac become usable again. Please test out upcoming updates for Pamac to see if the issue becomes solved or not.

If you are stuck in "Preparing...", you will have to manually kill the pamac-managerprocess.

Reported on Gitlab:
https://gitlab.manjaro.org/applications/pamac/issues/757

Upgrading firewalld package to 0.8.1-2 requires manual intervention

Please read this announcement if you have file conflicts when trying to upgrade firewalld package to 0.8.1-2.

Firewalld requires manual intervention

khotkeys identified as an orphaned package

You can remove that package, but might loose some functionality with your key-bindings. We made it now optional to be installed.


Weird font glitches (see screenshots below).

If you have weird glitches like below...

Screenshots


string3
strings%20mismatch

... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.


Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in

/usr/lib/python3.7/site-packages/

To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.


System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.


xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.


Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.


Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


gnome-shell-extension-desktop-icons

the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

Could you expand on this? Does that mean I should not upgrade if I want to continue using Gnome on Wayland? Why is this being done?

1 Like

I hope this will not land into stable. In our household we try to get rid off as much Xorg stuff as possible.

1 Like

There are lot of issues with extensions like Dash-To-Dock, which is broken in Wayland. Also other extensions do funky things. Therefore we decided to use only Xorg for now. For sure you can revert that config setting, but then you have to life with the current broken extensions:

1 Like

I guess it's a typo, innit?
But I've learnt a new German word today, thanks! :slight_smile:

1 Like

@jgierer12. @freed00m. Assuming you are running Gnome. You can manually re-enable Wayland by editing

/etc/gdm3/custom.conf

Comment out the line below so it looks like the following.

#WaylandEnable=false

Save and reboot or log out.

Personally I am of the opinion that Wayland is still not ready for general usage.

1 Like

Disabling Wayland is a drastic measure. For example, I actively try to use Wayland for everything, and disabling Wayland would break my setup. I think it's okay to ask the users to disable Wayland as a workaround for some issues they might encounter, but it should be their decision to make (because I'd rather live with some temporary inconveniences than disable Wayland).

1 Like

@Ste74 is currently checking again what to do. He recommended to disable Wayland. Also @Chrysostomus is looking into the matter.

We are looking into a solution which would mitigate the wayland bug enough that we didn't need to disable it for the stable update.

1 Like

Try the new solution manjaro-system pkgrel 2 should work as expected

pkgrel 3 pushed to unstable and testing. Please test if you find issues with it. If none are found we can make a stable snap tomorrow.

Expected behavior:

  • Wayland works
  • Dash to dock should work normally

Is it logical to push a broken package (hplip) on stable-staging update?

Do Manjaro wants to say to HP printers users: "We don't care about you? We don't need you?"

I will be seen as a very bad move.

Currently the hplip package in Stable is broken. This new revision fixes that.

2 Likes

Hmm, I've been using dash to dock on Gnome 3.36 and Wayland without issues since the release of 3.36, and all of my other extensions work fine as well. But I'm okay with disabling Wayland by default as long as I can still manually enable it.

dashtodock and dashtopanel not working properly after latest manjaro-gnome-assets,clicking on application menu causes interface to go black

It didn't install some necessary packages for gesture of Gnome Layout Switcher.

Is it intentional that at least some packages skipped testing?
For example, teamspeak 3.5.1 is available in unstable and stable, but not in testing.
Same is true for Kernel 5.6 rc7
Data according to repo-compare core and repo-compare community

1 Like

Testing branch is kind of a testbed. Stable gets currently updated from Stable-Staging which gets a Sync from Arch Stable like Unstable does. So there is some delay for Testing when it gets a new update. Our focus is on Unstable and Stable when Bugs get reported.

I really don't understand that move then. If I understand it correctly, testing is mostly obsolete now and replaced by stable-staging if I want to get updates earlier than stable, but not as fast as unstable, or am I seeing that wrong?

1 Like

Forum kindly sponsored by