[Testing Update] 2020-02-27 - LibGLVND, Latte-Dock, UKUI, Python, Haskell

Hello community,

here is another Testing Update.


UKUI is a lightweight desktop environment based on pluggable framework for Linux and other Unix-like Distributions.

Some feature-updates:

  • libglvnd got updated to 1.3.1
  • latte-dock is now at 0.9.9
  • More work went into UKUI
  • A lot of python and haskell updates

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our current 19.0 ISOs and give us the needed feedback. You might also want to give our latest spin with NX-Desktop a try ...

As always we appreciate your input and feedback for the updates.


Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

wget https://pkgbuild.com/~eschwartz/repo/x86_64-extracted/pacman-static
chmod +x pacman-static
sudo ./pacman-static -Syyu

Our current supported kernels

  • linux316 3.16.82
  • linux44 4.4.214
  • linux49 4.9.214
  • linux414 4.14.171
  • linux419 4.19.106
  • linux54 5.4.22
  • linux55 5.5.6
  • linux56 5.6-rc3
  • linux419-rt 4.19.103_rt42
  • linux54-rt 5.4.19_rt11

Package Changes (Thu Feb 27 08:47:02 CET 2020)

  • testing core x86_64: 2 new and 2 removed package(s)
  • testing multilib x86_64: 2 new and 2 removed package(s)
  • testing extra x86_64: 7 new and 6 removed package(s)
  • testing community x86_64: 540 new and 542 removed package(s)

A detailed list of all package changes can be reviewed here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

9 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


khotkeys identified as an orphaned package

You can remove that package, but might loose some functionality with your key-bindings. We made it now optional to be installed.


Optical Disc Drives not recognised with Kernel 5.6rc3

use any older kernel branch for now, reported here by @theboomboomcars


Older issues

Weird font glitches (see screenshots below).

If you have weird glitches like below...

Screenshots


string3
strings%20mismatch

... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.


Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in

/usr/lib/python3.7/site-packages/

To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.


System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.


xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.


Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.


Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


gnome-shell-extension-desktop-icons

the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

Installed today's updates on both my roommates and my computer. Both are set to create auto-snapshots. Today on mine which I did first it took forever to attempt to create the snapshot only to error out and not create it. On my roommates it took the normal amount of time to attempt to create the snapshot but still did not create one. The updates themselves did install fine on both systems, and I'm not seeing any issues on either system even after doing restarts on both. Rather than having to possibly spend a lot of time to try to figure out what caused the issue I've just deleted all snapshots on both systems and created a new one on each system.

No noticeable issues here, wireless still working fine after wpa-supplicant update on my laptop.

UKUI screenshot picture in the first post isn't loading on the forum but does if I right click to open the url in a new tab. maybe a discourse issue?

You are probably right about it being a Discourse problem, cause when I view the thread in FreshRSS the image is fine where in the browser it's broken. Also I noticed images in a thread I was helping in earlier redrawing themselves.

It was a link to the Chinese server. I've now uploaded it to our forum.

2 Likes

[SOLVED]I cannot update .. the terminal shows a "nule error or wrong argument" message when updating.. I already checked Mirror service and also updates my mirror list (pacman --fasttrack 5 && pacman -Syyu) rebooted and still have the same problem..
And using Octopi app it gets weirder, showing 0000 bytes to update

Summary

[manjaro@manjaro-pc ~]$ sudo /usr/lib/octopi/octphelper -ts
[sudo] password for manjaro:
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade...
warning: mpv: ignoring package upgrade (1:0.31.0-2 => 1:0.32.0-1)
resolving dependencies...
looking for conflicting packages...

Packages (11) electron-8.0.2-1 latte-dock-0.9.9-1 lib32-libglvnd-1.3.1-1 libglvnd-1.3.1-1 libsoup-2.68.4-1 libxcb-1.14-1
man-db-2.9.1-1 npm-6.14.0-1 playerctl-2.1.1-1 wpa_supplicant-2:2.9-7 xcb-proto-1.14-1

Total Installed Size: 211,32 MiB
Net Upgrade Size: -0,30 MiB

:: Proceed with installation? [Y/n] Y
( 0/11) checking keys in keyring [----------( 1/11) checking keys in keyring [####------( 2/11) checking keys in keyring [########--( 3/11) checking keys in keyring [##########( 4/11) checking keys in keyring [##########( 5/11) checking keys in keyring [##########( 6/11) checking keys in keyring [##########( 7/11) checking keys in keyring [##########( 8/11) checking keys in keyring [##########( 9/11) checking keys in keyring [##########(10/11) checking keys in keyring [##########(11/11) checking keys in keyring [#############################################] 100%
( 0/11) checking package integrity [----------( 1/11) checking package integrity [----------( 2/11) checking package integrity [----------( 3/11) checking package integrity [----------( 4/11) checking package integrity [#---------( 5/11) checking package integrity [##########( 6/11) checking package integrity [##########( 7/11) checking package integrity [##########( 8/11) checking package integrity [##########( 9/11) checking package integrity [##########(10/11) checking package integrity [##########(11/11) checking package integrity [#############################################] 100%
error: failed to commit transaction (wrong or NULL argument passed)
Errors occurred, no packages were upgraded.
Press any key to continue...
[manjaro@manjaro-pc ~]$

[SOLVED] it must have been a slow ftp server timing out--- so could not download the package fully (wpa_supplicant according to command line ls /var/cache/pacman/pkg/*.part ). Then I used sudo pacman -Sc to remove restant part of the latest package update and finally I could update successfully

Is there a UKUI based Manjaro release in development?

Today a Topgrade update was pushed and Timeshift at the end of creating a auto-snapshot gave me the below errors. I was hoping since I removed all snapshots and created a fresh one that would resolve the issue, but that does not seem to be the case.

(process:166364): GLib-GObject-WARNING **: 09:03:23.003: instance with invalid (NULL) class pointer

(process:166364): GLib-GObject-CRITICAL **: 09:03:23.004: g_signal_handlers_destroy: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(process:166364): GLib-GObject-CRITICAL **: 09:03:23.004: g_object_unref: assertion 'old_ref > 0' failed
E: Error opening file “/mnt/timeshift/backup/timeshift/snapshots/2020-02-29_08-56-36/rsync-log-changes”: File exists
Error while configuring 
E: Failed to write file: /mnt/timeshift/backup/timeshift/snapshots/2020-02-29_08-56-36/rsync-log-changes
280.31% complete (00:00:00 remaining)
                                                                                
Created control file: /mnt/timeshift/backup/timeshift/snapshots/2020-02-29_08-56-36/info.json
RSYNC Snapshot saved successfully (409s)
Tagged snapshot '2020-02-29_08-56-36': ondemand
------------------------------------------------------------------------------
Upgrading topgrade (4.0.2-1 -> 4.1.0-1)...
Transaction successfully finished.

What does Topgrade have to do with Timeshift? I have both installed and have had no issues with my Timeshift backups.

I said a Topgrade update was pushed today and after the following was preformed Timeshift proceeded to create a auto-snapshot before installing Topgrade. Timeshift was preforming perfectly without any warnings prior to the updates from the 27th hence my first post in this thread.

Preparing...
Cloning topgrade build files...
Checking topgrade dependencies...
Synchronizing package databases...
Refreshing herecura.db...
Resolving dependencies...
Checking inter-conflicts...

Building topgrade...
==> Making package: topgrade 4.1.0-1 (Sat 29 Feb 2020 08:53:02 AM PST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading topgrade-4.1.0.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100   126  100   126    0     0    520      0 --:--:-- --:--:-- --:--:--   520

100  762k    0  762k    0     0   939k      0 --:--:-- --:--:-- --:--:--  939k
==> Validating source files with sha256sums...
    topgrade-4.1.0.tar.gz ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting topgrade-4.1.0.tar.gz with bsdtar
==> Starting build()...
   Compiling libc v0.2.66
   Compiling proc-macro2 v1.0.8
   Compiling unicode-xid v0.2.0
   Compiling syn v1.0.14
   Compiling cfg-if v0.1.10
   Compiling rustversion v1.0.2
   Compiling autocfg v1.0.0
   Compiling memchr v2.3.0
   Compiling lazy_static v1.4.0
   Compiling getrandom v0.1.14
   Compiling cc v1.0.50
   Compiling serde v1.0.104
   Compiling bitflags v1.2.1
   Compiling unicode-segmentation v1.6.0
   Compiling regex-syntax v0.6.14
   Compiling ppv-lite86 v0.2.6
   Compiling unicode-width v0.1.7
   Compiling log v0.4.8
   Compiling quick-error v1.2.3
   Compiling rustc-demangle v0.1.16
   Compiling anyhow v1.0.26
   Compiling termcolor v1.1.0
   Compiling nix v0.17.0
   Compiling strsim v0.8.0
   Compiling ansi_term v0.11.0
   Compiling vec_map v0.8.1
   Compiling same-file v1.0.6
   Compiling topgrade v4.1.0 (/var/tmp/pamac-build-gravedigger/topgrade/src/topgrade-4.1.0)
   Compiling remove_dir_all v0.5.2
   Compiling void v1.0.2
   Compiling glob v0.3.0
   Compiling thread_local v1.0.1
   Compiling heck v0.3.1
   Compiling textwrap v0.11.0
   Compiling num-traits v0.2.11
   Compiling num-integer v0.1.42
   Compiling humantime v1.3.0
   Compiling c2-chacha v0.2.3
   Compiling walkdir v2.3.1
   Compiling aho-corasick v0.7.8
   Compiling quote v1.0.2
   Compiling atty v0.2.14
   Compiling dirs-sys v0.3.4
   Compiling termios v0.3.1
   Compiling clicolors-control v1.0.1
   Compiling time v0.1.42
   Compiling backtrace-sys v0.1.32
   Compiling regex v1.3.4
   Compiling clap v2.33.0
   Compiling rand_core v0.5.1
   Compiling dirs v2.0.2
   Compiling directories v2.0.2
   Compiling chrono v0.4.10
   Compiling env_logger v0.7.1
   Compiling console v0.9.2
   Compiling rand_chacha v0.2.1
   Compiling shellexpand v1.1.1
   Compiling syn-mid v0.5.0
   Compiling pretty_env_logger v0.4.0
   Compiling rand v0.7.3
   Compiling backtrace v0.3.43
   Compiling failure v0.1.6
   Compiling tempfile v3.1.0
   Compiling which v3.1.0
   Compiling serde_derive v1.0.104
   Compiling strum_macros v0.17.1
   Compiling thiserror-impl v1.0.10
   Compiling proc-macro-error v0.4.8
   Compiling proc-macro-error-attr v0.4.8
   Compiling thiserror v1.0.10
   Compiling strum v0.17.1
   Compiling structopt-derive v0.4.2
   Compiling structopt v0.3.9
   Compiling multimap v0.8.0
   Compiling toml v0.5.6
   Compiling rust-ini v0.14.0
    Finished release [optimized] target(s) in 3m 21s
==> Entering fakeroot environment...
==> Starting package()...
==> Tidying install...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Stripping unneeded symbols from binaries and libraries...
  -> Compressing man and info pages...
==> Checking for packaging issues...
==> Creating package "topgrade"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: topgrade 4.1.0-1 (Sat 29 Feb 2020 08:56:31 AM PST)
==> Cleaning up...

Refreshing herecura.db...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...

/dev/sdc1 is mounted at: /mnt/timeshift/backup, options: rw,relatime,space_cache,subvolid=5,subvol=/

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by