[Testing Update] 2020-02-05 - Kernels, Calamares, LibreOffice, Nvidia, KDE-Git

Hello community,

here is another Testing Update.


FOSDEM was a blast. You may check-out Twitter to get a grasp out of it.

Some feature-updates:

  • Most of the Kernels got updated
  • LibreOffice is now at 6.4
  • Palemoon browser got a minor fix to display youtube correctly.
  • Mesa got updated to 19.3.3
  • Nvidia driver got renewed to 440.59
  • The usual upstream fixes

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our current 19.0-pre4 ISOs and give us the needed feedback. You might also want to give our latest spin with NX-Desktop a try ...

As always we appreciate your input and feedback for the updates.


Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

wget https://pkgbuild.com/~eschwartz/repo/x86_64-extracted/pacman-static
chmod +x pacman-static
sudo ./pacman-static -Syyu

Our current supported kernels

  • linux316 3.16.81
  • linux44 4.4.212
  • linux49 4.9.212
  • linux414 4.14.169
  • linux419 4.19.101
  • linux53 5.3.18 [EOL]
  • linux54 5.4.17
  • linux55 5.5.2
  • linux419-rt 4.19.94_rt39
  • linux54-rt 5.4.10_rt5

Package Changes (Wed Feb 5 08:04:31 CET 2020)

  • testing community x86_64: 548 new and 529 removed package(s)
  • testing core x86_64: 24 new and 24 removed package(s)
  • testing extra x86_64: 380 new and 378 removed package(s)
  • testing multilib x86_64: 15 new and 16 removed package(s)

A detailed package list of all changes made to this update-set may be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

10 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Older issues

Weird font glitches (see screenshots below).

If you have weird glitches like below...

Screenshots


string3
strings%20mismatch

... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.


Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in

/usr/lib/python3.7/site-packages/

To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.


System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.


xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.


Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.


Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


gnome-shell-extension-desktop-icons

the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

Obtained through the Unstable branch today. No issues to report yet, and, I hope, it will stay that way.
BTW the update of utils-linux has fixed the problem with user-mountable NFS shares, it was an upstream bug after all.

nice, some python updates in those packages. now the only thing keeping python2 on my system is gimp.

Update went great, no issues here that I can see after the update and a reboot. Since python is be or is depreciated any way of seeing which programs I have are still using python?

pactree -r python2

Check in /usr/lib/python2.7/site-packages/ as well.

1 Like

Oh nice. I'm looking forward to that.

Big update but all seems fine with Kernel 5.5.2 so far.
Thank you.

Actually, gst-plugins-bad has a dependency on something that depends on python2.

pacman -Qi python2
Look at "Required by" section.

Looks like still:

i-nex
java8-open.jfx
libkate
tautulli
torrent-search

pactree -r python2
python2
├─i-nex
├─java8-openjfx
├─libkate
│ └─libtiger
│   └─gst-plugins-bad
├─python2-appdirs
│ └─python2-setuptools
│   └─tautulli
├─python2-cairo
│ ├─pygtk
│ │ ├─gimp
│ │ └─torrent-search
│ └─terminator
├─python2-dbus
│ ├─terminator
│ └─torrent-search
├─python2-gobject
│ └─terminator
├─python2-gobject2
│ └─pygtk
├─python2-httplib2
│ └─torrent-search
├─python2-ordered-set
│ └─python2-setuptools
├─python2-psutil
│ └─terminator
├─python2-pyparsing
│ └─python2-packaging
│   └─python2-setuptools
├─python2-pytz
│ └─tautulli
├─python2-six
│ └─python2-packaging
├─python2-twodict-git
│ └─youtube-dl-gui-git
├─python2-wxpython3
│ ├─playonlinux
│ └─youtube-dl-gui-git
├─tautulli
└─torrent-search

uh, no, no "actually". that may still require it on YOUR system, but i stated the only relevant package on MY system.

1 Like

clean installed KDE Dev , from Februar 05 ,, but Not have sound on Nvidia 440 HDMi ! ! ( GP104 )

Why ?

Everything's working perfectly.
No problems with this update under KDE.

Do you mean pactree -r python2? Otherwise you only get the packages python2 is depending on.

4 Likes

You can simply also use dependency-checker from pamac-common package to have a list what needs what.

3 Likes

Thank you! But I think I prefer pactree because of just the tree-structure.

All good with KDE, apart still random disconnection or speed connections issues with Network-Manager. The last version working for me without issues is 1-22-2.1

Yep, good catch. I edited my post.

On HP Spectre x360 aw00013dx I still get this with the 5.5 kernel:

[ 4.893773] sof-audio-pci 0000:00:1f.3: Direct firmware load for intel/sof/sof-icl.ri failed with error -2
[ 4.893775] sof-audio-pci 0000:00:1f.3: error: request firmware intel/sof/sof-icl.ri failed err: -2
[ 4.893776] sof-audio-pci 0000:00:1f.3: error: failed to load DSP firmware -2
[ 4.893776] sof-audio-pci 0000:00:1f.3: error: sof_probe_work failed err: -2

:frowning:

Forum kindly sponsored by