[Testing Update] 2020-01-25 - RT-Kernel, AMDVLK 2020.Q1.1, Manjaro Browser Settings

Hello community,

here is another Testing Update ...


Our Manjaro Laptop in cooperation with TUXEDO Computers will be available in Mid-February. Stay tuned for more information on additional goodies we have at launch ...

Some feature-updates:

  • RT-Kernel got updated
  • AMDVLK is now at 2020.Q1.1
  • manjaro-browser-settings should now respect changes made by the user
  • The usual upstream fixes

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our current 18.1.5 ISOs and give us the needed feedback. You might also want to give our latest spin with NX-Desktop a try ...

As always we appreciate your input and feedback for the updates.


Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

wget https://pkgbuild.com/~eschwartz/repo/x86_64-extracted/pacman-static
chmod +x pacman-static
sudo ./pacman-static -Syyu

Our current supported kernels

  • linux316 3.16.81
  • linux44 4.4.211
  • linux49 4.9.211
  • linux414 4.14.167
  • linux419 4.19.98
  • linux53 5.3.18 [EOL]
  • linux54 5.4.14
  • linux55 5.5-rc7
  • linux419-rt 4.19.94_rt39
  • linux54-rt 5.4.10_rt5

Package Changes (Sat Jan 25 08:37:23 CET 2020)

  • testing community x86_64: 135 new and 135 removed package(s)
  • testing core x86_64: 4 new and 6 removed package(s)
  • testing extra x86_64: 3 new and 3 removed package(s)
  • testing multilib x86_64: 3 new and 3 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-01-24           2020-01-25
-------------------------------------------------------------------------------
                          brave-beta             1.3.97-1            1.3.100-1
                         linux419-rt       4.19.94_rt38-2       4.19.94_rt39-1
               linux419-rt-acpi_call             1.1.0-12             1.1.0-13
                linux419-rt-bbswitch               0.8-12               0.8-13
             linux419-rt-broadcom-wl      6.30.223.271-12      6.30.223.271-13
                 linux419-rt-headers       4.19.94_rt38-2       4.19.94_rt39-1
            linux419-rt-nvidia-340xx            340.108-2            340.108-3
            linux419-rt-nvidia-390xx            390.132-4            390.132-5
            linux419-rt-nvidia-418xx            418.113-3            418.113-4
            linux419-rt-nvidia-430xx             430.64-3             430.64-4
            linux419-rt-nvidia-435xx             435.21-7             435.21-8
            linux419-rt-nvidia-440xx             440.44-3             440.44-4
                linux419-rt-nvidiabl              0.88-12              0.88-13
                   linux419-rt-r8168           8.048.00-1           8.048.00-2
               linux419-rt-rtl8723bu   4.3.9.3.13200.0-59   4.3.9.3.13200.0-60
                linux419-rt-tp_smapi               0.43-8               0.43-9
             linux419-rt-vhba-module           20200106-1           20200106-2
linux419-rt-virtualbox-guest-modules              6.1.2-1              6.1.2-2
 linux419-rt-virtualbox-host-modules              6.1.2-1              6.1.2-2
            manjaro-browser-settings           20181222-1           20200124-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-01-24           2020-01-25
-------------------------------------------------------------------------------
                         assaultcube            1.2.0.2-4            1.2.0.2-5
                         astromenace              1.4.1-1              1.4.1-2
                                 bam              0.5.1-1              0.5.1-2
                                bass               1.2-12               1.2-13
                                bolt                0.8-2                0.8-3
                      docker-compose             1.25.2-1             1.25.3-1
                       dwarffortress            0.44.12-1            0.44.12-2
           firefox-developer-edition             73.0b8-1             73.0b9-1
  firefox-developer-edition-i18n-ach             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-af             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-an             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-ar             73.0b8-1             73.0b9-1
  firefox-developer-edition-i18n-ast             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-az             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-be             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-bg             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-bn             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-br             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-bs             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-ca             73.0b8-1             73.0b9-1
  firefox-developer-edition-i18n-cak             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-cs             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-cy             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-da             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-de             73.0b8-1             73.0b9-1
  firefox-developer-edition-i18n-dsb             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-el             73.0b8-1             73.0b9-1
firefox-developer-edition-i18n-en-ca             73.0b8-1             73.0b9-1
firefox-developer-edition-i18n-en-gb             73.0b8-1             73.0b9-1
firefox-developer-edition-i18n-en-us             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-eo             73.0b8-1             73.0b9-1
firefox-developer-edition-i18n-es-ar             73.0b8-1             73.0b9-1
firefox-developer-edition-i18n-es-cl             73.0b8-1             73.0b9-1
firefox-developer-edition-i18n-es-es             73.0b8-1             73.0b9-1
firefox-developer-edition-i18n-es-mx             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-et             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-eu             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-fa             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-ff             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-fi             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-fr             73.0b8-1             73.0b9-1
firefox-developer-edition-i18n-fy-nl             73.0b8-1             73.0b9-1
firefox-developer-edition-i18n-ga-ie             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-gd             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-gl             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-gn             73.0b8-1             73.0b9-1
firefox-developer-edition-i18n-gu-in             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-he             73.0b8-1             73.0b9-1
firefox-developer-edition-i18n-hi-in             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-hr             73.0b8-1             73.0b9-1
  firefox-developer-edition-i18n-hsb             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-hu             73.0b8-1             73.0b9-1
firefox-developer-edition-i18n-hy-am             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-ia             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-id             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-is             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-it             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-ja             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-ka             73.0b8-1             73.0b9-1
  firefox-developer-edition-i18n-kab             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-kk             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-km             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-kn             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-ko             73.0b8-1             73.0b9-1
  firefox-developer-edition-i18n-lij             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-lt             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-lv             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-mk             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-mr             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-ms             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-my             73.0b8-1             73.0b9-1
firefox-developer-edition-i18n-nb-no             73.0b8-1             73.0b9-1
firefox-developer-edition-i18n-ne-np             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-nl             73.0b8-1             73.0b9-1
firefox-developer-edition-i18n-nn-no             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-oc             73.0b8-1             73.0b9-1
firefox-developer-edition-i18n-pa-in             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-pl             73.0b8-1             73.0b9-1
firefox-developer-edition-i18n-pt-br             73.0b8-1             73.0b9-1
firefox-developer-edition-i18n-pt-pt             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-rm             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-ro             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-ru             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-si             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-sk             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-sl             73.0b8-1             73.0b9-1
  firefox-developer-edition-i18n-son             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-sq             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-sr             73.0b8-1             73.0b9-1
firefox-developer-edition-i18n-sv-se             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-ta             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-te             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-th             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-tr             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-uk             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-ur             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-uz             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-vi             73.0b8-1             73.0b9-1
   firefox-developer-edition-i18n-xh             73.0b8-1             73.0b9-1
firefox-developer-edition-i18n-zh-cn             73.0b8-1             73.0b9-1
firefox-developer-edition-i18n-zh-tw             73.0b8-1             73.0b9-1
                                hugo             0.63.0-1             0.63.1-1
                          jupyterlab              1.2.5-1              1.2.6-1
                            minetest              5.1.0-2              5.1.1-1
                     minetest-common              5.1.0-2              5.1.1-1
                     minetest-server              5.1.0-2              5.1.1-1
                                 ois                1.5-1                1.5-2
                     python-sphinx-1              1.8.5-3              1.8.5-4
                      python2-sphinx              1.8.5-3              1.8.5-4
                           sleuthkit              4.7.0-1              4.8.0-1
                               tiled              1.3.2-1              1.3.2-2
                           widelands                 20-5                 20-6
                          youtube-dl         2020.01.15-1         2020.01.24-1
                           zeroc-ice              3.7.3-1              3.7.3-2
                      zeroc-ice-java              3.7.3-1              3.7.3-2


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-01-24           2020-01-25
-------------------------------------------------------------------------------
                                dbus            1.12.16-4                    -
                           dbus-docs            1.12.16-4                    -


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-01-24           2020-01-25
-------------------------------------------------------------------------------
             ca-certificates-mozilla             3.49.1-2             3.49.2-1
                                dbus            1.12.16-3            1.12.16-5
                           dbus-docs            1.12.16-3            1.12.16-5
                                 nss             3.49.1-2             3.49.2-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-01-24           2020-01-25
-------------------------------------------------------------------------------
                              amdvlk          2019.Q4.5-1          2020.Q1.1-1
                     gst-plugins-bad             1.16.2-1             1.16.2-2
                    gst-plugins-good             1.16.2-1             1.16.2-2


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-01-24           2020-01-25
-------------------------------------------------------------------------------
                        lib32-amdvlk          2019.Q4.5-1          2020.Q1.1-1
                          lib32-dbus            1.12.16-1            1.12.16-2
                           lib32-nss             3.49.1-2             3.49.2-1
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

8 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Weird font glitches (see screenshots below).

If you have weird glitches like below...

Screenshots


string3
strings%20mismatch

... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.


Older issues

Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in

/usr/lib/python3.7/site-packages/

To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.


System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.


xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.


Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.


Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


gnome-shell-extension-desktop-icons

the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

All well for me: linux54+xfs+zfs+nvidia+xfce
Thank you!

Seems fine here too. FF is still opening on the Default new tab I specified on my machines and not the manjaro home page. I may complain to Mozilla though about the new build spam they've introduced. Each update to the browser recently a new tab opens with what's new highlights or recommendations now to use Pocket. I have disabled such crud from the new tab so they should also honour that for browser updates.

Nice system packaging design!

1 Like

Works for me: XFCE pre3 (unstable) Cinnamon (unstable) VMWARE Instances;
XFCE: all good no Kernel Build errors or other issues
Cinnamon: all good no Kernel Build errors or other issues

Got offeded the updates this morning and manjaro-browser-settings 20200124-1 after downloading just sat there doing nothing. After 10 minutes of it sitting there not doing anything I canceled the updates. I then proceeded to do the updates individually and got waiting for another package manager to exit. I simply restarted and did each update individually with manjaro-browser-settings being last. When I attempt to install it I get.

Preparing...
Synchronizing package databases...
Resolving dependencies...
Checking inter-conflicts...
Running post-transaction hooks...
Checking keyring...
Checking integrity...
Failed to commit transaction:
wrong or NULL argument passed

Nee help fixing it.

Which package manager was used? Pamac? If so, some is odd. Open a terminal and issue a sudo pacman -Syyu and see if that works. As an alternative you can do pamac upgrade in a terminal. The GTK-UI sometimes hangs for some reason. Also happend on my end sometimes ... @guinux: some ideas?

1 Like

That's not spam. The pocket information is a bit annoying, but still not spam.

I'll attempt the update via Konsole. As for the message about the package manager that'a normal when the manager failed to finish a update. I've had it in other distros, and I've seen plenty of post about it in other forums. It in itself is not really a issue, entering a command in Konsole or a simple reboot addresses the problem.

[agentx@Secret-Computer ~]$ sudo pacman -Syyu
[sudo] password for agentx: 
:: Synchronizing package databases...
 core                  167.9 KiB  1569 KiB/s 00:00 100%
 extra                1970.7 KiB  17.0 MiB/s 00:00 100%
 community               5.8 MiB  52.3 MiB/s 00:00 100%
 multilib              192.5 KiB  62.7 MiB/s 00:00 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (1) manjaro-browser-settings-20200124-1

Total Installed Size:   0.09 MiB
Net Upgrade Size:      -0.09 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                     100%
(1/1) checking package integrity                   100%
error: failed to commit transaction (wrong or NULL argument passed)
Errors occurred, no packages were upgraded.
[agentx@Secret-Computer ~]$

It's all good, Running Xfce Pre 3 Testing, see specs:

bob@Manjaro-Testing~$ inxi-Fxzc0
[bob@Manjaro ~]$ inxi -Fxzc0
System:
  Host: Manjaro Kernel: 5.5.0-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.2.0 Desktop: Xfce 4.14.2 Distro: Manjaro Linux 
Machine:
  Type: Desktop System: Hewlett-Packard product: HP Compaq Elite 8300 SFF 
  v: N/A serial: <filter> 
  Mobo: Hewlett-Packard model: 3397 serial: <filter> UEFI: Hewlett-Packard 
  v: K01 v02.99 date: 09/15/2015 
Battery:
  Device-1: hidpp_battery_0 model: Logitech M570 charge: 80% 
  status: Discharging 
CPU:
  Topology: Quad Core model: Intel Core i5-3470 bits: 64 type: MCP 
  arch: Ivy Bridge rev: 9 L2 cache: 6144 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 25554 
  Speed: 1596 MHz min/max: 1600/3600 MHz Core speeds (MHz): 1: 1596 2: 1597 
  3: 1597 4: 1597 
Graphics:
  Device-1: NVIDIA GK208 [GeForce GT 720] vendor: Micro-Star MSI 
  driver: nvidia v: 435.21 bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.7 driver: nvidia 
  unloaded: modesetting,nouveau resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GT 720/PCIe/SSE2 v: 4.6.0 NVIDIA 435.21 
  direct render: Yes 
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Device-2: NVIDIA GK208 HDMI/DP Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Sound Server: ALSA v: k5.5.0-1-MANJARO 
Network:
  Device-1: Intel 82579LM Gigabit Network vendor: Hewlett-Packard 
  driver: e1000e v: 3.2.6-k port: f040 bus ID: 00:19.0 
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: e000 
  bus ID: 03:00.0 
  IF: wlp3s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 2.73 TiB used: 25.58 GiB (0.9%) 
  ID-1: /dev/sda vendor: HGST (Hitachi) model: HUS724020ALE641 
  size: 1.82 TiB 
  ID-2: /dev/sdb vendor: Western Digital model: WD10EZEX-08M2NA0 
  size: 931.51 GiB 
Partition:
  ID-1: / size: 888.27 GiB used: 25.56 GiB (2.9%) fs: ext4 dev: /dev/sda5 
Sensors:
  System Temperatures: cpu: 35.0 C mobo: 29.8 C gpu: nvidia temp: 53 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 28% 
Info:
  Processes: 200 Uptime: 14m Memory: 7.72 GiB used: 853.8 MiB (10.8%) 
  Init: systemd Compilers: gcc: 9.2.0 Shell: bash v: 5.0.11 inxi: 3.0.37

Got it.

Upgrading manjaro-browser-settings (20181222-1 -> 20200124-1)...
Transaction successfully finished.

Needed to delete manjaro-browser-settings from /var/cache/pacman/pkg/. Looks like it only partially downloaded and Pamac kept trying to build and install from it instead of redownloading and replacing the bad version. Now quick question do i need all that in /var/cache/pacman/pkg/ after updates? seems to be multiple versions of items. Here's the page I got the fix from, It's at the bottom of the first post.

https://bbs.archlinux.org/viewtopic.php?id=133791

Might wanna keep some versions to attempt package downgrades in case of problems. For housekeeping see
https://wiki.archlinux.org/index.php/pacman#Cleaning_the_package_cache

1 Like

Hopefully not crazy overpriced like their other offerings :sweat_smile:

1 Like

@philm

GRUB LOCALE = broken as usual
No one there to repair?!
Und sonst:
It's all good, running GNOME...

it's unsolicited, therefore it is spam

It's not advertising, THEREFORE it is NOT spam.

Could you please update to newerst youtube-dl also on stable?
Because the old version is broken and with that useles, it doesn't work with many videos anymore.

yes it is, they are advertising a service whether you like to perceive it that way or not. I have no interest in Firefox Sync, Pocket, giving Mozilla my email address for Privacy Protections I have no use for. Yet, I cannot opt out of these tabs that appear frequently which makes it unsolicited and repetitive badgering of end users, ergo spam.

Spam definition is - unsolicited usually commercial messages (such as e-mails, text messages, or Internet postings) sent to a large number of recipients or posted in a large number of places.

1 Like

UMM youtube-dl and youtube-gui-git just updated in the repos not even a week ago, and I just used it a couple of days ago without issue.

@antikythera you're still wrong.

Forum kindly sponsored by