[Testing Update] 2020-01-08 - KDE-Git, Pamac 9.3, Firefox 72, Plasma 5.17.5, Haskell

Hello community,

here is another Testing Update for 2020! Tell us how 2019 was for you ...


Manjaro ARM Team will be at #FOSDEM2020

Some feature-updates:

  • Updated some KDE-git packages
  • We fixed some issues within Pamac 9.3 series
  • Firefox is now at v72.0
  • Plasma5 we updated to 5.17.5
  • Added some more Haskell updates/rebuilds
  • The usual upstream fixes

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our current 18.1.5 ISOs and give us the needed feedback. You might also want to give our latest spin with NX-Desktop a try ...

As always we appreciate your input and feedback for the updates.


Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on.


Our current supported kernels:

  • linux316 3.16.80
  • linux44 4.4.208
  • linux49 4.9.208
  • linux414 4.14.162
  • linux419 4.19.93
  • linux53 5.3.18 [EOL]
  • linux54 5.4.8
  • linux55 5.5-rc5
  • linux419-rt 4.19.90_rt35
  • linux54-rt 5.4.5_rt3

Package Changes (Wed Jan 8 15:38:23 CET 2020)

  • testing community x86_64: 337 new and 327 removed package(s)
  • testing core x86_64: 11 new and 9 removed package(s)
  • testing extra x86_64: 187 new and 182 removed package(s)
  • testing multilib x86_64: 4 new and 4 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-01-06           2020-01-08
-------------------------------------------------------------------------------
                   bettercap-capletsv20191009.r336.9b56899-1v20200108.r337.554c7c8-1
                                caja             1.22.3-0                    -
                        discover-git5.17.80.r7534.g3a83cae8-15.17.80.r7536.g82b421b8-1
                         drkonqi-git5.17.80.r469.ge3d96c40-15.17.80.r470.ge944f62f-1
            frameworkintegration-git5.66.0.r496.g7c2e801-15.66.0.r497.gcf2acc7-1
           gnome-layout-switcher-dev              0.6.6-1              0.6.6-2
                     kactivities-git5.66.0.r1264.gec1f6b79-15.66.0.r1265.g409a2c0a-1
                        kcmutils-git5.66.0.r360.g45021ba-15.66.0.r361.g6d6e242-1
                     kcoreaddons-git5.66.0.r925.g8bfe934-15.66.0.r928.g837621e-1
                kdeplasma-addons-git5.17.80.r8245.g7ed37a8a9-15.17.80.r8246.ga18bc820c-1
                     kinfocenter-git5.17.80.r1584.g6453a9f-15.17.80.r1587.g35f6d3f-1
                             kio-git5.66.0.r3735.g92258554-15.66.0.r3739.g40470f6c-1
                      knetattach-git5.17.80.r7224.g22046a9fc-15.17.80.r7242.g51f8849e4-1
                         kscreen-git5.17.80.r1219.g602904a-15.17.80.r1222.ga5c4e99-1
                       ksysguard-git5.17.80.r3202.gbdef3d08-15.17.80.r3204.g2b61540e-1
                    ktextwidgets-git5.66.0.r292.ga8b2bf7-15.66.0.r294.ga85a513-1
                  kwidgetsaddons-git5.66.0.r620.ge157817-15.66.0.r621.gfcc7978-1
                            kwin-git5.17.80.r17591.gab8563894-15.17.80.r17600.gee5f63c07-1
                      libkscreen-git5.17.80.r1495.g08a8259-15.17.80.r1498.g05e361e-1
    manjaro-kde-minimal-settings-dev           20200106-4           20200107-1
            manjaro-kde-settings-dev           20200106-4           20200107-1
                               marco             1.22.4-0                    -
               networkmanager-qt-git5.66.0.r1026.geee95e3-15.66.0.r1027.g7627f64-1
           onlyoffice-desktopeditors              5.4.2-1              5.4.2-2
                                 pix              2.4.3-2              2.4.5-1
      plasma-browser-integration-git5.17.80.r996.g268577a6-15.17.80.r997.g7489d255-1
                  plasma-desktop-git5.17.80.r7224.g22046a9fc-15.17.80.r7242.g51f8849e4-1
                plasma-framework-git5.66.0.r15332.g8232ed1b7-15.66.0.r15334.gb387faa93-1
                       plasma-nm-git5.17.80.r2732.g34ce1817-15.17.80.r2736.g169d398b-1
                      plasma-sdk-git5.17.80.r2130.g549d9b8-15.17.80.r2132.g87accc3-1
                    plasma-vault-git5.17.80.r242.gb984ad9-15.17.80.r243.gf8c6924-1
          plasma-wayland-session-git5.17.80.r8585.g4446d687d-15.17.80.r8598.gc3912e015-1
                plasma-workspace-git5.17.80.r8585.g4446d687d-15.17.80.r8598.gc3912e015-1
                      powerdevil-git5.17.80.r2241.g954c84af-15.17.80.r2242.g44939dd1-1
                         purpose-git5.66.0.r725.ge00c189-15.66.0.r726.g8dc165f-1
                           solid-git5.66.0.r532.gcb5a9fe-15.66.0.r533.g11ec991-1
             syntax-highlighting-git5.66.0.r1059.gb490730-15.66.0.r1060.ge94fbd0-1
                  systemsettings-git5.17.80.r2175.g6977f90b-15.17.80.r2177.g613e36c7-1
                             xplayer              2.2.3-1              2.2.5-1
                             xviewer              2.4.2-1              2.4.3-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-01-06           2020-01-08
-------------------------------------------------------------------------------
                         asciidoctor             2.0.10-1             2.0.10-2
                               atril             1.22.2-3             1.22.3-1
                               botan             2.12.1-2             2.13.0-1
                 cairo-dock-plug-ins             3.4.1-14             3.4.1-15
                                caja             1.22.2-1             1.22.3-1
                              catch2             2.11.0-1             2.11.1-1
                        cdemu-client              3.2.3-1              3.2.4-1
                        cdemu-daemon              3.2.3-1              3.2.4-1
                              cobalt             0.15.4-1             0.15.6-1
                            ecasound              2.9.2-3              2.9.2-4
                       elasticsearch              7.5.0-1              7.5.1-1
                               giada             0.16.0-1             0.16.1-1
                           git-annex         7.20191230-5         7.20191230-7
                              gitlab             12.6.0-1             12.6.2-2
                       gitlab-gitaly             1.78.0-1             1.78.0-2
                        gitlab-shell           2:10.3.0-1           2:10.3.0-2
                         gnome-boxes             3.34.2-1             3.34.3-1
                    haskell-aeson-qq             0.8.3-10             0.8.3-11
                  haskell-cheapskate          0.1.1.1-111          0.1.1.1-112
                     haskell-githash           0.1.3.3-16           0.1.3.3-17
             haskell-haddock-library              1.8.0-7              1.8.0-8
                      haskell-hakyll         4.12.5.2-156         4.12.5.2-158
                        haskell-here            1.2.13-93            1.2.13-94
                       haskell-hpack            0.33.0-29            0.33.0-30
                   haskell-hspec-wai             0.9.2-89             0.9.2-90
              haskell-hspec-wai-json            0.9.2-101            0.9.2-103
                 haskell-interpolate            0.2.0-107            0.2.0-108
    haskell-interpolatedstring-perl6              1.0.2-8              1.0.2-9
             haskell-optparse-simple           0.1.1.2-93           0.1.1.2-94
                      haskell-pantry           0.1.1.1-92           0.1.1.1-93
               haskell-persistent-qq            2.9.1-104            2.9.1-105
              haskell-servant-server            0.16.2-62            0.16.2-63
                    haskell-src-meta             0.8.2-39              0.8.3-1
                 haskell-tasty-rerun            1.1.14-41             1.1.15-1
                   haskell-tree-diff               0.1-39               0.1-40
                    haskell-trifecta                 2-75                2.1-1
                          haskell-tz            0.1.3.3-4            0.1.3.3-5
                      haskell-tzdata     0.1.20190325.0-2     0.1.20190911.0-1
              haskell-wai-app-static          3.1.6.3-142          3.1.6.3-143
                   haskell-wai-extra            3.0.28-31             3.0.29-1
                  haskell-wai-logger             2.3.6-12             2.3.6-13
              haskell-wai-websockets          3.0.1.2-109          3.0.1.2-111
                  haskell-websockets          0.12.5.3-40           0.12.7.0-1
                       haskell-yesod            1.6.0-399            1.6.0-400
                  haskell-yesod-auth             1.6.8-72             1.6.8-73
                  haskell-yesod-core            1.6.17-18            1.6.17-19
               haskell-yesod-default            1.2.0-635            1.2.0-636
                  haskell-yesod-form             1.6.7-58             1.6.7-59
            haskell-yesod-persistent            1.6.0.4-3            1.6.0.4-4
                haskell-yesod-static          1.6.0.1-255          1.6.0.1-256
                  haskell-yesod-test             1.6.9-18             1.6.9-19
                               hiera              3.4.4-2              3.6.0-1
                               hivex             1.3.18-3             1.3.18-4
                         hledger-web              1.16-13              1.16-14
                              hoogle         5.0.17.11-50         5.0.17.11-51
                          ibus-table             1.9.22-1             1.9.23-1
                               idris             1.3.2-46             1.3.2-48
                                jadx              1.0.0-1              1.1.0-1
            java-xmlgraphics-commons                2.3-1                2.4-1
                                 kea             1.5.0-11             1.5.0-12
                              kibana              7.5.0-1              7.5.1-1
                             klayout               0.26-2               0.26-3
                              libluv             1.30.1-1             1.32.0-1
                           libmirage              3.2.3-1              3.2.4-1
              libperconaserverclient           8.0.16_7-1           8.0.18_9-1
                    libqtshadowsocks              2.1.0-8              2.1.0-9
                           libsigrok              0.5.2-1              0.5.2-2
                        libxxf86misc              1.0.4-1                    -
                            logstash              7.5.0-1              7.5.1-1
                              lolcat            100.0.0-1            100.0.0-2
                               marco             1.22.3-1             1.22.4-1
                              marisa              0.2.5-7              0.2.5-8
                             marsyas              0.5.0-6              0.5.0-7
                mate-session-manager             1.22.2-2             1.22.3-1
                         mcollective             2.12.5-1             2.12.5-2
                          metasploit             5.0.60-1             5.0.60-2
                       mod_passenger              6.0.4-1              6.0.4-2
                              murmur              1.3.0-5              1.3.0-6
                 nginx-mod-passenger              6.0.4-1              6.0.4-2
                              nodejs             13.5.0-2             13.6.0-1
                             notmuch             0.29.3-1             0.29.3-2
                        notmuch-mutt             0.29.3-1             0.29.3-2
                     notmuch-runtime             0.29.3-1             0.29.3-2
                         notmuch-vim             0.29.3-1             0.29.3-2
                              pandoc               2.8-13               2.8-14
                     pandoc-citeproc           0.16.4.1-9          0.16.4.1-10
                     pandoc-crossref           0.3.5.0-13           0.3.5.0-14
                           passenger              6.0.4-1              6.0.4-2
                          pcsc-tools              1.5.4-2              1.5.5-1
                      percona-server           8.0.16_7-1           8.0.18_9-1
              percona-server-clients           8.0.16_7-1           8.0.18_9-1
                         perl-marisa              0.2.5-7              0.2.5-8
                           postgrest             6.0.2-19             6.0.2-21
                   powerdns-recursor              4.2.0-4              4.2.1-1
                              puppet             6.10.1-1             6.10.1-2
                             puppet5             5.5.17-3             5.5.17-4
                           py3status               3.22-1               3.23-1
                             pythia8             8.2.43-2             8.2.44-3
                        python-arrow             0.15.2-3             0.15.5-1
                  python-elementpath              1.3.3-1              1.4.0-1
                  python-fastnumbers              2.2.1-2              3.0.0-1
                  python-flask-babel             0.12.2-3             0.12.2-4
                         python-fuse              0.3.1-2              1.0.0-1
                       python-marisa              0.2.5-7              0.2.5-8
             python-os-client-config             1.32.0-3             1.33.0-1
                    python-oslo-i18n             3.25.0-1             3.25.1-1
                     python-oslo-log             3.45.1-1             3.45.2-1
                     python-oslotest              3.8.1-3              3.9.0-1
                      python-pikepdf              1.8.2-1              1.8.3-1
                      python-promise              2.2.0-3              2.3.0-1
                       python-pylast              3.1.0-2              3.2.0-1
                      python-pymongo             3.10.0-2             3.10.1-1
                      python-pythia8             8.2.43-2             8.2.44-3
                      python-testflo              1.3.4-3              1.3.5-1
                      python-unicorn              1.0.1-7              1.0.1-8
                       python-uproot            3.10.12-1             3.11.0-1
               python-uproot-methods              0.7.1-5              0.7.2-1
                      python-wcwidth              0.1.7-5              0.1.8-1
                        python-whelk              2.7.1-4              2.8.2-1
                        python2-fuse              0.3.1-2              1.0.0-1
            python2-os-client-config             1.32.0-3             1.33.0-1
                   python2-oslo-i18n             3.25.0-1             3.25.1-1
                    python2-oslo-log             3.45.1-1             3.45.2-1
                    python2-oslotest              3.8.1-3              3.9.0-1
                     python2-portend                2.6-1                2.6-2
                     python2-pymongo             3.10.0-2             3.10.1-1
                     python2-tempora             1.14.1-4             1.14.1-5
                     python2-wcwidth              0.1.7-5              0.1.8-1
                            rabbitmq              3.8.1-1              3.8.2-1
                       rabbitmqadmin              3.8.1-1              3.8.2-1
                                root            6.18.04-7            6.18.04-8
                           root-cuda            6.18.04-7            6.18.04-8
                    ruby-addressable              2.7.0-1              2.7.0-2
                          ruby-async             1.23.0-1             1.23.0-2
                      ruby-async-dns              1.2.4-1              1.2.4-2
                       ruby-async-io             1.27.0-1             1.27.0-2
                            ruby-atk              3.4.1-1              3.4.1-2
                         ruby-augeas              0.5.0-3              0.5.0-4
                        ruby-bundler              2.1.2-1              2.1.4-1
                          ruby-cairo             1.16.4-1             1.16.4-2
                  ruby-cairo-gobject              3.4.1-1              3.4.1-2
                        ruby-chronic             0.10.2-1             0.10.2-2
                      ruby-colorator              1.1.0-5              1.1.0-6
                       ruby-colorize              0.8.1-6              0.8.1-7
                     ruby-concurrent              1.1.5-1              1.1.5-2
                        ruby-daemons              1.2.6-2              1.2.6-3
                           ruby-dbus             0.15.0-2             0.15.0-3
                       ruby-diff-lcs                1.3-3                1.3-4
                       ruby-em-proxy              0.1.9-5              0.1.9-6
                   ruby-eventmachine              1.2.7-2              1.2.7-3
                        ruby-faraday             0.16.2-1              1.0.0-1
             ruby-faraday-middleware             0.13.1-1             0.13.1-2
                            ruby-ffi             1.11.3-1             1.11.3-3
           ruby-forwardable-extended              2.6.0-4              2.6.0-5
                           ruby-gdk3              3.4.1-1              3.4.1-2
                    ruby-gdk_pixbuf2              3.4.1-1              3.4.1-2
                           ruby-gio2              3.4.1-1              3.4.1-2
                          ruby-glib2              3.4.1-1              3.4.1-2
          ruby-gobject-introspection              3.4.1-1              3.4.1-2
                          ruby-gpgme             2.0.19-1             2.0.19-2
                           ruby-gtk2              3.4.1-1              3.4.1-2
                           ruby-gtk3              3.4.1-1              3.4.1-2
                        ruby-hitimes              2.0.0-1              2.0.0-2
                            ruby-hoe             3.20.0-1             3.20.0-4
                        ruby-hpricot              0.8.6-8              0.8.6-9
                          ruby-iconv              1.0.5-2              1.0.5-3
               ruby-immutable-struct              2.3.0-1              2.3.0-2
                            ruby-irb              1.1.0-2              1.2.1-1
          ruby-jekyll-sass-converter              2.0.1-1              2.0.1-2
                       ruby-kramdown              2.1.0-1              2.1.0-2
                           ruby-mail              2.7.1-2              2.7.1-3
                       ruby-mail-gpg              0.4.0-2              0.4.0-3
                       ruby-manpages              0.6.1-2              0.6.1-3
                         ruby-marisa              0.2.5-7              0.2.5-8
                         ruby-maruku              0.7.3-4              0.7.3-5
                      ruby-mercenary              0.3.6-3              0.3.6-4
                     ruby-mime-types              3.2.2-2              3.2.2-3
                ruby-mime-types-data        3.2018.0812-1        3.2018.0812-2
                      ruby-mini_mime              1.0.1-1              1.0.1-2
                   ruby-mini_portile              0.6.2-2              0.6.2-3
                  ruby-mini_portile2              2.4.0-3              2.4.0-4
                       ruby-minitest             5.13.0-1             5.13.0-3
                          ruby-mocha              1.9.0-1              1.9.0-2
                        ruby-msgpack              1.3.1-1              1.3.1-2
                     ruby-multi_json             1.14.1-1             1.14.1-2
                 ruby-multipart-post              2.1.1-1              2.1.1-2
                       ruby-mustache              1.1.0-1              1.1.0-2
                     ruby-mustermann              1.0.3-1              1.0.3-2
       ruby-native-package-installer              1.0.6-3              1.0.6-4
                      ruby-nats-pure              0.6.2-1              0.6.2-2
                        ruby-ncurses             1.3.1-13             1.3.1-14
                        ruby-net-dns              0.8.0-5              0.8.0-6
                       ruby-net-ping              2.0.6-1              2.0.6-2
              ruby-network_interface              0.0.2-2              0.0.2-3
                          ruby-nio4r              2.5.2-1              2.5.2-2
                       ruby-optimist              3.0.0-1              3.0.0-2
                       ruby-packetfu             1.1.13-3             1.1.13-4
                          ruby-paint              2.1.0-1              2.1.0-2
                          ruby-pango              3.4.1-1              3.4.1-2
                       ruby-pathutil             0.16.1-3             0.16.1-4
                        ruby-pcaprub             0.12.4-5             0.12.4-6
                             ruby-pg              1.1.4-1              1.1.4-2
                     ruby-pkg-config              1.3.7-1              1.3.7-2
                       ruby-polyglot              0.3.5-6              0.3.5-7
                   ruby-power_assert              1.1.5-1              1.1.5-2
                  ruby-public_suffix              4.0.1-1              4.0.2-1
                           ruby-rack              2.0.5-2              2.0.8-1
                ruby-rack-protection              2.0.5-1              2.0.5-2
                        ruby-rainbow              3.0.0-4              3.0.0-5
                           ruby-rake             13.0.0-1             13.0.1-2
                  ruby-rake-compiler              1.0.7-2              1.0.7-3
                     ruby-rb-inotify             0.9.10-3             0.9.10-4
                      ruby-rdiscount            2.2.0.1-4            2.2.0.1-5
                           ruby-rdoc              6.2.0-1              6.2.0-2
                         ruby-reline              0.0.7-1              0.0.7-2
                           ruby-ronn              0.7.3-8              0.7.3-9
                          ruby-rouge             3.14.0-1             3.14.0-2
                          ruby-rspec              3.8.0-2              3.8.0-3
                     ruby-rspec-core              3.8.0-2              3.8.0-3
             ruby-rspec-expectations              3.8.1-2              3.8.1-3
                    ruby-rspec-mocks              3.8.0-2              3.8.0-3
                  ruby-rspec-support              3.8.0-2              3.8.0-3
                        ruby-rubydns              2.0.2-3              2.0.2-4
                         ruby-rugged           0.28.4.1-1           0.28.4.1-2
                      ruby-safe_yaml              1.0.4-4              1.0.4-5
                           ruby-sass              3.7.4-1              3.7.4-2
                    ruby-sass-listen              4.0.0-6              4.0.0-7
                ruby-semantic_puppet              1.0.2-2              1.0.2-3
                         ruby-shadow              2.5.0-4              2.5.0-5
                        ruby-sqlite3              1.4.1-1              1.4.2-2
                          ruby-stomp              1.4.8-1              1.4.8-2
                  ruby-sys-proctable              1.2.2-1              1.2.2-2
                 ruby-term-ansicolor              1.6.0-2              1.6.0-3
                      ruby-test-unit              3.3.4-1              3.3.4-2
                           ruby-thin              1.7.2-3              1.7.2-4
                           ruby-thor              1.0.1-1              1.0.1-2
                           ruby-tilt              2.0.8-3              2.0.8-4
                         ruby-timers              4.3.0-1              4.3.0-2
                           ruby-tins             1.16.3-2             1.16.3-3
                      ruby-titlecase   0.1.1+13+1d6b4f7-3   0.1.1+13+1d6b4f7-4
                        ruby-treetop             1.6.10-2             1.6.10-3
                        ruby-trollop              2.1.3-2              2.1.3-3
                 ruby-unicorn-engine              1.0.1-7              1.0.1-8
                           ruby-yard             0.9.14-2             0.9.14-3
                             ruby2.5              2.5.7-1                    -
                     ruby2.5-bundler              2.1.4-1                    -
                              rustup             1.20.2-1             1.21.1-1
                              semver              6.3.0-2              7.1.1-1
                          shellcheck             0.7.0-87             0.7.0-88
                                 snd               19.9-1               20.0-1
                            sonic-pi              3.1.0-7              3.1.0-8
                              sqlmap             1.3.11-1                1.4-1
                               stack            2.1.3-108            2.1.3-109
                               swig3             3.0.12-2             3.0.12-3
                      tamarin-prover            1.4.1-217            1.4.1-218
                             taskell            1.9.0.0-4            1.9.0.0-5
                    telegram-desktop             1.8.15-4              1.9.3-1
                              texlab              1.8.0-1              1.9.0-1
                         uboot-tools            2019.07-1            2020.01-1
                             udiskie              2.0.1-1              2.0.2-1
                           uglify-js              3.7.3-1              3.7.4-1
                             unicorn              1.0.1-7              1.0.1-8
                               uwsgi             2.0.18-6             2.0.18-7
                    uwsgi-plugin-cgi             2.0.18-6             2.0.18-7
                    uwsgi-plugin-jvm             2.0.18-6             2.0.18-7
                  uwsgi-plugin-lua51             2.0.18-6             2.0.18-7
                   uwsgi-plugin-mono             2.0.18-6             2.0.18-7
               uwsgi-plugin-notfound             2.0.18-6             2.0.18-7
                    uwsgi-plugin-php             2.0.18-6             2.0.18-7
                   uwsgi-plugin-psgi             2.0.18-6             2.0.18-7
                   uwsgi-plugin-pypy             2.0.18-6             2.0.18-7
                 uwsgi-plugin-python             2.0.18-6             2.0.18-7
                uwsgi-plugin-python2             2.0.18-6             2.0.18-7
                   uwsgi-plugin-rack             2.0.18-6             2.0.18-7
                 uwsgi-plugin-webdav             2.0.18-6             2.0.18-7
                 uwsgi-plugin-zabbix             2.0.18-6             2.0.18-7
         v2ray-domain-list-community       202001060909-1       202001070832-1
                         v2ray-geoip           20191119-1       202001080103-1
                             vagrant              2.2.6-2              2.2.6-3
                           veracrypt       1.24.hotfix1-1       1.24.update3-1
                                vimb              3.5.0-1              3.6.0-1
                             weechat                2.7-1                2.7-2
                        wire-desktop          3.11.2912-1          3.12.2916-1
                              wpscan            1:3.7.5-1            1:3.7.5-2
                     xmms2 0.8DrO_o.949.gca15e830-1 80.8DrO_o.949.gca15e830-19
                              xrootd             4.11.0-3             4.11.1-1
                             zn_poly              0.9.1-2              0.9.2-1
                 zsh-autosuggestions              0.6.3-1              0.6.4-1
        haskell-first-class-families                    -            0.6.0.0-1
                        haskell-hint                    -            0.9.0.2-1
                 haskell-type-errors                    -            0.2.0.0-1
                                juce                    -              5.4.5-1
                         python-adal                    -              1.2.2-1
                   python-kubernetes                    -             10.0.1-2
                  ruby-activesupport                    -            6.0.2.1-2
                           ruby-i18n                    -              1.7.0-2
                           ruby-json                    -              2.3.0-2
               ruby-test_declarative                    -              0.0.6-1
                         ruby-tzinfo                    -              2.0.1-1
                       ruby-zeitwerk                    -              2.2.2-1
                         tpm2-pkcs11                    -              1.0.1-1
                           yggdrasil                    -             0.3.12-2


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-01-06           2020-01-08
-------------------------------------------------------------------------------
                           amd-ucode   20191220.6871bff-1   20200107.67d4ff5-1
                      linux-firmware   20191220.6871bff-1   20200107.67d4ff5-1
                             linux54              5.4.8-2              5.4.8-3
                     linux54-headers              5.4.8-2              5.4.8-3
                         mhwd-amdgpu              1.2.1-1             19.1.0-1
                            mhwd-ati              7.7.0-1             19.1.0-1
                             mhwd-db              0.6.4-4              0.6.4-6
                              pacman              5.2.1-2              5.2.1-3


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-01-06           2020-01-08
-------------------------------------------------------------------------------
                              dhcpcd              8.1.4-1              8.1.5-1
                              libcap               2.28-1               2.29-1
                            libevent             2.1.11-4             2.1.11-5


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-01-06           2020-01-08
-------------------------------------------------------------------------------
               calamares-git 3.2.18.r6866.f7ed4f322-1 3.2.18.r6892.d47544e1e-1
                        manjaro-alsa            2012.11-1           20200107-1
                     manjaro-printer           20170501-1           20200107-1
                       manjaro-pulse            2012.11-1           20200107-1
                   manjaro-bluetooth                    -           20200107-1
                   manjaro-gstreamer                    -           20200107-1
                       manjaro-modem                    -           20200107-1
                     manjaro-network                    -           20200107-1
                       manjaro-vaapi                    -           20200107-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-01-06           2020-01-08
-------------------------------------------------------------------------------
                            apparmor             2.13.3-3             2.13.3-4
                           bluedevil           1:5.17.4-1           1:5.17.5-1
                              breeze             5.17.4-1             5.17.5-1
                         breeze-grub             5.17.4-1             5.17.5-1
                          breeze-gtk             5.17.4-1             5.17.5-1
                            chromium       79.0.3945.88-2      79.0.3945.117-1
                        dconf-editor             3.34.2-1             3.34.3-1
                            discover             5.17.4-1             5.17.5-1
                             drkonqi             5.17.4-1             5.17.5-1
                             firefox               71.0-1               72.0-1
                    firefox-i18n-ach               71.0-1               72.0-1
                     firefox-i18n-af               71.0-1               72.0-1
                     firefox-i18n-an               71.0-1               72.0-1
                     firefox-i18n-ar               71.0-1               72.0-1
                    firefox-i18n-ast               71.0-1               72.0-1
                     firefox-i18n-az               71.0-1               72.0-1
                     firefox-i18n-be               71.0-1               72.0-1
                     firefox-i18n-bg               71.0-1               72.0-1
                     firefox-i18n-bn               71.0-1               72.0-1
                     firefox-i18n-br               71.0-1               72.0-1
                     firefox-i18n-bs               71.0-1               72.0-1
                     firefox-i18n-ca               71.0-1               72.0-1
            firefox-i18n-ca-valencia               71.0-1               72.0-1
                    firefox-i18n-cak               71.0-1               72.0-1
                     firefox-i18n-cs               71.0-1               72.0-1
                     firefox-i18n-cy               71.0-1               72.0-1
                     firefox-i18n-da               71.0-1               72.0-1
                     firefox-i18n-de               71.0-1               72.0-1
                    firefox-i18n-dsb               71.0-1               72.0-1
                     firefox-i18n-el               71.0-1               72.0-1
                  firefox-i18n-en-ca               71.0-1               72.0-1
                  firefox-i18n-en-gb               71.0-1               72.0-1
                  firefox-i18n-en-us               71.0-1               72.0-1
                     firefox-i18n-eo               71.0-1               72.0-1
                  firefox-i18n-es-ar               71.0-1               72.0-1
                  firefox-i18n-es-cl               71.0-1               72.0-1
                  firefox-i18n-es-es               71.0-1               72.0-1
                  firefox-i18n-es-mx               71.0-1               72.0-1
                     firefox-i18n-et               71.0-1               72.0-1
                     firefox-i18n-eu               71.0-1               72.0-1
                     firefox-i18n-fa               71.0-1               72.0-1
                     firefox-i18n-ff               71.0-1               72.0-1
                     firefox-i18n-fi               71.0-1               72.0-1
                     firefox-i18n-fr               71.0-1               72.0-1
                  firefox-i18n-fy-nl               71.0-1               72.0-1
                  firefox-i18n-ga-ie               71.0-1               72.0-1
                     firefox-i18n-gd               71.0-1               72.0-1
                     firefox-i18n-gl               71.0-1               72.0-1
                     firefox-i18n-gn               71.0-1               72.0-1
                  firefox-i18n-gu-in               71.0-1               72.0-1
                     firefox-i18n-he               71.0-1               72.0-1
                  firefox-i18n-hi-in               71.0-1               72.0-1
                     firefox-i18n-hr               71.0-1               72.0-1
                    firefox-i18n-hsb               71.0-1               72.0-1
                     firefox-i18n-hu               71.0-1               72.0-1
                  firefox-i18n-hy-am               71.0-1               72.0-1
                     firefox-i18n-ia               71.0-1               72.0-1
                     firefox-i18n-id               71.0-1               72.0-1
                     firefox-i18n-is               71.0-1               72.0-1
                     firefox-i18n-it               71.0-1               72.0-1
                     firefox-i18n-ja               71.0-1               72.0-1
                     firefox-i18n-ka               71.0-1               72.0-1
                    firefox-i18n-kab               71.0-1               72.0-1
                     firefox-i18n-kk               71.0-1               72.0-1
                     firefox-i18n-km               71.0-1               72.0-1
                     firefox-i18n-kn               71.0-1               72.0-1
                     firefox-i18n-ko               71.0-1               72.0-1
                    firefox-i18n-lij               71.0-1               72.0-1
                     firefox-i18n-lt               71.0-1               72.0-1
                     firefox-i18n-lv               71.0-1               72.0-1
                     firefox-i18n-mk               71.0-1               72.0-1
                     firefox-i18n-mr               71.0-1               72.0-1
                     firefox-i18n-ms               71.0-1               72.0-1
                     firefox-i18n-my               71.0-1               72.0-1
                  firefox-i18n-nb-no               71.0-1               72.0-1
                  firefox-i18n-ne-np               71.0-1               72.0-1
                     firefox-i18n-nl               71.0-1               72.0-1
                  firefox-i18n-nn-no               71.0-1               72.0-1
                     firefox-i18n-oc               71.0-1               72.0-1
                  firefox-i18n-pa-in               71.0-1               72.0-1
                     firefox-i18n-pl               71.0-1               72.0-1
                  firefox-i18n-pt-br               71.0-1               72.0-1
                  firefox-i18n-pt-pt               71.0-1               72.0-1
                     firefox-i18n-rm               71.0-1               72.0-1
                     firefox-i18n-ro               71.0-1               72.0-1
                     firefox-i18n-ru               71.0-1               72.0-1
                     firefox-i18n-si               71.0-1               72.0-1
                     firefox-i18n-sk               71.0-1               72.0-1
                     firefox-i18n-sl               71.0-1               72.0-1
                    firefox-i18n-son               71.0-1               72.0-1
                     firefox-i18n-sq               71.0-1               72.0-1
                     firefox-i18n-sr               71.0-1               72.0-1
                  firefox-i18n-sv-se               71.0-1               72.0-1
                     firefox-i18n-ta               71.0-1               72.0-1
                     firefox-i18n-te               71.0-1               72.0-1
                     firefox-i18n-th               71.0-1               72.0-1
                     firefox-i18n-tl               71.0-1               72.0-1
                     firefox-i18n-tr               71.0-1               72.0-1
                    firefox-i18n-trs               71.0-1               72.0-1
                     firefox-i18n-uk               71.0-1               72.0-1
                     firefox-i18n-ur               71.0-1               72.0-1
                     firefox-i18n-uz               71.0-1               72.0-1
                     firefox-i18n-vi               71.0-1               72.0-1
                     firefox-i18n-xh               71.0-1               72.0-1
                  firefox-i18n-zh-cn               71.0-1               72.0-1
                  firefox-i18n-zh-tw               71.0-1               72.0-1
                       four-in-a-row             3.34.1-1             3.34.3-1
                                 gjs           2:1.58.3-1           2:1.58.4-1
                       gnome-klotski             3.34.0-1             3.34.3-1
                        gnome-taquin             3.34.2-1             3.34.3-1
                                gvim           8.2.0033-1           8.2.0100-1
                               iagno             3.34.3-1             3.34.4-1
                   kactivitymanagerd             5.17.4-1             5.17.5-1
                       kde-cli-tools             5.17.4-1             5.17.5-1
                      kde-gtk-config             5.17.4-1             5.17.5-1
                         kdecoration             5.17.4-1             5.17.5-1
                    kdeplasma-addons             5.17.4-1             5.17.5-1
                            kdevelop              5.4.5-2              5.4.6-1
                        kdevelop-php              5.4.5-1              5.4.6-1
                     kdevelop-python              5.4.5-1              5.4.6-1
                             kgamma5             5.17.4-1             5.17.5-1
                            khotkeys             5.17.4-1             5.17.5-1
                         kinfocenter             5.17.4-1             5.17.5-1
                           kmenuedit             5.17.4-1             5.17.5-1
                          knetattach             5.17.4-2             5.17.5-1
                  kross-interpreters            19.12.0-1            19.12.0-2
                             kscreen             5.17.4-1             5.17.5-1
                       kscreenlocker             5.17.4-1             5.17.5-1
                         ksshaskpass             5.17.4-1             5.17.5-1
                           ksysguard             5.17.4-1             5.17.5-1
                         kwallet-pam             5.17.4-1             5.17.5-1
                kwayland-integration             5.17.4-1             5.17.5-1
                                kwin             5.17.4-4             5.17.5-1
                             kwrited             5.17.4-1             5.17.5-1
                            libglvnd              1.3.0-1              1.3.0-2
                          libkscreen             5.17.4-1             5.17.5-1
                        libksysguard             5.17.4-1             5.17.5-1
                             libwebp              1.0.3-1              1.1.0-1
                               meson             0.52.1-1             0.53.0-1
                               milou             5.17.4-1             5.17.5-1
                              oxygen             5.17.4-1             5.17.5-1
                           pacrunner               0.14-1               0.17-1
               perl-template-toolkit               2.29-3              3.002-1
          plasma-browser-integration             5.17.4-1             5.17.5-1
                      plasma-desktop             5.17.4-2             5.17.5-1
                  plasma-integration             5.17.4-2             5.17.5-1
                           plasma-nm             5.17.4-1             5.17.5-1
                           plasma-pa             5.17.4-1             5.17.5-1
                          plasma-sdk             5.17.4-1             5.17.5-1
                  plasma-thunderbolt             5.17.4-1             5.17.5-1
                        plasma-vault             5.17.4-1             5.17.5-1
              plasma-wayland-session             5.17.4-1             5.17.5-1
                    plasma-workspace             5.17.4-1             5.17.5-1
         plasma-workspace-wallpapers             5.17.4-1             5.17.5-1
                    polkit-kde-agent             5.17.4-1             5.17.5-1
                          powerdevil             5.17.4-1             5.17.5-1
                          prometheus             2.15.1-1             2.15.2-1
                         python-mako             1.0.14-3              1.1.0-1
                        python-numpy             1.18.0-1             1.18.1-1
                          python-pip             19.2.3-3               19.3-1
                   python-setuptools           1:42.0.2-1           1:43.0.0-1
                        python2-mako             1.0.14-3              1.1.0-1
                         python2-pip             19.2.3-3               19.3-1
                  python2-setuptools           1:42.0.2-1           1:43.0.0-1
                                 qca              2.2.1-3              2.2.1-4
                             rrdtool              1.7.2-1              1.7.2-2
                                ruby              2.6.5-1              2.7.0-1
                           ruby-docs              2.6.5-1              2.7.0-1
                            rubygems              3.1.2-1              3.1.2-4
                            sddm-kcm             5.17.4-1             5.17.5-1
                          subversion             1.13.0-1             1.13.0-2
                      systemsettings             5.17.4-1             5.17.5-1
                        user-manager             5.17.4-1             5.17.5-1
                                 vim           8.2.0033-1           8.2.0100-1
                         vim-runtime           8.2.0033-1           8.2.0100-1
                             wavpack              5.1.0-2              5.2.0-1
              xdg-desktop-portal-kde             5.17.4-1             5.17.5-1
                           zxing-cpp              1.0.7-1              1.0.8-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-01-06           2020-01-08
-------------------------------------------------------------------------------
                        lib32-libcap               2.27-1               2.29-1
                       lib32-libgusb              0.3.1-1              0.3.1-2
                       lib32-libwebp              1.0.3-1              1.1.0-1
                       lib32-wavpack              5.1.0-2              5.2.0-1
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

5 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Do I need to downgrade systemd?

Not necessarily. If systemd 244.1-1.1 works fine for you, you can keep it. If you have issues related to systemd, of course, you may want to downgrade the packages related to systemd.

This is valid until Manjaro Team says otherwise. If the team asks everyone to downgrade the packages for a reason or another, do it.

From philm:

Pamac: I can't build AUR packages

Before anything else, please verify in /etc/pamac.conf if BuildDirectory is set up correctly. For example:

## AUR build directory:
BuildDirectory = /var/tmp

If you have something like /var or / instead, you might have been affected by the following bug. A bug in Pamac "corrupted" the value of BuildDirectory, which ultimately leads to a directory that Pamac can't write in (to create a directory) because the user does not have the permission to do so, hence why Pamac failed to build AUR packages.

This bug should be fixed by now in Pamac 9.2.0rc, but users affected by the bug have to change back this parameter to a correct value manually, which can be done either with a text editor by editing /etc/pamac.conf OR graphically within Pamac GTK by going in Preferences > AUR.

pacman-mirrors

.. & it's Perfect .... NOW! :tongue:

Is good for me but have many new software what is it ?

À installer  (20):
  pulseaudio-jack              13.0-2                                    extra      16,3 ko
  confuse                      3.2.2-1                                   community  40,6 ko
  libftdi                      1.4-4                                     community  109,0 ko
  libusb-compat                0.1.5-2                                   extra      12,4 ko
  lirc                         1:0.10.1-4                                extra      1,2 Mo
  pulseaudio-lirc              13.0-2                                    extra      6,9 ko
  portaudio                    1:19.6.0-6                                extra      97,3 ko
  fluidsynth                   2.1.0-1                                   extra      224,0 ko
  libcanberra-gstreamer        0.30+2+gc0620e4-2                         extra      9,7 ko
  lib32-openal                 1.20.0-1                                  multilib   698,2 ko
  lib32-db                     5.3.28-4                                  multilib   863,2 ko
  lib32-libsamplerate          0.1.9-2                                   multilib   941,6 ko
  lib32-jack                   0.125.0-2                                 multilib   39,4 ko
  lib32-portaudio              190600_20161030-2                         multilib   64,0 ko
  lib32-sdl2                   2.0.10-1                                  multilib   433,7 ko
  lib32-fluidsynth             2.1.0-1                                   multilib   194,3 ko
  lib32-libunwind              1.3.1-1                                   multilib   50,1 ko
  lib32-gstreamer              1.16.2-1                                  multilib   1,0 Mo
  lib32-libcanberra-gstreamer  0.30+2+gc0620e4-1                         multilib   10,9 ko
  python-contextlib2           0.6.0-3                                   community  15,2 ko

That is many new soft to install.

Best Regards
Thx for new AMD Code and new Firefox

most of these are in kde edition pre-installed
some of them are needed for steam/wine.
and its good to have them installed.

you could also check and install for full support
manjaro-alsa
manjaro-pulse
manjaro-vaapi
manjaro-gstreamer
manjaro-network
manjaro-modem
manjaro-bluetooth
manjaro-printer

these packages make a basic manjaro system.

1 Like

just got the updates. got this before the buids / installs:

Warning: dependency cycle detected:
Warning: rubygems will be installed before its ruby dependency

got this after the builds / installs:

http://distro.ibiblio.org/manjaro/testing/community/x86_64/semver-7.1.1-1-any.pkg.tar.xz: Error 404
http://distro.ibiblio.org/manjaro/testing/core/x86_64/mhwd-ati-19.1.0-1-any.pkg.tar.zst: Error 404
http://mirror.catn.com/pub/manjaro/testing/core/x86_64/libcap-2.29-1-x86_64.pkg.tar.xz: Error 404
http://mirror.catn.com/pub/manjaro/testing/core/x86_64/amd-ucode-20200107.67d4ff5-1-any.pkg.tar.zst: Error 404
https://mirror.clarkson.edu/manjaro/testing/core/x86_64/libcap-2.29-1-x86_64.pkg.tar.xz: Error 404
https://mirror.clarkson.edu/manjaro/testing/core/x86_64/amd-ucode-20200107.67d4ff5-1-any.pkg.tar.zst: Error 404
http://linorg.usp.br/manjaro/testing/core/x86_64/linux54-5.4.8-3-x86_64.pkg.tar.zst: Error 404
https://mirrors.ocf.berkeley.edu/manjaro/testing/core/x86_64/amd-ucode-20200107.67d4ff5-1-any.pkg.tar.zst: Error 404
http://linorg.usp.br/manjaro/testing/core/x86_64/mhwd-amdgpu-19.1.0-1-any.pkg.tar.zst: Error 404
https://download.nus.edu.sg/mirror/manjaro/testing/core/x86_64/libevent-2.1.11-5-x86_64.pkg.tar.xz: Error 404
https://download.nus.edu.sg/mirror/manjaro/testing/core/x86_64/linux-firmware-20200107.67d4ff5-1-any.pkg.tar.zst: Error 404
https://mirrors.ocf.berkeley.edu/manjaro/testing/core/x86_64/libcap-2.29-1-x86_64.pkg.tar.xz: Error 404
https://mirrors.piconets.webwerks.in/manjaro-mirror/testing/core/x86_64/mhwd-amdgpu-19.1.0-1-any.pkg.tar.zst: Error 404
https://mirrors.piconets.webwerks.in/manjaro-mirror/testing/core/x86_64/libevent-2.1.11-5-x86_64.pkg.tar.xz: Error 404
https://mirrors.sjtug.sjtu.edu.cn/manjaro/testing/core/x86_64/mhwd-amdgpu-19.1.0-1-any.pkg.tar.zst: Error 404
https://mirrors.sjtug.sjtu.edu.cn/manjaro/testing/core/x86_64/libevent-2.1.11-5-x86_64.pkg.tar.xz: Error 404
https://ba.mirror.garr.it/mirrors/manjaro/testing/core/x86_64/mhwd-amdgpu-19.1.0-1-any.pkg.tar.zst: Error 404
https://ba.mirror.garr.it/mirrors/manjaro/testing/core/x86_64/libevent-2.1.11-5-x86_64.pkg.tar.xz: Error 404
https://ct.mirror.garr.it/mirrors/manjaro/testing/core/x86_64/mhwd-amdgpu-19.1.0-1-any.pkg.tar.zst: Error 404
https://ct.mirror.garr.it/mirrors/manjaro/testing/core/x86_64/libevent-2.1.11-5-x86_64.pkg.tar.xz: Error 404

Your mirror is not fully synced: 404 means "not found", see HTTP Status Code Definitions

has to be on their end cause i just refreched my mirror list not even an hour before these updates dropped.

No problem here. But it looks like Firefox 72.0 is already dead: https://www.archlinux.org/packages/extra/x86_64/firefox/

72.0.1 -> https://www.mozilla.org/en-US/security/known-vulnerabilities/firefox/#firefox72.0.1

https://www.mozilla.org/en-US/security/advisories/mfsa2020-03/

out of 371.? megs to be downloaded the first 320.? went like a bat out of hell, the next 51.? took at least 4 times as long to download. wan't too surprised when i saw all the 404's. already did a reboot and all looks and feels fine. as for firefox not surprised being mozilla.

After updating today and rebooting I experienced scaling issues: Dolphin's font size became like it was scaled to 2x, while systemsettings was fine. Reducing the Forced-DPI from 144 to 96 made everything become tiny as scaling 1.0 on the HiDPI screen. :slight_smile:
I opened an issue on the KDE bug tracker to track it: https://bugs.kde.org/show_bug.cgi?id=416014

Downgrading to stable "resolved" the issue for me. I wonder if anyone else experienced those weird issues.

It has an AVG 1084 over Firefox 72 which can be directed to stable as a security fix of multiple issues and severity critical.
[manjaro-security] [ASA-202001-1] firefox: multiple issues

repositories

1 Like

It looks like the Arch packager for Plasma did not update to Qt 5.14 before building Plasma 5.17.5.

image

I can confirm, but so far everything is running fine.

@philm What's new in linux 5.4.8-3? Looks like you've forgotten to update GitLab's files...

The fonts are all messed up. After the upgrade, the fonts got thicker and on some letters it looks like they are leaking. Especially the Mono fonts in Konsole. I like my fonts clean and crisp, this sucks :slight_smile:

Upgraded to 5.4.10 in Manjaro GitLab's.
Changelog
[pkg-upd] 5.4.8-3
Bug 205745 - i2c_hid i2c-SYNA7DB5:01: failed to reset device.

Forum kindly sponsored by