[Testing Update] 2020-01-06 - Pamac, KDE-git, Linux419-Extramodules, Haskell

Hello community,

here is another Testing Update for 2020! Tell us how 2019 was for you ...


Manjaro ARM Team will be at #FOSDEM2020

Some feature-updates:

  • mhwd got initial Nvidia-Prime support for 440 and 435 driver series
  • Updated some KDE-git packages
  • linux419-extramodules got rebuild as issues were reported
  • We fixed some issues within Pamac 9.3 series
  • Added some more Haskell updates/rebuilds
  • The usual upstream fixes

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our current 18.1.5 ISOs and give us the needed feedback.

As always we appreciate your input and feedback for the updates.


Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on.


Our current supported kernels:

  • linux316 3.16.80
  • linux44 4.4.207
  • linux49 4.9.207
  • linux414 4.14.161
  • linux419 4.19.92
  • linux53 5.3.18 [EOL]
  • linux54 5.4.7
  • linux55 5.5-rc4
  • linux419-rt 4.19.90_rt35
  • linux54-rt 5.4.5_rt3

Package Changes (Mon Jan 6 15:09:59 CET 2020)

  • testing community x86_64: 245 new and 248 removed package(s)
  • testing core x86_64: 3 new and 3 removed package(s)
  • testing extra x86_64: 46 new and 46 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-01-05           2020-01-06
-------------------------------------------------------------------------------
                          attica-git5.66.0.r733.gf02d472-15.66.0.r735.g540de0a-1
                           baloo-git5.66.0.r2679.gde269bf4-15.66.0.r2680.gbe2edc51-1
                       bluedevil-git5.17.80.r2035.gd23c7465-15.17.80.r2036.g9291b9d0-1
                        bluez-qt-git5.66.0.r574.g85774a8-15.66.0.r575.g6a9b33b-1
                               brave             1.1.23-1             1.2.41-1
                          brave-beta             1.2.36-1             1.3.84-1
                          breeze-git5.17.80.r1915.g9a7ef259-15.17.80.r1928.gd9edbe05-1
                    breeze-icons-git5.66.0.r1442.g7a39dc74-15.66.0.r1452.gef8d76dc-1
                        discover-git5.17.80.r7524.geb33fe4b-15.17.80.r7534.g3a83cae8-1
             extra-cmake-modules-git5.66.0.r3125.g44adaad-15.66.0.r3126.gc427b4e-1
            frameworkintegration-git5.66.0.r495.g3ac69a7-15.66.0.r496.g7c2e801-1
                            hw-probe 1.4+197.g0fd5fc5c1c-1 1.4+200.gd4c0f2cdde-1
                     kactivities-git5.66.0.r1263.gb8ae6c54-15.66.0.r1264.gec1f6b79-1
               kactivities-stats-git5.66.0.r261.g2edcd24-15.66.0.r262.ge83917e-1
                         kapidox-git5.66.0.r446.g7808ebd-15.66.0.r447.g816abe8-1
                        karchive-git5.66.0.r403.g068fc91-15.66.0.r404.gef0ca4a-1
                           kauth-git5.66.0.r327.g450c37b-15.66.0.r330.g06ea41a-1
                      kbookmarks-git5.66.0.r306.gaccf5ae-15.66.0.r308.g43d4663-1
                        kcmutils-git5.66.0.r357.gb1fb1c6-15.66.0.r360.g45021ba-1
                         kcodecs-git5.66.0.r289.g7310a34-15.66.0.r291.g1832299-1
                     kcompletion-git5.66.0.r340.gfac1837-15.66.0.r343.g846f686-1
                         kconfig-git5.66.0.r632.g30d271f-15.66.0.r640.gae93e9d-1
                  kconfigwidgets-git5.66.0.r424.ge08df69-15.66.0.r428.g05ea3d2-1
                     kcoreaddons-git5.66.0.r920.g9578a7d-15.66.0.r925.g8bfe934-1
                          kcrash-git5.66.0.r282.gf525730-15.66.0.r283.gde12e2d-1
                     kdbusaddons-git5.66.0.r289.g24c99e8-15.66.0.r290.g2fa4f94-1
                   kde-cli-tools-git5.17.80.r1739.g14fd6b2-15.17.80.r1740.gffdeac0-1
                  kde-gtk-config-git5.17.80.r769.ga23a063-15.17.80.r773.g19ca9f6-1
                    kdeclarative-git5.66.0.r736.g07fb49e-15.66.0.r737.g90e2e2e-1
                            kded-git5.66.0.r291.g28e5ce0-15.66.0.r292.gcef90f9-1
                 kdelibs4support-git5.66.0.r916.g2824c1cb-15.66.0.r917.gde9d7036-1
                kdeplasma-addons-git5.17.80.r8242.gb4047f4d5-15.17.80.r8245.g7ed37a8a9-1
                 kdesignerplugin-git5.66.0.r261.g0d18bbe-15.66.0.r263.gb506809-1
                           kdesu-git5.66.0.r379.g8376e5f-15.66.0.r381.gb1c4649-1
                       kdewebkit-git5.66.0.r214.g0718b05-15.66.0.r215.ga99c992-1
                          kdnssd-git5.66.0.r241.g0461d82-15.66.0.r242.g9075560-1
                       kdoctools-git5.66.0.r517.g36fae95-15.66.0.r519.g5a43b8b-1
                      kemoticons-git5.66.0.r299.ga181311-15.66.0.r301.gf97ebd0-1
                   kfilemetadata-git5.66.0.r671.g6d63278-15.66.0.r673.g852fce9-1
                    kglobalaccel-git5.66.0.r338.g36ecfb6-15.66.0.r340.g8959260-1
                      kguiaddons-git5.66.0.r257.g6fe7a9c-15.66.0.r258.gd838a49-1
                       kholidays-git5.66.0.r835.gce2c2af-15.66.0.r836.g678024f-1
                        khotkeys-git5.17.80.r1973.g25c418a-15.17.80.r1975.gfbdf715-1
                           khtml-git5.66.0.r479.gde69047-15.66.0.r481.ge3f9392-1
                           ki18n-git5.66.0.r365.g584b8fd-15.66.0.r374.g836908f-1
                     kiconthemes-git5.66.0.r403.g874abc8-15.66.0.r405.g6595dd6-1
                       kidletime-git5.66.0.r231.g8c1a725-15.66.0.r232.g56d4c17-1
                   kimageformats-git5.57.0.r255.gce56b97-15.57.0.r256.gb7cd5cd-1
                     kinfocenter-git5.17.80.r1581.gf8342c8-15.17.80.r1584.g6453a9f-1
                           kinit-git5.66.0.r323.g29690cf-15.66.0.r324.g6a4cb9e-1
                             kio-git5.66.0.r3717.ga5b66926-15.66.0.r3735.g92258554-1
                       kirigami2-git5.66.0.r2025.ga298164d-15.66.0.r2028.g6d86da08-1
                     kitemmodels-git5.66.0.r398.g67d0e66-15.66.0.r403.g89e24bd-1
                      kitemviews-git5.66.0.r253.g87b6136-15.66.0.r255.ge707ca0-1
                     kjobwidgets-git5.66.0.r276.ge5ed35c-15.66.0.r277.gbd83f77-1
                             kjs-git5.66.0.r259.g193b54f-15.66.0.r260.g9eb9920-1
                        kjsembed-git5.66.0.r226.g8d6ce91-15.66.0.r228.gc007880-1
                    kmediaplayer-git5.66.0.r222.g6be6a26-15.66.0.r223.g2bddfa5-1
                      knetattach-git5.17.80.r7185.g3309bfdc7-15.17.80.r7224.g22046a9fc-1
                       knewstuff-git5.66.0.r761.gc16f096-15.66.0.r763.g7a142f8-1
                  knotifications-git5.66.0.r483.g84113c3-15.66.0.r485.g8c3bbf9-1
                   knotifyconfig-git5.66.0.r262.g276b5ef-15.66.0.r264.g8e5d1cb-1
                        kpackage-git5.66.0.r555.gcfd1f97-15.66.0.r558.ga5353cb-1
                          kparts-git5.66.0.r368.g43a6d34-15.66.0.r372.g40b3f47-1
                         kpeople-git5.66.0.r1230.g6b3b4d4-15.66.0.r1231.gaf910cb-1
                       kplotting-git5.66.0.r218.ge7addbc-15.66.0.r219.g552ed10-1
                            kpty-git5.66.0.r240.ge538ee7-15.66.0.r241.gcdf5270-1
                           kross-git5.66.0.r264.g4c884f3-15.66.0.r265.g122a0fa-1
                         kscreen-git5.17.80.r1218.g5e9c06f-15.17.80.r1219.g602904a-1
                        kservice-git5.66.0.r713.g2037100-15.66.0.r716.ga265bee-1
                       ksysguard-git5.17.80.r3198.g8690c526-15.17.80.r3202.gbdef3d08-1
                     ktexteditor-git5.66.0.r2299.g973b2ad5-15.66.0.r2303.g6609e4f9-1
                    ktextwidgets-git5.66.0.r290.g49bf62f-15.66.0.r292.ga8b2bf7-1
                 kunitconversion-git5.66.0.r286.ga93d345-15.66.0.r287.g40344df-1
                         kwallet-git5.66.0.r935.gbb4eed3-15.66.0.r937.g3bf7b90-1
                        kwayland-git5.66.0.r968.g123ebd5-15.66.0.r971.gb054f8a-1
                  kwidgetsaddons-git5.66.0.r619.g84d17cb-15.66.0.r620.ge157817-1
                            kwin-git5.17.80.r17584.g054cfc1c8-15.17.80.r17591.gab8563894-1
                   kwindowsystem-git5.66.0.r485.g6e9eb11-15.66.0.r487.g6ab1b7b-1
                         kxmlgui-git5.66.0.r582.g9761d4c-15.66.0.r586.gb834a85-1
                   kxmlrpcclient-git5.66.0.r375.ga3160b72b-15.66.0.r376.g867d2dc35-1
                    libksysguard-git5.17.80.r1757.g161b6c4-15.17.80.r1758.g2ed58ad-1
                           milou-git5.17.80.r667.gdfecda3-15.17.80.r668.g33f31fb-1
                 modemmanager-qt-git5.66.0.r440.gecfee77-15.66.0.r441.g8a1dfb0-1
               networkmanager-qt-git5.66.0.r1022.g9ae07de-15.66.0.r1026.geee95e3-1
                          oxygen-git5.17.80.r4346.g9ab4dc4d-15.17.80.r4349.g435becaf-1
                    oxygen-icons-git5.66.0.r209.g117351e-15.66.0.r210.g0847b87-1
                oxygen-icons-svg-git5.66.0.r209.g117351e-15.66.0.r210.g0847b87-1
      plasma-browser-integration-git5.17.80.r992.g182edeac-15.17.80.r996.g268577a6-1
                  plasma-desktop-git5.17.80.r7185.g3309bfdc7-15.17.80.r7224.g22046a9fc-1
                plasma-framework-git5.66.0.r15327.g6f183b4ce-15.66.0.r15332.g8232ed1b7-1
                       plasma-nm-git5.17.80.r2728.gf372ca18-15.17.80.r2732.g34ce1817-1
                      plasma-sdk-git5.17.80.r2129.gfc9a63c-15.17.80.r2130.g549d9b8-1
          plasma-wayland-session-git5.17.80.r8568.gbd2b9284e-15.17.80.r8585.g4446d687d-1
                plasma-workspace-git5.17.80.r8568.gbd2b9284e-15.17.80.r8585.g4446d687d-1
                      powerdevil-git5.17.80.r2230.g14212f78-15.17.80.r2241.g954c84af-1
                          prison-git5.66.0.r230.gd9b9eb3-15.66.0.r232.g4f89316-1
                         purpose-git5.66.0.r724.g16a4905-15.66.0.r725.ge00c189-1
              qqc2-desktop-style-git5.66.0.r320.gdc33a7c-15.66.0.r322.g5ac3e52-1
                           solid-git5.66.0.r530.g084311a-15.66.0.r532.gcb5a9fe-1
                          sonnet-git5.66.0.r507.g201ece6-15.66.0.r508.g748eecd-1
                     syndication-git5.66.0.r746.ge771230-15.66.0.r747.g35ec20b-1
             syntax-highlighting-git5.66.0.r1058.g6ddf50d-15.66.0.r1059.gb490730-1
                  systemsettings-git5.17.80.r2172.g8aaf43c4-15.17.80.r2175.g6977f90b-1
                    threadweaver-git5.66.0.r424.gd251299-15.66.0.r425.gf4ff8e0-1
                    user-manager-git5.17.80.r466.g39ce0e8-15.17.80.r468.g339fb64-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-01-05           2020-01-06
-------------------------------------------------------------------------------
                              bslizr              1.2.2-1              1.2.4-1
                       cabal-install          2.4.0.0-177          2.4.0.0-178
                              ccache              3.7.6-1              3.7.7-1
                     cloudprint-cups 1:20160502.r16.g1f27903-2               -
                               darcs           2.14.2-148           2.14.2-149
                             freeciv              2.6.0-3              2.6.1-1
                           git-annex         7.20191230-3         7.20191230-5
                haskell-authenticate             1.3.5-18             1.3.5-19
          haskell-authenticate-oauth            1.6.0.1-9           1.6.0.1-11
                         haskell-aws           0.21.1-140           0.21.1-141
               haskell-basic-prelude              0.7.0-1              0.7.0-2
                  haskell-cheapskate          0.1.1.1-110          0.1.1.1-111
               haskell-cipher-aes128            0.7.0.4-7            0.7.0.5-1
              haskell-classy-prelude              1.5.0-1              1.5.0-2
               haskell-conduit-extra             1.3.4-34             1.3.4-35
                   haskell-criterion          1.5.5.0-103          1.5.5.0-104
          haskell-cryptohash-conduit            0.1.1-324            0.1.1-325
          haskell-cryptonite-conduit            0.2.2-218            0.2.2-219
                         haskell-dav            1.3.3-132              1.3.4-1
                        haskell-dbus             1.2.7-62             1.2.7-63
             haskell-dlist-instances            0.1.1.1-1            0.1.1.1-2
                        haskell-drbg             0.5.5-72             0.5.5-73
                   haskell-esqueleto             3.3.0-11             3.3.0-12
                  haskell-fdo-notify            0.3.1-222            0.3.1-223
                        haskell-feed           1.2.0.1-24           1.2.0.1-25
               haskell-fold-debounce            0.2.0.9-2            0.2.0.9-3
                     haskell-githash           0.1.3.3-15           0.1.3.3-16
                      haskell-hakyll         4.12.5.2-155         4.12.5.2-156
                    haskell-hopenpgp               2.9-15               2.9-16
                       haskell-hpack            0.33.0-28            0.33.0-29
                   haskell-hspec-wai             0.9.2-88             0.9.2-89
              haskell-hspec-wai-json            0.9.2-100            0.9.2-101
                haskell-html-conduit           1.3.2.1-24           1.3.2.1-25
                        haskell-http         4000.3.14-72         4000.3.14-73
                 haskell-http-client             0.6.4-35             0.6.4-36
             haskell-http-client-tls          0.3.5.3-150          0.3.5.3-151
                haskell-http-conduit           2.3.7.3-32           2.3.7.3-33
               haskell-http-download            0.1.0.1-7            0.1.0.1-8
                   haskell-js-jquery            3.3.1-316            3.3.1-317
                haskell-monad-logger            0.3.31-20            0.3.31-21
  haskell-mono-traversable-instances            0.1.0.0-1            0.1.0.0-2
                    haskell-mustache            2.3.0-265            2.3.0-267
          haskell-mutable-containers              0.3.4-1              0.3.4-2
             haskell-optparse-simple           0.1.1.2-92           0.1.1.2-93
                      haskell-pantry           0.1.1.1-91           0.1.1.1-92
                  haskell-persistent            2.10.4-23            2.10.4-24
               haskell-persistent-qq            2.9.1-103            2.9.1-104
           haskell-persistent-sqlite            2.10.5-49            2.10.5-50
         haskell-persistent-template             2.7.3-28             2.7.3-29
             haskell-persistent-test           2.0.3.0-54           2.0.3.0-55
                  haskell-pipes-http             1.0.6-62             1.0.6-63
            haskell-project-template          0.2.0.1-188          0.2.0.1-189
                 haskell-rio-orphans           0.1.1.0-47           0.1.1.0-48
                         haskell-rsa             2.3.1-39             2.3.1-40
                         haskell-say            0.1.0.1-2            0.1.0.1-3
              haskell-servant-server            0.16.2-61            0.16.2-62
                       haskell-shake            0.18.4-14            0.18.4-15
             haskell-simple-sendfile            0.2.30-17            0.2.30-18
           haskell-streaming-commons           0.2.1.1-17            0.2.1.2-1
           haskell-tagstream-conduit          0.5.5.3-313          0.5.5.3-314
                 haskell-tar-conduit             0.3.2-35             0.3.2-36
           haskell-test-framework-th              0.2.4-1              0.2.4-2
                      haskell-turtle            1.5.15-14            1.5.15-15
                          haskell-tz            0.1.3.3-3            0.1.3.3-4
                      haskell-tzdata     0.1.20190325.0-1     0.1.20190325.0-2
              haskell-wai-app-static          3.1.6.3-141          3.1.6.3-142
                   haskell-wai-extra            3.0.28-30            3.0.28-31
          haskell-wai-handler-launch          3.0.2.4-251          3.0.2.4-252
                  haskell-wai-logger             2.3.6-11             2.3.6-12
              haskell-wai-websockets          3.0.1.2-108          3.0.1.2-109
                        haskell-warp             3.3.5-12             3.3.5-13
                    haskell-warp-tls             3.2.9-12             3.2.9-13
                  haskell-websockets          0.12.5.3-39          0.12.5.3-40
                        haskell-wreq          0.5.3.2-102          0.5.3.2-104
                 haskell-xml-conduit          1.8.0.1-106          1.8.0.1-107
                  haskell-xml-hamlet           0.5.0.1-29           0.5.0.1-30
                       haskell-yesod            1.6.0-398            1.6.0-399
                  haskell-yesod-auth             1.6.8-71             1.6.8-72
                  haskell-yesod-core            1.6.17-17            1.6.17-18
               haskell-yesod-default            1.2.0-634            1.2.0-635
                  haskell-yesod-form             1.6.7-57             1.6.7-58
            haskell-yesod-persistent            1.6.0.4-2            1.6.0.4-3
                haskell-yesod-static          1.6.0.1-254          1.6.0.1-255
                  haskell-yesod-test             1.6.9-17             1.6.9-18
                         hledger-web              1.16-12              1.16-13
                              hoogle         5.0.17.11-49         5.0.17.11-50
                      hopenpgp-tools              0.23-15              0.23-16
                               idris             1.3.2-45             1.3.2-46
                           imagescan             3.61.0-1             3.61.0-2
                             ipvsadm               1.30-1               1.31-1
                          libalkimia              8.0.2-1              8.0.2-2
                            lollypop             1.2.18-1             1.2.19-1
                              magnum            2019.01-1            2019.10-1
                      magnum-plugins            2019.01-2            2019.10-1
                             mailman             2.1.29-1             2.1.29-2
                              pandoc               2.8-12               2.8-13
                     pandoc-citeproc           0.16.4.1-8           0.16.4.1-9
                     pandoc-crossref           0.3.5.0-12           0.3.5.0-13
                            phonegap              8.2.2-2              8.2.2-3
                           postgrest             6.0.2-18             6.0.2-19
                                ptex              2.3.0-1              2.3.0-2
                               pyenv             1.2.15-1             1.2.16-1
                python-aiohttp-socks              0.2.2-3              0.3.3-1
                      python-axolotl              0.2.3-2              0.2.3-3
                     python-billiard            3.6.1.0-3            3.6.1.0-4
                   python-colorclass              2.2.0-5              2.2.0-6
                      python-cypari2              2.1.1-2              2.1.1-3
                      python-expects              0.9.0-3              0.9.0-4
                  python-flask-login              0.4.1-3              0.4.1-4
                    python-flask-wtf             0.14.2-4             0.14.2-5
                       python-fpylll           0.5.1dev-1           0.5.1dev-2
                   python-hypothesis             4.54.2-1             4.54.2-2
                       python-josepy              1.2.0-3              1.2.0-4
                  python-lark-parser              0.7.8-3              0.7.8-4
                  python-librabbitmq              2.0.0-3              2.0.0-4
                      python-logbook              1.5.3-3              1.5.3-4
                      python-markups              3.0.0-7              3.0.0-8
                        python-paste              3.2.3-1              3.2.4-1
                      python-pymongo             3.10.0-1             3.10.0-2
                        python-pysmi              0.3.4-3              0.3.4-4
        python-pytest-fixture-config              1.7.0-3              1.7.0-4
                python-pytest-shutil              1.7.0-3              1.7.0-4
            python-pytest-virtualenv              1.7.0-3              1.7.0-4
                python-sparqlwrapper              1.8.4-2              1.8.5-1
          python-zope-deferredimport              4.3.1-3              4.3.1-4
                python-zope-location                4.2-3                4.2-4
                  python2-hypothesis             4.54.2-1             4.54.2-2
                 python2-lark-parser              0.7.8-3                    -
                       python2-paste              3.2.3-1              3.2.4-1
                     python2-pymongo             3.10.0-1             3.10.0-2
                                qcad           3.24.0.0-1           3.24.1.0-1
                     ruby2.5-bundler              2.1.3-1              2.1.4-1
                          shellcheck             0.7.0-86             0.7.0-87
                            singular           4.1.2.p2-4           4.1.2.p2-5
                                 sk1           1:2.0rc4-4                    -
                               stack            2.1.3-106            2.1.3-108
                          strawberry              0.6.7-2              0.6.8-1
                      tamarin-prover            1.4.1-216            1.4.1-217
                             taskell            1.9.0.0-2            1.9.0.0-4
         v2ray-domain-list-community       202001050350-1       202001060909-1
                      wireguard-dkms       0.0.20191226-1       0.0.20200105-1
                              xmobar              0.31-41              0.31-42


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-01-05           2020-01-06
-------------------------------------------------------------------------------
                                mhwd             0.6.3-15              0.6.4-1
                             mhwd-db             0.6.3-16              0.6.4-3


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-01-05           2020-01-06
-------------------------------------------------------------------------------
                                grep                3.3-3                3.4-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-01-05           2020-01-06
-------------------------------------------------------------------------------
                  linux419-acpi_call             1.1.0-82             1.1.0-83
                   linux419-bbswitch               0.8-82               0.8-83
                linux419-broadcom-wl      6.30.223.271-81      6.30.223.271-82
                linux419-ndiswrapper              1.62-31              1.62-32
               linux419-nvidia-340xx            340.108-2            340.108-3
               linux419-nvidia-390xx           390.132-11           390.132-12
               linux419-nvidia-418xx           418.113-10           418.113-11
               linux419-nvidia-430xx            430.64-10            430.64-11
               linux419-nvidia-435xx            435.21-21            435.21-22
               linux419-nvidia-440xx             440.44-5             440.44-6
                   linux419-nvidiabl              0.88-81              0.88-82
                      linux419-r8168           8.047.05-7           8.047.05-8
                  linux419-rtl8723bu   4.3.9.3.13200.0-66   4.3.9.3.13200.0-67
                   linux419-tp_smapi              0.43-31              0.43-32
                linux419-vhba-module          20190831-21          20190831-22
   linux419-virtualbox-guest-modules              6.1.0-5              6.1.0-6
    linux419-virtualbox-host-modules              6.1.0-5              6.1.0-6
                        linux419-zfs             0.8.2-17             0.8.2-18
              manjaro-tools-base-git      r2852.699d178-1      r2853.3ff82a8-1
               manjaro-tools-iso-git      r2852.699d178-1      r2853.3ff82a8-1
               manjaro-tools-pkg-git      r2852.699d178-1      r2853.3ff82a8-1
              manjaro-tools-yaml-git      r2852.699d178-1      r2853.3ff82a8-1
                           pamac-cli          9.3.0beta-1          9.3.0beta-3
                        pamac-common          9.3.0beta-1          9.3.0beta-3
                           pamac-gtk          9.3.0beta-1          9.3.0beta-3
                   pamac-snap-plugin          9.3.0beta-1          9.3.0beta-3
             pamac-tray-appindicator          9.3.0beta-1          9.3.0beta-3
                               snapd             2.42.4-1             2.42.5-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-01-05           2020-01-06
-------------------------------------------------------------------------------
                        arch-signoff                0.3-2                0.4-1
                                gcab                1.3-1                1.4-1
                      gnome-contacts               3.34-1             3.34.1-1
                         gnome-notes             3.34.1-1             3.34.2-1
                               irssi              1.2.2-1              1.2.2-2
                             libgusb              0.3.1-1              0.3.1-2
                            libinput             1.14.3-1             1.15.0-1
                           mercurial                5.2-1              5.2.1-1
                               nginx             1.16.1-1             1.16.1-2
              postgresql-old-upgrade               11.6-1               11.6-2
                        pyqt-builder              1.1.0-1              1.2.0-1
                        python-pyqt5             5.14.0-3             5.14.1-1
                      python2-django            1.11.27-1                    -
                       python2-pyqt5             5.14.0-3             5.14.1-1
                                sane             1.0.28-2             1.0.28-3
                            seahorse             1:3.34-2           1:3.34.1-1
                                sip5              5.0.1-1              5.1.0-1
                            xvidcore              1.3.6-1              1.3.7-1
                           nginx-src                    -             1.16.1-2
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

9 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Do I need to downgrade systemd?

Not necessarily. If systemd 244.1-1.1 works fine for you, you can keep it. If you have issues related to systemd, of course, you may want to downgrade the packages related to systemd.

This is valid until Manjaro Team says otherwise. If the team asks everyone to downgrade the packages for a reason or another, do it.

From philm:

Pamac: I can't build AUR packages

Before anything else, please verify in /etc/pamac.conf if BuildDirectory is set up correctly. For example:

## AUR build directory:
BuildDirectory = /var/tmp

If you have something like /var or / instead, you might have been affected by the following bug. A bug in Pamac "corrupted" the value of BuildDirectory, which ultimately leads to a directory that Pamac can't write in (to create a directory) because the user does not have the permission to do so, hence why Pamac failed to build AUR packages.

This bug should be fixed by now in Pamac 9.2.0rc, but users affected by the bug have to change back this parameter to a correct value manually, which can be done either with a text editor by editing /etc/pamac.conf OR graphically within Pamac GTK by going in Preferences > AUR.

pacman-mirrors

just got the updates. tested pamac reinstalling firefox and was asked for my password. all's good here. thanks

1 Like

Hum is it me or pamac doesn't ask for any password for going on with the updates. I think it is from the previous update. It should, yes ?

Added some more updates:

:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-01-05           2020-01-06
-------------------------------------------------------------------------------
                      guayadeque 0.4.6.r2121.85c97c95-2 0.4.6.r2123.71b5e350-1
                         keyboardctl              0.1.6-2                    -
                         locale-info               2.21-3                    -


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-01-05           2020-01-06
-------------------------------------------------------------------------------
                       linux55 5.5rc4.d1229.gfd69884-1 5.5rc5.d0105.gc79f46a-1
               linux55-headers 5.5rc4.d1229.gfd69884-1 5.5rc5.d0105.gc79f46a-1
                             mhwd-db              0.6.4-3              0.6.4-4


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-01-05           2020-01-06
-------------------------------------------------------------------------------
                   linux55-acpi_call            1.1.0-0.5            1.1.0-0.7
                    linux55-bbswitch              0.8-0.5              0.8-0.7
                 linux55-broadcom-wl     6.30.223.271-0.5     6.30.223.271-0.7
                linux55-nvidia-390xx          390.132-0.5          390.132-0.7
                linux55-nvidia-418xx          418.113-0.3          418.113-0.7
                linux55-nvidia-430xx           430.64-0.5           430.64-0.7
                linux55-nvidia-435xx           435.21-0.5           435.21-0.7
                linux55-nvidia-440xx           440.44-0.5           440.44-0.7
                    linux55-nvidiabl             0.88-0.5             0.88-0.7
                       linux55-r8168         8.047.05-0.5         8.047.05-0.7
                   linux55-rtl8723bu    4.3.9.3.13200-0.5    4.3.9.3.13200-0.7
                    linux55-tp_smapi             0.43-0.5             0.43-0.7
                 linux55-vhba-module         20190831-0.5         20190831-0.7
    linux55-virtualbox-guest-modules            6.1.0-0.5            6.1.0-0.7
     linux55-virtualbox-host-modules            6.1.0-0.5            6.1.0-0.7

Yes, it is from the previous one. After this one it should be ok again.

This is fixed with this update

Indeed. This bug has been fixed, and with pamac 9.3.0beta-3, Pamac should ask you for your password in order to do transactions again.

Ok thanks for the multiples responses :grin:, it does now. The logic is a bit different it seems. When I click update, it does a bunch of things before asking for a password. It's different then before when a password was ask BEFORE doing anything.

Would my 1050 Ti even be supported by 435/440? Since mhwd always installed 430.

It installs on my NVIDIA GP107M [GeForce GTX 1050 Mobile], no idea what benefits it'll give me.
If you get errors about bumblebee, remove via the hardware settings

Do you have tearing problems? Last time I tried installing this stuff on my own I couldn't get rid of the tearing since the intel options didn't work anymore.

Yes, it's supported. Enjoy prime!

1 Like

I haven't tested it much, if at all.
Kinda busy, but I did check to see if nvidia was working (handbrake nvec x265 convert, I'm sure there are easier ways, but habit has me using this to check. And it worked fine.)
And I've seen no tearing in virtual desktop in KDE Plasma (desktop 1 to 2 to 3 to 4 to 1 via hotkeys)

1 Like

Afaik kde comes with a compositor. I was asking because I don't want to rely on compositing.

Tearing is still the main issue for me when using the discrete GPU as the main renderer with PRIME on any compatible nvidia proprietary driver version provided by Manjaro. Thankfully I don't have any issue with the PRIME Offload method, even though it is not power efficient at all on pre-Turing GPU.

You're also running KDE.

still a issue with pamac. just was informed that topgrade had a update. clicked on apply and it updated / built the new version THEN asked for my password.

This is an AUR package, the authentication is only needed for installing the newly built package after downloading/building..

1 Like

ok maybe the actual install was so fast i didn't notice it after enter my password. i'll keep a close eye on the next one. thanks

Forum kindly sponsored by