[Testing Update] 2019-12-06 - Kernels, Mesa, Firefox, KDE-git

Was something wrong with breath theme ?

image

Congrats on the wedding!

So far so good, XFCE with Cleanjaro kernel. Latest MESA seems to be working well too. Only played around 5 minutes of Stellaris, but that 5 minutes was fine.

All is well and happy here.
Though I am also curious about the breath theme.

Have noticed that the DKMS virtualbox-guest-modules returns an error on Arch with Latest 419 Kernel. Is there a way to fix or has virtualbox dropped the support for the 419?

A post was merged into an existing topic: Congratulations to Philm and Trang

octopi 0.9.0-20 solved my issue with octopi cache cleaner... now it works fine. Thanks guys

no issues so far on KDE for me :slight_smile:

Is this the root cause of:

Was an Error like this:

==> dkms install vboxhost/5.2.22_OSE -k 4.14.88-1-lts
Error! Bad return status for module build on kernel: 4.14.88-1-lts (x86_64)
Consult /var/lib/dkms/vboxhost/5.2.22_OSE/build/make.log for more information

But on the newest 4.19 on arch

Have a nice wedding day!

Nothing broken till now.

The update itself went fine, but i'm just mentioning an ongoing bug existing [Manjaro & Arch, at least] ever since systemd left v242 & became v243 & v244.

Summary

7/12/19: Once again i have had to downgrade systemd back to the last version before 243. All 243 & 244 versions still conflict with the firejail firetools utility fstats such that with >242 + fstats open + application windows open like thunderbird & firefox [including Dev & Nightly], cpu% continuously spikes to ~80%, passing continually from core to core, together with cpu temperature rising by many degrees above normal. No such bug exists with systemd <243. This is definitely an upstream bug, not Manjaro's or Arch's.

select a package by number: 29
 systemd-242.84-2-x86_64                                  4.6 MiB  1469 KiB/s 00:03 [################################################] 100%
 systemd-242.84-2-x86_64.sig                            310.0   B  0.00   B/s 00:00 [################################################] 100%
loading packages...
warning: downgrading package systemd (243.162-2 => 242.84-2)
resolving dependencies...
looking for conflicting packages...

Package (1)  Old Version  New Version  Net Change

systemd      243.162-2    242.84-2      -0.48 MiB

Total Installed Size:  20.60 MiB
Net Upgrade Size:      -0.48 MiB

:: Proceed with installation? [Y/n]  Y

Previously:

Reproducible crash during shutdown.

Toady I saw that my PC shows a core dump short before finishing the shutdown. The only trace in the log is this entry:

Dez 07 08:46:48 rakete kernel: systemd-shutdow: 65 output lines suppressed due to ratelimiting

It is all going very fast so I had to film the shutdown. The first thing I see are these errors:

I see them for kernel 5.4.2 and 4.19.88. But the following core dump only happens with kernel 5.4.2:

Any idea what that is? Looks like a systemd issue which is causing kernel 5.4.2 to crash.


System:    Host: rakete Kernel: 4.19.88-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: Xfce 4.14.1 
           tk: Gtk 3.24.12 info: xfce4-panel wm: xfwm4 dm: GDM 3.34.1, LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: Micro-Star model: MPG X570 GAMING EDGE WIFI (MS-7C37) v: 1.0 serial: <root required> 
           UEFI: American Megatrends v: 1.60 date: 11/06/2019 
CPU:       Topology: 8-Core model: AMD Ryzen 7 3700X bits: 64 type: MT MCP arch: Zen L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 115233 
           Speed: 4337 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 1: 4130 2: 3950 3: 3499 4: 4004 5: 3545 
           6: 3957 7: 3588 8: 3544 9: 3523 10: 3518 11: 3522 12: 3808 13: 3535 14: 3562 15: 3840 16: 3865 
Graphics:  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: Gigabyte driver: nvidia v: 440.36 bus ID: 2d:00.0 
           chip ID: 10de:1c82 
           Display: x11 server: X.Org 1.20.6 driver: nvidia resolution: 2560x1440~60Hz 
           OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 440.36 direct render: Yes 
Audio:     Device-1: NVIDIA GP107GL High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 2d:00.1 
           chip ID: 10de:0fb9 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: Micro-Star MSI driver: snd_hda_intel 
           v: kernel bus ID: 2f:00.4 chip ID: 1022:1487 
           Sound Server: ALSA v: k4.19.88-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 v: kernel 
           port: d000 bus ID: 27:00.0 chip ID: 10ec:8168 
           IF: enp39s0 state: up speed: 1000 Mbps duplex: full mac: 00:d8:61:9d:02:43 
           Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel port: d000 bus ID: 29:00.0 
           chip ID: 8086:24fb 
           IF: wlp41s0 state: down mac: d4:d2:52:f7:15:ca 
Drives:    Local Storage: total: 15.46 TiB used: 5.52 TiB (35.7%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 1TB size: 931.51 GiB speed: 31.6 Gb/s lanes: 4 
           serial: S4EWNG0M201473P rev: 2B2QEXM7 temp: 47 C scheme: GPT 
           ID-2: /dev/sda vendor: Western Digital model: WD40EZRZ-00WN9B0 size: 3.64 TiB speed: 6.0 Gb/s rotation: 5400 rpm 
           serial: WD-WCC4E1SSP28F rev: 0A80 temp: 31 C scheme: GPT 
           ID-3: /dev/sdb vendor: Western Digital model: WD40EZRZ-00GXCB0 size: 3.64 TiB speed: 6.0 Gb/s rotation: 5400 rpm 
           serial: WD-WCC7K7EK9VC4 rev: 0A80 temp: 29 C scheme: GPT 
           ID-4: /dev/sdc vendor: Western Digital model: WD40EZRZ-00WN9B0 size: 3.64 TiB speed: 6.0 Gb/s rotation: 5400 rpm 
           serial: WD-WCC4E5HF3P4S rev: 0A80 temp: 31 C scheme: GPT 
           ID-5: /dev/sdd vendor: Western Digital model: WD40EZRZ-00WN9B0 size: 3.64 TiB speed: 6.0 Gb/s rotation: 5400 rpm 
           serial: WD-WCC4E1SSP6NC rev: 0A80 temp: 32 C scheme: GPT 
RAID:      Device-1: zstore type: zfs status: ONLINE size: 7.25 TiB free: 824.00 GiB allocated: 6.45 TiB 
           array-1: mirror status: ONLINE size: 3.62 TiB free: 410.00 GiB Components: online: N/A 
           array-2: mirror status: ONLINE size: 3.62 TiB free: 414.00 GiB Components: online: N/A 
Partition: ID-1: / size: 58.57 GiB used: 44.02 GiB (75.2%) fs: xfs dev: /dev/nvme0n1p2 
           ID-2: /home size: 871.99 GiB used: 559.48 GiB (64.2%) fs: xfs dev: /dev/nvme0n1p3 
           ID-3: /opt size: 814.93 GiB used: 222.92 GiB (27.4%) fs: zfs raid: zstore/opt 
Unmounted: ID-1: /dev/sda1 size: 3.64 TiB fs: zfs_member label: zstore uuid: 14393956364711311496 
           ID-2: /dev/sda9 size: 8.0 MiB fs: <root required> label: N/A uuid: N/A 
           ID-3: /dev/sdb1 size: 3.64 TiB fs: zfs_member label: zstore uuid: 14393956364711311496 
           ID-4: /dev/sdb9 size: 8.0 MiB fs: <root required> label: N/A uuid: N/A 
           ID-5: /dev/sdc1 size: 3.64 TiB fs: zfs_member label: zstore uuid: 14393956364711311496 
           ID-6: /dev/sdc9 size: 8.0 MiB fs: <root required> label: N/A uuid: N/A 
           ID-7: /dev/sdd1 size: 3.64 TiB fs: zfs_member label: zstore uuid: 14393956364711311496 
           ID-8: /dev/sdd9 size: 8.0 MiB fs: <root required> label: N/A uuid: N/A 
Sensors:   System Temperatures: cpu: 52.8 C mobo: N/A gpu: nvidia temp: 56 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:      Processes: 447 Uptime: 6m Memory: 31.42 GiB used: 2.32 GiB (7.4%) Init: systemd v: 243 Compilers: gcc: 9.2.0 
           clang: 9.0.0 Shell: zsh v: 5.7.1 running in: tilix inxi: 3.0.37

EDIT:
It looks like it is a reoccurrence of this issue:

EDIT 2:
I downgraded to

systemd 242.84-2
systemd-libs 242.84-2

It does not show any errors or crashes.

2 Likes

To be honest, I feel a little disappointed that you've abused your position to use this forum for your family announcements. Believe it or not, some of us did not come here to discuss your family situation. Manjaro is a group effort and I clicked on this post to read about a testing update, not your personal life. Congratulations from those who are interested are in order but would have been appropriate in a separate forum post, not in the text of a testing update post. It's not that I don't care, I'm happy that you're happy, it's just not the right place and I feel it's an abuse of our trust. Also, I think marriage is an outdated social institution that I don't believe in.

Let's celebrate Phil's and Trang's wedding today

It feels like I'm expected to be involved in or interested in something when I consented to no such thing. It feels like a violation and an imposition. So just for the record, I don't care about your wedding and it has nothing to do with me.

Edit: Ok, so upon reflection, I think that it's ok for someone to add a personal note to there post and is actually a nice thing or even just to talk about personal stuff, we are humans after all. What I think I objected to specifically was the wording of the caption under the picture. "Let's celebrate Phil's and Trang's wedding today" sounds more like an instruction rather than an opinion or a point of information. I hope I didn't hurt anyone's feelings.

1 Like

Scrolling with Firefox and Chromium is both choppy on kernel 5.3 since this update.
All is fine with kernel 4.19.

Looks ok here, both ... but I am using Brave now.
K 5.3.15

There is no i18n-pl updated package for firefox 71 :frowning:
Other languages are there.

Isn't it this one:

pamac search firefox-i18n-pl 
firefox-i18n-pl                                 71.0-1  extra 
Polish language pack for Firefox

?

1 Like

Yes, I have in testing firefox-i18n-pl 70.0.1-1. I guess I have to refresh mirrors.

There is problem with pamac. If a package is put on ignore list, it doesn't show that there is a newer version of the package. This is harmful behaviour. I may not want it to be updated automatically but I may want to see the newer version and update it manually. Octopi allowed for that, pamac idoesn't :frowning:.

EDIT: Why can't I update the package by using sudo pacman -S package_name?
It asks if I want to install it despite it being on ignore list. Usually when I said Y it was upgrading the package. This time it reinstalled the old version.
What gives? How can I manually upgrade a package from ignore group? Is it a pamac bug?

EDIT 2: Weird, it took few minutes for system to catch on... Now it shows the new version. Directly after the update, firefox was still unable to use it, and I was shown the old version. This is first time I see such weird behavior.
Anyway, all is good now. :thinking:

A post was merged into an existing topic: Congratulations to Philm and Trang

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by