[Testing Update] 2019-11-23 - Python 3.8, ICU and Poppler rebuilds - BREAKAGE expected!

Hello community,

I am happy to announce another Testing Update.

With this we most likely have BREAKAGE in several packages due to the python 3.8, poppler and ICU rebuilds by upstream. It might take a while until we find time to stablize testing branch again. So please explain precisely what issues you may have with this update, if any.

Some feature-updates:

  • python 3.8, poppler and icu rebuilds by Arch
  • we dropped catalyst driver for good
  • LibreOffice is now at 6.3.3
  • Brave-Browser launched it first stable release
  • the usual upstream fixes.

If you like following latest Plasma development you may also like to check out our current version of mnjaro-kde-vanilla, which we build on a regular basis against kde-git master packages.

As always we appreciate your input and feedback for the updates.


Our current supported kernels:

  • linux316 3.16.76
  • linux44 4.4.202
  • linux49 4.9.202
  • linux414 4.14.155
  • linux419 4.19.85
  • linux53 5.3.12
  • linux54 5.4.0-rc8 (not all modules build yet!)
  • linux419-rt 4.19.72_rt26
  • linux52-rt 5.2.21_rt13

Package Changes (Sat Nov 23 10:03:13 CET 2019)

  • testing community x86_64: 2786 new and 2765 removed package(s)
  • testing core x86_64: 200 new and 202 removed package(s)
  • testing extra x86_64: 580 new and 591 removed package(s)
  • testing multilib x86_64: 16 new and 19 removed package(s)

A detailed list of all packages changes may be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

12 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Post your errors and solutions (if you have any)

NOTE: If you are thinking - I downgrade the icu - DON'T - because you can - we tried with bad results. Systems may go into an endless loop. A downgrade will also make gtk apps fail with library errors.

Repo packages depending on icu

Manjaro packages depeding on icu

  • manjaro-settings-manager (icu 65) :white_check_mark: rebuilt @philm
  • boxit (icu 65) :white_check_mark: rebuilt @philm

Python rebuilds

Potential Overlay packages needing rebuild:

community branch
extra branch :white_check_mark:
core branch :white_check_mark:

Possible Overlay packages

  • menulibre (python 3.8) :white_check_mark:
  • cinnamon-settings :white_check_mark:
  • cinnamon-panel :white_check_mark:
6 Likes

All ship shape here C'pitan. Though i am on unstable i guess so my input doesnt count so much

467 packages updated :open_mouth:

Few warnings:

Warning: dependency cycle detected:
Warning: bashrc-manjaro will be installed before its bash dependency
Warning: mlocate: directory permissions differ on /var/lib/mlocate/filesystem: 750  package: 755

Rebooting now. Let's see what happens :wink:

edit Back in business, no issues so far :slight_smile:

1 Like

I am using unstable repo and I have a breakage in Bauh related to python 3.8:

$ bauh --help
Traceback (most recent call last):
File "/usr/bin/bauh", line 6, in
from pkg_resources import load_entry_point
File "/usr/lib/python3.8/site-packages/pkg_resources/init.py", line 3251, in
def _initialize_master_working_set():
File "/usr/lib/python3.8/site-packages/pkg_resources/init.py", line 3234, in _call_aside
f(*args, **kwargs)
File "/usr/lib/python3.8/site-packages/pkg_resources/init.py", line 3263, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python3.8/site-packages/pkg_resources/init.py", line 583, in _build_master
ws.require(requires)
File "/usr/lib/python3.8/site-packages/pkg_resources/init.py", line 900, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.8/site-packages/pkg_resources/init.py", line 786, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'bauh==0.7.0' distribution was not found and is required by the application

1 Like

that's weird i just checked an bauh is a community package and is at release 0.7.0-1

maybe try to uninstall bauh and then reinstall it?

Na, we didn't updated bauh yet ...

1 Like

Finally!

5 Likes

Rebuild of bauh against python 3.8 added.

2 Likes

Some AUR packages which require python were broken since it has gotten a major upgrade, and the path to site-packages has been changed. Got them fixed with this one-liner:

yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

This command requires expac as I'm too lazy to use awk :slight_smile:

2 Likes

Lutris-git didnt work. You need to do this to get lutris to work:

sudo mv /usr/lib/python3.7/site-packages/lutris* /usr/lib/python3.8/site-packages/

1 Like

I tried your command but expac is givging a lib error:

expac: error while loading shared libraries: libalpm.so.11: cannot open shared object file: No such file or directory

But the library is existing:

63# locate libalpm.so.11 
/var/lib/manjaro-tools/buildpkg/stable/x86_64/root/usr/lib/libalpm.so.11
/var/lib/manjaro-tools/buildpkg/stable/x86_64/root/usr/lib/libalpm.so.11.0.3

Any idea what is wrong?

It's probably looking in /usr/lib ..


The second post speaks of a problem only occuring on ARM platform, x86_64 is not affected.

I tried and lutris started without issues or necessary workarounds. Currently playing WoW with Lutris. What exactly did not work on your end?

Smooth update. Rebooted, and found and removed orphans:

$ sudo pacman -Rsn $(pacman -Qqdt)
[sudo] password for mparillo: 
checking dependencies...

Packages (3) python-shiboken2-5.13.2-3  mhwd-catalyst-1:15.201.1151-2  pyside2-5.13.2-2

Re-booted and no immediate breakage noticed.

Orphans:

sudo pacman -Qdt
libplacebo 1.21.0-1
mhwd-catalyst 1:15.201.1151-2

sudo pacman -Rsn $(pacman -Qqdt)
glslang-7.13.3496-1 
shaderc-2019.0-3  
spirv-tools-2019.3-2
libplacebo-1.21.0-1
mhwd-catalyst 1:15.201.1151-2

is there any difference between the old aufs patch and the aufs5.3-20191021.patch missing from the repo?

Packages (23) compiler-rt-9.0.0-2 diffstat-1.62-1 docbook-xml-4.5-8
glslang-7.13.3496-1 rarian-0.8.1-7 shaderc-2019.0-3
spirv-tools-2019.3-2 wxgtk-common-3.0.4-2 clang-9.0.0-3
gn-0.1576.81ee1967-1 gnome-doc-utils-0.20.10+16+gc03cc09-2
gperf-3.1-2 intltool-0.51.0-4 libplacebo-1.21.0-1 lld-9.0.0-1
mathjax-3.0.0-1 mhwd-catalyst-1:15.201.1151-2 ninja-1.9.0-1
python-attrs-19.3.0-3 quilt-0.66-1 w3m-0.5.3.git20190105-1
wxgtk2-3.0.4-2 yasm-1.3.0-3

it's safe to remove these?

Forum kindly sponsored by