[Testing Update] 2019-10-27 - KDE-Git, Nvidia, Xorg-Server

Hello community,

I am happy to announce another Testing Update. Mostly we have updates for Pacman 5.2 release.


Tell us about the default layout we should use for Gnome

Update news

This update holds the following changes:

  • KDE-Git packages got updated
  • Nvidia 440.26 driver got added to mhwd
  • Fixes for Intel within Xorg-Server
  • The usual updates and improvements and upstream package renewals
  • Manjaro 18.1.2-pre1 got released! Please test and give us feedback: gnome, kde, xfce
  • Latest efforts by KDE can be reviewed via our current KDE-Dev ISO or current KDE-Vanilla ISO

Give us the usual feedback and let us know what you think about this update.


Current supported Kernels

  • linux316 3.16.75
  • linux44 4.4.197 (no legacy nvidia-340 module!)
  • linux49 4.9.197
  • linux414 4.14.150
  • linux419 4.19.80
  • linux52 5.2.21 [EOL] (no catalyst module!)
  • linux53 5.3.7 (no catalyst module!)
  • linux54 5.4.0-rc4 (not all modules build yet!)
  • linux419-rt 4.19.72_rt26
  • linux52-rt 5.2.21_rt13

Package Changes (Sun Oct 27 11:38:57 CET 2019)

  • testing community x86_64: 264 new and 258 removed package(s)
  • testing core x86_64: 4 new and 5 removed package(s)
  • testing extra x86_64: 118 new and 166 removed package(s)
  • testing multilib x86_64: 3 new and 1 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-25           2019-10-27
-------------------------------------------------------------------------------
                          attica-git5.64.0.r718.g975c7de-15.64.0.r720.gc2cf236-1
                           baloo-git5.64.0.r2657.g59736f07-15.64.0.r2659.g2076190c-1
                           bettercap               2.26-1             2.26.1-1
                        bluez-qt-git5.64.0.r562.ga8630fd-15.64.0.r564.gd543051-1
                    breeze-icons-git5.64.0.r1417.ga51651fd-15.64.0.r1420.g8732c6a9-1
                               cpu-x             3.2.4-15             3.2.4-16
                        discover-git5.17.80.r7405.g62d595f2-15.17.80.r7414.g5d1b3718-1
                         drkonqi-git5.17.80.r444.gf7125e4e-15.17.80.r449.gfff04078-1
             extra-cmake-modules-git5.64.0.r3106.gd5ff844-15.64.0.r3109.gfd6e98b-1
            frameworkintegration-git5.64.0.r479.g4642047-15.64.0.r480.g5f45eb0-1
                     kactivities-git5.64.0.r1250.g8ece826d-15.64.0.r1252.g41f1aa00-1
               kactivities-stats-git5.64.0.r249.g196b045-15.64.0.r250.g61ece45-1
               kactivitymanagerd-git5.15.80.r1242.gb0f3ce6-15.15.80.r1243.gc7286de-1
                        karchive-git5.64.0.r386.gbd2c19d-15.64.0.r390.gff04258-1
                           kauth-git5.64.0.r313.g7826926-15.64.0.r314.gf5cc4e8-1
                      kbookmarks-git5.64.0.r285.g2023626-15.64.0.r287.g06de7be-1
                        kcmutils-git5.64.0.r334.g3b082be-15.64.0.r335.g1b4ac1c-1
                         kcodecs-git5.64.0.r275.gc1b036a-15.64.0.r277.g0141f96-1
                     kcompletion-git5.64.0.r324.g8961479-15.64.0.r326.g5076762-1
                         kconfig-git5.64.0.r607.gc4c6733-15.64.0.r609.gd704d7a-1
                  kconfigwidgets-git5.64.0.r403.g17cf999-15.64.0.r405.gbb97a37-1
                     kcoreaddons-git5.64.0.r888.ge28a5f4-15.64.0.r891.gff99d35-1
                          kcrash-git5.64.0.r267.g620db3b-15.64.0.r268.g4a1362d-1
                     kdbusaddons-git5.64.0.r279.g7d23bbf-15.64.0.r280.gc7be75b-1
                   kde-cli-tools-git5.17.80.r1712.g6d5eedf-15.17.80.r1716.g567df68-1
                    kdeclarative-git5.64.0.r709.gc8b95b0-15.64.0.r711.g3ea5611-1
                            kded-git5.64.0.r278.ge0f50e3-15.64.0.r279.gb9d9ac7-1
                kdeplasma-addons-git5.17.80.r8184.g4fe2549fe-15.17.80.r8185.gb91b56d28-1
                 kdesignerplugin-git5.64.0.r250.g6617495-15.64.0.r251.ga6a648b-1
                           kdesu-git5.64.0.r365.gb745758-15.64.0.r367.gebc428c-1
                       kdewebkit-git5.64.0.r206.g9c788cf-15.64.0.r207.g2f0ecd2-1
                          kdnssd-git5.64.0.r232.g5f435c1-15.64.0.r234.g0b9088a-1
                       kdoctools-git5.64.0.r503.g0c074de-15.64.0.r504.g3b50090-1
                      kemoticons-git5.64.0.r287.g5a50cd0-15.64.0.r289.gb583e9d-1
                   kfilemetadata-git5.64.0.r651.g6dbb992-15.64.0.r653.g22c2cd9-1
                    kglobalaccel-git5.64.0.r325.g2c31795-15.64.0.r327.g3b3402d-1
                      kguiaddons-git5.64.0.r247.gfea61e4-15.64.0.r248.gf69fb55-1
                       kholidays-git5.64.0.r825.g4729b9d-15.64.0.r826.gf057dd8-1
                        khotkeys-git5.17.80.r1958.g891ab87-15.17.80.r1959.g6c3ace7-1
                           khtml-git5.64.0.r470.g2d8cba0-15.64.0.r471.gf18eeec-1
                           ki18n-git5.64.0.r352.gef36994-15.64.0.r355.g9aab9cc-1
                     kiconthemes-git5.64.0.r385.gccf27d6-15.64.0.r387.g1afb596-1
                       kidletime-git5.64.0.r223.ge7ff2dc-15.64.0.r224.g324688e-1
                   kimageformats-git5.57.0.r244.gb14ef35-15.57.0.r247.gdd98b2b-1
                           kinit-git5.64.0.r310.g677b6a4-15.64.0.r312.gffac452-1
                             kio-git5.64.0.r3633.g12b68224-15.64.0.r3638.gde3ca85f-1
                       kirigami2-git5.64.0.r1958.g92f32ff9-15.64.0.r1960.ge20eef08-1
                     kitemmodels-git5.64.0.r371.g430fddb-15.64.0.r374.gecaa9e1-1
                      kitemviews-git5.64.0.r241.g2efc1cc-15.64.0.r243.gb3073b4-1
                     kjobwidgets-git5.64.0.r265.gbff3009-15.64.0.r266.ga45eb1e-1
                        kjsembed-git5.64.0.r214.ge0eca59-15.64.0.r215.g7d39fdd-1
                    kmediaplayer-git5.64.0.r210.gb76387a-15.64.0.r211.gc63efa2-1
                       kmenuedit-git5.17.80.r895.gff39823-15.17.80.r896.g9f1dfec-1
                      knetattach-git5.17.80.r7005.g528388bfe-15.17.80.r7015.g8b9511db3-1
                       knewstuff-git5.64.0.r708.g31cb0dd-15.64.0.r710.gf21a3f8-1
                  knotifications-git5.64.0.r468.gaa6bb9b-15.64.0.r469.g6e0fb81-1
                   knotifyconfig-git5.64.0.r251.g3f6bb65-15.64.0.r252.g79d485b-1
                        kpackage-git5.64.0.r538.g918c8ad-15.64.0.r540.g95906c6-1
                          kparts-git5.64.0.r348.g3106110-15.64.0.r350.ge1caa55-1
                         kpeople-git5.64.0.r1210.g3a49a42-15.64.0.r1211.g414261e-1
                       kplotting-git5.64.0.r209.g670d489-15.64.0.r210.g1627b67-1
                            kpty-git5.64.0.r230.g00efe6b-15.64.0.r231.g988460d-1
                           kross-git5.64.0.r254.g0e2f283-15.64.0.r255.g5e17d50-1
                         krunner-git5.64.0.r383.gb723ac3-15.64.0.r384.gbe15717-1
                         kscreen-git5.17.80.r1190.g948b677-15.17.80.r1191.g079bca9-1
                        kservice-git5.64.0.r693.ge9982e1-15.64.0.r695.ga631243-1
                       ksysguard-git5.17.80.r3168.g726e7b6d-15.17.80.r3170.gf9255000-1
                     ktexteditor-git5.64.0.r2262.g8780a11f-15.64.0.r2266.g03ce7332-1
                    ktextwidgets-git5.64.0.r274.gfd0a49f-15.64.0.r276.gb5252fc-1
                 kunitconversion-git5.64.0.r276.g2c688c9-15.64.0.r277.gfb71cd2-1
                         kwallet-git5.64.0.r922.gdf037e3-15.64.0.r924.g3a86b4b-1
                        kwayland-git5.64.0.r954.gb12b919-15.64.0.r956.ga45233a-1
                  kwidgetsaddons-git5.64.0.r604.g8a8d823-15.64.0.r606.gd400413-1
                            kwin-git5.17.80.r17428.g3faeb543a-15.17.80.r17440.g69a3517e0-1
                   kwindowsystem-git5.64.0.r472.g255f959-15.64.0.r474.ge04d00f-1
                         kxmlgui-git5.64.0.r555.g3836ef7-15.64.0.r558.ge9387f5-1
                   kxmlrpcclient-git5.64.0.r366.gd0c5ffceb-15.64.0.r367.gcd688f7bc-1
           manjaro-dynamic-wallpaper                1.1-1                1.2-1
                    matcha-gtk-theme           20191003-1           20191026-1
                           milou-git5.17.80.r653.g3f4794a-15.17.80.r655.geda3d27-1
                 modemmanager-qt-git5.64.0.r432.g2508682-15.64.0.r433.gb00077a-1
               networkmanager-qt-git5.64.0.r1014.g4a6a5e7-15.64.0.r1015.g63e806c-1
           onlyoffice-desktopeditors              5.3.5-2              5.4.1-1
                          pkgbrowser               0.21-2               0.22-1
      plasma-browser-integration-git5.17.80.r939.g559360c6-15.17.80.r942.gfcfab76f-1
                  plasma-desktop-git5.17.80.r7005.g528388bfe-15.17.80.r7015.g8b9511db3-1
                plasma-framework-git5.64.0.r15272.gbbe0148db-15.64.0.r15275.g12edce87b-1
                       plasma-nm-git5.17.80.r2672.g15f1600f-15.17.80.r2692.g6dfa9704-1
                       plasma-pa-git5.17.80.r774.g917cef6-15.17.80.r775.gd9eb1ad-1
                    plasma-vault-git5.17.80.r235.g1d6ef2d-15.17.80.r236.g9a02f98-1
          plasma-wayland-session-git5.17.80.r8412.gb3065f7db-15.17.80.r8429.ga53e8065f-1
                plasma-workspace-git5.17.80.r8412.gb3065f7db-15.17.80.r8429.ga53e8065f-1
                          prison-git5.64.0.r221.ge22ae93-15.64.0.r222.g0528ec9-1
                         purpose-git5.64.0.r703.g296017d-15.64.0.r704.g6c64851-1
              qqc2-desktop-style-git5.64.0.r300.gbcc30eb-15.64.0.r302.gbeba369-1
                           solid-git5.64.0.r512.gcf729bc-15.64.0.r514.g330f6f5-1
                          sonnet-git5.64.0.r489.g561875e-15.64.0.r490.ga418820-1
                     syndication-git5.64.0.r725.g5b014b8-15.64.0.r726.gd29810a-1
             syntax-highlighting-git5.64.0.r1032.gdbd14c4-15.64.0.r1034.g0b6e014-1
                  systemsettings-git5.17.80.r2138.g69138ea8-15.17.80.r2141.g1f929dda-1
                    threadweaver-git5.64.0.r411.gb5e4a06-15.64.0.r413.g74ecaf2-1
          xdg-desktop-portal-kde-git5.17.80.r191.g05dcd7b-15.17.80.r192.gc850554-1
            linux419-rt-nvidia-440xx                    -             440.26-1
             linux52-rt-nvidia-440xx                    -             440.26-1
                       package-query                    -               1.10-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-25           2019-10-27
-------------------------------------------------------------------------------
                            arp-scan              1.9.5-2              1.9.6-1
                              catch2              2.9.2-1             2.10.2-1
                             chezmoi              1.6.5-1              1.7.2-1
               cldr-emoji-annotation      35.12.14971.0-1  36.12.120191002.0-1
                          cloud-init               19.2-2               19.2-3
                             cockpit                205-2              205.1-1
                   cockpit-dashboard                205-2              205.1-1
                         cockpit-pcp                205-2              205.1-1
                        cozy-desktop             3.15.2-1             3.16.0-1
                         dns-lexicon              3.3.3-1              3.3.6-1
                           drumgizmo             0.9.18-1           0.9.18.1-1
                              eslint              6.5.1-1              6.6.0-1
                             esptool                2.7-1                2.8-1
                           exploitdb           20190915-1           20191024-1
                firefox-adblock-plus              3.6.3-1                3.7-1
           firefox-developer-edition             71.0b3-1             71.0b4-1
  firefox-developer-edition-i18n-ach             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-af             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-an             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-ar             71.0b3-1             71.0b4-1
  firefox-developer-edition-i18n-ast             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-az             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-be             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-bg             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-bn             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-br             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-bs             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-ca             71.0b3-1             71.0b4-1
  firefox-developer-edition-i18n-cak             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-cs             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-cy             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-da             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-de             71.0b3-1             71.0b4-1
  firefox-developer-edition-i18n-dsb             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-el             71.0b3-1             71.0b4-1
firefox-developer-edition-i18n-en-ca             71.0b3-1             71.0b4-1
firefox-developer-edition-i18n-en-gb             71.0b3-1             71.0b4-1
firefox-developer-edition-i18n-en-us             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-eo             71.0b3-1             71.0b4-1
firefox-developer-edition-i18n-es-ar             71.0b3-1             71.0b4-1
firefox-developer-edition-i18n-es-cl             71.0b3-1             71.0b4-1
firefox-developer-edition-i18n-es-es             71.0b3-1             71.0b4-1
firefox-developer-edition-i18n-es-mx             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-et             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-eu             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-fa             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-ff             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-fi             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-fr             71.0b3-1             71.0b4-1
firefox-developer-edition-i18n-fy-nl             71.0b3-1             71.0b4-1
firefox-developer-edition-i18n-ga-ie             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-gd             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-gl             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-gn             71.0b3-1             71.0b4-1
firefox-developer-edition-i18n-gu-in             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-he             71.0b3-1             71.0b4-1
firefox-developer-edition-i18n-hi-in             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-hr             71.0b3-1             71.0b4-1
  firefox-developer-edition-i18n-hsb             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-hu             71.0b3-1             71.0b4-1
firefox-developer-edition-i18n-hy-am             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-ia             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-id             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-is             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-it             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-ja             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-ka             71.0b3-1             71.0b4-1
  firefox-developer-edition-i18n-kab             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-kk             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-km             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-kn             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-ko             71.0b3-1             71.0b4-1
  firefox-developer-edition-i18n-lij             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-lt             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-lv             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-mk             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-mr             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-ms             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-my             71.0b3-1             71.0b4-1
firefox-developer-edition-i18n-nb-no             71.0b3-1             71.0b4-1
firefox-developer-edition-i18n-ne-np             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-nl             71.0b3-1             71.0b4-1
firefox-developer-edition-i18n-nn-no             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-oc             71.0b3-1             71.0b4-1
firefox-developer-edition-i18n-pa-in             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-pl             71.0b3-1             71.0b4-1
firefox-developer-edition-i18n-pt-br             71.0b3-1             71.0b4-1
firefox-developer-edition-i18n-pt-pt             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-rm             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-ro             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-ru             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-si             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-sk             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-sl             71.0b3-1             71.0b4-1
  firefox-developer-edition-i18n-son             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-sq             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-sr             71.0b3-1             71.0b4-1
firefox-developer-edition-i18n-sv-se             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-ta             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-te             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-th             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-tr             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-uk             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-ur             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-uz             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-vi             71.0b3-1             71.0b4-1
   firefox-developer-edition-i18n-xh             71.0b3-1             71.0b4-1
firefox-developer-edition-i18n-zh-cn             71.0b3-1             71.0b4-1
firefox-developer-edition-i18n-zh-tw             71.0b3-1             71.0b4-1
     firefox-extension-privacybadger          2019.9.23-1          2019.10.8-1
                           git-annex         7.20191017-9         7.20191024-1
                              gradle              5.6.2-3              5.6.3-1
                          gradle-doc              5.6.2-3              5.6.3-1
                          gradle-src              5.6.2-3              5.6.3-1
                                grpc             1.24.2-1             1.24.3-1
                            grpc-cli             1.24.2-1             1.24.3-1
                               hexyl              0.5.1-1              0.6.0-1
               intel-compute-runtime        19.41.14441-1        19.42.14504-1
                  intel-media-driver             19.3.0-1             19.3.1-1
                             ipython              7.8.0-1              7.9.0-1
                           keepassxc              2.4.3-1              2.5.0-1
                              libasr              1.0.2-3              1.0.3-1
                       libmicrohttpd             0.9.67-1             0.9.68-1
                            lollypop              1.2.0-1              1.2.2-1
                                 mpv          1:0.29.1-11           1:0.30.0-2
                             neomutt           20180716-8           20191025-1
                              netcdf              4.7.1-1              4.7.2-1
                    nextcloud-client              2.5.3-2              2.6.0-3
                  nodejs-lts-dubnium            10.16.3-1            10.17.0-1
               perl-io-captureoutput             1.1104-5             1.1105-1
                            php-grpc             1.24.2-1             1.24.3-1
                                po4a               0.56-1               0.57-1
                           polyphone              2.1.2-1              2.1.3-1
                       python-cftime              1.0.4-1            1.0.4.2-1
              python-dephell-markers              1.0.0-1              1.0.1-1
                       python-grpcio             1.24.2-1             1.24.3-1
                      python-netcdf4              1.5.2-1              1.5.3-1
              python-netcdf4-openmpi              1.5.2-1              1.5.3-1
        python-pallets-sphinx-themes              1.2.2-1              1.2.2-3
                python-pytest-forked              1.1.1-1              1.1.3-1
                      python2-cftime              1.0.4-1            1.0.4.2-1
                     python2-netcdf4              1.5.2-1              1.5.3-1
             python2-netcdf4-openmpi              1.5.2-1              1.5.3-1
               python2-pytest-forked              1.1.1-1              1.1.3-1
                           retroarch            1.7.9.2-1              1.8.0-1
                    sonic-visualiser                3.3-1                4.0-1
                       subdownloader              2.1.0-1              2.1.0-2
                         tidalcycles              1.4.2-9              1.4.4-1
                               v2ray             4.20.0-3             4.21.1-1
                         v2ray-geoip           20190813-1           20191022-1
                           veracrypt               1.23-1               1.24-1
                             vim-ale              2.5.0-1              2.6.0-1
                       wireshark-cli              3.0.5-1              3.0.6-1
                        wireshark-qt              3.0.5-1              3.0.6-1
                      xmonad-contrib              0.15-20               0.16-1
                                yara             3.10.0-1             3.11.0-1
                           electron5                    -             5.0.11-1
                             netplan                    -               0.98-1
                     python2-path.py                    -             11.5.1-2


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-25           2019-10-27
-------------------------------------------------------------------------------
                             mhwd-db             0.6.3-12             0.6.3-13
                              pacman              5.2.0-1              5.2.0-2
                   mhwd-nvidia-440xx                    -             440.26-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-25           2019-10-27
-------------------------------------------------------------------------------
                           amd-ucode   20190923.417a9c6-1   20191022.2b016af-1
                      linux-firmware   20190923.417a9c6-1   20191022.2b016af-1
                              man-db              2.8.7-1              2.9.0-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-25           2019-10-27
-------------------------------------------------------------------------------
              manjaro-tools-base-git      r2824.3748533-1      r2826.d7c6bae-1
               manjaro-tools-iso-git      r2824.3748533-1      r2826.d7c6bae-1
               manjaro-tools-pkg-git      r2824.3748533-1      r2826.d7c6bae-1
              manjaro-tools-yaml-git      r2824.3748533-1      r2826.d7c6bae-1
                       package-query                1.9-2                    -
                         thunderbird             68.2.0-0                    -
                 thunderbird-i18n-ar             68.2.0-0                    -
                thunderbird-i18n-ast             68.2.0-0                    -
                 thunderbird-i18n-be             68.2.0-0                    -
                 thunderbird-i18n-bg             68.2.0-0                    -
                 thunderbird-i18n-br             68.2.0-0                    -
                 thunderbird-i18n-ca             68.2.0-0                    -
                 thunderbird-i18n-cs             68.2.0-0                    -
                 thunderbird-i18n-cy             68.2.0-0                    -
                 thunderbird-i18n-da             68.2.0-0                    -
                 thunderbird-i18n-de             68.2.0-0                    -
                thunderbird-i18n-dsb             68.2.0-0                    -
                 thunderbird-i18n-el             68.2.0-0                    -
              thunderbird-i18n-en-gb             68.2.0-0                    -
              thunderbird-i18n-en-us             68.2.0-0                    -
              thunderbird-i18n-es-ar             68.2.0-0                    -
              thunderbird-i18n-es-es             68.2.0-0                    -
                 thunderbird-i18n-et             68.2.0-0                    -
                 thunderbird-i18n-eu             68.2.0-0                    -
                 thunderbird-i18n-fi             68.2.0-0                    -
                 thunderbird-i18n-fr             68.2.0-0                    -
              thunderbird-i18n-fy-nl             68.2.0-0                    -
              thunderbird-i18n-ga-ie             68.2.0-0                    -
                 thunderbird-i18n-gd             68.2.0-0                    -
                 thunderbird-i18n-gl             68.2.0-0                    -
                 thunderbird-i18n-he             68.2.0-0                    -
                 thunderbird-i18n-hr             68.2.0-0                    -
                thunderbird-i18n-hsb             68.2.0-0                    -
                 thunderbird-i18n-hu             68.2.0-0                    -
              thunderbird-i18n-hy-am             68.2.0-0                    -
                 thunderbird-i18n-id             68.2.0-0                    -
                 thunderbird-i18n-is             68.2.0-0                    -
                 thunderbird-i18n-it             68.2.0-0                    -
                 thunderbird-i18n-ja             68.2.0-0                    -
                 thunderbird-i18n-ko             68.2.0-0                    -
                 thunderbird-i18n-lt             68.2.0-0                    -
              thunderbird-i18n-nb-no             68.2.0-0                    -
                 thunderbird-i18n-nl             68.2.0-0                    -
              thunderbird-i18n-nn-no             68.2.0-0                    -
                 thunderbird-i18n-pl             68.2.0-0                    -
              thunderbird-i18n-pt-br             68.2.0-0                    -
              thunderbird-i18n-pt-pt             68.2.0-0                    -
                 thunderbird-i18n-rm             68.2.0-0                    -
                 thunderbird-i18n-ro             68.2.0-0                    -
                 thunderbird-i18n-ru             68.2.0-0                    -
                 thunderbird-i18n-si             68.2.0-0                    -
                 thunderbird-i18n-sk             68.2.0-0                    -
                 thunderbird-i18n-sl             68.2.0-0                    -
                 thunderbird-i18n-sq             68.2.0-0                    -
                 thunderbird-i18n-sr             68.2.0-0                    -
              thunderbird-i18n-sv-se             68.2.0-0                    -
                 thunderbird-i18n-tr             68.2.0-0                    -
                 thunderbird-i18n-uk             68.2.0-0                    -
                 thunderbird-i18n-vi             68.2.0-0                    -
              thunderbird-i18n-zh-cn             68.2.0-0                    -
              thunderbird-i18n-zh-tw             68.2.0-0                    -
                         xorg-server           1.20.5-2.1           1.20.5-4.1
                  xorg-server-common           1.20.5-2.1           1.20.5-4.1
                   xorg-server-devel           1.20.5-2.1           1.20.5-4.1
                    xorg-server-xdmx           1.20.5-2.1           1.20.5-4.1
                  xorg-server-xephyr           1.20.5-2.1           1.20.5-4.1
                   xorg-server-xnest           1.20.5-2.1           1.20.5-4.1
                    xorg-server-xvfb           1.20.5-2.1           1.20.5-4.1
                xorg-server-xwayland           1.20.5-2.1           1.20.5-4.1
               linux316-nvidia-440xx                    -             440.26-1
               linux414-nvidia-440xx                    -             440.26-1
               linux419-nvidia-440xx                    -             440.26-1
                linux44-nvidia-440xx                    -             440.26-1
                linux52-nvidia-440xx                    -             440.26-1
                linux53-nvidia-440xx                    -             440.26-1
                linux54-nvidia-440xx                    -           440.26-0.1
                  nvidia-440xx-utils                    -             440.26-1
                 opencl-nvidia-440xx                    -             440.26-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-25           2019-10-27
-------------------------------------------------------------------------------
            archlinux-appstream-data           20190925-1           20191027-1
                              cantor            19.08.2-1            19.08.2-2
                                cups              2.3.0-3              2.3.0-4
                         gnome-music           1:3.34.0-2           1:3.34.1-1
                           intel-tbb             2019.9-1             2019.9-2
                         jdk-openjdk             13.u33-1          13.0.1.u9-1
                       jdk11-openjdk         11.0.4.u11-1         11.0.5.u10-1
                        jdk8-openjdk             8.u222-2             8.u232-1
                         jre-openjdk             13.u33-1          13.0.1.u9-1
                jre-openjdk-headless             13.u33-1          13.0.1.u9-1
                       jre11-openjdk         11.0.4.u11-1         11.0.5.u10-1
              jre11-openjdk-headless         11.0.4.u11-1         11.0.5.u10-1
                        jre8-openjdk             8.u222-2             8.u232-1
               jre8-openjdk-headless             8.u222-2             8.u232-1
                             libcups              2.3.0-3              2.3.0-4
                              libssh              0.9.0-1              0.9.1-1
                         libssh-docs              0.9.0-1              0.9.1-1
                          libtommath              1.1.0-1              1.2.0-1
                         openjdk-doc             13.u33-1          13.0.1.u9-1
                         openjdk-src             13.u33-1          13.0.1.u9-1
                       openjdk11-doc         11.0.4.u11-1         11.0.5.u10-1
                       openjdk11-src         11.0.4.u11-1         11.0.5.u10-1
                        openjdk8-doc             8.u222-2             8.u232-1
                        openjdk8-src             8.u222-2             8.u232-1
                               pango         1:1.44.6+2-1           1:1.44.7-1
                   perl-http-cookies               6.04-4               6.05-1
                      perl-mime-lite              3.030-5              3.031-1
                        python-cairo             1.18.1-1             1.18.2-1
                       python2-cairo             1.18.1-1             1.18.2-1
                         thunderbird             68.1.1-1             68.2.0-1
                 thunderbird-i18n-ar             68.1.0-1             68.2.0-1
                thunderbird-i18n-ast             68.1.0-1             68.2.0-1
                 thunderbird-i18n-be             68.1.0-1             68.2.0-1
                 thunderbird-i18n-bg             68.1.0-1             68.2.0-1
                 thunderbird-i18n-br             68.1.0-1             68.2.0-1
                 thunderbird-i18n-ca             68.1.0-1             68.2.0-1
                 thunderbird-i18n-cs             68.1.0-1             68.2.0-1
                 thunderbird-i18n-cy             68.1.0-1             68.2.0-1
                 thunderbird-i18n-da             68.1.0-1             68.2.0-1
                 thunderbird-i18n-de             68.1.0-1             68.2.0-1
                thunderbird-i18n-dsb             68.1.0-1             68.2.0-1
                 thunderbird-i18n-el             68.1.0-1             68.2.0-1
              thunderbird-i18n-en-gb             68.1.0-1             68.2.0-1
              thunderbird-i18n-en-us             68.1.0-1             68.2.0-1
              thunderbird-i18n-es-ar             68.1.0-1             68.2.0-1
              thunderbird-i18n-es-es             68.1.0-1             68.2.0-1
                 thunderbird-i18n-et             68.1.0-1             68.2.0-1
                 thunderbird-i18n-eu             68.1.0-1             68.2.0-1
                 thunderbird-i18n-fi             68.1.0-1             68.2.0-1
                 thunderbird-i18n-fr             68.1.0-1             68.2.0-1
              thunderbird-i18n-fy-nl             68.1.0-1             68.2.0-1
              thunderbird-i18n-ga-ie             68.1.0-1             68.2.0-1
                 thunderbird-i18n-gd             68.1.0-1             68.2.0-1
                 thunderbird-i18n-gl             68.1.0-1             68.2.0-1
                 thunderbird-i18n-he             68.1.0-1             68.2.0-1
                 thunderbird-i18n-hr             68.1.0-1             68.2.0-1
                thunderbird-i18n-hsb             68.1.0-1             68.2.0-1
                 thunderbird-i18n-hu             68.1.0-1             68.2.0-1
              thunderbird-i18n-hy-am             68.1.0-1             68.2.0-1
                 thunderbird-i18n-id             68.1.0-1             68.2.0-1
                 thunderbird-i18n-is             68.1.0-1             68.2.0-1
                 thunderbird-i18n-it             68.1.0-1             68.2.0-1
                 thunderbird-i18n-ja             68.1.0-1             68.2.0-1
                 thunderbird-i18n-ko             68.1.0-1             68.2.0-1
                 thunderbird-i18n-lt             68.1.0-1             68.2.0-1
              thunderbird-i18n-nb-no             68.1.0-1             68.2.0-1
                 thunderbird-i18n-nl             68.1.0-1             68.2.0-1
              thunderbird-i18n-nn-no             68.1.0-1             68.2.0-1
                 thunderbird-i18n-pl             68.1.0-1             68.2.0-1
              thunderbird-i18n-pt-br             68.1.0-1             68.2.0-1
              thunderbird-i18n-pt-pt             68.1.0-1             68.2.0-1
                 thunderbird-i18n-rm             68.1.0-1             68.2.0-1
                 thunderbird-i18n-ro             68.1.0-1             68.2.0-1
                 thunderbird-i18n-ru             68.1.0-1             68.2.0-1
                 thunderbird-i18n-si             68.1.0-1             68.2.0-1
                 thunderbird-i18n-sk             68.1.0-1             68.2.0-1
                 thunderbird-i18n-sl             68.1.0-1             68.2.0-1
                 thunderbird-i18n-sq             68.1.0-1             68.2.0-1
                 thunderbird-i18n-sr             68.1.0-1             68.2.0-1
              thunderbird-i18n-sv-se             68.1.0-1             68.2.0-1
                 thunderbird-i18n-tr             68.1.0-1             68.2.0-1
                 thunderbird-i18n-uk             68.1.0-1             68.2.0-1
                 thunderbird-i18n-vi             68.1.0-1             68.2.0-1
              thunderbird-i18n-zh-cn             68.1.0-1             68.2.0-1
              thunderbird-i18n-zh-tw             68.1.0-1             68.2.0-1
                      vulkan-headers          1:1.1.123-1          1:1.1.126-1
                    vulkan-html-docs          1:1.1.123-1          1:1.1.126-1
                   vulkan-icd-loader            1.1.123-1            1.1.126-1
            vulkan-validation-layers            1.1.121-1            1.1.125-1
                         xorg-server             1.20.5-2             1.20.5-4
                  xorg-server-common             1.20.5-2             1.20.5-4
                   xorg-server-devel             1.20.5-2             1.20.5-4
                    xorg-server-xdmx             1.20.5-2             1.20.5-4
                  xorg-server-xephyr             1.20.5-2             1.20.5-4
                   xorg-server-xnest             1.20.5-2             1.20.5-4
                    xorg-server-xvfb             1.20.5-2             1.20.5-4
                xorg-server-xwayland             1.20.5-2             1.20.5-4


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-25           2019-10-27
-------------------------------------------------------------------------------
            lib32-nvidia-440xx-utils                    -             440.26-1
           lib32-opencl-nvidia-440xx                    -             440.26-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-25           2019-10-27
-------------------------------------------------------------------------------
                         lib32-pango           1:1.44.6-1           1:1.44.7-1
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

5 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


gnome-shell-extension-desktop-icons

the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

so far so well, will put it through the grinder to see if it stays together! :slight_smile:

Switch to nvidia 440xx and all is good: linux53+nvidia+zfs+xfce

2 Likes

All good on my end with nvidia 440xx and linux54 :wink:

1 Like

will try that combination.
Finally hardware VP9 acceleration, should help with 8K60P lol

1 Like

nvidia 440xx has the same issue that 435.xx has, on an optimus laptop using a prime setup with prime synchronization enabled nvidia_drm modeset=1 causes a loop of system wide lockups for 5s frozen/2s not frozen whenever vulkan is used with vsync. i went back to 430.xx and all works perfectly. :man_shrugging:

3 Likes

No issues detected in KDE, Gnome, and LXQT. All on VM's.

I've been using 440 driver in hybrid Intel / Nvidia mode for about a week now and I found no issues. Except that vsync thing (no freezes though, that seems to be specific for @dglt's device generation).

as in render offload introduced with 435.xx? or prime as in this setup ?

both are entirely different setups.

My KDE system is still alive.

3 Likes

Everything went well in the update!
I am using Kernel 5.3 and Driver Nvidia 440, together with KDE Plasma 5.17.1!
My video card is a GeForce 740M!

Updated to kernel 5.4 and latest NVIDIA.
Everything runs like expected. Resolve Studio included.

Installed the nvidia-440 driver tonight using mwhd. It works okay but I had to reapply the KDE compositor settings I normally use. That's the first time when changing nvidia drivers this has been necessary for me though. Not sure why but they were being ignored so everything was being rendered by software rather than hardware.

inxi -G:
Graphics:  Device-1: NVIDIA GM206 [GeForce GTX 960] driver: nvidia v: 440.26 
           Display: x11 server: X.Org 1.20.5 driver: nvidia resolution: 1280x1024~60Hz 
           OpenGL: renderer: GeForce GTX 960/PCIe/SSE2 v: 4.6.0 NVIDIA 440.26 

uname -mrs:
Linux 5.4.0-1-MANJARO x86_64

EDIT - I have screen tearing on my notebook with Intel HD 4000 GPU despite having a config file with the tearfree option set. It's seemingly being ignored, so tearing is visible whatever application or desktop effect is running. I've tried toggling the compositor like I did for the desktop and it made no difference. same kernel as desktop, that's not a factor though because the tearing only started with today's xorg-server update.

/etc/X11/xorg.conf.d/20-intel.conf which used to be fine:

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "TearFree" "true"
EndSection
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel 
           Display: x11 server: X.Org 1.20.5 driver: intel resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 19.2.2

xorg-server is definitely ignoring the .conf file. I tried without it and renaming it to a lower number to increase it's priority, Neither made any difference.

EDIT 2.3 million - I found the culprit, I've removed .drirc I'd set previously and the tearing issue is gone. the 20-intel.conf is no longer needed either.

1 Like

Oh wow, cool -- so you have changed from Cinnamon recently, have you?

Only on my laptop to test it out on real hardware (scrapping out an old Cinnamon installation in the process), my desktop computer runs the same Cinnamon system since a little bit more than one year now.

2 Likes

Updated, switching to nvidia 440, and everything seems to work well on my PC so far.

Edit:
Just a little side note. Some GTK3 application might break if composite extension is disabled in xfce. Enabling that extension with nvidia card is now have no negative impact, so I recommend to set their composite extension enabled if anyone has that disabled before.

mpv 1:0.30.0-2 appears to cause keyboard shortcuts in smplayer to stop responding -- spacebar to pause, etc.. Switching the engine to mplayer resolves this as does downgrading mpv.

Edit: I should have included that I am using KDE plasma.

Same here on gnome, this is a known bug after the last update of mpv and I hope it will be fixed soon.
https://bugs.archlinux.org/task/64268?project=5&string=smplayer

2 Likes

Offload of course, I don't like the idea of full-nvidia setups in Linux.

Forum kindly sponsored by