[Testing Update] 2019-10-23 - Kernels, Plasma, Framework, LibreOffice, Firefox, Virtualbox

Hello community,

I am happy to announce another Testing Update. Mostly we have updates for our Manjaro 18.1.2-pre1 release.

Update news

This update holds the following changes:

  • For KDE fans we have more or less a double feature of Plasma. First we have the official Plasma 5.17.1 release. Then we updated our KDE-Dev packages to their latest git-snapshots.
  • KDE Frameworks is now at 5.63
  • LibreOffice got updated to 6.2.8
  • AMD FOSS drivers got renewed to 19.1.0
  • Firefox is now at 70.0
  • Virtualbox got updated to 6.0.14
  • The usual updates and improvements and upstream package renewals
  • Manjaro 18.1.2-pre1 got released! Please test and give us feedback: gnome, kde, xfce
  • Latest efforts by KDE can be reviewed via our current KDE-Dev ISO or current KDE-Vanilla ISO

Give us the usual feedback and let us know what you think about this update.


Current supported Kernels

  • linux316 3.16.75
  • linux44 4.4.197 (no legacy nvidia-340 module!)
  • linux49 4.9.197
  • linux414 4.14.150
  • linux419 4.19.80
  • linux52 5.2.21 [EOL] (no catalyst module!)
  • linux53 5.3.7 (no catalyst module!)
  • linux54 5.4.0-rc4 (not all modules build yet!)
  • linux419-rt 4.19.72_rt26
  • linux52-rt 5.2.21_rt13

Package Changes (Wed Oct 23 10:24:46 CEST 2019)

  • testing community x86_64: 874 new and 853 removed package(s)
  • testing core x86_64: 34 new and 35 removed package(s)
  • testing extra x86_64: 547 new and 545 removed package(s)
  • testing multilib x86_64: 20 new and 20 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

12 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Pamac-Qt is not compatible to 9.0 API of Pamac

gnome-shell-extension-desktop-icons

the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

I am currently unable to update, there is an issue but it could be on my side. I get an issue saying
Conflicting files: linux-firmware: /usr/lib/firmware/rtlwifi/rtl8812aefw.bin already exists in filesystem linux-firmware: /usr/lib/firmware/rtlwifi/rtl8812aefw_wowlan.bin already exists in filesystem

EDIT: Fixed it by removing the files then upgrading the package

No major problems so far on my PC and Laptop - the only "bug" i've seen is the "application" launcher animation next to the mouse cursor - on my intel laptop - the animation is 5 times bigger as normal - on my pc with nvidia graphics the animation is completely missing.

that's nothing problematic for me, i've just noticed it. reset / changing the settings in the settings application does nothing.

KDE Plasma

EDIT: Just updated my 3rd installation in Virtualbox - In VBOX the Application launching indicator is working fine, so maybe a problem with intel drivers & nvidia drivers!? don't know ...

EDIT 2: That'S what i mean. This is how it looks like on my Laptop -> Way too big.
Screenshot_20191023_170645

On my PC with NVIDIA Drivers the bouncing animation& Icon is completely gone.

And in my VM it looks like as usual - normal size.

Firefox 70.0 update on the stable channel went fine.

Thanks!

1 Like

You list Manjaro Testing 18.1.2-pre1 release. In header yet it is not available for install.
Currently running Juhraya 18.1.1. according to Manjaro Hello with fresh upgrade and mirrors synced.

The update is mainly for KDE plasma, as it was recently updated to 5.17

All good with the update apparently, but just got a plasmashell core dump.

https://pastebin.com/nfzhaKYV

I'll investigate more about it once i got some time.

So far, so good on 2 VM's (Gnome and KDE). Did the update in my usual manner, via TTY. Time to live on the "edge" and update the LXQT VM.

1 Like

We all tend to use one system - and one system only.

My greatest respect and :raised_hand: :tophat:'s off to those of you running VMs just to check updates.

Your effort and reports is invaluable. Thank you :slight_smile:

9 Likes

Well, it's kinda fun! We actually like it, teehee.

1 Like

Well, the update went okay on LXQT in a VM with some minor issues. The Window Button controls on Pamac disappear when you open it from the system tray. However, when you open it from the program menu, the window button controls are there. Other than that, everything seems to run okay. Now if I could figure out how to get the terminal to let me delete ONE letter with the backspace key instead of the whole darn word. Things would be golden.

1 Like

You got me intrigued, so i've just launched my LXQT VM & am doing its update [not done for a while so this might get "exciting"].

1 Like

update wants to remove kde packages with *-git variant, I don't dare to do that on bare metal...

Did you install from kde-dev ISO then? I got no such warnings with my bare metal systems. Please post the output you are concerned about.

This installation is from oktober 2014, installed Manjaro KDE.

Good Luck!

1 Like

Please post the output from pacman for review

Never mind I installed plasma wayland from git. Nevermind I will update this way :wink:

Regarding the activity icon issue are you using Wayland on the affected installations? I have normal size with Xorg on my NVIDIA GTX 960 with 430 branch driver and kernel 5.4. The Intel HD 4000 in my laptop also has normal size too with Xorg. I haven't checked Wayland.

In the past when I have tried Wayland the pointer and activity animations have been inconsistently sized depending on what is running but that was cured by specifying a specific pointer size in System Settings.

Forum kindly sponsored by