[Testing Update] 2019-10-04 - Gnome-Keyring, Budgie, Firefox

Hello community,

I am happy to announce another Testing Update. Mostly we have updates to Gnome-Keyring, Firefox and Budgie.


repo-compare is one of our new web-services. Give us your feedback on that new service!

Update news

This update holds the following changes:

  • seems we currently face some issues with gnome-keyring outside of Gnome. Let us know if those are fixed on our end.
  • Budgie got updated to work with Gnome 3.34
  • Firefox fixed some crashes when playing Youtube videos
  • The usual updates and improvements and upstream package renewals
  • Manjaro 18.1.1-pre2 got released! Please test and give us feedback: gnome, kde, xfce
  • Latest efforts by KDE can be reviewed via our current KDE-Dev ISO or current KDE-Vanilla ISO

Give us the usual feedback and let us know what you think about this update.


Current supported Kernels

  • linux316 3.16.74
  • linux44 4.4.194 (no legacy nvidia-340 module!)
  • linux49 4.9.194
  • linux414 4.14.146
  • linux419 4.19.76
  • linux52 5.2.18 (no catalyst module!)
  • linux53 5.3.2 (no catalyst module!)
  • linux54 5.4.0-rc1 (not all modules build yet!)
  • linux419-rt 4.19.72_rt25
  • linux52-rt 5.2.17_rt9

Package Updates (Fri Oct 4 10:09:38 CEST 2019)

  • testing community x86_64: 106 new and 110 removed package(s)
  • testing core x86_64: 2 new and 2 removed package(s)
  • testing extra x86_64: 117 new and 116 removed package(s)
  • testing multilib x86_64: 2 new and 2 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-03           2019-10-04
-------------------------------------------------------------------------------
               debian-whois-mkpasswd              5.5.1-1              5.5.2-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-03           2019-10-04
-------------------------------------------------------------------------------
               aarch64-linux-gnu-gdb                8.3-1              8.3.1-1
                             acme.sh              2.8.2-2              2.8.3-1
                              aeolus              0.9.7-2              0.9.7-3
                   arm-none-eabi-gdb                8.3-1              8.3.1-1
                             avr-gdb                8.3-1              8.3.1-1
                      budgie-desktop  10.5+35+ga023c778-1             10.5.1-1
                             calibre             3.48.0-1              4.0.0-1
                           clthreads              2.4.2-3              2.4.2-4
                           clxclient              3.9.2-2              3.9.2-3
                               cudnn           7.6.3.30-1           7.6.4.38-1
                                dart              2.5.0-1              2.5.1-1
                         debootstrap            1.0.115-1            1.0.116-1
                           deepin-wm             1.9.38-2             1.9.38-3
                            deja-dup               40.1-2               40.1-3
                              eslint              6.5.0-1              6.5.1-1
                              girara              0.3.2-1              0.3.3-1
                              gitlab             12.3.3-1             12.3.4-1
                    gitlab-workhorse              8.7.0-3             8.12.0-1
                                grpc             1.24.0-1             1.24.1-1
                            grpc-cli             1.24.0-1             1.24.1-1
                                 hub             2.12.7-1             2.12.8-1
                             jenkins              2.196-1              2.197-1
                        languagetool                4.6-1                4.7-1
                        libmediainfo              19.07-1              19.09-1
                           mediainfo              19.07-1              19.09-1
                       mediainfo-gui              19.07-1              19.09-1
                                 mpv           1:0.29.1-8           1:0.29.1-9
                            node-gyp              5.0.2-2              5.0.3-1
                              nodejs            12.11.0-1            12.11.1-1
                            openblas              0.3.6-1              0.3.7-1
                               peony              1.1.5-1              1.1.6-1
                       perl-sys-virt              5.5.0-1              5.6.0-1
                            php-grpc             1.24.0-1             1.24.1-1
                               ponyc             0.31.0-1             0.32.0-1
                    python-aniso8601              7.0.0-1              8.0.0-1
                      python-apispec              2.0.2-1              3.0.0-1
           python-aws-sam-translator             1.14.0-1             1.15.0-1
                        python-blosc              1.8.1-1              1.8.1-4
                   python-bottleneck              1.2.1-3              1.2.1-5
                       python-docker              4.0.2-1              4.1.0-1
                python-elasticsearch              7.0.4-1              7.0.5-1
                     python-envisage              4.7.2-1              4.8.0-2
                   python-et-xmlfile              1.0.1-4              1.0.1-5
                    python-fonttools              4.0.0-1              4.0.2-1
                       python-grpcio             1.24.0-1             1.24.1-1
                        python-jdcal              1.4.1-1              1.4.1-2
                       python-joblib             0.13.2-1             0.14.0-3
                  python-lark-parser              0.7.5-1              0.7.7-1
                      python-logbook              1.4.3-1              1.5.2-1
                      python-numexpr              2.7.0-1              2.7.0-2
                     python-openmdao              2.8.0-1              2.9.0-1
                     python-openpyxl              2.6.2-2              3.0.0-1
            python-pandas-datareader              0.7.4-1              0.8.1-1
                        python-parse             1.12.0-1             1.12.1-1
                     python-pathspec              0.5.9-2              0.6.0-1
                 python-phonenumbers            8.10.19-1            8.10.20-1
                       python-pluggy             0.12.0-1             0.13.0-1
                      python-pylibmc              1.6.0-1              1.6.1-1
                 python-pytest-xdist             1.29.0-1             1.30.0-1
                      python-pytorch              1.2.0-2              1.2.0-3
                 python-pytorch-cuda              1.2.0-2              1.2.0-3
                  python-pytorch-opt              1.2.0-2              1.2.0-3
             python-pytorch-opt-cuda              1.2.0-2              1.2.0-3
                       python-ropper            1.11.11-1             1.12.5-1
              python-snowballstemmer              1.2.1-3              1.9.1-1
                   python-tensorflow              2.0.0-1              2.0.0-2
              python-tensorflow-cuda              2.0.0-1              2.0.0-2
               python-tensorflow-opt              2.0.0-1              2.0.0-2
          python-tensorflow-opt-cuda              2.0.0-1              2.0.0-2
               python-text-unidecode                1.2-2                1.3-1
                     python-traitsui              6.1.2-1              6.1.3-1
                         python-xlrd              1.2.0-1              1.2.0-2
                   python-xlsxwriter              1.2.0-1              1.2.1-2
                         python-xlwt              1.3.0-2              1.3.0-3
                   python2-aniso8601              7.0.0-1              8.0.0-1
                       python2-blosc              1.8.1-1                    -
                  python2-bottleneck              1.2.1-3                    -
               python2-elasticsearch              7.0.4-1              7.0.5-1
                  python2-et-xmlfile              1.0.1-4                    -
                       python2-jdcal              1.4.1-1                    -
                      python2-joblib             0.13.2-1                    -
                 python2-lark-parser              0.7.5-1              0.7.7-1
                     python2-logbook              1.4.3-1              1.5.2-1
                    python2-openpyxl              2.6.2-2                    -
                       python2-parse             1.12.0-1             1.12.1-1
                      python2-pluggy             0.12.0-1             0.13.0-1
                     python2-pylibmc              1.6.0-1              1.6.1-1
                python2-pytest-xdist             1.29.0-1             1.30.0-1
                      python2-ropper            1.11.11-1             1.12.5-1
             python2-snowballstemmer              1.2.1-3              1.9.1-1
              python2-text-unidecode                1.2-2                1.3-1
                        python2-xlrd              1.2.0-1                    -
                  python2-xlsxwriter              1.2.0-1                    -
                        python2-xlwt              1.3.0-2                    -
                            qastools             0.21.0-4             0.22.0-1
                              rclone             1.49.3-1             1.49.4-1
               riscv64-linux-gnu-gdb                8.3-1              8.3.1-1
                              ropper            1.11.11-1             1.12.5-1
                        rust-bindgen             0.50.0-1             0.51.1-1
                                 sbt            1:1.3.0-1            1:1.3.1-1
                              scrapy              1.6.0-1              1.7.3-1
                       spice-vdagent             0.19.0-1             0.19.0-2
                              sqlmap              1.3.8-2             1.3.10-1
                          tensorflow              2.0.0-1              2.0.0-2
                     tensorflow-cuda              2.0.0-1              2.0.0-2
                      tensorflow-opt              2.0.0-1              2.0.0-2
                 tensorflow-opt-cuda              2.0.0-1              2.0.0-2
                             unbound              1.9.3-4              1.9.4-1
                             zathura              0.4.3-3              0.4.4-1
                              libemf                    -             1.0.11-2
                             libilbc                    -              2.0.2-4
                           libmysofa                    -                0.8-1
                              libsvm                    -               3.24-1
                                mujs                    -              1.0.6-1
                                vmaf                    -             1.3.15-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-03           2019-10-04
-------------------------------------------------------------------------------
             ca-certificates-mozilla               3.46-1             3.46.1-1
                                 nss               3.46-1             3.46.1-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-03           2019-10-04
-------------------------------------------------------------------------------
                        gtk3-classic            3.24.11-1            3.24.11-2
                       gnome-keyring                    -         1:3.34.0-1.1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-03           2019-10-04
-------------------------------------------------------------------------------
                             firefox             69.0.1-1             69.0.2-1
                    firefox-i18n-ach             69.0.1-1             69.0.2-1
                     firefox-i18n-af             69.0.1-1             69.0.2-1
                     firefox-i18n-an             69.0.1-1             69.0.2-1
                     firefox-i18n-ar             69.0.1-1             69.0.2-1
                    firefox-i18n-ast             69.0.1-1             69.0.2-1
                     firefox-i18n-az             69.0.1-1             69.0.2-1
                     firefox-i18n-be             69.0.1-1             69.0.2-1
                     firefox-i18n-bg             69.0.1-1             69.0.2-1
                     firefox-i18n-bn             69.0.1-1             69.0.2-1
                     firefox-i18n-br             69.0.1-1             69.0.2-1
                     firefox-i18n-bs             69.0.1-1             69.0.2-1
                     firefox-i18n-ca             69.0.1-1             69.0.2-1
                    firefox-i18n-cak             69.0.1-1             69.0.2-1
                     firefox-i18n-cs             69.0.1-1             69.0.2-1
                     firefox-i18n-cy             69.0.1-1             69.0.2-1
                     firefox-i18n-da             69.0.1-1             69.0.2-1
                     firefox-i18n-de             69.0.1-1             69.0.2-1
                    firefox-i18n-dsb             69.0.1-1             69.0.2-1
                     firefox-i18n-el             69.0.1-1             69.0.2-1
                  firefox-i18n-en-ca             69.0.1-1             69.0.2-1
                  firefox-i18n-en-gb             69.0.1-1             69.0.2-1
                  firefox-i18n-en-us             69.0.1-1             69.0.2-1
                     firefox-i18n-eo             69.0.1-1             69.0.2-1
                  firefox-i18n-es-ar             69.0.1-1             69.0.2-1
                  firefox-i18n-es-cl             69.0.1-1             69.0.2-1
                  firefox-i18n-es-es             69.0.1-1             69.0.2-1
                  firefox-i18n-es-mx             69.0.1-1             69.0.2-1
                     firefox-i18n-et             69.0.1-1             69.0.2-1
                     firefox-i18n-eu             69.0.1-1             69.0.2-1
                     firefox-i18n-fa             69.0.1-1             69.0.2-1
                     firefox-i18n-ff             69.0.1-1             69.0.2-1
                     firefox-i18n-fi             69.0.1-1             69.0.2-1
                     firefox-i18n-fr             69.0.1-1             69.0.2-1
                  firefox-i18n-fy-nl             69.0.1-1             69.0.2-1
                  firefox-i18n-ga-ie             69.0.1-1             69.0.2-1
                     firefox-i18n-gd             69.0.1-1             69.0.2-1
                     firefox-i18n-gl             69.0.1-1             69.0.2-1
                     firefox-i18n-gn             69.0.1-1             69.0.2-1
                  firefox-i18n-gu-in             69.0.1-1             69.0.2-1
                     firefox-i18n-he             69.0.1-1             69.0.2-1
                  firefox-i18n-hi-in             69.0.1-1             69.0.2-1
                     firefox-i18n-hr             69.0.1-1             69.0.2-1
                    firefox-i18n-hsb             69.0.1-1             69.0.2-1
                     firefox-i18n-hu             69.0.1-1             69.0.2-1
                  firefox-i18n-hy-am             69.0.1-1             69.0.2-1
                     firefox-i18n-ia             69.0.1-1             69.0.2-1
                     firefox-i18n-id             69.0.1-1             69.0.2-1
                     firefox-i18n-is             69.0.1-1             69.0.2-1
                     firefox-i18n-it             69.0.1-1             69.0.2-1
                     firefox-i18n-ja             69.0.1-1             69.0.2-1
                     firefox-i18n-ka             69.0.1-1             69.0.2-1
                    firefox-i18n-kab             69.0.1-1             69.0.2-1
                     firefox-i18n-kk             69.0.1-1             69.0.2-1
                     firefox-i18n-km             69.0.1-1             69.0.2-1
                     firefox-i18n-kn             69.0.1-1             69.0.2-1
                     firefox-i18n-ko             69.0.1-1             69.0.2-1
                    firefox-i18n-lij             69.0.1-1             69.0.2-1
                     firefox-i18n-lt             69.0.1-1             69.0.2-1
                     firefox-i18n-lv             69.0.1-1             69.0.2-1
                     firefox-i18n-mk             69.0.1-1             69.0.2-1
                     firefox-i18n-mr             69.0.1-1             69.0.2-1
                     firefox-i18n-ms             69.0.1-1             69.0.2-1
                     firefox-i18n-my             69.0.1-1             69.0.2-1
                  firefox-i18n-nb-no             69.0.1-1             69.0.2-1
                  firefox-i18n-ne-np             69.0.1-1             69.0.2-1
                     firefox-i18n-nl             69.0.1-1             69.0.2-1
                  firefox-i18n-nn-no             69.0.1-1             69.0.2-1
                     firefox-i18n-oc             69.0.1-1             69.0.2-1
                  firefox-i18n-pa-in             69.0.1-1             69.0.2-1
                     firefox-i18n-pl             69.0.1-1             69.0.2-1
                  firefox-i18n-pt-br             69.0.1-1             69.0.2-1
                  firefox-i18n-pt-pt             69.0.1-1             69.0.2-1
                     firefox-i18n-rm             69.0.1-1             69.0.2-1
                     firefox-i18n-ro             69.0.1-1             69.0.2-1
                     firefox-i18n-ru             69.0.1-1             69.0.2-1
                     firefox-i18n-si             69.0.1-1             69.0.2-1
                     firefox-i18n-sk             69.0.1-1             69.0.2-1
                     firefox-i18n-sl             69.0.1-1             69.0.2-1
                    firefox-i18n-son             69.0.1-1             69.0.2-1
                     firefox-i18n-sq             69.0.1-1             69.0.2-1
                     firefox-i18n-sr             69.0.1-1             69.0.2-1
                  firefox-i18n-sv-se             69.0.1-1             69.0.2-1
                     firefox-i18n-ta             69.0.1-1             69.0.2-1
                     firefox-i18n-te             69.0.1-1             69.0.2-1
                     firefox-i18n-th             69.0.1-1             69.0.2-1
                     firefox-i18n-tr             69.0.1-1             69.0.2-1
                     firefox-i18n-uk             69.0.1-1             69.0.2-1
                     firefox-i18n-ur             69.0.1-1             69.0.2-1
                     firefox-i18n-uz             69.0.1-1             69.0.2-1
                     firefox-i18n-vi             69.0.1-1             69.0.2-1
                     firefox-i18n-xh             69.0.1-1             69.0.2-1
                  firefox-i18n-zh-cn             69.0.1-1             69.0.2-1
                  firefox-i18n-zh-tw             69.0.1-1             69.0.2-1
                             flatpak              1.4.3-1              1.5.0-1
                                 gdb                8.3-1              8.3.1-1
                          gdb-common                8.3-1              8.3.1-1
                              gmime3              3.2.3-3              3.2.4-1
                               gsasl              1.8.0-9              1.8.1-1
                               libuv             1.31.0-1             1.32.0-1
                               msmtp              1.8.5-1              1.8.6-1
                           msmtp-mta              1.8.5-1              1.8.6-1
                             pkgfile                 19-1                 20-2
                       python-beaker             1.10.1-1             1.11.0-1
                    python-packaging               19.1-2               19.2-2
                          python-pip             19.0.3-1             19.2.3-1
                      python-urllib3             1.25.3-1             1.25.5-1
                  python-urllib3-doc             1.25.3-1             1.25.5-1
                      python2-beaker             1.10.1-1             1.11.0-1
                python2-configparser              3.8.1-1              4.0.2-1
                   python2-packaging               19.1-2               19.2-2
                         python2-pip             19.0.3-1             19.2.3-1
                     python2-urllib3             1.25.3-1             1.25.5-1
                      zita-alsa-pcmi              0.3.2-1              0.3.2-2
                      zita-resampler              1.6.2-1              1.6.2-2


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-03           2019-10-04
-------------------------------------------------------------------------------
                  lib32-gtk3-classic            3.24.11-1            3.24.11-2


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-03           2019-10-04
-------------------------------------------------------------------------------
                           lib32-nss               3.46-1             3.46.1-1

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

12 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Pamac-Qt is not compatible to 9.0 API of Pamac

I think it’s time for a next stable update, I have noticed that on the linux52 Snaps won’t start :confused:

1 Like

Your patch fixed Mate/Gnome-keyring issue :clap:

GNOME 3.34 and Pamac 9.0.0 (and perhaps Mesa 19.2.0 to some extents?) gave us some trouble in Testing. That is essentially why it is taking so long to get anything released in Stable.

You can read Testing announcement to have a better idea of what is going on now.


:smiley:

2 Likes

I can wait driving on 419 :slight_smile:

Man you just have snaps, I got a 5700 XT in the box waiting to be used! Still though I'm perfectly ok with waiting if it means more stability (although, kinda sucks that arguably the worst DE is slowing Manjaro down)

You can always pull a newer kernel with necessary modules from the testing repo and install it manually if you're so impatient. Same goes for @Danielsuarez369
Backup first of course.

4 Likes

Hm, I also want to buy this GPU, but later this year and have a System with btrfs Filesystem and Snapshots :slight_smile:

Hope the 5.4 kernel is than released.
But at the moment I have other probs :smiley:

I just observed a problem with network-manager. If i manualy set an IP address on my network card the "apply button" doesn't get "enabled" so i can't apply the changes, anyone can confirm that ?

1 Like

Uploaded new version of mate-session-manager please check if gnome-keyring issue is gone now.

:wink:

I saw that Archlinux done the same...

https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/mate-session-manager&id=4f82f6addb79099948cb8167c9aaf70e9c0aa2f8

Will test this ASAP and report :slight_smile:

@benjamimgois
You were right! The button has no function at all.
Also, you can not create new profiles.

2 Likes

Tested and works - updated both mate-session-manager and gnome-keyring. Thenks :slight_smile:

I had just activated the night mode (Gnome). After a few minutes I used the function "Disable until tomorrow". Shortly thereafter, I rebooted the system and night mode has re-enabled, although the next day has not yet started.

At the moment the function should be called: Disable until next session. :sunglasses:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by