[Testing Update] 2019-10-03 - Octopi, Mesa, Gnome, Budgie, Repo-Compare

Hello community,

I am happy to announce another Testing Update. Mostly we have updates to Gnome, Budgie, Octopi and Mesa.


repo-compare is one of our new web-services. Give us your feedback on that new service!

Update news

This update holds the following changes:

  • repo-compare got further UI enhancements
  • We hopefully fixed more Gnome issues
  • Budgie should now work with Gnome 3.34
  • Mesa 19.2 got further fixed
  • Some work went into Octopi. Give us some feedback if there are some improvements.
  • The usual updates and improvements and upstream package renewals
  • Manjaro 18.1.1-pre2 got released! Please test and give us feedback: gnome, kde, xfce
  • Latest efforts by KDE can be reviewed via our current KDE-Dev ISO or current KDE-Vanilla ISO

Give us the usual feedback and let us know what you think about this update.


Current supported Kernels

  • linux316 3.16.74
  • linux44 4.4.194 (no legacy nvidia-340 module!)
  • linux49 4.9.194
  • linux414 4.14.146
  • linux419 4.19.76
  • linux52 5.2.18 (no catalyst module!)
  • linux53 5.3.2 (no catalyst module!)
  • linux54 5.4.0-rc1 (not all modules build yet!)
  • linux419-rt 4.19.72_rt25
  • linux52-rt 5.2.17_rt9

Package Updates (Thu Oct 3 12:00:09 CEST 2019)

  • testing community x86_64: 26 new and 25 removed package(s)
  • testing core x86_64: 2 new and 2 removed package(s)
  • testing extra x86_64: 19 new and 26 removed package(s)
  • testing multilib x86_64: 8 new and 15 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-02           2019-10-03
-------------------------------------------------------------------------------
                                bauh              0.6.1-1              0.6.2-1
      gnome-shell-extension-arc-menu              33.2-2 33.6+dev+2+g7390788-1
                              octopi             0.9.0-15             0.9.0-16
          octopi-notifier-frameworks             0.9.0-15             0.9.0-16
                 octopi-notifier-qt5             0.9.0-15             0.9.0-16
            dynamic-wallpaper-editor                    -              2.3-1.1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-02           2019-10-03
-------------------------------------------------------------------------------
                                anki             2.1.14-1             2.1.15-1
                      budgie-desktop               10.5-3  10.5+35+ga023c778-1
                              elixir              1.9.0-1              1.9.1-1
               freepats-general-midi           20190813-1           20191001-1
                              gitlab             12.3.2-1             12.3.3-1
                                  go             2:1.13-1           2:1.13.1-1
                              go-pie             2:1.13-1           2:1.13.1-1
                             libxmlb             0.1.11-1             0.1.12-1
                     multipath-tools              0.8.2-1              0.8.3-1
                            newsboat               2.17-1             2.17.1-1
                              podman              1.5.1-1              1.6.0-1
                       podman-docker              1.5.1-1              1.6.0-1
                           polyphone              2.0.1-5              2.1.1-1
                        python-jinja             2.10.1-1             2.10.1-2
                       python2-jinja             2.10.1-1             2.10.1-2
                              qtpass              1.3.0-1              1.3.1-1
                                repo             1.13.3-1             1.13.6-1
                            sagemath                8.9-2                8.9-3
                    sagemath-jupyter                8.9-2                8.9-3
                            singular           4.1.2.p2-1           4.1.2.p2-2


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-02           2019-10-03
-------------------------------------------------------------------------------
                            iana-etc           20190823-1           20190930-1
                             libpcap              1.9.0-1              1.9.1-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-02           2019-10-03
-------------------------------------------------------------------------------
               gnome-shell 1:3.34.0+157+g2dbdf792d-0 1:3.34.0+163+g6a6d66486-0
                            libglvnd            1.2.0-0.2                    -
                   libva-mesa-driver           19.2.0-0.1                    -
                                mesa           19.2.0-0.1                    -
                          mesa-vdpau           19.2.0-0.1                    -
                        mutter 3.34.0+41+g437f6b3d5-0.1 3.34.0+47+g105a3f757-0
                         opencl-mesa           19.2.0-0.1                    -
                        vulkan-intel           19.2.0-0.1                    -
                   vulkan-mesa-layer           19.2.0-0.1                    -
                       vulkan-radeon           19.2.0-0.1                    -


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-02           2019-10-03
-------------------------------------------------------------------------------
                               cmake             3.15.3-2             3.15.4-1
                             flatpak              1.4.2-1              1.4.3-1
                            graphviz             2.42.1-1             2.42.2-1
                             haveged              1.9.6-4              1.9.8-1
                            libglvnd              1.1.1-1              1.2.0-1
                   libva-mesa-driver             19.1.7-1             19.2.0-2
                                mesa             19.1.7-1             19.2.0-2
                          mesa-vdpau             19.1.7-1             19.2.0-2
                         opencl-mesa             19.1.7-1             19.2.0-2
                                rust           1:1.37.0-2           1:1.38.0-1
                           rust-docs           1:1.37.0-2           1:1.38.0-1
                              screen              4.6.2-1              4.7.0-1
                             tcpdump              4.9.2-1              4.9.3-1
                        vulkan-intel             19.1.7-1             19.2.0-2
                   vulkan-mesa-layer             19.1.7-1             19.2.0-2
                       vulkan-radeon             19.1.7-1             19.2.0-2
                     lib32-rust-libs                    -           1:1.38.0-1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-02           2019-10-03
-------------------------------------------------------------------------------
                      lib32-libglvnd            1.2.0-0.2                    -
             lib32-libva-mesa-driver           19.2.0-0.1                    -
                          lib32-mesa           19.2.0-0.1                    -
                    lib32-mesa-vdpau           19.2.0-0.1                    -
                  lib32-vulkan-intel           19.2.0-0.1                    -
                 lib32-vulkan-radeon           19.2.0-0.1                    -


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-02           2019-10-03
-------------------------------------------------------------------------------
                      lib32-libglvnd              1.1.1-1              1.2.0-1
                       lib32-libpcap              1.9.0-1              1.9.1-1
             lib32-libva-mesa-driver             19.1.7-1             19.2.0-2
                          lib32-mesa             19.1.7-1             19.2.0-2
                    lib32-mesa-vdpau             19.1.7-1             19.2.0-2
                          lib32-rust             1.37.0-2                    -
                  lib32-vulkan-intel             19.1.7-1             19.2.0-2
                 lib32-vulkan-radeon             19.1.7-1             19.2.0-2
                           wine-nine                0.4-1                0.5-1
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

8 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Pamac-Qt is not compatible to 9.0 API of Pamac

Getting many errors from Chromium (maybe I always got them and never noticed since I used to launch Chromium from the Application Launcher)

$ chromium
[1205:1205:1003/093927.688678:ERROR:sandbox_linux.cc(369)] InitializeSandbox() called with multiple threads in process gpu-process.
[1162:1162:1003/094031.788490:ERROR:page_load_metrics_update_dispatcher.cc(166)] Invalid first_paint 9924.33 s for first_image_paint 9924.33 s
[1162:1162:1003/094032.785872:ERROR:page_load_metrics_update_dispatcher.cc(166)] Invalid first_paint 9924.33 s for first_image_paint 9924.33 s
[1162:1162:1003/094034.485863:ERROR:page_load_metrics_update_dispatcher.cc(166)] Invalid first_paint 9924.33 s for first_image_paint 9924.33 s
[1162:1162:1003/094041.154567:ERROR:page_load_metrics_update_dispatcher.cc(166)] Invalid first_paint 9924.33 s for first_image_paint 9924.33 s

But at least it launches and appears to run fine again. So this appears to fix my issue first posted with the 2019-09-28 release:

1 Like

No problems, xfce on HP all Intel. Have been playing with pamac, both the gui and cli versions and want to congratulate you especially on the ease of use in the cli version. It works exactly as expected and should be second nature to anyone coming from an apt system. Look forward to seeing it develop.

Back on testing with my ivy-bridge notebook.
HW-acceleration working again with new mesa.

...aah, repo-compare is very handy. :eyes:

2 Likes

I had reported that I could not boot into Budgie after a recent testing update, and had switched to Stable so that I could access my data. Today, seeing that there are some new Budgie and Gnome testing updates, I switch back to testing and, after updating, am able to boot into the DE again. Problem solved!

1 Like

No problems on xfce on HP with AMD and nvidia since upgrading to:

bob@Manjaro-Testing~$ inxi -Fxzc0
[bob@Manjaro-Testing ~]$ inxi -Fxzc0
System:
  Host: Manjaro-Testing Kernel: 5.3.2-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 9.1.0 Desktop: Xfce 4.14.1 Distro: Manjaro Linux 
Machine:
  Type: Desktop System: Hewlett-Packard product: HP EliteDesk 705 G1 SFF 
  v: N/A serial: <filter> 
  Mobo: Hewlett-Packard model: 2215 serial: <filter> UEFI: Hewlett-Packard 
  v: L06 v02.30 date: 03/22/2018 
Battery:
  Device-1: hidpp_battery_0 model: Logitech M570 charge: 95% 
  status: Discharging 
CPU:
  Topology: Quad Core model: AMD A10-6800K APU with Radeon HD Graphics 
  bits: 64 type: MCP arch: Piledriver rev: 1 L2 cache: 2048 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 
  bogomips: 32753 
  Speed: 2942 MHz min/max: 2000/4100 MHz Core speeds (MHz): 1: 2310 2: 2562 
  3: 1995 4: 1995 
Graphics:
  Device-1: NVIDIA GK208 [GeForce GT 720] vendor: Micro-Star MSI 
  driver: nvidia v: 435.21 bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.5 driver: nvidia unloaded: modesetting 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GT 720/PCIe/SSE2 v: 4.6.0 NVIDIA 435.21 
  direct render: Yes 
Audio:
  Device-1: AMD FCH Azalia vendor: Hewlett-Packard driver: snd_hda_intel 
  v: kernel bus ID: 00:14.2 
  Device-2: NVIDIA GK208 HDMI/DP Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Sound Server: ALSA v: k5.3.2-1-MANJARO 
Network:
  Device-1: Broadcom and subsidiaries NetXtreme BCM5762 Gigabit Ethernet PCIe vendor: Hewlett-Packard driver: tg3 v: 3.137 port: e000 bus ID: 04:00.0 
  IF: enp4s0 state: down mac: <filter> 
  Device-2: Ralink MT7601U Wireless Adapter type: USB driver: mt7601u 
  bus ID: 4-1:2 
  IF: wlp0s19f2u1 state: up mac: <filter> 
Drives:
  Local Storage: total: 2.73 TiB used: 72.40 GiB (2.6%) 
  ID-1: /dev/sda vendor: HGST (Hitachi) model: HUS724020ALE641 
  size: 1.82 TiB 
  ID-2: /dev/sdb vendor: Western Digital model: WD10EZEX-08M2NA0 
  size: 931.51 GiB 
Partition:
  ID-1: / size: 911.41 GiB used: 28.64 GiB (3.1%) fs: ext4 dev: /dev/sda4 
  ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 13.6 C mobo: N/A gpu: nvidia temp: 64 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 42% 
Info:
  Processes: 186 Uptime: 2h 52m Memory: 7.76 GiB used: 857.5 MiB (10.8%) 
  Init: systemd Compilers: gcc: 9.1.0 Shell: bash v: 5.0.11 inxi: 3.0.36

Linux 5.4rc1.d0930.g54 Needs work though, will not boot up.

I had to downgrade gnome-keyring on my manjaro testing. I see the same bug on my Archlinux desktop PC.

See these bugs reports:

https://bugs.archlinux.org/task/63995


Annoying.

Yet another GNOME 3.34 problem (well, one of its component to be more precise).

Lol, for how long this release will hold us (Manjaro) back?

Well the update of Gnome keyring fixed some issues in Deepin. We will see how it goes.

1 Like

Looks like this bug is getting worked on.

I hope they'll be a patch soon. I choose to downgrade gnome-keyring on my installation in order to keep a working Mate desktop.

1 Like

Thanks. ... I had same issue for a few days, and did not find the cause/solution.

Working splendidly as always! Kernel 5.3 / 4.19, Xfce.

i got tearing in chromium when scrolling web pages with my i3-3110m's HD 4000 graphics too which is also now fixed, in all other applications it was and is still working properly.

Video decoding is broken even on this update. Downgrading libva-mesa-driver & mesa-vdpau packages to ver. 19.1.7 or 19.1 series restores video decoding on my machine.

Edit : Even after downgrading those packages, video decode is still somewhat broken. I had to revert all mesa packages back to 19.1.7 to get it working again

What videos using which media player?

1 Like

@fredb74 did you open a bug report also on Mate side? As Gnome came to this solution pointing it to a problem of Mate.

The entire point of the patch is that the calls are handled before the application quits (well, before gnome-session registers that the application is quit, but same thing). So if mate session manager waits for the process to quit before handling the dbus calls, then we are in an unsolvable situation.

Yes I do. It seems you noticed it. Anyway, here is the link: https://github.com/mate-desktop/mate-session-manager/issues/222

As an old (arch)linux user, I know how to downgrade and keep a package outdated for some times until it a bug is fixed. But I don't think a lot of manjaro users could do the same.

I'm pragmatic. If it takes too long to be fixed, I will uninstall Mate and use another desktop environment.

Well, it might be a small fight between Mate and Gnome. Most likely Mate has to adopt somehow to upstream changes by Gnome.

1 Like

@oberon, time to update GPG keys?

error: nerd-fonts-terminus: signature from "Bernhard Landauer <bernhard@manjaro.org>" is invalid
:: File /var/cache/pacman/pkg/nerd-fonts-terminus-2.0.0-2-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).

No, it must have been a broken download of the package on my end. False alarm! :blush:

1 Like

Forum kindly sponsored by