[Testing Update] 2019-09-29 - Bauh, Linux54, Gnome Themes, Calamares, Manjaro 18.1.1-pre1

Hello community,

I am happy to announce another Testing Update. Mostly we have Manjaro 18.1.1-pre1, updated development Kernel and the usual upstream updates.


See what bauh 0.6 series will bring for you!

Update news

This update holds the following changes:

  • bauh is now at 0.6.1
  • Pamac got it's second release candidate for v9.0 series.
  • We added the latest development kernel 5.4rc0.d0928.gaefcf2f-1. Note that only few modules build!
  • We worked on our Gnome Themes and updated some of gnome packages
  • Calamares gained some fixes in regard of GeoIP
  • Manjaro 18.1.1-pre1 got released! Please test and give us feedback: gnome, kde, xfce
  • Latest efforts by KDE can be reviewed via our current KDE-Dev ISO or current KDE-Vanilla ISO

Give us the usual feedback and let us know what you think about this update.


Current supported Kernels

  • linux316 3.16.74
  • linux44 4.4.194 (no legacy nvidia-340 module!)
  • linux49 4.9.194
  • linux414 4.14.146
  • linux419 4.19.75
  • linux51 5.1.21 [EOL]
  • linux52 5.2.17 (no catalyst module!)
  • linux53 5.3.1 (no catalyst module!)
  • linux54 5.4.0-rc0 (not all modules build yet!)
  • linux419-rt 4.19.72_rt25
  • linux52-rt 5.2.17_rt9

Package Updates (Sun Sep 29 18:28:56 CEST 2019)

  • testing community x86_64: 52 new and 67 removed package(s)
  • testing core x86_64: 3 new and 3 removed package(s)
  • testing extra x86_64: 30 new and 38 removed package(s)
  • testing multilib x86_64: 1 new and 1 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-09-28           2019-09-29
-------------------------------------------------------------------------------
                                bauh              0.5.2-1              0.6.1-1
                   manjaro-gdm-theme           20190928-1           20190929-1
                           timeshift            19.08.1-2            19.08.1-3


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-09-28           2019-09-29
-------------------------------------------------------------------------------
                            bugzilla              5.0.4-1              5.0.6-1
                          containerd              1.2.9-1              1.3.0-1
                          displaycal            3.8.6.0-1            3.8.7.0-1
                            ejabberd              19.08-1              19.09-1
                                entr                4.2-1                4.3-1
                                exim             4.92.2-1             4.92.3-1
                           freebasic             1.07.0-1             1.07.1-1
                             haproxy              2.0.5-1              2.0.7-1
                                knot              2.8.3-1              2.8.4-1
                              kresus             0.14.0-2             0.14.0-3
                             libvirt              5.5.0-1              5.6.0-1
                      libvirt-python              5.3.0-1              5.7.0-1
                     libvirt-python2              5.3.0-1              5.7.0-1
               matrix-appservice-irc             0.12.0-1             0.13.0-1
                             minicom              2.7.1-2              2.7.1-3
                              murmur              1.3.0-1              1.3.0-2
                                mypy              0.720-2              0.730-1
                      netcdf-fortran              4.5.1-1              4.5.2-1
              netcdf-fortran-openmpi              4.5.1-1              4.5.2-1
                           nextcloud             16.0.4-1             16.0.5-1
             nextcloud-app-bookmarks            1:2.1.0-1            1:2.1.1-1
                         openvswitch             2.11.1-1             2.12.0-1
                          phpmyadmin            4.9.0.1-1              4.9.1-1
                      python-cheroot              6.5.8-1              7.0.0-1
               python-docker-pycreds              0.4.0-1              0.4.0-3
                        python-gitdb              2.0.5-2              2.0.6-1
             python-jsonrpclib-pelix              0.4.0-1              0.4.0-2
                     python-keyutils                0.6-1                0.6-2
                         python-nltk                3.4-1              3.4.5-1
                       python-peewee             3.11.1-1             3.11.2-1
                       python-pipenv         2018.11.26-1         2018.11.26-2
                     python-psycopg2              2.8.3-1              2.8.3-2
                        python-pyaes              1.6.1-2              1.6.1-3
               python-pytest-twisted               1.11-1               1.12-1
                    python-sqlobject              3.7.0-2              3.7.3-1
                     python2-cheroot              6.5.8-1              7.0.0-1
              python2-docker-pycreds              0.4.0-1                    -
                         python2-irc               16.4-1                    -
            python2-jsonrpclib-pelix              0.4.0-1                    -
                    python2-keyutils                0.6-1                    -
                        python2-nltk                3.4-1                    -
                      python2-pipenv         2018.11.26-1                    -
                    python2-psycopg2              2.8.3-1                    -
                       python2-pyaes              1.6.1-2                    -
                  python2-pydocstyle              3.0.0-1                    -
                       python2-pyotp              2.3.0-1                    -
              python2-pytest-twisted               1.11-1               1.12-1
            python2-service_identity             18.1.0-2                    -
                   python2-sqlobject              3.7.0-2              3.7.3-1
                      python2-stopit              1.1.2-2                    -
                        python2-suds                0.6-3                    -
                 python2-swiftclient              3.8.1-1                    -
                     python2-trustme              0.5.2-1                    -
                      python2-tweepy              3.8.0-1                    -
                         qutebrowser              1.8.0-1              1.8.1-1
                        riot-desktop              1.3.6-1              1.4.0-1
                            riot-web              1.3.6-1              1.4.0-1
                                simh              3.9.0-4               3.10-1
                    telegram-desktop              1.8.8-1              1.8.9-1
                        virt-install              2.2.0-2              2.2.1-1
                        virt-manager              2.2.0-2              2.2.1-1
                             webhook              2.6.9-2             2.6.10-1
                                yarn             1.17.3-1             1.19.0-1
                               zapcc         7.0.325000-2         7.0.325000-3
                python-matrix_client                    -              0.3.2-1


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-09-28           2019-09-29
-------------------------------------------------------------------------------
                       linux54 5.4rc0.d0919.gb41dae0-1 5.4rc0.d0928.gaefcf2f-1
               linux54-headers 5.4rc0.d0919.gb41dae0-1 5.4rc0.d0928.gaefcf2f-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-09-28           2019-09-29
-------------------------------------------------------------------------------
                               links             2.20.1-1             2.20.2-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-09-28           2019-09-29
-------------------------------------------------------------------------------
                           calamares            3.2.13-10           3.2.13.1-1
                   linux54-acpi_call            1.1.0-0.1            1.1.0-0.2
                    linux54-bbswitch              0.8-0.1              0.8-0.2
                 linux54-broadcom-wl     6.30.223.271-0.1     6.30.223.271-0.2
                linux54-nvidia-390xx          390.129-0.1                    -
                linux54-nvidia-418xx           418.88-0.1                    -
                linux54-nvidia-430xx           430.40-0.1                    -
                linux54-nvidia-435xx           435.21-0.1                    -
                    linux54-nvidiabl             0.88-0.1             0.88-0.2
                       linux54-r8168         8.047.02-0.1                    -
                   linux54-rtl8723bu    4.3.9.3.13200-0.1    4.3.9.3.13200-0.2
                    linux54-tp_smapi             0.43-0.1             0.43-0.2
                 linux54-vhba-module         20190831-0.1         20190831-0.2
                         linux54-zfs            0.8.2-0.1            0.8.2-0.2
                  manjaro-tools-base             0.15.9-6             0.15.9-7
              manjaro-tools-base-git      r2813.6fe92d3-1      r2820.90a00d6-1
                   manjaro-tools-iso             0.15.9-6             0.15.9-7
               manjaro-tools-iso-git      r2813.6fe92d3-1      r2820.90a00d6-1
                   manjaro-tools-pkg             0.15.9-6             0.15.9-7
               manjaro-tools-pkg-git      r2813.6fe92d3-1      r2820.90a00d6-1
                  manjaro-tools-yaml             0.15.9-6             0.15.9-7
              manjaro-tools-yaml-git      r2815.f0494d3-1      r2820.90a00d6-1
                     optimus-manager                1.2-1              1.2.1-1
                           pamac-cli            9.0.0rc-5           9.0.0rc2-1
                       pamac-cli-dev            9.0.0rc-1                    -
                        pamac-common            9.0.0rc-5           9.0.0rc2-1
                    pamac-common-dev            9.0.0rc-1                    -
                           pamac-gtk            9.0.0rc-5           9.0.0rc2-1
                       pamac-gtk-dev            9.0.0rc-1                    -
                   pamac-snap-plugin            9.0.0rc-5           9.0.0rc2-1
               pamac-snap-plugin-dev            9.0.0rc-1                    -
             pamac-tray-appindicator            9.0.0rc-5           9.0.0rc2-1
         pamac-tray-appindicator-dev            9.0.0rc-1                    -
                         gnome-shell               - 1:3.34.0+157+g2dbdf792d-0
                              mutter                - 3.34.0+41+g437f6b3d5-0.1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-09-28           2019-09-29
-------------------------------------------------------------------------------
                          fluidsynth              2.0.6-1              2.0.7-1
                                 gyp  20190716.fcd686f1-1  20190716.fcd686f1-2
                          liblangtag              0.6.2-2              0.6.3-1
                            pipewire  0.2.6+1+g37613b67-1              0.2.7-1
                       pipewire-docs  0.2.6+1+g37613b67-1              0.2.7-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-09-28           2019-09-29
-------------------------------------------------------------------------------
                    lib32-fluidsynth              2.0.6-1              2.0.7-1
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

9 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Pamac 9.0rc may crash due to AUR

Pamac-Qt is not compatible to 9.0 API of Pamac

Kernel 5.3 series don't support Flatpak out of the box

Flatpaks still do not work without manual interaction.
Switching from the bubblewrap package to bubblewrap-suid fixes this.
However, almost all users on stable currently have the normal bubblewrap package installed and not everybody will know what to do. Not all users read the forum and some may wondering why flatpaks stop working.
Are you planning some kind of migration?

Edit: Other than that, current testing update seems fine. No new problems on my machine.

What exactly do you mean? It is known that linux53 missed a config setting.

Oh, it's linux53 specific. It works without changing the bubblewrap package on linux52.
But well, linux53 still has this problem, so it is still missing this config setting. Are you sure you pushed the new build to the testing branch?

Gnome problems seems solved.

the nvidia module for this particular rc of kernel 5.4 is clearly one of the missing ones so I've booted to kernel 5.3 which is now my backup kernel on this system instead. A non-issue but feeding back in case any other nvidia driver users attempt to install kernel 5.4rc0.d0928.gaefcf2f-1. Put simply DON'T yet :wink:

Apart from that no issues whatsoever :+1:

bauh is coming along nicely by the looks of it from the screenshot above

As usual close to rc1 of a kernel most of the extra modules break. Especially Nvidia drivers.

1 Like

Yeah I've a rather sadistic sense of humour so it kind of amuses me that rc0 is usually fine but then something causes breakages in rc1. I've seen it in the past with other devices too so have learnt not to expect it to work, but if you don't try you never know...

2 Likes

There's a resemblance isn't it? :laughing:
linustorvalds1-580x358 00013r4b

But seriously, just look at the enormous amount of recent merges, something is likely to break compatibility.
Back in 09-19 mainline was very close to 5.3, but since then many things have been landed to the mainline kernel.

5 Likes

Hi people, in my system since about 2 weeks the following effects occur.

Headphones:
After every reboot there is no music output. I have to pull out the headphone jack once and then the sound output works again.

Signal-Desktop-bin (AUR): With Kernel 53 the application doesn't start anymore. As solution I could use the Snappackage, which also runs with Kernel 53.

lightdm: the following error message still exists in the journalctl:
gkr-pam: unable to locate daemon control file

Translated with www.DeepL.com/Translator

Looks like something in linux53 has broken mullvad-vpn 2019.8-2 for me. The GUI segfaults but the Cli portion continues to work. :woman_shrugging:
Guess I'll head over their github and let them know. :wink:

Linux52 no issues.

works for me - just to be sure: did you rebuild it after the update?

There's nothing to rebuild, it's a binary package made from the RPM.

@philm, it seems bauh 0.6.X is not displaying update notifications in the tray mode. I will try to publish a fix release tonight or tomorrow.

Hi @Cedric_K, I added a hotfix to the package which should fix https://github.com/signalapp/Signal-Desktop/issues/3536

Could you try the updated PKGBUILD ?

The error message was:

$ signal-desktop 
[1618790:1001/004226.997288:FATAL:setuid_sandbox_host.cc(157)] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I'm aborting now. You need to make sure that /opt/Signal/chrome-sandbox is owned by root and has mode 4755.
fish: “./signal-desktop” terminated by signal SIGTRAP (Trace or breakpoint trap)

I have noticed this also when logging out. Xfce PulseAudio Plugin reverts to line-out when it logs back in. But I did not remember if it always did this. I am using kernel 5.2.

TY, it works now.

I update my system stable->unstable. After that gnome not loaded and started. I inspect system and understand that problem is package manjaro-gdm-theme 20190929-1. Problem is : GDM not loaded and Gnome-shell too. I install and change GDM with SDDM, after that Gnome not load again. After that I downgrade package manjaro-gdm-theme (20190929-1 -> 20190928-2), all working fine.

Hello @philm and guys,
yesterday's latest update ( including bluez 5.51-2 packages update ) solved missing automatic connection to BOSE sound link speaker at last ! I mean this Bluetooth connection worked the first time but whenever I changed into a different application source, for example moved from Firefox into VLC player, this connection went down and the new opened application changed to connect to stereo Analog internal audio source and not the BOSE sound link Bluetooth .. well I feel happy this is now working good ..so I don't need to reconnect Bluetooth audio output manually every time I pick another media application.. (this happened even though I had set BOSE Bluetooth speakers as my audio 1st option as default in KDE settings) ..Thanks a lot for that bluez packages update guys..you rock !:metal:

Forum kindly sponsored by