[Testing Update] 2019-09-24 - Kernels, KDE-Dev, Systemd, Gnome 3.34, Pamac, Mesa

Hello community,

I am happy to announce another Testing Update. Mostly we have Kernels, Gnome 3.34 and needed rebuilds with this one.


Our first Gnome 3.34 ISO is online now

Update news

This update holds the following changes:

  • Beginning with Pamac 9.0 series, we now support snaps via a plugin
  • Most of our Kernels got updated
  • We managed to get Gnome 3.34 ready. Tell us what we might have missed and as usual, please deactivate your external plugins before upgrading.
  • Mesa got a new point-release.
  • Some Browser got updated as needed
  • Manjaro 18.1.0 got released today. Please test and give us feedback.
  • Latest efforts by KDE can be reviewed via our current KDE-Dev ISO or current KDE-Vanilla ISO

Give us the usual feedback and let us know what you think about this update.


Current supported Kernels

  • linux316 3.16.73
  • linux44 4.4.194 (no legacy nvidia-340 module!)
  • linux49 4.9.194
  • linux414 4.14.146
  • linux419 4.19.75
  • linux51 5.1.21 [EOL]
  • linux52 5.2.17 (no catalyst module!)
  • linux53 5.3.1 (no catalyst module!)
  • linux419-rt 4.19.72_rt25
  • linux52-rt 5.2.14_rt7

Package Updates (Tue Sep 24 08:53:46 CEST 2019)

  • testing community x86_64: 433 new and 419 removed package(s)
  • testing core x86_64: 27 new and 25 removed package(s)
  • testing extra x86_64: 264 new and 342 removed package(s)
  • testing multilib x86_64: 12 new and 12 removed package(s)

A list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

15 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Changes made to Grub 2.04-6

Due to some bugs with the Fedora patches in regard of BTRFS we are using now the Ubuntu approach to hide the menu via GRUB_TIMEOUT.

These are the current options to style the timeout:

GRUB_TIMEOUT_STYLE=countdown
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT_STYLE=menu

You may want to double-check your settings in /etc/default/grub

We also provide a new package called grub-vanilla. Learn more about it here.


Thunderbird 68.0 disabled my extensions!

Thunderbird 68 changes the way extensions work in line with Firefox 68. This will mean incompatible extensions are disabled.

The Thunderbird developers have made it as easy as possible for extensions developers to update the extensions to get them working again.

However, it will take time for extensions to 1) be updated and 2) make their way onto AMO for download.

You have two basic choices:

  1. Add IgnorePkg = thunderbird to your /etc/pacman.conf until your "critical" extension is updated
  2. Keep checking for updates for your "critical" extension, and possibly pester the developer to update it

Option 2 is the more proactive.


pip behaves differently

pip now includes by default the --user flag for all operations.


Asian/CJK characters display as blocks

Install noto-fonts-cjk or another font of your choice. The problem seems related to a ttf-droid update.

https://bugs.archlinux.org/task/63205


libbloom>=1.6-2 update requires manual intervention

(Taken from Arch Linux website, 2019-07-11 by Felix Yan. Source: https://www.archlinux.org/news/libbloom16-2-update-requires-manual-intervention/)

The libbloom package prior to version 1.6-2 was missing a soname link. This has been fixed in 1.6-2, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libbloom: /usr/lib/libbloom.so.1 exists in filesystem

when updating, use

pacman -Suy --overwrite usr/lib/libbloom.so.1

to perform the upgrade.

tensorflow>=1.14.0-5 update requires manual intervention

From Konstantin Gizdov on August 20, 2019

The tensorflow packages prior to version 1.14.0-5 were missing some soname links. This has been fixed in 1.14.0-5, so the upgrade will need to overwrite the untracked soname links created by ldconfig. If you get an errors like so.

tensorflow: /usr/lib/libtensorflow.so.1 exists in filesystem
tensorflow: /usr/lib/libtensorflow_cc.so.1 exists in filesystem
tensorflow: /usr/lib/libtensorflow_framework.so.1 exists in filesystem

when updating, use

pacman -Suy --overwrite=usr/lib/libtensorflow.so.1,usr/lib/libtensorflow_cc.so.1,usr/lib/libtensorflow_framework.so.1

to perform the upgrade.

astyle>=3.1-2 update requires manual intervention

Of Antonio Rojas in August 26

The astyle package prior to version 3.1-2 was missing a soname link. This has been fixed in 3.1-2, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

astyle: /usr/lib/libastyle.so.3 exists in filesystem

when updating, use

pacman -Suy --overwrite usr/lib/libastyle.so.3

to perform the upgrade.

The update went through smoothly and everything seems to be working as it should.

Thank you so much for all the great things you all do!

:heart_decoration:

some sysinfo

System:
Kernel: 4.19.75-1-MANJARO x86_64 bits: 64
parameters: BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64
root=UUID=5a845a02-650d-42ac-92d9-b42473b830ef rw quiet resume=/dev/sda8
security=apparmor apparmor=1
Desktop: Xfce 4.14.1 Distro: Manjaro Linux

CPU:
Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP
family: 6 model-id: 8E (142) stepping: A (10) microcode: B4
L2 cache: 6144 KiB
Speed: 1676 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 1676 2: 1867
3: 1558 4: 1861 5: 2002 6: 1275 7: 1622 8: 1501

Graphics:
Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting
resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2)
v: 4.5 Mesa 19.1.7

1 Like

I see that Nim has already been updated to v1.0, wow! (the release was yesterday evening)

If somebody on testing branch (I'm on stable) could just double-check something, it would be great. There was a last-minute fix, after v1.0 has been already tagged, so everything was re-tagged after the fix — just to make sure that the Manjaro has the correct updated version.

Can you please install Nim and check the printed git hash after you do nim -v? If you see git hash: f7a8fc46c0012033917582eb740dc0343c093e35 then everything is ok, that is the correct git hash.

~ >>> nim -v                                                                                                                                                                                                      
Nim Compiler Version 1.0.0 [Linux: amd64]
Compiled at 2019-09-23
Copyright (c) 2006-2019 by Andreas Rumpf

active boot switches: -d:release -d:nativeStackTrace

no git hash visible

Heh, I decided to fire up my Manjaro VM, switch to test branch there, and to test it :slight_smile:

On a first glance, it seems that everything is ok.

Update worked flawlessly and Gnome 3.34 is really fluid even without any additional patches. :slight_smile:

During the update I got this error:

:: unable to satisfy dependency 'gnome-shell<3.34' required by gnome-shell-extension-arc-menu

Everything else is fine and I really enjoy it, Gnome 3.34 is very nice!, but Arc Menu is highly useful for me, I hope it is only something temporary!

All seems good on KDE all-Intel laptop.

Arc menu and Desktop icons both break when updating, Arc Menu stays in a "Needs update" state while Desktop icons crashes

It is gone from kernel.org for some weeks now - I thought you wanted to follow the removal there?

Arc menu is currently not working on Gnome 3.34. Please uninstall before upgrading. We will keep track with upstream and reintroduce it when ready.

Well i think i´m the first to have problems. Gnome doesn´t start anymore and show this gray screen.

Press Ctrl+Alt+F3 to access TTY3 and then Ctrl+Alt+F1 and see if that unlocks the screen. If not, then go back to TTY3, log in as your user and run systemctl reboot.
If all this persists, that means you have an extension that prevents GDM to start properly. Think what that might be and report back.

1 Like

Thanks for the answer @bogdancovaciu, i just tried what you suggest but i can´t unlock the screen. I had just a feel extensions installed (ARC MENU, DASH TO PANEL and VITTALS). Is there a way to uninstall the gnome-extensions by the CLI ?

Try this way:

  1. Open TTY3 as i mentioned previously and as your user.
  2. Go to the extensions directory:
    cd ~/.local/share/gnome-shell/extensions
  3. List the extensions and get the name of the unwanted extension :
    ls -l
  4. Delete the extension directory:
    rm -r extension@author
    Note: - replace extension with the real name of it.
  5. reboot after that, but also make sure you didn't had a partial update, or the "wrong" systemd version, so run:
    sudo pacman-mirrors -f5 && sudo pacman -Syyuu
2 Likes

No luck here.. The only extension on the folder were Vittals, i remove it. Tried the system upgrade with pacman but there were no packages to update. Still receive the same error.

From the same TTY3:
systemctl stop gdm
then
systemctl disable gdm
then
systemctl enable gdm --now

The only issue I've encountered with GNOME 3.34.0 is when restarting GNOME Shell, some program windows are destroyed like Chrome & qBitTorrent.

All my machines updated without issue except my haunted one (Absu).
Was running linux53 during the update. Something in the update nuked my internet.
No errors in Journal or dmesg. Would show link was up and connected but no internet. Turned off VPN to eliminate variables.
Confirmed with another computer I actually had internet, affirmative.
Deleted all Network-Manglers saved connections. No joy.
Changed to Linux52, Internet was back.
So you got me. Linux53 will not connect now for me using Linux53.

Forum kindly sponsored by