[Testing Update] 2019-09-11 - Kernels, KDE-Dev, Systemd 243.9, QT 5.13.1, Haskell

Hello community,

I am happy to announce another Testing Update. Mostly we have Kernels, KDE-Dev and Systemd updates with this one.


More about the server upgrade you may find here.

Update news

This update holds the following changes:

  • Kernels got updated to it's latest revisions
  • We managed to renew our KDE-Dev packages
  • Some work went into fixing Systemd 243 series
  • Qt5 got bumped to 5.13.1 which brings needed fixes. Report if we still have to rebuild some packages against it.
  • The usual Haskell and Python updates
  • Manjaro 18.1-rc10 got released couple of days ago. Please test and give us feedback.
  • Latest efforts by KDE can be reviewed via our current KDE-Dev ISO or current KDE-Vanilla ISO
  • Manjaro Juhraya ISOs got updated, including flatpak and snap support pre-activated. Office can be selected during installation between libreoffice-still or freeoffice: XFCE, KDE, Gnome

Give us the usual feedback and let us know what you think about this update.


Current supported Kernels

  • linux316 3.16.73
  • linux44 4.4.192 (no legacy nvidia-340 module!)
  • linux49 4.9.192
  • linux414 4.14.143
  • linux419 4.19.72
  • linux51 5.1.21 [EOL]
  • linux52 5.2.14 (no catalyst module!)
  • linux53 5.3-rc8 (not all modules build yet!)
  • linux419-rt 4.19.50_rt22
  • linux52-rt 5.2.10_rt5-1

Package Updates (Wed Sep 11 11:29:32 CEST 2019)

  • testing community x86_64: 502 new and 500 removed package(s)
  • testing core x86_64: 26 new and 26 removed package(s)
  • testing extra x86_64: 223 new and 223 removed package(s)
  • testing multilib x86_64: 10 new and 11 removed package(s)

A list of all package changes may be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

6 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Changes made to Grub 2.04-6

Due to some bugs with the Fedora patches in regard of BTRFS we are using now the Ubuntu approach to hide the menu via GRUB_TIMEOUT.

These are the current options to style the timeout:

GRUB_TIMEOUT_STYLE=countdown
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT_STYLE=menu

You may want to double-check your settings in /etc/default/grub

We also provide a new package called grub-vanilla. Learn more about it here.


Thunderbird 68.0 disabled my extensions!

Thunderbird 68 changes the way extensions work in line with Firefox 68. This will mean incompatible extensions are disabled.

The Thunderbird developers have made it as easy as possible for extensions developers to update the extensions to get them working again.

However, it will take time for extensions to 1) be updated and 2) make their way onto AMO for download.

You have two basic choices:

  1. Add IgnorePkg = thunderbird to your /etc/pacman.conf until your "critical" extension is updated
  2. Keep checking for updates for your "critical" extension, and possibly pester the developer to update it

Option 2 is the more proactive.


pip behaves differently

pip now includes by default the --user flag for all operations.


Asian/CJK characters display as blocks

Install noto-fonts-cjk or another font of your choice. The problem seems related to a ttf-droid update.

https://bugs.archlinux.org/task/63205


libbloom>=1.6-2 update requires manual intervention

(Taken from Arch Linux website, 2019-07-11 by Felix Yan. Source: https://www.archlinux.org/news/libbloom16-2-update-requires-manual-intervention/)

The libbloom package prior to version 1.6-2 was missing a soname link. This has been fixed in 1.6-2, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libbloom: /usr/lib/libbloom.so.1 exists in filesystem

when updating, use

pacman -Suy --overwrite usr/lib/libbloom.so.1

to perform the upgrade.

tensorflow>=1.14.0-5 update requires manual intervention

From Konstantin Gizdov on August 20, 2019

The tensorflow packages prior to version 1.14.0-5 were missing some soname links. This has been fixed in 1.14.0-5, so the upgrade will need to overwrite the untracked soname links created by ldconfig. If you get an errors like so.

tensorflow: /usr/lib/libtensorflow.so.1 exists in filesystem
tensorflow: /usr/lib/libtensorflow_cc.so.1 exists in filesystem
tensorflow: /usr/lib/libtensorflow_framework.so.1 exists in filesystem

when updating, use

pacman -Suy --overwrite=usr/lib/libtensorflow.so.1,usr/lib/libtensorflow_cc.so.1,usr/lib/libtensorflow_framework.so.1

to perform the upgrade.

updaitng

Even tho Everything went smoothly - it seems this issue described by @mbod is still present.

1 Like

I have FreeOffice put on TaskManager KDE. After update, FO icon on Task Manager lost, just show "?" icon. Also it happened on Office Menu.

Applicable?

https://bbs.archlinux.org/viewtopic.php?id=233820

1 Like

On my end It didn't change, at least on XFCE. Currently testing 18.1 KDE. Let me see if I find some ...

Sadly no. Thanks kindly!

Found it. Thx for reporting @leo4kusuma

2 Likes

I had to remove bleachbit:

Fehler: Konnte den Vorgang nicht durchführen (In Konflikt stehende Dateien)
bleachbit: /usr/share/bleachbit/Action.pyc existiert im Dateisystem
...
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.
Error installing repo packages

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Deleting /usr/share/bleachbit folder and re-installing bleachbit solved problem...

1 Like

No issues:
Xfce Testing (Minimal architect install). 5.3 and 4.19 kernels. Terminal, sudo pacman -Syyu.

Thanks for fix it. New update of FO fix my report before.

Same here.

Anyone having issues with youtube-dl as well? Does not seem to work anymore.

edit
downgrading does not help. Maybe youtube screewed things up.

More people in the same situation

3 Likes

I still have the same issue that I boot into a black screen when laptop is attached to the docking station. I have to boot the laptop standalone and once logged in, I can attach it to the docking station.

I'm still having the same issue as with the last update where I boot to a black screen on KDE-dev running any kernel. It boots the 2nd or 3rd try without me having changed anything though. I ran journalctl --no-pager --no-hostname -xb -1 -p3 and this is what I believe is the relevant output:

Sep 11 14:56:20 kernel: sp5100-tco sp5100-tco: Watchdog hardware is disabled
Sep 11 14:56:25 kernel: ccp 0000:0a:00.1: sev command 0x4 timed out, disabling PSP
Sep 11 14:56:25 kernel: ccp 0000:0a:00.1: SEV: failed to get status. Error: 0x0

Also, KWrite is no longer launching and gives the following error:
kwrite: symbol lookup error: /usr/lib/libKF5TextEditor.so.5: undefined symbol: _ZNK19KSyntaxHighlighting6Format20hasUnderlineOverrideEv

youtube-dl was just updated with a temporary fix for this, you can download again with youtube-dl version 2019.09.12. It was released a few minutes ago.

1 Like

Yeah i know. Should have linked it here

Nothing to say for now. Manjaro Cinnamon here.

Did the upgrade with Pamac GTK (yeah, despite a systemd upgrade, I am a mad man).

2 Likes

Forum kindly sponsored by Bytemark