[Testing Update] 2019-09-01 - Manjaro 18.1-rc9, VHBA Module, CDemu

Hello community,

I am happy to announce another Testing Update. Mostly we have Manjaro 18.1-rc9, vhba-module and cdemu updates with this one.

Update news

This update holds the following changes:

  • Manjaro 18.1-rc9 got released. Please test and give us feedback.
  • cdemu is now at 3.2.3
  • The usual upstream updates including python and perl
  • Latest efforts by KDE can be reviewed via our current KDE-Dev ISO or current KDE-Vanilla ISO
  • Manjaro Juhraya ISOs got updated, including flatpak and snap support pre-activated. Office can be selected during installation between libreoffice-still or freeoffice: XFCE, KDE, Gnome

Give us the usual feedback and let us know what you think about this update.


Current supported Kernels

  • linux316 3.16.73
  • linux44 4.4.190 (no legacy nvidia-340 module!)
  • linux49 4.9.190
  • linux414 4.14.141
  • linux419 4.19.69
  • linux51 5.1.21 [EOL]
  • linux52 5.2.11 (no catalyst module!)
  • linux53 5.3-rc6 (not all modules build yet!)
  • linux419-rt 4.19.50_rt22
  • linux52-rt 5.2.10_rt5-1

Package Updates (Sun Sep 1 09:13:46 CEST 2019)

  • testing community x86_64: 45 new and 51 removed package(s)
  • testing extra x86_64: 11 new and 11 removed package(s)
  • testing multilib x86_64: 1 new and 1 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-31           2019-09-01
-------------------------------------------------------------------------------
 gnome-shell-extension-dash-to-panel                v20-1     v22+6+g06d50e8-1
             linux419-rt-vhba-module           20190410-4           20190831-1
              linux52-rt-vhba-module           20190410-2           20190831-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-31           2019-09-01
-------------------------------------------------------------------------------
                              acpica           20190703-1           20190816-1
                             aws-cli           1.16.225-1           1.16.230-1
                             caprine             2.35.0-1             2.37.0-1
                        cdemu-client              3.2.1-1              3.2.3-1
                        cdemu-daemon              3.2.2-1              3.2.3-1
                        cozy-desktop             3.14.0-1             3.15.0-1
                                cppo              1.6.5-2                    -
                            electron              6.0.6-1              6.0.7-1
                              embree              3.6.0-1              3.6.1-1
                              eslint              6.2.2-1              6.3.0-1
                               i3-wm               4.17-1             4.17.1-1
                         jami-daemon           20190603-1           20190813-1
                          jami-gnome           20190603-1           20190813-1
                    jupyter-notebook              6.0.0-1              6.0.1-1
                              kasync              0.2.0-2              0.3.0-1
                               kdav2              0.2.0-1              0.3.0-1
                              kimap2              0.2.1-1              0.3.0-1
                               kitty             0.14.3-1             0.14.4-1
                       libjamiclient           20190603-1           20190813-1
                           libmirage              3.2.2-1              3.2.3-1
                  libsecp256k1 20170927+825+g0b70241-1 20190822+995+ge729cc7-1
                   materia-gtk-theme           20190315-1           20190831-1
                      matrix-synapse              1.2.1-1              1.3.1-1
                              menhir           20190626-3                    -
                              merlin              3.3.2-2                    -
                                 min             1.10.1-1             1.11.0-1
                              netcdf              4.7.0-1              4.7.1-1
                      netcdf-fortran              4.4.5-2              4.5.0-1
              netcdf-fortran-openmpi              4.4.5-2              4.5.0-1
                      netcdf-openmpi              4.7.0-1              4.7.1-1
                        ocaml-biniou              1.2.1-2                    -
                   ocaml-easy-format              1.3.1-5                    -
                        ocaml-yojson              1.4.1-6                    -
                             opendht            1:1.9.5-2           1:1.10.1-1
                            paraview              5.6.1-2              5.6.2-1
                     parity-ethereum              2.5.6-1              2.5.7-1
              perl-extutils-cppguess               0.19-2               0.20-1
                               ponyc             0.30.0-1             0.31.0-1
                      python-awkward             0.12.7-1             0.12.8-1
                        python-boto3            1.9.215-1            1.9.220-1
                     python-botocore           1.12.215-1           1.12.220-1
                      python-execnet              1.7.0-1              1.7.1-1
                       python2-boto3            1.9.215-1            1.9.220-1
                    python2-botocore           1.12.215-1           1.12.220-1
                     python2-execnet              1.7.0-1              1.7.1-1
                               qt5ct               0.39-2               0.40-1
                             solfege             3.22.2-5             3.23.4-1
                   teensy-loader-cli                2.1-2                2.1-3


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-31           2019-09-01
-------------------------------------------------------------------------------
                linux414-vhba-module          20190410-21           20190831-1
                linux419-vhba-module          20190410-26           20190831-1
                 linux44-vhba-module           20190410-3           20190831-1
                 linux49-vhba-module           20190410-8           20190831-1
                 linux52-vhba-module          20190410-14           20190831-1
                 linux53-vhba-module         20190410-0.7         20190831-0.1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-31           2019-09-01
-------------------------------------------------------------------------------
                         imagemagick           7.0.8.62-1           7.0.8.63-1
                     imagemagick-doc           7.0.8.62-1           7.0.8.63-1
                          libmagick6          6.9.10.62-1          6.9.10.63-1
                              ostree             2019.3-1             2019.3-2
                               scons              3.1.1-1              3.1.1-2


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-31           2019-09-01
-------------------------------------------------------------------------------
                       lib32-libcups             2.2.11-1              2.3.0-1
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

8 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Changes made to Grub 2.04-6

Due to some bugs with the Fedora patches in regard of BTRFS we are using now the Ubuntu approach to hide the menu via GRUB_TIMEOUT.

These are the current options to style the timeout:

GRUB_TIMEOUT_STYLE=countdown
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT_STYLE=menu

You may want to double-check your settings in /etc/default/grub

We also provide a new package called grub-vanilla. Learn more about it here.


Thunderbird 68.0 disabled my extensions!

Thunderbird 68 changes the way extensions work in line with Firefox 68. This will mean incompatible extensions are disabled.

The Thunderbird developers have made it as easy as possible for extensions developers to update the extensions to get them working again.

However, it will take time for extensions to 1) be updated and 2) make their way onto AMO for download.

You have two basic choices:

  1. Add IgnorePkg = thunderbird to your /etc/pacman.conf until your "critical" extension is updated
  2. Keep checking for updates for your "critical" extension, and possibly pester the developer to update it

Option 2 is the more proactive.


pip behaves differently

pip now includes by default the --user flag for all operations.


Asian/CJK characters display as blocks

Install noto-fonts-cjk or another font of your choice. The problem seems related to a ttf-droid update.

https://bugs.archlinux.org/task/63205


libbloom>=1.6-2 update requires manual intervention

(Taken from Arch Linux website, 2019-07-11 by Felix Yan. Source: https://www.archlinux.org/news/libbloom16-2-update-requires-manual-intervention/)

The libbloom package prior to version 1.6-2 was missing a soname link. This has been fixed in 1.6-2, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libbloom: /usr/lib/libbloom.so.1 exists in filesystem

when updating, use

pacman -Suy --overwrite usr/lib/libbloom.so.1

to perform the upgrade.

tensorflow>=1.14.0-5 update requires manual intervention

From Konstantin Gizdov on August 20, 2019

The tensorflow packages prior to version 1.14.0-5 were missing some soname links. This has been fixed in 1.14.0-5, so the upgrade will need to overwrite the untracked soname links created by ldconfig. If you get an errors like so.

tensorflow: /usr/lib/libtensorflow.so.1 exists in filesystem
tensorflow: /usr/lib/libtensorflow_cc.so.1 exists in filesystem
tensorflow: /usr/lib/libtensorflow_framework.so.1 exists in filesystem

when updating, use

pacman -Suy --overwrite=usr/lib/libtensorflow.so.1,usr/lib/libtensorflow_cc.so.1,usr/lib/libtensorflow_framework.so.1

to perform the upgrade.

2 Likes

Installer froze at startup see attached:

Redownload the ISO as we had some issues with mhwd. Also check for the new checksums.

MHWD still not working, installed nvidia 435 manually. Also installed libreoffice-still manually, see specs below:

bob@Manjaro-Testing~$ inxi-Fxz
System:
  Host: HP-rc9 Kernel: 5.3.0-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.1.0 Desktop: Xfce 4.14.1 Distro: Manjaro Linux 
Machine:
  Type: Desktop System: Hewlett-Packard product: HP EliteDesk 705 G1 SFF 
  v: N/A serial: <filter> 
  Mobo: Hewlett-Packard model: 2215 serial: <filter> UEFI: Hewlett-Packard 
  v: L06 v02.30 date: 03/22/2018 
Battery:
  Device-1: hidpp_battery_0 model: Logitech M570 charge: 100% 
  status: Discharging 
CPU:
  Topology: Quad Core model: AMD A10-6800K APU with Radeon HD Graphics 
  bits: 64 type: MCP arch: Piledriver rev: 1 L2 cache: 2048 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 
  bogomips: 32749 
  Speed: 1995 MHz min/max: 2000/4100 MHz Core speeds (MHz): 1: 1996 2: 1995 
  3: 1996 4: 1989 
Graphics:
  Device-1: NVIDIA GK208 [GeForce GT 720] vendor: Micro-Star MSI 
  driver: nvidia v: 435.21 bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.5 driver: nvidia unloaded: modesetting 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GT 720/PCIe/SSE2 v: 4.6.0 NVIDIA 435.21 
  direct render: Yes 
Audio:
  Device-1: AMD FCH Azalia vendor: Hewlett-Packard driver: snd_hda_intel 
  v: kernel bus ID: 00:14.2 
  Device-2: NVIDIA GK208 HDMI/DP Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Sound Server: ALSA v: k5.3.0-1-MANJARO 
Network:
  Device-1: Broadcom and subsidiaries NetXtreme BCM5762 Gigabit Ethernet PCIe vendor: Hewlett-Packard driver: tg3 v: 3.137 port: e000 bus ID: 04:00.0 
  IF: enp4s0 state: down mac: <filter> 
  Device-2: Ralink MT7601U Wireless Adapter type: USB driver: mt7601u 
  bus ID: 3-1:2 
  IF: wlp0s19f2u1 state: up mac: <filter> 
Drives:
  Local Storage: total: 2.73 TiB used: 26.31 GiB (0.9%) 
  ID-1: /dev/sda vendor: HGST (Hitachi) model: HUS724020ALE641 
  size: 1.82 TiB 
  ID-2: /dev/sdb vendor: Western Digital model: WD10EZEX-08M2NA0 
  size: 931.51 GiB 
Partition:
  ID-1: / size: 911.41 GiB used: 26.31 GiB (2.9%) fs: ext4 dev: /dev/sda4 
  ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 5.6 C mobo: N/A gpu: nvidia temp: 49 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 28% 
Info:
  Processes: 176 Uptime: 10m Memory: 7.76 GiB used: 843.2 MiB (10.6%) 
  Init: systemd Compilers: gcc: 9.1.0 Shell: bash v: 5.0.9 inxi: 3.0.36 

Why, did it install 418 drivers or not? 430 and 435 are not shipping with the ISOs.

I have this problem every launch, try to reinstall manjaro with "systemd.mask=mhwd-live.service" as parameter. I always add parameter "blacklist=nvidia" and "nouveau.modeset=0" just to be sure. I hope it will fix ur problem.

There were no nvidia drivers installed at all. I chose 435 as I wanted to have the most recent upgrade along with Kernel: 5.3.0-1. I prefer to test everything. I did click on Libreoffice in the installer as well.

I am experiencing the issue with KDE Plasma mentioned earlier. Seemingly ramdom hangs of Plasma when interacting with e.g. systemtray. Possibly related: I need to click Konsole everytime I activate it using the 'Toggle Background Window' shortcut for it to gain focus. I haven't been able to find anything in the journal or an exact match in the KDE Bugtracker.

1 Like

Is there a log entry that can help you out?

If it's a fresh install, I wonder if the calamares log will show what happened?

It is too long for the forum, got an E-mail? Perhaps I can send it as attachment?

Just use pastebin or dpaste and link it here.
:wink:

https://pastebin.com/JyLxGRkR

Getting an issue with qt5ct.
None of the qt applications I try to open will work, this might be related to icons, since it only starts breaking after saving a change to the icon set.

qt5ct: using qt5ct plugin
Configuration path: "/home/longtomjr/.config/qt5ct"
Shared QSS paths: ("/home/longtomjr/.local/share/qt5ct/qss", "/home/longtomjr/.local/share/flatpak/exports/share/qt5ct/qss", "/var/lib/flatpak/exports/share/qt5ct/qss", "/usr/local/share/qt5ct/qss", "/usr/share/qt5ct/qss", "/var/lib/snapd/desktop/qt5ct/qss")
Shared color scheme paths: ("/home/longtomjr/.local/share/qt5ct/colors", "/home/longtomjr/.local/share/flatpak/exports/share/qt5ct/colors", "/var/lib/flatpak/exports/share/qt5ct/colors", "/usr/local/share/qt5ct/colors", "/usr/share/qt5ct/colors", "/var/lib/snapd/desktop/qt5ct/colors")
malloc(): unsorted double linked list corrupted
fish: “qt5ct” terminated by signal SIGABRT (Abort)

Worked before the update.

When i delete my config everything works fine - until I do a icon change again. Will try to find upstream and see if they have a report.

From the changelog

Version 0.40

  • using separate thread for icon theme loading

May - or may not be related. Anyone else using qt5ct?

EDIT: Upstream ticket https://sourceforge.net/p/qt5ct/tickets/70/

KDE GTK Breeze and GTK Breath - A theme issue with Thunderbird if you get rid of the title bar using CSD:

image

The two Lightning tab buttons are harder to see because of the lack of contrast between them and the dark background. I know it's not a manjaro issue per-say, just an observation with the new build's feature set. Enable the title bar again and there's no issue because the tab bar they are on goes light grey.

Ya, found the bug. 18.1.0-rc9 is still buggy. I tried to fix a thing with installing additional packages, which messed up driver installation. Should be fixed by tomorrow. Will reupload the ISOs then.

2 Likes

Out of curiosity I down loaded the "Current" ISO 9-2-19 rc9 and the same results came up. Glad you found it and look forward to doing this again some time. (NOT REALLY.)

I wonder what the common factor is? As i read various posts mentioning such problems over the past couple of recent Testing updates, i pondered how it can be that others have suffered this painful hassle, yet my Plasma continues to be great in my Tower [fwiw; no LatteDock (KSmoothDock instead), no Bluetooth, no WiFi, no Nvidia (only integrated Intel GPU)]. :thinking:

1 Like

Are you installing the latest versions or using what you have?

Forum kindly sponsored by Bytemark