[Testing Update] 2019-08-28 - Kernels, Nvidia, KDE-Dev, Mesa, Python, Haskell

Hello community,

I am happy to announce another Testing Update. Mostly we have Nvidia, KDE-Dev and Mesa updates with this one.

Update news

This update holds the following changes:

  • Most of our Kernels got updated. Note that linux50-rt got dropped.
  • Nvidia drivers got extended to 418xx, 430xx and 435xx series
  • Mesa is now at 19.1.5
  • updates to KDE-Dev packages
  • The usual upstream updates
  • Latest efforts by KDE can be reviewed via our current KDE-Dev ISO or current KDE-Vanilla ISO
  • Manjaro Juhraya ISOs got updated, including flatpak and snap support pre-activated. Office can be selected during installation between libreoffice-still or freeoffice: XFCE, KDE, Gnome

Give us the usual feedback and let us know what you think about this update.


Current supported Kernels

  • linux316 3.16.73
  • linux44 4.4.190 (no legacy nvidia-340 module!)
  • linux49 4.9.190
  • linux414 4.14.140
  • linux419 4.19.68
  • linux51 5.1.21 [EOL]
  • linux52 5.2.10 (no catalyst module!)
  • linux53 5.3-rc6 (not all modules build yet!)
  • linux419-rt 4.19.50_rt22
  • linux52-rt 5.2.10_rt5-1

Package Updates (Wed Aug 28 09:23:49 CEST 2019)

  • testing community x86_64: 809 new and 852 removed package(s)
  • testing core x86_64: 20 new and 21 removed package(s)
  • testing extra x86_64: 137 new and 140 removed package(s)
  • testing multilib x86_64: 12 new and 13 removed package(s)

A list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

11 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Asian/CJK characters display as blocks

Install noto-fonts-cjk or another font of your choice. The problem seems related to a ttf-droid update.

https://bugs.archlinux.org/task/63205


libbloom>=1.6-2 update requires manual intervention

(Taken from Arch Linux website, 2019-07-11 by Felix Yan. Source: https://www.archlinux.org/news/libbloom16-2-update-requires-manual-intervention/)

The libbloom package prior to version 1.6-2 was missing a soname link. This has been fixed in 1.6-2, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libbloom: /usr/lib/libbloom.so.1 exists in filesystem

when updating, use

pacman -Suy --overwrite usr/lib/libbloom.so.1

to perform the upgrade.

tensorflow>=1.14.0-5 update requires manual intervention

From Konstantin Gizdov on August 20, 2019

The tensorflow packages prior to version 1.14.0-5 were missing some soname links. This has been fixed in 1.14.0-5, so the upgrade will need to overwrite the untracked soname links created by ldconfig. If you get an errors like so.

tensorflow: /usr/lib/libtensorflow.so.1 exists in filesystem
tensorflow: /usr/lib/libtensorflow_cc.so.1 exists in filesystem
tensorflow: /usr/lib/libtensorflow_framework.so.1 exists in filesystem

when updating, use

pacman -Suy --overwrite=usr/lib/libtensorflow.so.1,usr/lib/libtensorflow_cc.so.1,usr/lib/libtensorflow_framework.so.1

to perform the upgrade.

Changes made to Grub 2.04-3


Due to some bugs with the Fedora patches in regard of BTRFS we are using now the Ubuntu approach to hide the menu via GRUB_TIMEOUT=0.

These are the current options to style the timeout:

GRUB_TIMEOUT_STYLE=countdown
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT_STYLE=menu

NB - If you do not use btrfs on your drives, you may wish to add grub to the ignored packages line in /etc/pacman.conf before running this update.

3 Likes

reboot is ok , but on the other side grub always appears on boot with this version ?

First boot of KDE desktop was very tardy though, I thought it had frozen as there was no progress indicator on the Breeze theme splash screen but left it and eventually the desktop was rendered. Performance is back to normal so I hope it was just re-generating something as a one off. I'll edit the post if otherwise.

EDIT - KDE is messed up after all, pastebin of log from base system onwards where KDE starts: https://pastebin.com/raw/tLvYySGj

SOLVED - by @zbe two posts down (also does not affect my laptop with a bluetooth device)

4 Likes

I've just successfully updated my Unstable VM, so next to do is my Testing VM. Tomorrow my real Testing Tower... maybe.


Testing VM also updated & rebooted ok.

Both VMs did this, during the upgrades; seems a bit odd given i use x64 not x86. Don't know what the implications are of the error:

Summary
~
To install (14):
  lib32-libdbusmenu-glib                16.04.0-3                                 multilib   41.8 kB
  lib32-libdbusmenu-gtk2                16.04.0-3                                 multilib   29.4 kB
  lib32-libindicator-gtk2               12.10.1-7                                 multilib   23.3 kB
  lib32-nspr                            4.22-1                                    multilib   109.7 kB
  lib32-nss                             3.45-1                                    multilib   989.7 kB
  lib32-sqlite                          3.29.0-1                                  multilib   458.5 kB
~

Downloading lib32-gettext (0.20.1-1)...                                                                              
Downloading lib32-harfbuzz (2.6.1-1)...                                                                              
Downloading lib32-libldap (2.4.48-1)...                                                                              
Downloading lib32-mesa (19.1.5-1)...                                                                                 
Downloading lib32-libindicator-gtk2 (12.10.1-7)...                                                                   
Downloading lib32-libdbusmenu-glib (16.04.0-3)...                                                                    
Downloading lib32-libdbusmenu-gtk2 (16.04.0-3)...                                                                    
Downloading lib32-nspr (4.22-1)...                                                                                   
Downloading lib32-sqlite (3.29.0-1)...       
~

Installing libindicator-gtk2 (12.10.1-8)...                                                                  [96/106]
Installing lib32-libindicator-gtk2 (12.10.1-7)...                                                            [97/106]
Configuring lib32-libindicator-gtk2...
Unable to open directory usr/lib32/gio/modules: Error opening directory “usr/lib32/gio/modules”: No such file or directory
~

Ha, the Tower update was the least eventful of the three. No problems at all [& not even any lib32 packages involved].


I am a little surprised though that neither of the last two Testing Updates has included the new Dolphin [19.08.0-2.3], needed to fix the bugged Split Pane View at launch. Mine remains good since i installed the new package manually a few days ago, but anyone else will still have the bugged 19.08.0-2 version unless they also manually do that, given it has not come through the official updates yet.

I had same lag after update on unstable VM -- disabling bluetooth fixed it.

sudo systemctl disable --now bluetooth
3 Likes

hmm, okay thanks that should sort the desktop then but I do use bluetooth on my laptop so if the same happens with that I won't be best pleased.

EDIT - thanks that worked nicely for the KDE delay, please add it to the known issues and solutions wiki above as it's your discovery

Hi!! Thanks for the fix, I have had the same issue with my PC for KDE testing.

:grinning:

I have the same issue. Very slow boot every time and journalctl log shows those "plasmashell invalid metadata" errors (same as at micsim35's log)

I think the kdeconnect 1.3.5-2 is the root cause, because reverting it back to version 1.3.5-1 fixes the issue.

I also have had problems with KDE Connect, it didn't found my phone, linking again solved the issue.

Possibly and seemingly dependent on whether or not a bluetooth device is present. My laptop is fine thankfully which has a bluetooth adaptor that I use. The desktop that doesn't was the system throwing the hissy fit above over bluetooth. I think the metadata errors can be ignored, I thought they may be relevant but they aren't.

With regards the grub update I have added grub to my ignored packages list on my laptop and will do the same to the desktop. I don't use btrfs and the changes were specifically to deal with a problem fedora grub (aka the build manjaro normally use) caused with that file system.

I use btrfs, everything worked flawlessly before this update, now GRUB is showing the menu for 30 seconds even if I set the timeout to 1 or 0, I tried both menu and hidden style and I get the same result. Any suggestion?

1 Like

You can try solutions from this thread.

Simplest is

3 Likes

Seems to be that new driver with official prime support doesnt require reboot after an update to work, unlike bumblebee, which is great.

I've got some conflicting files:

manjaro-bspwm-settings: /etc/skel/.config/rofi/config-extended.rasi exists in filesystem (owned by lemonpanel)
manjaro-bspwm-settings: /etc/skel/.config/rofi/config-monocle.rasi exists in filesystem (owned by lemonpanel)
manjaro-bspwm-settings: /etc/skel/.config/rofi/rofimenu.rasi exists in filesystem (owned by lemonpanel)

@Chrysostomus, maybe something should be repackaged?

As others have mentioned. The update killed my KDE desktop launching.

systemctl mask bluetooth.service fixed it for me as well.

I don't use bluetooth so it's not an issue.

Will be updating my other KDE system (Tiamat) later today which does have bluetooth. I'll see if the same happens.

Update 2019-08-28T21:37:00Z

Tiamat (With a working bluetooth) had no issues with KDE hanging on reboot.

1 Like

KDE here - launched fine after the update - with bluetooth enabled. I do have some wierd and interesting results with the pager and task manager in using i3 as my wm. Also - when I try to open the add widgets screen - it breaks pretty badly (to the point where i have to quit plasmashell and restart it, might be compton.

Everything is fine though - seems like normal breaking one would expect from running a frankenDE

Thanks! I'll try to get it done tomorrow

Currently working on revision 4 to fix the grub issue.

1 Like

Update without problem here on my KDE laptop. As already reported by others seems that the problem with desktop startup depends of which you have a Bluetooth device/adapter connected or not. I use a Bluetooth mouse and no problem here.

Forum kindly sponsored by Bytemark