[Testing Update] 2019-08-17 - Kernels, Systemd, KDE-Git

Hello community,

I am happy to announce another Testing Update. Mostly we have KDE-Git, Systemd and Kernel updates with this one.

Update news

This update holds the following changes:

  • Most of our Kernel got updated. We added RT-Kernel 5.2 series
  • We renewed some KDE-Git packages
  • Systemd got some fixes for dbus
  • The usual upstream updates
  • Latest efforts by KDE can be reviewed via our current KDE-Dev ISO or current KDE-Vanilla ISO
  • Manjaro Juhraya ISOs got updated, including flatpak and snap support pre-activated. Office can be selected during installation between libreoffice-still or freeoffice: XFCE, KDE, Gnome

Give us the usual feedback and let us know what you think about this update.


Current supported Kernels

  • linux316 3.16.70
  • linux44 4.4.189 (no legacy nvidia-340 module!)
  • linux49 4.9.189
  • linux414 4.14.139
  • linux419 4.19.67
  • linux51 5.1.21 [EOL]
  • linux52 5.2.9 (no catalyst module!)
  • linux53 5.3-rc4 (not all modules build yet!)
  • linux419-rt 4.19.50_rt22
  • linux50-rt 5.0.21_rt16
  • linux52-rt 5.2.9_rt3

Package Updates (Sat Aug 17 21:45:47 CEST 2019)

  • testing community x86_64: 280 new and 256 removed package(s)
  • testing core x86_64: 14 new and 14 removed package(s)
  • testing extra x86_64: 89 new and 87 removed package(s)
  • testing multilib x86_64: 2 new and 2 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-15           2019-08-17
-------------------------------------------------------------------------------
                    appimagelauncher              1.4.0-1              1.5.0-1
                          attica-git5.61.0.r706.ga715be5-15.62.0.r708.g134e029-1
                           baloo-git5.60.0.r2620.gdfd33e6e-15.62.0.r2638.gee17a86b-1
                        bluez-qt-git5.60.0.r540.g3333dee-15.62.0.r551.g7211e78-1
                          breeze-git5.16.80.r1875.gc9241635-15.16.80.r1881.g6b63429f-1
                      breeze-gtk-git5.16.80.r333.g28292c7-15.16.80.r334.g80bcaaf-1
                    breeze-icons-git5.60.0.r1341.gb30b08bf-15.62.0.r1369.g335221e2-1
                        discover-git5.16.80.r7319.g9e0c7f34-15.16.80.r7323.ge576f8a6-1
                         drkonqi-git5.16.80.r422.g847619ac-15.16.80.r430.g0f3ec01b-1
             extra-cmake-modules-git5.61.0.r3084.g6709de1-15.62.0.r3086.g6faff48-1
            frameworkintegration-git5.60.0.r460.gcdb3ad6-15.62.0.r470.g836c7f4-1
               gnome-layout-switcher                0.4-1                0.5-1
                     kactivities-git5.61.0.r1241.g7a2c30de-15.62.0.r1242.g725f18c6-1
               kactivities-stats-git5.60.0.r217.gb45c34e-15.62.0.r225.gddb1169-1
               kactivitymanagerd-git5.15.80.r1215.gf4c21bd-15.15.80.r1216.gcc2a788-1
                         kapidox-git5.61.0.r438.g1c08ce7-15.62.0.r439.g21ce35e-1
                        karchive-git5.61.0.r375.g3c6f3e7-15.62.0.r376.g843c0ed-1
                           kauth-git5.61.0.r307.g4ccbb45-15.62.0.r308.g56d6049-1
                      kbookmarks-git5.61.0.r270.gc9cde78-15.62.0.r271.ge8a2c01-1
                        kcmutils-git5.61.0.r315.g0fb2b0e-15.62.0.r318.gb07d7ec-1
                         kcodecs-git5.61.0.r264.g2b1bc93-15.62.0.r265.gb8dfb85-1
                     kcompletion-git5.61.0.r305.g12ca6c1-15.62.0.r306.g40833f0-1
                         kconfig-git5.61.0.r580.g5d3e71b-15.62.0.r584.g403c617-1
                  kconfigwidgets-git5.61.0.r385.g4d9313c-15.62.0.r387.gc42c313-1
                     kcoreaddons-git5.61.0.r844.g13b32c1-15.62.0.r846.g969e01d-1
                          kcrash-git5.61.0.r260.gd97269a-15.62.0.r262.ge64b831-1
                     kdbusaddons-git5.61.0.r272.g8ec55bd-15.62.0.r274.g94644b1-1
                    kdeclarative-git5.61.0.r689.g77386b6-15.62.0.r690.ge2f0dc6-1
                            kded-git5.61.0.r273.g53097cc-15.62.0.r274.g3552573-1
                 kdelibs4support-git5.60.0.r871.g99deeb70-15.62.0.r890.gb3df9f31-1
                kdeplasma-addons-git5.16.80.r8158.g2e0ddd4cb-15.16.80.r8161.gc162d7704-1
                 kdesignerplugin-git5.61.0.r245.gcc27fa4-15.62.0.r246.g7261e12-1
                           kdesu-git5.60.0.r352.g65065ed-15.62.0.r358.gd610576-1
                       kdewebkit-git5.61.0.r200.gd5a6705-15.62.0.r201.g8b62243-1
                          kdnssd-git5.60.0.r219.g9f3b977-15.62.0.r225.g2158cf6-1
                       kdoctools-git5.61.0.r494.g60d4076-15.62.0.r495.g404165b-1
                      kemoticons-git5.61.0.r276.ga66b9e9-15.62.0.r278.ga7ce6b8-1
                   kfilemetadata-git5.61.0.r638.ge1cb130-15.62.0.r639.gfd0ed62-1
                    kglobalaccel-git5.61.0.r312.g6d720d4-15.62.0.r315.g1980d48-1
                      kguiaddons-git5.61.0.r240.g71d2fee-15.62.0.r241.gd31b29e-1
                       kholidays-git5.60.0.r809.gb7a99e5-15.62.0.r818.g9382ce0-1
                        khotkeys-git5.16.80.r1940.gdd0166d-15.16.80.r1941.g91d6356-1
                           khtml-git5.60.0.r458.gbb96523-15.62.0.r465.g2a64baa-1
                           ki18n-git5.61.0.r340.g8f84d19-15.62.0.r341.g8846fab-1
                     kiconthemes-git5.61.0.r370.g8688829-15.62.0.r372.g41ca479-1
                       kidletime-git5.61.0.r216.g85a2a8e-15.62.0.r218.geecba30-1
                   kimageformats-git5.57.0.r231.g0196444-15.57.0.r237.g40353da-1
                     kinfocenter-git5.16.80.r1530.gcff5924-15.16.80.r1535.g549ded1-1
                           kinit-git5.61.0.r304.g5e8a784-15.62.0.r305.gf703b55-1
                             kio-git5.61.0.r3494.gb8a4c222-15.62.0.r3500.gc411033a-1
                       kirigami2-git5.61.0.r1882.g29dffaf4-15.62.0.r1888.gb3ffca13-1
                     kitemmodels-git5.60.0.r349.gb55c6d9-15.62.0.r360.g072dc8f-1
                      kitemviews-git5.61.0.r228.g20239e4-15.62.0.r229.ge0c5680-1
                     kjobwidgets-git5.61.0.r256.g47240e0-15.62.0.r257.g791ee03-1
                             kjs-git5.61.0.r236.g9fe690b-15.62.0.r237.ge147a08-1
                        kjsembed-git5.60.0.r205.g015a455-15.62.0.r210.g0d84b16-1
                    kmediaplayer-git5.60.0.r200.g5df67a2-15.62.0.r206.g31d10d6-1
                      knetattach-git5.16.80.r6822.g489a6dc75-15.16.80.r6842.gb69801267-1
                       knewstuff-git5.61.0.r687.g9513555-15.62.0.r690.g69f7de4-1
                  knotifications-git5.61.0.r442.g0b6973a-15.62.0.r450.gb7bc334-1
                   knotifyconfig-git5.60.0.r238.g16e1d57-15.62.0.r245.g27a8fd1-1
                        kpackage-git5.61.0.r528.g412fee1-15.62.0.r530.gedd7852-1
                          kparts-git5.61.0.r327.g105e60b-15.62.0.r329.gf4b7a82-1
                         kpeople-git5.60.0.r1180.g45bb019-15.62.0.r1191.g9fc710f-1
                       kplotting-git5.61.0.r200.g7619077-15.62.0.r201.g4a0518a-1
                            kpty-git5.61.0.r223.g389e702-15.62.0.r224.ged48654-1
                           kross-git5.60.0.r243.gc14fa36-15.62.0.r248.gd13a6c9-1
                         krunner-git5.60.0.r364.ga07027c-15.62.0.r370.g0400eb3-1
                   kscreenlocker-git5.16.80.r711.g68464e2-15.16.80.r717.g5803ab9-1
                        kservice-git5.61.0.r667.g0f1d958-15.62.0.r670.gc56a94c-1
                       ksysguard-git5.16.80.r3121.gf9f1eea9-15.16.80.r3122.g3cec7273-1
                     ktexteditor-git5.60.0.r2072.gdeb27c1b-15.62.0.r2096.g64cdeeca-1
                    ktextwidgets-git5.61.0.r265.gddf8153-15.62.0.r266.g000c81f-1
                 kunitconversion-git5.61.0.r269.g24a45f5-15.62.0.r270.g63a0759-1
                         kwallet-git5.61.0.r908.ge0321a1-15.62.0.r910.ga594092-1
            kwayland-integration-git5.16.80.r117.g1e8696a-15.16.80.r121.g16c6a2e-1
                  kwidgetsaddons-git5.61.0.r565.g080aeaa-15.62.0.r567.g01ebafa-1
                   kwindowsystem-git5.61.0.r438.g9a75713-15.62.0.r442.g288b78d-1
                         kxmlgui-git5.61.0.r518.ge529dfc-15.62.0.r519.g9d1d83a-1
                   kxmlrpcclient-git5.60.0.r354.g4c1885ad3-15.62.0.r360.g5c52ecff3-1
                              libc++              8.0.0-1            8.0.1-1.0
                           libc++abi              8.0.0-1            8.0.1-1.0
                  libc++experimental              8.0.0-1            8.0.1-1.0
                      libkscreen-git5.16.80.r1472.gcc8f88d-15.16.80.r1478.g989df1e-1
                           milou-git5.16.80.r626.g5698f9d-15.16.80.r646.gaa9e1d6-1
                 modemmanager-qt-git5.60.0.r419.g5e6d614-15.62.0.r427.g6c17e8b-1
               networkmanager-qt-git5.60.0.r995.g2b6a4ff-15.62.0.r1003.gbd749fe-1
                    oxygen-icons-git5.60.0.r189.g791f45f-15.62.0.r196.gd10c293-1
                oxygen-icons-svg-git5.60.0.r189.g791f45f-15.62.0.r196.gd10c293-1
      plasma-browser-integration-git5.16.80.r830.gaed338c6-15.16.80.r838.g55d78db6-1
                  plasma-desktop-git5.16.80.r6822.g489a6dc75-15.16.80.r6842.gb69801267-1
                plasma-framework-git5.61.0.r15227.g134b2ac33-15.62.0.r15229.ge454afa35-1
                       plasma-nm-git5.16.80.r2635.g463c6bb2-15.16.80.r2638.ga7eb3cb5-1
                       plasma-pa-git5.16.80.r728.ga420dd6-15.16.80.r729.gfaef1e8-1
                      plasma-sdk-git5.16.80.r2065.gc69afe2-15.16.80.r2067.gcf3df11-1
                plasma-workspace-git5.16.80.r7818.g6e067d12d-15.16.80.r7838.g4a2f759a1-1
                          prison-git5.60.0.r206.gd9d12b1-15.62.0.r212.gae60d91-1
                         purpose-git5.60.0.r636.g729a841-15.62.0.r663.g0b75343-1
              qqc2-desktop-style-git5.60.0.r270.g6eb266c-15.62.0.r286.gda70e0e-1
                        sddm-kcm-git5.16.80.r463.gbf436d3-15.16.80.r467.g430f5c0-1
                           solid-git5.61.0.r494.gcd306b2-15.62.0.r496.geb82729-1
                          sonnet-git5.61.0.r479.g5972d78-15.62.0.r480.ga5e568a-1
                     syndication-git5.60.0.r710.g4c0f4aa-15.62.0.r717.gcaad94f-1
             syntax-highlighting-git5.61.0.r976.g75e233d-15.62.0.r987.gff06ba2-1
                  systemsettings-git5.16.80.r2056.g3149f99-25.16.80.r2057.gf49e7ec-2
                    threadweaver-git5.61.0.r401.g5c6ff07-15.62.0.r404.ga65b3fa-1
                    user-manager-git5.16.80.r447.g29768b0-15.16.80.r448.gece7561-1
                          linux52-rt                    -          5.2.9_rt3-1
                linux52-rt-acpi_call                    -              1.1.0-1
                 linux52-rt-bbswitch                    -                0.8-1
              linux52-rt-broadcom-wl                    -       6.30.223.271-1
                  linux52-rt-headers                    -          5.2.9_rt3-1
             linux52-rt-nvidia-340xx                    -            340.107-1
             linux52-rt-nvidia-390xx                    -            390.129-1
                   linux52-rt-nvidia                    -             435.17-1
                 linux52-rt-nvidiabl                    -               0.88-1
                    linux52-rt-r8168                    -           8.047.02-1
                linux52-rt-rtl8723bu                    -      4.3.9.3.13200-1
                 linux52-rt-tp_smapi                    -               0.43-1
              linux52-rt-vhba-module                    -           20190410-1
 linux52-rt-virtualbox-guest-modules                    -             6.0.10-1
  linux52-rt-virtualbox-host-modules                    -             6.0.10-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-15           2019-08-17
-------------------------------------------------------------------------------
                      acpi_call-dkms            1.1.0-238            1.1.0-239
                     arduino-builder              1.4.4-1              1.4.4-2
                         arduino-cli              0.4.0-1              0.4.0-2
                           bettercap             2.24.1-1             2.24.1-2
                         browserpass              3.0.6-1              3.0.6-3
                             buildah              1.9.2-1              1.9.2-2
                              camlp4               4.07-2               4.08-1
                              camlp5               7.08-1               7.08-2
                             chezmoi              1.6.1-1              1.6.1-3
                      clementine 1.3.1.r702.3b76fa627-2 1.3.1.r771.75f18dab2-1
                         cni-plugins              0.8.1-1              0.8.1-2
                                code             1.37.0-1             1.37.1-1
                     consul-template             0.20.0-1             0.20.0-2
                      container-diff             0.15.0-1             0.15.0-2
                          containerd              1.2.7-1              1.2.7-2
                                 coq              8.9.1-1              8.9.1-2
                             coq-doc              8.9.1-1              8.9.1-2
                              coqide              8.9.1-1              8.9.1-2
                            deadbeef              0.7.2-5              1.8.2-1
                          deepin-api              5.0.0-1              5.0.0-2
                       deepin-daemon              5.0.0-1              5.0.0-2
                               delve              1.2.0-1              1.2.0-2
                                 dep              0.5.4-1              0.5.4-2
                      dns-over-https              2.1.1-1              2.1.1-2
                      dnscrypt-proxy             2.0.25-1             2.0.25-2
                              docker          1:19.03.1-1          1:19.03.1-2
                      docker-machine             0.16.1-2             0.16.1-3
                                dune             1.11.0-1             1.11.1-1
                              elixir              1.8.2-1              1.9.0-1
                            evilginx              2.3.0-2              2.3.0-3
                 firefox-dark-reader             4.7.14-1             4.7.16-1
                                 fzf             0.18.0-1             0.18.0-2
                           git-annex         7.20190730-9        7.20190730-10
                              gitlab             12.1.6-1             12.1.6-2
                       gitlab-gitaly             1.56.0-1             1.56.0-2
                       gitlab-runner             12.1.0-1             12.1.0-2
                        gitlab-shell            2:9.3.0-1            2:9.3.0-2
                    gitlab-workhorse              8.7.0-2              8.7.0-3
                              glider              0.7.0-1              0.7.0-2
                          go-bindata              3.4.0-2              3.4.0-3
                         go-ethereum              1.9.1-1              1.9.1-2
                             go-ipfs             0.4.20-1             0.4.22-1
                           go-md2man             1.0.10-1             1.0.10-2
                           gocryptfs                1.7-2                1.7-4
                   golang-deepin-gir              2.0.2-1              2.0.2-2
golang-github-linuxdeepin-go-dbus-factory         0.9.0-1              0.9.0-2
                              gopass              1.8.6-1              1.8.6-2
                                gost              2.8.1-1              2.8.1-2
                             grafana              6.3.2-1              6.3.3-1
                                  gx             0.14.1-2             0.14.1-3
                               gx-go              1.9.0-1              1.9.0-2
                   haskell-esqueleto              3.1.0-3              3.1.0-4
                      haskell-libmpd           0.9.0.8-70            0.9.0.9-1
                      haskell-pantry            0.1.1.1-8            0.1.1.1-9
                  haskell-persistent             2.10.0-4             2.10.1-1
               haskell-persistent-qq             2.9.1-52             2.9.1-53
           haskell-persistent-sqlite             2.10.4-5             2.10.4-6
         haskell-persistent-template              2.7.2-4              2.7.2-5
             haskell-persistent-test            2.0.3.0-4            2.0.3.0-5
                       haskell-yesod            1.6.0-319            1.6.0-320
                  haskell-yesod-auth             1.6.7-39             1.6.7-40
                  haskell-yesod-form             1.6.6-13             1.6.6-14
            haskell-yesod-persistent           1.6.0.2-71           1.6.0.2-72
                haskell-yesod-static          1.6.0.1-171          1.6.0.1-172
                  haskell-yesod-test           1.6.6.1-65           1.6.6.1-66
                              hcloud             1.13.0-1             1.13.0-2
                         hledger-web           1.14.1-117           1.14.1-118
                            hsetroot              1.0.2-7              1.0.4-1
                                 hub             2.12.3-1             2.12.3-3
                           i2c-tools                4.1-1                4.1-2
                  intel-opencl-clang              8.0.1-1              8.0.1-2
                                  io         2017.06.08-5         2017.06.08-6
                                kbfs              4.3.1-1              4.3.1-3
                     kcm-wacomtablet            1:3.1.1-1            1:3.2.0-1
                              kcptun           20190809-1           20190809-2
                             keybase              4.3.1-1              4.3.1-3
                         keybase-gui              4.3.1-1              4.3.1-3
                             kubectl             1.15.1-1             1.15.1-2
                        libmediainfo              19.04-1              19.07-1
                             libwrap             7.6.24-4             7.6.28-1
                             liteide                 36-2                 36-3
                               marco             1.22.1-1             1.22.2-1
                    mate-applet-dock               0.88-1               0.89-1
                         mate-themes            3.22.19-1            3.22.20-1
                     mate-user-guide             1.22.1-1             1.22.2-1
                     mate-user-share             1.22.0-1             1.22.1-1
                           mediainfo              19.04-1              19.07-1
                       mediainfo-gui              19.04-1              19.07-1
                                meek               0.30-2               0.30-3
                              menhir           20190626-1           20190626-2
                              merlin              3.2.2-2              3.3.2-1
                            meshbird                2.3-1                2.3-2
                            minikube              1.3.0-1              1.3.1-1
                               minio         2019.08.14-1         2019.08.14-2
                        minio-client         2019.07.31-1         2019.07.31-2
                        ocaml-biniou              1.2.0-4              1.2.1-1
                   ocaml-easy-format              1.3.1-3              1.3.1-4
                       ocaml-findlib              1.8.1-1              1.8.1-2
                        ocaml-lablgl               1.06-1               1.06-2
                           ocaml-num                1.2-1                1.2-2
                        ocaml-yojson              1.4.1-4              1.4.1-5
                             oidentd              2.3.2-1              2.4.0-1
                                opam              2.0.5-1              2.0.5-3
                              packer              1.4.2-2              1.4.2-3
                  papirus-icon-theme           20190802-1           20190817-1
                 perl-ppix-quotelike              0.007-2              0.008-1
                    perl-ppix-regexp              0.065-2              0.066-1
                    perl-test-simple           1.302164-2           1.302166-1
                    perl-test2-suite           0.000122-2           0.000124-1
                              podman              1.4.4-1              1.4.4-2
                       podman-docker              1.4.4-1              1.4.4-2
                         python-amqp              2.5.0-1              2.5.1-1
           python-aws-sam-translator             1.13.1-1             1.13.2-1
                        python-black             19.3b0-1             19.3b0-2
                 python-phonenumbers            8.10.16-1            8.10.17-1
                python-pycryptodomex              3.7.3-1              3.8.2-1
                       python-pyglet              1.3.2-2              1.4.2-1
                  python-ruamel-yaml             0.16.1-1             0.16.4-1
                           python-rx              1.6.1-3              3.0.1-1
            python-typing_extensions              3.7.2-2              3.7.4-1
                        python2-amqp              2.5.0-1              2.5.1-1
                   python2-daemonize              2.5.0-1                    -
                      python2-pyglet              1.3.2-2              1.4.2-1
                              rclone             1.48.0-1             1.48.0-2
                              restic              0.9.5-1              0.9.5-2
                                root            6.18.00-2            6.18.00-3
                           root-cuda            6.18.00-2            6.18.00-3
                         ruby-rugged             0.28.3-1           0.28.3.1-1
                                runc           1.0.0rc8-1           1.0.0rc8-2
            shadowsocks-v2ray-plugin              1.1.0-1              1.1.0-2
                               shfmt              2.6.4-1              2.6.4-2
                              skopeo             0.1.39-1             0.1.39-2
               spirv-llvm-translator            8.0.1.1-1            8.0.1.2-1
                               stack              2.1.3-8              2.1.3-9
                            startdde              5.0.1-1              5.0.1-2
                               swig3             3.0.12-1             3.0.12-2
                      tamarin-prover            1.4.1-129            1.4.1-131
                        tcp-wrappers             7.6.24-4             7.6.28-1
                            toastify              0.3.4-2              0.4.0-1
                               v2ray             4.20.0-1             4.20.0-2
         v2ray-domain-list-community         20190815.1-1         20190815.1-2
                         v2ray-geoip           20190611-1           20190813-1
                         vapoursynth              R47.1-1              R47.2-1
                              vegeta             12.7.0-2             12.7.0-3
                           wallutils              5.8.1-1              5.8.1-2
                        wire-desktop           3.9.2895-4          3.10.2904-1
            xfce4-whiskermenu-plugin              2.3.2-1              2.3.3-1
                              xmobar            0.29.5-41            0.29.5-42
                              xxhash              0.7.0-1              0.7.1-1
              yubikey-touch-detector              1.3.0-1              1.3.0-3
              haskell-broadcast-chan                    -            0.2.0.2-1
                        haskell-dyre                    -             0.8.12-1
                  haskell-io-storage                    -                0.3-1
                 haskell-xdg-basedir                    -              0.2.2-1
                        lua-argparse                    -              0.7.0-1
                      lua51-argparse                    -              0.7.0-1
                      lua52-argparse                    -              0.7.0-1
                python-click-plugins                    -              1.1.1-2
               python2-click-plugins                    -              1.1.1-2


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-15           2019-08-17
-------------------------------------------------------------------------------
                            linux414           4.14.138-1           4.14.139-1
                    linux414-headers           4.14.138-1           4.14.139-1
                            linux419            4.19.66-1            4.19.67-1
                    linux419-headers            4.19.66-1            4.19.67-1
                             linux52              5.2.8-1              5.2.9-1
                     linux52-headers              5.2.8-1              5.2.9-1
                             systemd             242.84-1             242.85-1
                        systemd-libs             242.84-1             242.85-1
                  systemd-resolvconf             242.84-1             242.85-1
                  systemd-sysvcompat             242.84-1             242.85-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-15           2019-08-17
-------------------------------------------------------------------------------
                           amd-ucode   20190717.bf13a71-1   20190815.07b925b-1
                                dbus            1.12.16-1            1.12.16-2
                           dbus-docs            1.12.16-1            1.12.16-2
                      linux-firmware   20190717.bf13a71-1   20190815.07b925b-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-15           2019-08-17
-------------------------------------------------------------------------------
               calamares-git 3.2.13.r6387.b700eea6f-1 3.2.13.r6425.43820c920-1
                  linux414-acpi_call            1.1.0-113            1.1.0-114
                   linux414-bbswitch              0.8-113              0.8-114
                linux414-broadcom-wl     6.30.223.271-113     6.30.223.271-114
                   linux414-catalyst    1:15.201.1151-113    1:15.201.1151-114
                linux414-ndiswrapper               1.62-8               1.62-9
                     linux414-nvidia           1:435.17-1           1:435.17-2
               linux414-nvidia-340xx           340.107-72           340.107-73
               linux414-nvidia-390xx            390.129-3            390.129-4
                   linux414-nvidiabl             0.88-113             0.88-114
                      linux414-r8168           8.047.02-5           8.047.02-6
                  linux414-rt3562sta       2.4.1.1_r4-112       2.4.1.1_r4-113
                   linux414-tp_smapi               0.43-5               0.43-6
                linux414-vhba-module          20190410-18          20190410-19
   linux414-virtualbox-guest-modules             6.0.10-5             6.0.10-6
    linux414-virtualbox-host-modules             6.0.10-5             6.0.10-6
                        linux414-zfs             0.8.1-11             0.8.1-12
                  linux419-acpi_call             1.1.0-59             1.1.0-60
                   linux419-bbswitch               0.8-58               0.8-59
                linux419-broadcom-wl      6.30.223.271-58      6.30.223.271-59
                   linux419-catalyst     1:15.201.1151-56     1:15.201.1151-57
                linux419-ndiswrapper               1.62-8               1.62-9
                     linux419-nvidia           1:435.17-1           1:435.17-2
               linux419-nvidia-340xx           340.107-58           340.107-59
                   linux419-nvidiabl              0.88-58              0.88-59
                      linux419-r8168           8.047.02-9          8.047.02-10
                  linux419-rtl8723bu   4.3.9.3.13200.0-43   4.3.9.3.13200.0-44
                   linux419-tp_smapi               0.43-8               0.43-9
                linux419-vhba-module          20190410-23          20190410-24
   linux419-virtualbox-guest-modules             6.0.10-8             6.0.10-9
    linux419-virtualbox-host-modules             6.0.10-8             6.0.10-9
                        linux419-zfs             0.8.1-16             0.8.1-17
                   linux52-acpi_call             1.1.0-11             1.1.0-12
                    linux52-bbswitch               0.8-11               0.8-12
                 linux52-broadcom-wl      6.30.223.271-11      6.30.223.271-12
                 linux52-ndiswrapper               1.62-7               1.62-8
                      linux52-nvidia           1:435.17-1           1:435.17-2
                linux52-nvidia-340xx           340.107-12           340.107-13
                linux52-nvidia-390xx            390.129-6            390.129-7
                    linux52-nvidiabl              0.88-11              0.88-12
                       linux52-r8168          8.047.02-12          8.047.02-13
                   linux52-rtl8723bu     4.3.9.3.13200-10     4.3.9.3.13200-12
                    linux52-tp_smapi              0.43-11              0.43-12
                 linux52-vhba-module          20190410-11          20190410-12
    linux52-virtualbox-guest-modules            6.0.10-10            6.0.10-11
     linux52-virtualbox-host-modules            6.0.10-10            6.0.10-11
                         linux52-zfs             0.8.1-12             0.8.1-13
              manjaro-tools-base-git      r2796.0a314fd-1      r2798.9ebf14d-1
               manjaro-tools-iso-git      r2796.0a314fd-1      r2798.9ebf14d-1
               manjaro-tools-pkg-git      r2796.0a314fd-1      r2798.9ebf14d-1
              manjaro-tools-yaml-git      r2796.0a314fd-1      r2798.9ebf14d-1
                        nvidia-utils           1:435.17-3           1:435.17-6
                       pamac-cli-dev              8.0.4-1         9.0.0alpha-1
                    pamac-common-dev              8.0.4-1         9.0.0alpha-1
                       pamac-gtk-dev              8.0.4-2         9.0.0alpha-1
         pamac-tray-appindicator-dev              8.0.4-1         9.0.0alpha-1
            linux419-rt-nvidia-390xx                    -            390.129-2
               pamac-snap-plugin-dev                    -         9.0.0alpha-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-15           2019-08-17
-------------------------------------------------------------------------------
                        alertmanager             0.18.0-1             0.18.0-2
                              apache             2.4.39-1             2.4.41-1
                                cups             2.2.11-2             2.2.12-1
                        cups-filters             1.25.1-1             1.25.2-1
                         flashplugin         32.0.0.223-1         32.0.0.238-1
                      graphicsmagick             1.3.32-1             1.3.33-1
                            graphviz            2.40.1-17            2.40.1-18
                        java-openjfx          11.0.3.u1-1          12.0.2.u1-1
                    java-openjfx-doc          11.0.3.u1-1          12.0.2.u1-1
                    java-openjfx-src          11.0.3.u1-1          12.0.2.u1-1
                            lablgtk2             2.18.6-3             2.18.8-1
                             libcups             2.2.11-2             2.2.12-1
                                llvm              8.0.1-1              8.0.1-2
                           llvm-libs              8.0.1-1              8.0.1-2
                          llvm-ocaml              8.0.1-1              8.0.1-2
                               ocaml             4.07.1-1             4.08.0-2
                 ocaml-compiler-libs             4.07.1-1             4.08.0-2
                        ocaml-ctypes             0.14.0-2             0.14.0-3
                      ocaml-integers              0.2.2-2              0.3.0-1
                        ocaml-result                1.3-2                1.3-3
                         ocaml-topkg              0.9.1-2              0.9.1-3
                          ocamlbuild             0.14.0-2             0.14.0-3
                        pepper-flash         32.0.0.223-1         32.0.0.238-1
                          prometheus             2.10.0-1             2.11.2-1
        prometheus-blackbox-exporter             0.14.0-2             0.14.0-3
            prometheus-node-exporter             0.18.1-1             0.18.1-2
                                rust           1:1.36.0-1           1:1.37.0-1
                           rust-docs           1:1.36.0-1           1:1.37.0-1
                                swig              4.0.0-1              4.0.0-2
                              unison             2.51.2-3             2.51.2-4
                   vulkan-icd-loader            1.1.117-1            1.1.119-1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-15           2019-08-17
-------------------------------------------------------------------------------
                       lib32-systemd             242.84-1             242.85-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-15           2019-08-17
-------------------------------------------------------------------------------
             lib32-vulkan-icd-loader            1.1.115-1            1.1.119-1

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

10 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Asian/CJK characters display as blocks

Install noto-fonts-cjk or another font of your choice. The problem seems related to a ttf-droid update.

https://bugs.archlinux.org/task/63205


libbloom>=1.6-2 update requires manual intervention

(Taken from Arch Linux website, 2019-07-11 by Felix Yan. Source: https://www.archlinux.org/news/libbloom16-2-update-requires-manual-intervention/)

The libbloom package prior to version 1.6-2 was missing a soname link. This has been fixed in 1.6-2, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libbloom: /usr/lib/libbloom.so.1 exists in filesystem

when updating, use

pacman -Suy --overwrite usr/lib/libbloom.so.1

to perform the upgrade.

@philm kernel in the desc should be 5.2.9 :slight_smile:

1 Like

Typo, i presume, given atm i already have 5.2.8, & just below what i've quoted above, is:

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-15           2019-08-17
-------------------------------------------------------------------------------
                             linux52              5.2.8-1              5.2.9-1
                     linux52-headers              5.2.8-1              5.2.9-1

The damn Llamas turned the 9 upside down when they posted or just pasted it from a previous announcement. Things like that is why the Pythons sacked them from titling their films.

1 Like

Updated successfully.:+1:
LXQT with Kernel 5.2.
Thanks!

@philm: Thanks for all the work. I got a request, please. Following the last 2019-07-13 Stable Update, I am still under the impression that the transition to Xfce 4.14 final including all auxiliaries (e.g. Thunar and its plugins) is not fully completed, not even with Testing 2019-08-15.

So, please:
(a) Correct me if I am mistaken. In this case, I would love to be wrong...
(b) In case I am not too wrong, then please let the next Stable update be mainly concerned with Xfce cleanup. Please, don‘t put in too much other stuff which could cause other issues.

Just my feeling. I did in fact postpone 08-13 since I consider that one a bit immature.

Thanks in advance!

2 Likes

I just added some small fixes I missed yesterday.

### BoxIt memo ###

User philip created a snapshot of branch 'unstable' to 'testing'.

 - testing community x86_64:  14 new and 13 removed package(s)
 - testing core x86_64:  4 new and 6 removed package(s)
 - testing extra x86_64:  3 new and 3 removed package(s)

:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-17           2019-08-18
-------------------------------------------------------------------------------
                             buildah              1.9.2-2             1.10.1-1
                         cni-plugins              0.8.1-2              0.8.2-1
                              conmon            1:0.3.0-1            1:2.0.0-1
                             git-lfs              2.8.0-1              2.8.0-2
                                hugo             0.57.0-1             0.57.2-1
                            influxdb              1.7.3-2              1.7.7-1
                          mit-scheme             10.1.9-1            10.1.10-1
                              podman              1.4.4-2              1.5.1-1
                       podman-docker              1.4.4-2              1.5.1-1
                        python-wheel             0.33.4-1             0.33.5-1
                       python2-wheel             0.33.4-1             0.33.5-1
                               subdl              1.1.0-1              1.1.2-1
                            tinyxml2              7.0.1-1              7.1.0-1
                            watchman                    -              4.9.0-2


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-17           2019-08-18
-------------------------------------------------------------------------------
                               glibc             2.29-3.1                    -
                         lib32-glibc             2.29-3.1                    -
                             systemd             242.85-1             242.85-2
                        systemd-libs             242.85-1             242.85-2
                  systemd-resolvconf             242.85-1             242.85-2
                  systemd-sysvcompat             242.85-1             242.85-2


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-17           2019-08-18
-------------------------------------------------------------------------------
                            alsa-lib              1.1.9-1              1.1.9-2
                           mercurial              5.0.2-1                5.1-1
                 xf86-input-libinput             0.28.2-1             0.29.0-1

3 Likes

Just wondering if perhaps you can add a feature to select either freeoffice, libreoffice still, libreoffice fresh or none of them?? this would be handy for those who would like to use the latest stable version, ie 6.3

IIRC it has already been installed.

Test it with RC8.

who is IIRC

= if i recall/remember correctly

afaik = as far as i know

hhgttg = hitchhikers guide to the galaxy

6 Likes

thanks mate. not so sure of these abbreviations

TLAs.

:laughing:

I thought it was IRC chat software

I had a problem with DeadBeef 1.8.2, no sound:

convgui: gtkui plugin not found
plugin Converter GTK3 UI failed to connect to dependencies, deactivated.
plugin Playlist browser GTK3 failed to connect to dependencies, deactivated.
shellexecui: can't find gtkui plugin
plugin Shellexec GTK3 UI failed to connect to dependencies, deactivated.
resume: track 289 pos 0.000000 playlist 57
gtkui plugin compiled for gtk version: 2.24.32
connecting button tray signals
pa_simple_new failed: conection refused

although I mark as I could solved, I wasn't able.

Try to remove any external plugins.

I have pulse plugin installed 0.1, but in the SourceForge page of Deadbeef there is a 1.0.

That is not an external plugin. Did you add anything to Deadbeef?

User normally installs directly to /usr/lib/deadbeef . If you do not remember, check the timestamps. All the default plugins have the same timstamp on my system.

I uninstalled the extra plugins. And I am using the alsa plugin.

Forum kindly sponsored by Bytemark