[Testing Update] 2019-08-12 - XFCE 4.14, LibreOffice 6.3, Kernels, LibInput 1.14, Haskell

As part of the workaround previously described,
I replaced

  • exo by exo-gtk3
  • xfce4-notifyd by xfce4-notifyd-gtk3
  • libxfce4ui by libxfce4ui-gtk3
  • xfconf by xfconf-gtk3

Is it advisable to revert these changes now?

Thank you very much and kind regards.

LibreOffice 6.3's new Tip of the Day feature made me chuckle, next they will introduce an animated paperclip or dog offering help to compose a letter :smiley:

At least the tip can be easily turned off though.

I see you are trying to turn me off. I'm sorry Dave, i'm afraid i can't do that.

6 Likes

There may be other overlays that need to be removed.

I did not get xfce4-pulseaudio-plugin-0.4.2-2-x86_64.pkg.tar.xz

Which results in partial update and:

Plugin "PulseAudio Plugin" unexpectedly left the panel, do you want to restart it?

It cannot be restarted.

Right, another overlay I removed now.

1 Like

Hi @Yorper

That is strange...
Unless those java apps use deprecated classes, there should not be a problem.

Did jdk-openjdk and jre-openjdk also update to version 11? Or remained to version 8 in your system

The rest stayed at 8. The java-openjfx appears to have been removed from manjaros repo and thus forced update to 11, provided by arch.

Did you try to run them from Terminal with

java -jar ...

to see what messages they give?

There should be a java8-openjfx in the repo?

1 Like

Then try updating the rest.
If this is not possible, I don't know how to downgrade since 8 is not in repos.
Maybe 8 passed to AUR? Check again...

So far no real problems, just some graphical glitches, like a new solid border around some panel elements and some green dots.

I hadn't noticed this package as i'd been using the one you had made. Problem solved :+1:

Your logs are empty :grin:
As it's hard to understand what's going on remotely, I'd suggest to remove and install some kernel again in order to reproduce the issue, then on the next reboot check journal.

Error in libreoffice-fresh after update: When forgetting to add space between words, doing it later will leave an underline as if it is misspelling.
mistake%20in%20libreoffice-fresh

Able to correct it by doing the space again. Tried re-installing did not help.

1 Like

I was curious so just checked since I use LO Writer a lot. I think it may be a GPU driver or DE related glitch. XFCE has had some major updates as well today after all.

It's behaving on my KDE installs with Intel and AMD hardware respectively if I type your example of 'Beckyhas' and then go back to add the space, the error indication goes immediately.

Graphic driver: nvidia v: 430.40, Desktop: Xfce 4.14.1 Both updated today.

1 Like

Which modules haven't been built yet out of curiosity? Is there a way to check? Getting a 5700 XT in a week so curious

Compare pacman -Ss linux52 and pacman -Ss linux53.

2 Likes

Ah ok! Thank you so much! Love your work!

Issue/question
Why is libplacebo needed now and why does it conflict with libplacebo-git from the AUR?

Forum kindly sponsored by Bytemark